Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Tim Moore
@TimMoore

@erip curious to get your thoughts on this https://github.com/lagom/lagom.github.io/pull/158#discussion_r206003293

Every service run in Developer Mode has slightly different settings, see the docs for Service Gateway, Service Locator or your services.

As an aside, this also makes me wonder whether there should be a configurable default address for all services, so you don't have to set it in so many different places.

Elijah Rippeth
@erip
That seems very reasonable.
I can submit a PR for that tonight. Sorry about being MIA for the unidoc thing — crazy week last week. :sweat:
Tim Moore
@TimMoore
No need to apologize!
Jules Ivanic
@guizmaii
;)
Tim Moore
@TimMoore
@guizmaii thanks… I’ll give it a look when I get a chance
Jules Ivanic
@guizmaii
:+1:
Elijah Rippeth
@erip
When publishing the java docs, do you all just issue an sbt unidoc? or is there more magic than that? I want to make sure I’m not introducing regressions...
Tim Moore
@TimMoore
@erip I think that's right
Yeah:
  sbt unidoc
  cd docs
  sbt markdownStageSite
(or you could test with sbt run inside docs)
Elijah Rippeth
@erip
docs/ has its own build.sbt that I haven’t touched yet, so I think it might spuriously succeed.
Elijah Rippeth
@erip
Anyone know why travis is giving me permission errors??? See here
Elijah Rippeth
@erip
I think it might be related to lagom/lagom#1523, but other subsequent PRs aren’t having this issue.
Elijah Rippeth
@erip
I take it no one else has encountered this?
Elijah Rippeth
@erip
Hmm… it looks like there was a caching issue. (lagom/lagom#1525) Might be worth reporting to Travis folks.
Tim Moore
@TimMoore
Sorry, @erip most of the team is on leave this week so we're a bit slow on responses
Elijah Rippeth
@erip
No problem. :smile:
Tim Moore
@TimMoore
There was a recent change to the cache configuration that seems to have triggered this
Elijah Rippeth
@erip
I figured it out — seems to be a travis bug/quirk
I cherrypicked the commit and closed the offensive PR… CI is running fine now. Unfortunate that I couldn’t (easily?) preserve the original PR
Tim Moore
@TimMoore
Yeah OK you saw it… yes related to #1523. It seems like clearing the cache fixes it at least temporarily but we're watching to see if we need to roll back that change.
Elijah Rippeth
@erip
but unidoc seems to be done. :smile:
Tim Moore
@TimMoore
:tada:
Elijah Rippeth
@erip
Yay, #1525 finally passed. :D
Elijah Rippeth
@erip
@renatocaval If you'd like, I can make the port names PR a WIP so I can keep going with it.
I had meant to do that, but fell asleep. :zzz:
Renato Cavalcanti
@octonato
Hi @erip,
I think it's good to have small PRs. I think we can merge it soon
before merging
Elijah Rippeth
@erip
I can remove it quickly -- hold tight
Done!
Renato Cavalcanti
@octonato
thanks, I will check it in a while
Elijah Rippeth
@erip
btw, is @ignasi35 responsible for reviewing the unidoc PR when he gets back from vacation?
Renato Cavalcanti
@octonato
no, but we can make him responsible if you want :-)
I'm back today, still catching up
it's on our list @erip
it's just going slowly during summer breaks
Elijah Rippeth
@erip
No, I just wanted to make sure. :smile: I'm excited to keep pushing on the sbt 1.x stuff.
Renato Cavalcanti
@octonato
@erip I was about to merge and then I saw a small improvements we can still make
left a comment here: https://github.com/lagom/lagom/pull/1527/files#r211369678
Elijah Rippeth
@erip
done
:+1:
Ignasi Marimon-Clos
@ignasi35
@erip are you around? (this is probably better to discuss lagom/lagom#1542 )
:point_up: August 20, 2018 3:55 PM LOL
Elijah Rippeth
@erip
I am
:smile:
Ignasi Marimon-Clos
@ignasi35
Nice, about the dependency issues. Is it possible you were not reloading your project after tunning the dependencies?
Elijah Rippeth
@erip
It's very possible...
Let me clone on my work laptop and give it a shot