Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
stone.212
@stone212
Is it possible to use this with a private server and Gitlab Community Edition?
When I try, the Kanban home page still tries to log into "gitlab.com"
Leso_KN
@leso-kn
@stone212 Sorry for the delay, I'm quite busy at the moment. Yes, it's possible! You'll need to change some environment variables. Have a look at leanlabs' installation guide or the readme of my fork at
@egandro btw thanks for forking the repo. Much appreciated 👍
@odin243 Uhm.. that's a bit weired. In any case you can try running npm install in the projects root. It will install all necessary
node dependencies. If that doesn't work try removing the node_modules directory and run the command again
Leso_KN
@leso-kn
@rs-ds Welcome :)
Wheeler Games
@wheelergames_gitlab
Hi @leso-kn thanks so much for keeping a fork of this up and running
I've just pulled and tried to run it, and I get the problem others have mentioned of the localhost appearing to login, and then just reloading the login page again
when I looked in the docker logs it looks like it's still calling api/v3/
I have the latest code from your repo...
any ideas?
[Macaron] Started POST /api/oauth for 172.17.0.7
[Macaron] Completed /api/oauth 200 OK in 1.436487991s
[Macaron] Started GET /ws/ for 172.17.0.7
[sockets] [Info] [172.17.0.7:41772] Connection established
[Macaron] Completed /ws/ 0  in 272.471µs
[Macaron] Started GET /api/boards for 172.17.0.7
[Macaron] Started GET /api/boards/starred for 172.17.0.7
Bad response code: 410 
 Request url: /api/v3/projects?archived=false&page=1&per_page=100 
 Data map[error:API V3 is no longer supported. Use API V4 instead.][Macaron] Completed /api/boards 401 Unauthorized in 435.747047ms
Bad response code: 410 
 Request url: /api/v3/projects/starred?archived=false&page=1&per_page=100 
 Data map[error:API V3 is no longer supported. Use API V4 instead.][Macaron] Completed /api/boards/starred 401 Unauthorized in 447.847152ms
[Macaron] Started GET / for 172.17.0.7
[Macaron] Completed / 200 OK in 1.946692ms
[Macaron] Started GET / for 172.17.0.7
[Macaron] Completed / 200 OK in 2.184624ms
[sockets] [Error] [172.17.0.7:41772] Error reading from socket: websocket: close 1001 
2019/02/07 00:00:45 true
[sockets] [Info] [172.17.0.7:41772] Connection closed
Wheeler Games
@wheelergames_gitlab
I look forward to your response soon
but I still see v3 in the codebase everywhere
is it possible your v4 is on a branch and you forgot to commit it? or maybe not on master?
Hrm.. that's odd, i think you might be right @wheelergames_gitlab. It only seems to have updated board.service.js. I'll push the missing changes this evening
Btw sorry for the link, i wanted to paste a screenshot but the mobile gitter's really crappy
Wheeler Games
@wheelergames_gitlab
Thanks
look forward to having a go with it tmrw
Leso_KN
@leso-kn
Short update, i didn't push the changes yet. Asi said, I'm very busy at the moment, it
will have to wait, sorry
Wheeler Games
@wheelergames_gitlab
no probs
it's not blocking me, it's just a nice to have
I'd like to try and use issue boards for my workflow (currently using a spreadsheet)
Leso_KN
@leso-kn
@wheelergames_gitlab Hi again! Sorry it took me so long
So i just had a look at the files again but i'm a bit confused now. Everything seems to be configured fine for api v4
image.png
@wheelergames_gitlab Which version of kanban do you use? Did you clone the fork from https://github.com/leso-kn/kanban following the instructions in the readme?
Also, i noticed in the readme it still says leanlabsio/kanban. Maybe you accidently used their repository?
  • readme updated
Wheeler Games
@wheelergames_gitlab
Hi @leso-kn I really am not sure what I'm doing wrong
I pull the repo fresh
run make dev
add my client and secret to the docker_compose.yaml
and run docker compose up
and I get told
[Macaron] Started GET /api/boards for 172.17.0.7
[Macaron] Started GET /api/boards/starred for 172.17.0.7
Bad response code: 410 
 Request url: /api/v3/projects?archived=false&page=1&per_page=100 
 Data map[error:API V3 is no longer supported. Use API V4 instead.][Macaron] Completed /api/boards 401 Unauthorized in 454.733455ms
[Macaron] Started GET / for 172.17.0.7
[Macaron] Completed / 200 OK in 1.916342ms
Bad response code: 410
I've checked, and I have your latest code
I'm on the latest commit
it must be the make dev command that is doing something wrong
Wheeler Games
@wheelergames_gitlab
I think the problem is the make file, uses a leanlabs image to build from
leanlabs/kanban:1.7.1
and I think this hasn't been updated in 4 yrs so still points to v3
is there a way to use your code to build from instead of using their image?
Wheeler Games
@wheelergames_gitlab
waaaiiittt
i shouldn't be running docker compose down, docker compose up after
because that's removing the docker container made with the make file...