by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jul 12 05:40

    etr on master

    Add AppVeyor badge (compare)

  • Jul 12 05:33

    etr on master

    Removing windows as now buildin… (compare)

  • Jul 12 05:30

    etr on master

    Add configuration to build on A… (compare)

  • Jul 12 05:30
    etr closed #200
  • Jul 12 05:30
    codecov[bot] commented #200
  • Jul 12 05:30
    codecov[bot] commented #200
  • Jul 12 05:29
    codecov[bot] commented #200
  • Jul 12 05:29
    codecov[bot] commented #200
  • Jul 12 05:19
    etr assigned #200
  • Jul 12 05:19
    etr opened #200
  • Jul 12 04:47

    etr on appveyor_v2

    isolate libmicrohttpd (compare)

  • Jul 12 04:39

    etr on appveyor_v2

    add include and lib (compare)

  • Jul 12 04:30

    etr on appveyor_v2

    fix the prefix (compare)

  • Jul 12 04:24

    etr on appveyor_v2

    print few paths (compare)

  • Jul 12 04:17

    etr on appveyor_v2

    Print some paths (compare)

  • Jul 12 04:07

    etr on appveyor_v2

    Fix command (compare)

  • Jul 12 04:00

    etr on appveyor_v2

    Use msys shell (compare)

  • Jul 12 03:49

    etr on appveyor_v2

    change prefix (compare)

  • Jul 12 03:38

    etr on appveyor_v2

    ls tools (compare)

  • Jul 12 03:28

    etr on appveyor_v2

    Use MinGW64 (compare)

evilteq
@evilteq
hello
I've only been able to find packages for libhttpserver on fedora, and on archlinux through a seemingly abandoned AUR
why is it? Is it too complex process or something like it?
Sebastiano Merlino
@etr
hey @evilteq, thanks for reaching
we used to have a maintainer to produce the fedora packages (never has an arch one - unsure who built that)
to be honest, I don't think it is too hard to build - the building process for this library is quite standard so it shouldn't be impossible to build packages (different topic to maintain them aligned with the dependencies of each version of these OS)
are you searching for the packages on a specific distro?
evilteq
@evilteq
Archlinux
I can build that one, actually already have, but I was wondering why it is missing from almost every distro
evilteq
@evilteq
oh, and actually now that i make it fully, with tests, it fails :D
[CHECK FAILURE] (../../test/integ/authentication.cpp:166) - error in "digest_auth": Not Found!=SUCCESS
  • Time spent during "digest_auth": 4.86523 ms
    Running test (4): digest_auth_wrong_pass
    [CHECK FAILURE] (../../test/integ/authentication.cpp:197) - error in "digest_auth_wrong_pass": Not Found!=FAIL
  • Time spent during "digest_auth_wrong_pass": 5.07007 ms
Sebastiano Merlino
@etr
uhm... that's weird. I mean the error is still not what I'd expect because it feels awfully specific. But have you obtained this by standard "configure -> make" ?
evilteq
@evilteq
yes
and then make check
maybe it's because i took it from the default branch
I emailed it to where it pointed me
evilteq
@evilteq
I mean, it's not a problem to me right now, we have not started and even then we wont be using authentication, but I thought you would like to read about it
Sebastiano Merlino
@etr
Thanks for reporting this. The mainline should always compile correctly (that's the reason we have travis in place). If it is not doing so, it might be worth understanding what is going on. Would you mind opening an issue? I guess I need some info to be able to debug it given it does compile and test correctly on travis.
If you use the "Bug Report" template, that will already request you most of the questions I might need to root cause this.
evilteq
@evilteq
nagvenk
@nagvenk

Hi
I am not able to build or make this library under VM and ubuntu 16.04 lts environment. Host os is win10.
I followed below build steps

Building
libhttpserver uses the standard system where the usual build process involves running

./bootstrap
mkdir build
cd build
../configure
make
make install # (optionally to install on the system)

for some reason i was not able ot make it.
Can any one help me in this regard.


checking microhttpd.h usability... no ===> log for ../configure
checking microhttpd.h presence... no
checking for microhttpd.h... no
configure: error: "microhttpd.h not found"
rayap@rayap-VirtualBox:~/edge/src/edge_examples/rotate_state_subscriber/libhttpserver/build$ make
make: * No targets specified and no makefile found. Stop.
rayap@rayap-VirtualBox:~/edge/src/edge_examples/rotate_state_subscriber/libhttpserver/build$

xctest
@xctest
Anybody
Ho Ming Tsui
@alantsui_gitlab
Can anyone tell me how to include this library in cmake, I installed this library via brew
Sebastiano Merlino
@etr
Hey, sorry, for some reason gitter was not sending me notifications. @nagvenk from your error, it seems that you haven't installed libmicrohttpd on your system (libmicrohttpd is a dependency of the library)
@alantsui_gitlab the library offers a CMakeModule file that should allow you to refer to it when using CMake