Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Christopher J. Brody
    @brodybits
    If you are having trouble, it is best to start with an extremely simple test, such as what I put in README.md.
    lyric123123
    @lyric123123
    Ionic + cordova ,but this is an extremely simple test.
    Christopher J. Brody
    @brodybits
    Aah yes. Ionic, which I think you know is basically a version of Angular with the UI framework, can be a pain to use with Cordova. They have ngCordova.
    lyric123123
    @lyric123123
    Thanks
    lyric123123
    @lyric123123
    At the same mistake again.

    I downloaded the zip file from that site (the link is at the top right), then extracted the two files in the folder (src/android/libs) and placed them in the project's libs directory. Then, I refreshed the project.

    As the error kept going, he told me to "Make sure you removed sqlite-native-driver.jar". I deleted that file from the libs directory, refreshed the project, and The following error.

    08-27 11:31:20.065: W/dalvikvm(5138): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Lio/liteglue/SQLitePlugin;
    08-27 11:31:20.185: W/System.err(5138): java.lang.ClassNotFoundException: io.liteglue.SQLitePlugin
    08-27 11:31:20.185: W/System.err(5138): at java.lang.Class.classForName(Native Method)
    08-27 11:31:20.195: W/System.err(5138): at java.lang.Class.forName(Class.java:251)
    08-27 11:31:20.195: W/System.err(5138): at java.lang.Class.forName(Class.java:216)
    08-27 11:31:20.195: W/System.err(5138): at org.apache.cordova.PluginManager.instantiatePlugin(PluginManager.java:403)
    08-27 11:31:20.195: W/System.err(5138): at org.apache.cordova.PluginManager.getPlugin(PluginManager.java:193)
    08-27 11:31:20.195: W/System.err(5138): at org.apache.cordova.PluginManager.exec(PluginManager.java:141)
    08-27 11:31:20.195: W/System.err(5138): at org.apache.cordova.CordovaBridge.jsExec(CordovaBridge.java:63)
    08-27 11:31:20.195: W/System.err(5138): at org.apache.cordova.ExposedJsApi.exec(ExposedJsApi.java:40)
    08-27 11:31:20.295: W/System.err(5138): at com.android.org.chromium.base.SystemMessageHandler.nativeDoRunLoopOnce(Native Method)
    08-27 11:31:20.295: W/System.err(5138): at com.android.org.chromium.base.SystemMessageHandler.handleMessage(SystemMessageHandler.java:27)
    08-27 11:31:20.305: W/System.err(5138): at android.os.Handler.dispatchMessage(Handler.java:102)
    08-27 11:31:20.305: W/System.err(5138): at android.os.Looper.loop(Looper.java:136)
    08-27 11:31:20.305: W/System.err(5138): at android.os.HandlerThread.run(HandlerThread.java:61)
    08-27 11:31:20.315: W/System.err(5138): Caused by: java.lang.UnsatisfiedLinkError: Couldn't load sqlc-native-driver from loader dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.ionicframework.testplugin2382207-1.apk"],nativeLibraryDirectories=[/data/app-lib/com.ionicframework.testplugin2382207-1, /system/lib]]]: findLibrary returned null
    08-27 11:31:20.315: W/System.err(5138): at java.lang.Runtime.loadLibrary(Runtime.java:358)
    08-27 11:31:20.315: W/System.err(5138): at java.lang.System.loadLibrary(System.java:526)
    08-27 11:31:20.375: W/System.err(5138): at io.liteglue.SQLiteConnector.<init>(SQLiteConnector.java:8)
    08-27 11:31:20.375: W/System.err(5138): at io.liteglue.SQLitePlugin.<clinit>(SQLitePlugin.java:47)
    08-27 11:31:20.385: W/System.err(5138): ... 13 more
    08-27 11:31:20.385: I/System.out(5138): Error adding plugin io.liteglue.SQLitePlugin.
    08-27 11:31:20.385: W/System.err(5138): java.lang.NullPointerException
    08-27 11:31:20.415: W/System.err(5138): at org.apache.cordova.PluginManager.getPlugin(PluginManager.java:195)
    08-27 11:31:20.425: W/System.err(5138): at org.apache.cordova.PluginManager.exec(PluginManager.java:141)
    08-27 11:31:20.435: W/System.err(5138): at org.apache.cordova.CordovaBridge.jsExec(CordovaBridge.java:63)
    08-27 11:31:20.435: W/System.err(5138): at org.apache.cordova.ExposedJsApi.exec(ExposedJsApi.java:40)
    08-27 11:31:20.435: W/System.err(5138): at com.android.org.chromium.base.SystemMessageHandler.nativeDoRunLoopOnce(Native Method)
    08-27 11:31:20.435: W/System.err(5138): at com.android.org.chromium.base.SystemMessageHandler.handleMessage(SystemMessageHandler.java:27)
    08-27 11:31:20.435: W/System.err(5138): at android.os.Handler.dispatchMessage(Handler.java:102)
    08-27 11:31:20.445: W/System.err(5138): at android.os.Looper.loop(Looper.java:136)
    08-27 11:31:20.445: W/System.err(5138): at android.os.HandlerThread.run(HandlerThread.java:61)
    08-27 11:31:21.615: I/Choreographer(5138): Skipped 54 frames! The application may be doing too much work on its main thread.
    08-27 11:31:22.405: I/Choreographer(5138): Skipped 47 frames! The application may be doing too much work on its main thread.
    then
    blob
    lyric123123
    @lyric123123
    The same error, add the jar is not effective.
    Christopher J. Brody
    @brodybits
    You have to remove sqlite-native-driver.jar
    and make sure you install the native libraries in your libs directory instead
    lyric123123
    @lyric123123
    How to install the native libraries in my libs directory.
    Christopher J. Brody
    @brodybits
    You have to do jar xf sqlite-native-driver.jar to extract it.
    You will get a lib directory
    You have to move all the subdirectories from the lib directory into your libs directory
    I need to fix this very soon!
    lyric123123
    @lyric123123
    OK, thanks.
    shizhidi
    @shizhidi
    i want to know, where is the *.db file,I see no file on your mobile phone.
    Who knows?
    my phone
    Chun-Sheng, Li
    @peter279k
    Hi.If you use adt-bundle ,and you can open the DDMS.
    then open the file explorer and choose following path data/data/com.example.name.your-app-name/databases/your-db-name.db
    Christopher J. Brody
    @brodybits
    Thanks @peter279k. Yes for Android, external applications cannot see your database file unless you root your device (which I do not recommend). This should be documented, when I get a chance.
    Roman Chukhan
    @karatsuba
    Hi everyone! I am trying to make foreign key in table, but it does not work. Are you include such functionality in your plugin? Maybe you have some examples? Thanks.
    Christopher J. Brody
    @brodybits
    Roman Chukhan
    @karatsuba
    Thanks for link!
    Now I have next error: "FOREIGN KEY constraint failed", code "6"
    I am trying do it on iPad. Can you help me with it?
    Christopher J. Brody
    @brodybits
    laoyao
    @laoyao
    @brodybits Is there any tool to open the encryptped sqlite file?
    I am using the Cordova-sqlcipher-adapter plugin encrypt the sqlite file
    Christopher J. Brody
    @brodybits
    The sqlcipher project itself includes a CLI tool that can be used to open your encrypted database file and execute some queries. Works just like the sqlite CLI tool.
    laoyao
    @laoyao
    how to check SQLite file if is encrypted?@brodybits
    Christopher J. Brody
    @brodybits
    Check whether the SQLite file has the standard header or not. For reference: https://www.zetetic.net/sqlcipher/design/
    laoyao
    @laoyao
    I am using sqlcipher version. When I execute create index sql, the plugin report success, but acturally there isn’t a index in the sqlite db. Is there any problem?
    @brodybits
    Christopher J. Brody
    @brodybits
    Can you explain how you create the index and how you look for the index?
    lasselaakkonen
    @lasselaakkonen

    I've been using an old version of "Cordova-SQLitePlugin" from "brodysoft" github account. Now I wanted to update my plugins and it was slightly confusing to try figure out where the plugin I had used had gone and is the litehelpers plugin the same one as the brodysoft one was.

    I even found a github issue litehelpers/Cordova-sqlite-storage#95 discussing this.

    Even though https://github.com/brodysoft/Cordova-SQLitePlugin redirects to https://github.com/litehelpers/Cordova-sqlite-storage it would be nice if the Cordova-sqlite-storage readme mentioned all the old repositories which have been deprecated, so that it would be more clear/explicit what the history of the plugin actually is.

    I assume litehelpers/Cordova-sqlite-storage is a newer version of brodysoft/Cordova-SQLitePlugin? Even though I've been using version 1.0.3 of Cordova-SQLitePlugin and Cordova-sqlite-storage seems to be now v0.7.11.

    laoyao
    @laoyao
    Is it possible to upgrade the sqlcipher’s sqlite version to the latest version(3.9.2)?
    Christopher J. Brody
    @brodybits
    I just filed sqlcipher/sqlcipher#145
    nodecraic
    @webworkio
    hey, if anyone has any remote remote , designer, DevOps or Sysadmin jobs they can post them at http://webwork.io
    Christopher J. Brody
    @brodybits
    One more spam and I will delete this room!
    jigarsangoi
    @jigarsangoi
    Hello
    David
    @sourcer18
    Hello!!!! , I need a tutorial with crud sqlite in XDK, could you give me a link intel?
    thanks!
    help!!!
    It is known this error?
    blob
    Intel XDK use and storage sqlite, but I fail to display data, any ideas?
    ikhsanputra07
    @ikhsanputra07
    hey everyone i have question about cordova-sqlite, does cordova-sqlite sync to potsgresql???
    john5037
    @john5037
    Hi