These are chat archives for locomotivecms/v3

16th
Mar 2017
Pascal Friederich
@paukul
Mar 16 07:41
Hi there, I'm facing an issue where the back office doesn't update stuff like the "title" / "name" of layouts after deploying updated ones via wagon. In our first run we all gave them the same title so now we have a bunch of "Page html, head, body" layouts in the layout dropdown. I changed the title in the layout_name.haml.liquid files and deployed them but back office refuses to update. Am I missing something? Do I need to clear some caches?
Nikolay Bonev
@DonKoko
Mar 16 14:33
@paukul that seems like a kinda difficult case
what will happen to the pages using those layouts?
if you change the name of the layout
Nikolay Bonev
@DonKoko
Mar 16 14:43
I would suggest to set up a testing copy of the website and start testing to remove the layouts and deploy again with the new names
Pascal Friederich
@paukul
Mar 16 15:01
blob
@DonKoko I did deploy, the pages don't break or anything, but the names for the layouts don't change in the backend. so this is the dropdown in the backoffice
and this is what my layout settings look like: https://gist.github.com/paukul/9973750fe9e558ff8393893e4493ffc8
My understanding was that if I would change a layout programatically and deploy it to the backend, it should, well, change in the backend. This includes attributes like its title
Nikolay Bonev
@DonKoko
Mar 16 15:02
yeah i understand
and you are only changing the title?
file name stays the same?
Pascal Friederich
@paukul
Mar 16 15:03
yeh
Nikolay Bonev
@DonKoko
Mar 16 15:03
well what i would do is just go to the cms and manually delete the layouts, each one of them and then deploy again
i remember i had similar issue some time ago and thats how i solved it
but as i told you earlier, better make a test env before doing that
Pascal Friederich
@paukul
Mar 16 15:04
hehe, sure, ok :-)
Nikolay Bonev
@DonKoko
Mar 16 15:04
unless you are already on a dev env
but thats what i would do
Pascal Friederich
@paukul
Mar 16 15:04
"have you tried turning it off and on again" :D
cheers mate, I'll give it a try
Nikolay Bonev
@DonKoko
Mar 16 15:08
you can also try deleting them from the cms
from wagon i mean
sorry
Pascal Friederich
@paukul
Mar 16 15:08
perfect. I'll try
Didier Lafforgue
@did
Mar 16 15:47
""have you tried turning it off and on again"
hilarious!
@paukul awesome general culture ;-)
:)
Didier Lafforgue
@did
Mar 16 15:55
IT crowd…well… it should be studied in any CS master degree.
Pascal Friederich
@paukul
Mar 16 15:55
true ;)
Nikolay Bonev
@DonKoko
Mar 16 16:59
@paukul did you manage to solve it?