Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 22 12:01
    jottr closed #1444
  • Sep 22 12:01
    jottr commented #1444
  • Sep 22 06:34
    alerque commented #1444
  • Sep 21 22:07
    jottr edited #1444
  • Sep 21 22:07
    jottr opened #1444
  • Sep 21 22:07
    jottr labeled #1444
  • Sep 18 04:20
    MiguelEXE edited #1443
  • Sep 18 01:11
    MiguelEXE opened #1443
  • Sep 18 01:11
    MiguelEXE labeled #1443
  • Sep 15 21:59
    siffiejoe commented #1257
  • Sep 15 11:51
    imolein commented #1257
  • Sep 09 16:27
    hishamhm commented #1440
  • Sep 09 16:20
    hishamhm commented #1441
  • Sep 09 16:20

    hishamhm on master

    Fix badge in the README (compare)

  • Sep 09 16:20
    hishamhm closed #1441
  • Sep 09 11:58
    codecov-commenter commented #1441
  • Sep 09 11:57
    codecov-commenter commented #1441
  • Sep 09 11:57
    codecov-commenter commented #1441
  • Sep 09 11:32
    ligurio opened #1441
  • Sep 09 09:59
    Yang-XL labeled #1440
Thijs Schreijer
@Tieske
I'm trying to upload a rock to the luarocks repo, but it fails. I cannot use the commandline (the upload command only supports rockspecs, not rocks), adding the rock file via the GUI fails with "error: missing file". If I add both rockspec and rock in the gui, only the rockspec gets uploaded.
How to get around this?
@leafo any ideas?
eladbs
@eladbs
I managed to pack and publish rocks to our server. It turned out that I packed the src and rockspec instead of the "binary" rock.
Dennis Schridde
@devurandom
Hi @hishamhm ! @alerque mentioned that you could change the lualdap entry in the root manifest. Is that correct? Would you be able to assist us (@fperrad and me) with a transfer? See my post from 2021-02-03 just a few lines above: https://gitter.im/luarocks/luarocks?at=601a882a9238c531ad1fa81c
Thijs Schreijer
@Tieske
@devurandom you might have more luck sending an email
Wbertro
@HolterPhylo
Hi, new to luarocks. On win10 x64, I installed lua 5.4.2 and [[lua -e "print('hello world')"]] works fine. Trying to install luarocks. Donwloaded luarocks.exe for x64 and running it in x64 Native Tools Command Prompt for VS 2019 says Warning: Lua 5.3 interpreter not found at C:\temp
Wbertro
@HolterPhylo
Question is: Can luarocks support 5.4.2 or not? What config file information I need to setup, if any?
Wbertro
@HolterPhylo
or where better can I ask these questions?
Wbertro
@HolterPhylo
ok, made progress. luarocks is installed!

Why is luarocks saying : Error: unknown option '-e' when...
```Installing https://luarocks.org/luacheck-0.24.0-2.src.rock
Missing dependencies for luacheck 0.24.0-2:
argparse >= 0.6.0 (not installed)

luacheck 0.24.0-2 depends on lua >= 5.1 (5.3-1 provided by VM)
luacheck 0.24.0-2 depends on argparse >= 0.6.0 (not installed)
Installing https://luarocks.org/argparse-0.7.1-1.src.rock

argparse 0.7.1-1 depends on lua >= 5.1, < 5.5 (5.3-1 provided by VM)
argparse 0.7.1-1 is now installed in C:/Lua (license: MIT)

luacheck 0.24.0-2 depends on luafilesystem >= 1.6.3 (1.8.0-1 installed)
Usage: luarocks [-h] [--version] [--dev] [--server <server>]
[--only-server <server>] [--only-sources <url>]
[--namespace <namespace>] [--lua-dir <prefix>]
[--lua-version <ver>] [--tree <tree>] [--local] [--global]
[--verbose] [--timeout <seconds>] [--pin] [<command>] ...

Error: unknown option '-e'
Did you mean '-h'?
Usage: luarocks [-h] [--version] [--dev] [--server <server>]
[--only-server <server>] [--only-sources <url>]
[--namespace <namespace>] [--lua-dir <prefix>]
[--lua-version <ver>] [--tree <tree>] [--local] [--global]
[--verbose] [--timeout <seconds>] [--pin] [<command>] ...

Error: unknown option '-e'
Did you mean '-h'?
luacheck 0.24.0-2 is now installed in C:/Lua (license: MIT)```

meandmymind
@meandmymind

hello, guys. I use lua project with cpp library and build it with cmake

cmake installation goes well

Scanning dependencies of target xxx
[ 33%] Building CXX object CMakeFiles/xxx.dir/src/xxx.cc.o
[ 66%] Building CXX object CMakeFiles/xxx.dir/src/xxx.cc.o
[100%] Linking CXX shared library xxx.so
[100%] Built target xxx

and then I get error make: *** No rule to make target 'install'. Stop.

generated Makefile in fact does not contain target install

how is it possible?

relevant rockspec

build = {
    type= "cmake",
    install = {
        lib = {
            "./build.luarocks/xxx.so",
             ["xxx"]="./xxx/xxx",
             ["xxx"]="./xxx/xxx",
             ["xxx"]="./xxx/xxx",
             ["xxx"]="./xxx/xxx"
        }
    }
}

furthermore, I build my project in docker container, and when I run this same code with same docker image in CI target install is found normally.

LuaRocks version 3.0.3

Dennis Schridde
@devurandom

@devurandom you might have more luck sending an email

@Tieske: Thanks, that worked!

iThorgrim.exe
@iThorgrim

Hello,

Since the last time I still haven't managed to build my application with LuaRocks.

If someone would be available to give me a little tutorial, I'm interested. I explain my problem:

I used LuaRocks to install a module, now I would like to create an executable for my software, but I can't generate it with my LuaRocks module.

I have looked everywhere, I can't find any guide, no tutorial, nothing that can explain step by step how to do it.

Caleb Maclennan
@alerque
Is the current state of your project FOSS and posted somewhere the whole thing could be looked over?
I would probably compare to some other app that is using LuaRocks to create an executable, but finding one that's a rough match for the other bits will make it easier to compare.
BONNAURE Olivier
@solisoft
Hi there, I'm trying to use lapis with openresty and all my rocks are in ~/.luarocks
but when I run lapis I have that :
~/.luarocks/bin/lapis serve
nginx: [alert] lua_code_cache is off; this will hurt performance in /Users/olivierbonnaure/workspace/fasty/nginx.conf.compiled:33
nginx: [error] init_by_lua error: init_by_lua:4: module 'ltn12' not found:
none of my rocks are available for openresty
OSX apple M1
Thijs Schreijer
@Tieske
@iThorgrim-Hub check the lua-mailing list archives. There are utilities that pack everything up into 1 executable file. An alternative, more dynamic, approach would be to ship laurocks with your application, have LuaRocks install everything in a tree within your app structure, and the use a "relative require" (Penlight has some stuff for that) to load the modules
@solisoft you need to update your LUA_PATH settings such that OpenResty looks in the right places. With OpenResty you can use: https://github.com/openresty/lua-nginx-module#lua_package_path to set it
Alex Guzun
@alexguzun

Hi there! Is everything ok with luarocks? Your build pipelines are failing with failures fetching rock files:
Example:
Error: Failed installing dependency: https://luarocks.org/kong-plugin-grpc-web-0.2.0-0.src.rock - Could not fetch rock file: Error fetching file: Failed downloading https://luarocks.org/kong-plugin-grpc-web-0.2.0-0.src.rock - kong-plugin-grpc-web-0.2.0-0.src.rock

The failing fetch is allways different

Thijs Schreijer
@Tieske
I noticed this too, usually with a "wantread" in the error message
solares
@solares
I'm trying to luarocks install http (on a dockerized Ubuntu), and it complains cqueues 20200726.54-0 depends on lua 5.4 (5.4-1 provided by VM). How can I satisfy lua 5.4 requirements? My docker image is 5.4.3, but reports 5.4-1. TIA anyone who can help.
Hisham Muhammad
@hishamhm
@solares is your installation failing? in other words, is it complaining that message or is it merely informing? :)
also, to anyone experience intermittent download failures, please make sure you upgrade to the latest LuaRocks 3.7.0, which has better handling of mirrors
solares
@solares
@hishamhm hello. It's failing. Final error is executor failed running [/bin/sh -c luarocks install http]: exit code: 1
Hisham Muhammad
@hishamhm
I don't think the depends on lua 5.4 message is the cause though, can you post the full output in a gist?
solares
@solares
> luarocks --version /usr/local/bin/luarocks 3.7.0
solares
@solares
@hishamhm
solares
@solares
Got past that bug. I added apt install m4 and apt install cqueues before luarocks install http.
Hisham Muhammad
@hishamhm
apt install cqueues shouldn't have been necessary, apt install m4 would have been sufficient
EduardasMeile
@EduardasMeile
@hishamhm Hello. Can you comment on the state of the Keplerproject codebase? I saw you had commits there. Me and my colleagues are using this stuff in production, but have concerns about things like WSAPI being dead projects.
solares
@solares

apt install cqueues shouldn't have been necessary, apt install m4 would have been sufficient

Thanks for the tip.

Hisham Muhammad
@hishamhm
@EduardasMeile some of the projects are indeed abandoned and looking for maintainers. I try to help out merging PRs and the like for projects for which I have commit access and some familiarity, but indeed there is no active development/roadmap for various of these projects.
Some orphaned Lua projects are now finding a new home at https://github.com/lunarmodules where a team of volunteers are helping to give a baseline of maintenance to them. Help is definitely welcome there! Also, if you're wondering about the status of any particular project in the keplerproject repo, I recommend opening an issue asking about it and seeing if you get a response (I don't know the exact status of each single project myself)
EduardasMeile
@EduardasMeile
@hishamhm Thank you for answering. Do you know if there is a reasonable replacement for WSAPI in the lua ecosystem that is actually being maintained? What is the preferred way of integrating a Lua web app with nginx (it does not support CGI natively)? The only way I got some WSAPI-based scripts to work with nginx is by using fcgiwrap and FastCGI. Perhaps you know of a better alternative?
Hisham Muhammad
@hishamhm
@EduardasMeile specifically about WSAPI, not that I'm aware of. I know that cgilua is used in production at PUC-Rio, so it continues to be maintained. As for alternatives, OpenResty is a currently-maintained package for running Lua+nginx (which includes its own nginx distribution), but it uses a different API, so your scripts would probably have to be ported over.
EduardasMeile
@EduardasMeile
@hishamhm Perhaps I am interpreting it wrong, but it really sounds like doing web apps specifically in Lua in 2021 is a bad idea?
We use Lua at my dayjob on embedded systems because of the small interpreter size and that is why WSAPI and such have been used historically.
but Xavante has no SSL support as far as I know
so we have recently started looking into a replacement
Hisham Muhammad
@hishamhm
OpenResty is actively maintained, and it's used in large projects such as Kong ( konghq.com ) — if your embedded system is big enough for nginx, it should be able to handle OpenResty.
EduardasMeile
@EduardasMeile
@hishamhm Isn't OpenResty more about extending nginx and making the webserver itself scriptable rather than writing more general Lua web apps?
Hisham Muhammad
@hishamhm
from what I can tell, it isn't lower level than WSAPI...
looks like there was even a bridge once: https://github.com/ignacio/wsapi-openresty
EduardasMeile
@EduardasMeile
unlike regular nginx that has a bitbake recipe, I'd need to make this cross-compile myself somehow, which might turn out to be a non-trivial task
a lot of projects do not support cross-compilation properly (nginx included) and need to be patched