Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 11 07:59
    netpipe commented #332
  • Jun 11 11:40
    luc-github commented #380
  • Jun 11 11:39
    luc-github commented #380
  • Jun 11 11:39
    luc-github commented #380
  • Jun 11 11:38
    luc-github commented #380
  • Jun 11 11:37
    luc-github commented #380
  • Jun 11 11:12
    ybott commented #380
  • Jun 11 05:57
    luc-github commented #380
  • Jun 11 05:33
    ybott commented #380
  • Jun 04 07:20
    stale[bot] unlabeled #380
  • Jun 04 07:20
    luc-github labeled #380
  • Jun 02 17:08
    stale[bot] labeled #380
  • Jun 02 17:08
    stale[bot] commented #380
  • May 27 04:22
    luc-github locked #381
  • May 27 04:22
    luc-github closed #381
  • May 27 04:20
    luc-github locked #372
  • May 27 04:20
    luc-github closed #372
  • May 05 21:09
    cirvladimir closed #384
  • May 05 21:09
    cirvladimir commented #384
  • May 05 20:33
    luc-github commented #384
Luc
@luc-github
if you have only one Fan/extruder/filament then you have a Davinci 1.0
if you have a J37 then it is a Davinci 1.0a
Jordan R Thompson
@jorythompson
Makes sense, the first screen says DA VINCI 1.0
So I can use the latest version of repetier?
Luc
@luc-github
so yes you need to compile according these settings to use this repository FW or use the corresponding binary in release
do not use the original repetier it won't work
Jordan R Thompson
@jorythompson
I didn't realize there was a pre-compiled binary... where is that located?
Luc
@luc-github
in release of github
Jordan R Thompson
@jorythompson
I have only found the source code for it here:https://github.com/luc-github/Repetier-Firmware-4-Davinci/releases/tag/v0.92.10rc4. I guess that is close enough
Luc
@luc-github
yes binaries are in zip
Jordan R Thompson
@jorythompson
Awesome! Is there a quick install guide (or even a slow-install one :-)
Luc
@luc-github
did you checked the readme and the FAQ (linked in readme) ?
Jordan R Thompson
@jorythompson
Found it. Thanks very much for your help!
Luc
@luc-github
have fun ^_^
Jordan R Thompson
@jorythompson
How badly can I mess up the printer if I get the wrong firmware installed?
BTW, the volvito form is no longer there
Luc
@luc-github
yes couple of years is gone
Jordan R Thompson
@jorythompson
Reading some more as I go... Do I need to compile or can I just flash the Davinci-1.0A-v0.92.10rc4.bin binary?
Jordan R Thompson
@jorythompson
I assume that I would use something like bossac to flash it?
Luc
@luc-github
Jordan R Thompson
@jorythompson

the FAA says to use: bossac -p <COMXXX> -R -e -w -v -b <yourbinfile>

but -R is no longer supported. What did -R do?

Luc
@luc-github
really I can see it in 1.8 / 1.9.1 and was in older one also I think
image.png
Jordan R Thompson
@jorythompson
OK - found it and you are correct, -R is there.
Luc
@luc-github
good
Jordan R Thompson
@jorythompson
I reset the firmware and tried installing but got this:

D:\Program Files (x86)\BOSSA>bossac -p com5 -R -e -v -b Davinci-1.0A-v0.92.10rc4.bin
Erase flash

Done in 0.032 seconds
Verify 206972 bytes of flash
[==============================] 100% (809/809 pages)
Verify failed
Page errors: 809
Byte errors: 204220

Luc
@luc-github
Jordan R Thompson
@jorythompson
I actually read that earlier, but none of the reasons listed affect me (the only possible one could be the USB cable, but I had been using it with the XYZ printing software earlier)
Luc
@luc-github
it does not mean communication is ok due to light close to usb cable or anything that bring interferences
as mentioned in FAQ item : This is not related to FW itself but your installation / hardware (previous FW is no more present and new FW is not yet active)
Jordan R Thompson
@jorythompson
I understand. I only mentioned it because the cable worked fine with the xyz software so it should be OK to install the firmware
Luc
@luc-github
I cannot say more sorry
can of course be due to damaged flash
Jordan R Thompson
@jorythompson
I rebooted, installed 1.5.8 and was able to flash repetier 0.92
Luc
@luc-github
great
Jordan R Thompson
@jorythompson
thanks for your help
... and hand-holding :-)
Luc
@luc-github
You are welcome Happy printing