These are chat archives for luyadev/luya

25th
Jun 2016
hakabe
@hakabe
Jun 25 2016 02:25
Your website seems to be down.
hakabe
@hakabe
Jun 25 2016 03:10
I'm trying to run this with WAMP-stack, but I'm getting 500 error. It works without .htaccess, so what apache modules do I need with this? Also can you update Windows Install/Upgrade section to current release 1.0dev?
Basil
@nadar
Jun 25 2016 05:42
Currently the luya rquires the apache mod_rewrite module. The current release is beta7. The 1.0@dev is only an branch alias in order to get the latest dev-master.
hakabe
@hakabe
Jun 25 2016 05:45
Thanks for the swift reply. I've have mod_rewrite enabled so that can't be it. Maybe WAMP-stack and its VHost.conf needs some tuning.
Basil
@nadar
Jun 25 2016 05:47
You could run this script so i can help you to debug:
Setup, import and migrate commands have you run successfull?
hakabe
@hakabe
Jun 25 2016 05:54
Setup, import and migrate commands have you run successfull?
Yes, both were successful.
1: [in_array('mod_rewrite', apache_get_modules())] true
2: [ini_get('short_open_tag')] ''
3: [ini_get('error_reporting')] '32767'
4: [phpversion()] '7.0.0'
5: [php_ini_loaded_file()] 'C:\\wamp64\\bin\\apache\\apache2.4.17\\bin\\php.ini'
6: [php_sapi_name()] 'apache2handler'
Basil
@nadar
Jun 25 2016 05:58
Maybe makre sure short open tag is enabled. Also check if the virtual host template is correct (AllowOverride All) - http://stackoverflow.com/questions/12272731/using-mod-rewrite-with-xampp-and-windows-7-64-bit
Does the kixkstarter application loads? Or is the problem onl when requesting the admin?
hakabe
@hakabe
Jun 25 2016 06:16

Kickstarter loads after removing .htaccess, but can't access admin without rewrites. With .htaccess both shows 500.
Problem was in the .htaccess file.

[core:alert] [pid 220:tid 1140] [client ::1:62208] C:/wamp64/www/luya/luya-kickstarter/public_html/.htaccess: Invalid command 'IndexIgnore', perhaps misspelled or defined by a module not included in the server configuration, referer: http://luya.dev/'

It seems that in Apache 2.4 IndexIgnore need mod_autoindex. The following scenario worked.

<ifModule mod_autoindex.c>
IndexIgnore */*
</ifModule>

Edit: Sorry I'm new here and seems that I'm not so good using these tags.

Basil
@nadar
Jun 25 2016 06:44
Maybe we should add this to the documentation.
Basil
@nadar
Jun 25 2016 06:50
Like an FAQ in the windows Installation part. "Getting 500 Error" @hakabe maybe you could help others too.
hakabe
@hakabe
Jun 25 2016 06:54
@nadar
Yes, that would be good. Helping others sounds like fun!