These are chat archives for luyadev/luya

22nd
Aug 2016
kovalin
@kovalin
Aug 22 2016 05:35

@nadar i edit my fille luya-kickstarter\vendor\luyadev\luya-module-admin\src\base\Filter.php
(del) abstract public static function identifier();
(add) public static function identifier();

php index.php import
PHP Fatal error: Non-abstract method admin\base\Filter::identifier() must contain body in D:\OpenServer\domains\luya\luya-kickstarter\vendor\luyadev\luya-module-admin\src\base\Filter.php on line 40
PHP Compile Error 'yii\base\ErrorException' with message 'Non-abstract method admin\base\Filter::identifier() must contain body'

in D:\OpenServer\domains\luya\luya-kickstarter\vendor\luyadev\luya-module-admin\src\base\Filter.php:40

Stack trace:

#0 [internal function]: yii\base\ErrorHandler->handleFatalError()

#1 {main}

Basil
@nadar
Aug 22 2016 06:43
Just change your composer packages to require the dev versions of luya and its module s and run composer update.
kovalin
@kovalin
Aug 22 2016 06:44
@nadar thanks for the reply, I updated the compositor, but maybe something went wrong.
Basil
@nadar
Aug 22 2016 06:45
Require ^1.0@dev link in the link above and run composer update
Basil
@nadar
Aug 22 2016 08:08
You can also create a new project with ^1.0@dev version like this:
composer create-project luyadev/luya-kickstarter:^1.0@dev