Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Martin Beták
    @matobet
    @jelkosz you won't believe it but oVirt REST api supports the following header: "Accept: application/json; detail=statistics+nics+disks" that returns the subcollections embedded in the VM response :) https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.0/html-single/REST_API_Guide/#sect-REST_API_Guide-Common_Features-Collections-Listing_Resource_Subcollections
    and it seems to have been supported since ovirt 3.0
    I already posted patch to exploit this in moVirt
    Tomas Jelinek
    @jelkosz
    wow, that's an interesting development :D
    Martin Beták
    @matobet
    yeah, doctor rest took a slight hit in terms of its future usefulness ....
    Martin Beták
    @matobet
    Hi all: I pushed a patch upgrading our dependencies from the deprecated suppor v4 library to v7. You will be probably required by android studio to download new minor release of platform tools.
    Martin Beták
    @matobet
    Cluster drawer is NO LONGER TRANSPARENT!!! I still cannot believe it :D
    Tomas Jelinek
    @jelkosz
    @/all Just created the v1stable branch - only stabilizing fixes should go to this branch so the master can contain all the bleeding edge changes
    Tomas Jelinek
    @jelkosz
    @/all hey all, I have created a release candidate - if you have some time please test it: https://github.com/matobet/moVirt/blob/master/moVirt/moVirt-debug-candidate.apk?raw=true
    @/all it contains all the new code from the current master - it seems stable enough to be tested
    Tomas Jelinek
    @jelkosz
    @/all ok, so first issue I found - after movirt restart the trusted CA was not properly set to the connection factory and the user had to re-login explicitly. It is fixed but the new build not done yet
    Tomas Jelinek
    @jelkosz
    @/all ok, so no new bugs found - released. Going to write some mail about it to users list
    Martin Beták
    @matobet
    @jelkosz I'm reviewing @zyx0225 patch for host actions and I notice that we have a nice way of determining wheter an action should be enabled in given entity status: see Vm.Command
    but for some reason the values of this enum appear to be unused anywhere in the current code :D
    I would suggest using this style for future status dependant commands and ideally making the VM ones work... what do you think @jelkosz ?
    Tomas Jelinek
    @jelkosz
    @matobet - completely agree - certainly better than a big if-else block
    @matobet could you please also add the comment to the patch?
    Martin Beták
    @matobet
    Ok I'll also make a new issue to properly utilize the Vm.Command
    Martin Beták
    @matobet
    created #68
    Frantisek Kobzik
    @hustodemon
    yoyo, whatup. is rdp client finally working in movirt?
    Tomas Jelinek
    @jelkosz
    @hustodemon glad you asked!
    @hustodemon when are you delivering the SPICE over SSL?
    jniederm
    @jniederm
    @hustodemon Hi, I'd like to ask, what is the format of signed websocket proxy ticket expected by the proxy?
    @hustodemon Is it really base64 encoded JSON that contains 'data' property which is url-encoded JSON string? (This is the format returned by SignStringQuery.)
    Frantisek Kobzik
    @hustodemon
    @jelkosz ouch...that hurts
    @jniederm seems like so, but i'm not sure about it. i need to checkout the sources.
    Tomas Jelinek
    @jelkosz
    @hustodemon we are working on it anyway :) Will tell you to review it when done
    cfrancio
    @cfrancio
    Hi, I just installed the app but I'm receiving a "returned token is empty" error when trying to connect
    On the other hand it seems the apk is version 1
    Any way to access last test version?
    Tomas Jelinek
    @jelkosz
    Hi, first of all the link to the apk here was outdated and we have forgotten to change after we published movirt to the play store - I have just fixed it
    than, the "returned token is empty" seems like there is some problem with the authentication - please make sure that the user name is in form "admin@internal" (e.g. don't forget to add the domain).
    2: please make sure the API URL is correct - e.g. it has the https:// at the beginning, the port :443 properly set and the /ovirt-engine/api properly added to the end. Also please make sure the url resolves properly to the engine from some browser on the same device (e.g. the url is correct and you are on the proper network)
    3: if you are using https (and not http) which you most probably do, please make sure that in the advanced settings under connection settings you have the certificate properly set (you can for testing purposes pick the "ignore certificate checking", if works, than you can pick the "trust specific certificate," download it and store)
    Tomas Jelinek
    @jelkosz
    @cfrancio after this it should work - please let me know how did you end up :)
    cfrancio
    @cfrancio
    Hi jelkosz, 1 and 2 are checked and ok. The answer for a mistake on this parameters is different (401 )
    I'm using the "Trust Specific Certificate" option
    Enforce HTTP Basic Auth is unchecked
    Tomas Jelinek
    @jelkosz
    @cfrancio there is also a chance that you have a custom certificate signed by a custom certificate which is not supported by movirt currently. Or, other option, in 3.5. oVirt engine there was a (recent) bug that the certificate was not generated properly during setup. It has been fixed and backported so if you update the engine it should ask you for re-generating the certificate
    @cfrancio or you can as a quick check try to ignore the certificate checking
    Martin Beták
    @matobet
    @jelkosz Hi I made an attempt to cut down the "pyramid of doom" of callbacks inside of SyncAdapter, I would be interested in your opinion on #128