Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 09:34
    bkueng commented #7941
  • 09:31
    bkueng synchronize #7941
  • 09:31

    bkueng on px4_motor_test

    MotorComponent: use same implem… PX4: enable motor test UI (compare)

  • 08:50
    mrivi opened #7944
  • 07:29
    Travis mavlink/qgroundcontrol (pr-mavlink_update) errored (10803)
  • 06:54

    PX4BuildBot on pr-mavlink_update

    Update mavlink v2.0 submodule W… (compare)

  • 04:36
    caleridas commented #7921
  • 04:19
    caleridas commented #7921
  • 00:44
    Antiheavy edited #7903
  • 00:01
    jlecoeur closed #7881
  • 00:01
    jlecoeur commented #7881
  • Oct 22 23:59
    jlecoeur opened #7943
  • Oct 22 21:43
    tilaktilak commented #7903
  • Oct 22 21:01
    tilaktilak commented #7921
  • Oct 22 20:42
    tilaktilak commented #7921
  • Oct 22 20:42
    tilaktilak commented #7921
  • Oct 22 17:00
    DonLakeFlyer commented #7921
  • Oct 22 16:54
    DonLakeFlyer commented #7941
  • Oct 22 16:50
    DonLakeFlyer commented #7941
  • Oct 22 16:46
    DonLakeFlyer commented #7941
DP
@dpbnasika
Hello, I have an issue with QGC detecting the vehicle , I upgraded recently from macOS Mojave to Catalina, Is there any solution for this?
David Sastre
@Davidsastresas
@dpbnasika check if you can manually select the port and connect that way. If so setting that connection to auto connect should work. Sometimes that happens also to me on custom firmwares for custom boards
In linux
I am giving travis a try, it runs fine but at the moment of deploy it states this:
Skipping a deployment with the s3 provider because this is not a tagged commit
Skipping a deployment with the releases provider because a custom condition was not met
I definitely need a lot of additional knowledge about CI scripts and all that, I am pretty new to it, but before studying deeply all that, do any of you know how to solve it?
Don Gagne
@DonLakeFlyer
All of that deploy stuff is specific to QGC CI. You are going to want to remove that and replace it with your own stuff to put the build results somewher.
DP
@dpbnasika
@Davidsastresas how can I connect the device to QGC via a terminal ?
William Barker
@wjbarker
Version question: 1.3.79 (yesterday) is the latest and 3.5.4 is previous? Not making sense to me.
Gus Grubba
@dogmaphobic
No, that was a bad tag that got inserted and the build system picked it up automatically as a consequence.
Don Gagne
@DonLakeFlyer
Did it trash Stable dropson S3?
Gus Grubba
@dogmaphobic
I don’t know what the build system does with these automatic builds...
Don Gagne
@DonLakeFlyer
@wjbarker Are you seeing the Stable build downloads as screwed up now with respect to being a 1.3.79 build instead of 3.5.4?
Yes, they are screwed up.
William Barker
@wjbarker
1.3.79 was listed as latest stable release. now it's gone
Don Gagne
@DonLakeFlyer
S3 drops got hosed because of this.
I'm going to need to do a point release to fix it.
Don Gagne
@DonLakeFlyer
I have a couple Stable things going through now. After that I'll mark a new release.
David Sastre
@Davidsastresas
Thank you
@dpbnasika Qgroundcontrol icon/comm links/add. There you go!
DP
@dpbnasika
@Davidsastresas , yes I tried it yesterday i tried and it was working now , seems there is a problem in auto connect , I saw in the link manger console, it is stuck at auto connecting to the device.
@Davidsastresas thank you
XBStation
@XBStation
Having a nice dat, i need Qgroundcontrol white labeled application to custom, please tell me how can i do it. Thank you
verse-y
@verse-y
How can I modify qgc to control multiple drones
nmr86
@nmr86
Hi! I tried to compile qgroundcontrol 3.5.5 with qt 5.13, ndk 19, jdk 1.8.0-192 and it get a lot of errors like : W System.err: at android.content.res.AssetManager.open(AssetManager.java:397)
W System.err: at org.qtproject.qt5.android.bindings.QtLoader.copyAsset(QtLoader.java:362)
app start with white screen(
what a do wrong?
Don Gagne
@DonLakeFlyer
You didn't follow the build instructions which say this: Qt version: 5.11.3 (only)
Muppavaram Sai Raghavendra
@Raghava248

Error while running qgroundcontrol.pro in qt creator ..16:37:54: Running steps for project qgroundcontrol…

16:37:54: Configuration unchanged, skipping qmake step.

16:37:54: Starting: “C:\Qt\Qt5.11.3\Tools\QtCreator\bin\jom.exe”

C:\Qt\Qt5.11.3\Tools\QtCreator\bin\jom.exe -f Makefile.Debug

C:\Qt\Qt5.11.3\5.11.3\msvc2015\bin\rcc.exe -name qgroundcontrol “C:\Users\Vamshi Goud\qgroundcontrol\qgroundcontrol.qrc” -pass 1 -o C:/Users/Vamshi Goud/build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug/rcc/qrc_qgroundcontrol.cpp

C:\Qt\Qt5.11.3\5.11.3\msvc2015\bin\rcc.exe: File does not exist ‘Goud/build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug/rcc/qrc_qgroundcontrol.cpp’

jom: C:\Users\Vamshi Goud\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile.Debug [rcc\qrc_qgroundcontrol.obj] Error 1

C:\Qt\Qt5.11.3\5.11.3\msvc2015\bin\rcc.exe -name qgcresources “C:\Users\Vamshi Goud\qgroundcontrol\qgcresources.qrc” -pass 1 -o C:/Users/Vamshi Goud/build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug/rcc/qrc_qgcresources.cpp

C:\Qt\Qt5.11.3\5.11.3\msvc2015\bin\rcc.exe: File does not exist ‘Goud/build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug/rcc/qrc_qgcresources.cpp’

jom: C:\Users\Vamshi Goud\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile.Debug [rcc\qrc_qgcresources.obj] Error 1

jom: C:\Users\Vamshi Goud\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile [debug] Error 2

16:37:59: The process “C:\Qt\Qt5.11.3\Tools\QtCreator\bin\jom.exe” exited with code 2.

Error while building/deploying project qgroundcontrol (kit: Desktop Qt 5.11.3 MSVC2015 32bit)

When executing step “Make”

16:37:59: Elapsed time: 00:04.

Please help me with this

Don Gagne
@DonLakeFlyer
File does not exist ‘Goud/build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug/rcc/qrc_qgroundcontrol.cpp’
Note the file name doesn't include the full path. Maybe a problem with spaces in the directory name? Fully delete build directory and try again. Might work.
Gus Grubba
@dogmaphobic
"C:\Users\Vamshi Goud\qgroundcontrol\qgcresources.qrc”
It’s definitely an issue with spaces in the path.
Muppavaram Sai Raghavendra
@Raghava248
ok ill try thank you
Muppavaram Sai Raghavendra
@Raghava248
I got an error while building qgroundcontrol.pro ....................................................link /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='' processorArchitecture=''" /VERSION:0.0 /MANIFEST:embed /OUT:debug\QGroundControl.exe @C:\Users\VAMSHI~1\AppData\Local\Temp\QGroundControl.exe.3064.638219.jom
LINK : fatal error LNK1104: cannot open file 'z.lib'
jom: C:\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile.Debug [debug\QGroundControl.exe] Error 1104
jom: C:\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile [debug] Error 2
11:41:04: The process "C:\Qt\Qt5.11.3\Tools\QtCreator\bin\jom.exe" exited with code 2.
Error while building/deploying project qgroundcontrol (kit: Desktop Qt 5.11.3 MSVC2015 32bit)
When executing step "Make" Please help me
11:41:04: Elapsed time: 12:54.
@dogmaphobic Thank you
@DonLakeFlyer Thank you
William Barker
@wjbarker
Previous version had actions available in guided mode (continue mission and change altitude). Current version action button is not available. Is there a configuration item somewhere?
Don Gagne
@DonLakeFlyer
It should work the same as before. Pause and Actions share the same slot. The Action button only shows up when the vehicle is paused.
William Barker
@wjbarker
puase is not there in current version
action is there but is greyed out
Don Gagne
@DonLakeFlyer
Are you flying fixed wing? Might be a bug which relates to disabling Pause during landing approach
William Barker
@wjbarker
fixed wing
Don Gagne
@DonLakeFlyer
Action will only enable if Continue or Change altitude are valid options at the current time. Might be some specific state causing it to go wrong. If so, enter a detailed Issue with exact repro steps. I tried a fixed wing and multi-rotor SITL PX4 and it seemed to work fine.
William Barker
@wjbarker
multi rotor same thing for me
I am using mission planner simulation so I can switch between old and new QGC versions while flying.
William Barker
@wjbarker
Pause button is not there in any mode. (not even greyed out, just missing)
Even before connect. Previous version has greyed out pause button, totally missing in current version.
William Barker
@wjbarker
OK, it looks this problem exists with any version I compiled myself. If I download the install package it works fine for same version. I am missing something when I compile.
Don Gagne
@DonLakeFlyer
That seems odd. Not sure how that could get screwed up.
Muppavaram Sai Raghavendra
@Raghava248
I got an error while building qgroundcontrol.pro ....................................................link /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='' processorArchitecture=''" /VERSION:0.0 /MANIFEST:embed /OUT:debug\QGroundControl.exe @C:\Users\VAMSHI~1\AppData\Local\Temp\QGroundControl.exe.3064.638219.jom
LINK : fatal error LNK1104: cannot open file 'z.lib'
jom: C:\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile.Debug [debug\QGroundControl.exe] Error 1104
jom: C:\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\Makefile [debug] Error 2
11:41:04: The process "C:\Qt\Qt5.11.3\Tools\QtCreator\bin\jom.exe" exited with code 2.
Error while building/deploying project qgroundcontrol (kit: Desktop Qt 5.11.3 MSVC2015 32bit)
When executing step "Make" Please help me
11:41:04: Elapsed time: 12:54. @wjbarker @DonLakeFlyer @dogmaphobic
Muppavaram Sai Raghavendra
@Raghava248
I some how resolved my previous error but this popped up again while trying to compile qgroundcontrol.pro in qtcreator please help me with this please help me regading this
c1xx:-1: error: C1033: cannot open program database ‘C:\build-qgroundcontrol-Desktop_Qt_5_11_3_MSVC2015_32bit-Debug\obj\QGroundControl.vc.pdb’