Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 25 14:02
    Yatin-Khurana commented #45
  • May 24 23:33
    juvinski commented #47
  • May 17 10:23
    safinwb commented #47
  • May 17 04:49
    juvinski commented #47
  • May 13 10:18
    Seeelefant commented #47
  • May 12 10:13
    safinwb commented #47
  • May 08 21:44
    Seeelefant commented #47
  • May 08 06:28
    juvinski commented #47
  • May 06 15:15
    Seeelefant commented #47
  • May 06 13:33
    juvinski commented #47
  • May 06 07:33
    Seeelefant commented #47
  • May 06 05:01
    juvinski commented #47
  • May 05 15:27
    juvinski commented #47
  • May 05 12:01
    50-sys commented #47
  • May 05 11:00
    50-sys commented #47
  • May 04 18:34
    50-sys commented #47
  • Mar 15 22:48
    Seeelefant commented #47
  • Mar 15 22:47
    Seeelefant edited #47
  • Mar 15 05:02
    timtuxworth commented #47
  • Mar 12 22:23
    Seeelefant commented #47
irwin riolinus
@irwinr89_twitter
does the FrSky OpenTX telemetry (Serial opt 10) work on BB? I thought I read that it wasnt supported
Vinicius Juvinski
@juvinski
I believe the main question is the inverted signal of the frsky telemetry
SERIALx_OPTIONS =160 (enable pull-up/pull-downs on TX and RX pins for those external inverter circuits that may require it)
irwin riolinus
@irwinr89_twitter
am using the Yaapu telemetry kit, i believe has inverter in it https://www.amazon.com/gp/product/B07KJFWTCB/
Vinicius Juvinski
@juvinski
So you just need to connect on one of serial ports (4 or 5) and set the correct baudrate and function, should work
irwin riolinus
@irwinr89_twitter
so am confused about Serial4....the bblue schec only shows physical ports for UART0, 1 and 5 (am using UART5 for Frsky Telem but no data so far)
where is 4?
i also cant get the airspeed sensor to work on I2C port, this is first time am running plane on bbblue
irwin riolinus
@irwinr89_twitter
image.png
i have I2C defined on uenv.txt
Vinicius Juvinski
@juvinski
The airspeed configuration is done in the parameter
You must select the digital option and on pin if I not wrong 64 or 65
Don’t need to change nothing in the code
irwin riolinus
@irwinr89_twitter
so i comment this line on uEnv.txt ?? --> dtb_overlay=/lib/firmware/BB-I2C1-00A0.dtbo
irwin riolinus
@irwinr89_twitter
pin 65 didnt work, pin 64 must be conflicting with IMU because horizon is all over the place with that one and speed is supersonic!
Vinicius Juvinski
@juvinski
No, you need to let the i2c line at uEnv
All sensors I vou is using i2c
Imu and baro
What I don’t remember is if the connector available is the same i2c of the baro and imu or if you need to load the i2c2 to enable the second i2c bus to use the board connector
irwin riolinus
@irwinr89_twitter
ill try i2c2
irwin riolinus
@irwinr89_twitter
no good
Vinicius Juvinski
@juvinski
But on i2cdetect you see the airspeed?
And have you enabled the i2c2 on the uEnv file ?
irwin riolinus
@irwinr89_twitter
yea...it cant detect airspeed neither a compass if I connect it
irwin riolinus
@irwinr89_twitter
the compass and airspeed are good and wired correctly, they work fine on my pixhawk4
Vinicius Juvinski
@juvinski
hi @irwinr89_twitter , I was looking the schematic
the mpu and baro is connected to the I2c2
image.png
and the connector available is the I2c1
image.png
what kernel version are you using ?
irwin riolinus
@irwinr89_twitter
am running the latest image on the beaglebone site (10.3) and kernel 4.19.191-bone-rt-r67
irwin riolinus
@irwinr89_twitter
if its I2C1 then is this error normal?
root@beaglebone:/home/debian# i2cdetect -r -y 1
Error: Could not open file /dev/i2c-1' or/dev/i2c/1': No such file or directory
set_
@silver2row
sometimes things change. Have you looked in /dev/bone/i2c?
Also... try to install libi2c-dev. This may help but I am not certain.
set_
@silver2row
I bring those two items up for one. B/c... w/ newer kernels and images, there are some differences and I need to figure things out too!
And secondly, who knows? We may learn from one another?
I found this through the beagleboard.org forums.
Nice! You guys updated a bunch!
Victor
@victor999
Is it normal for ESC to beep constantly (short beeps) from connecting the battery (power to BBBlue) and until arducopter started. Then I hear some sort of musical beeping. Beaglebone blue, I didn't fly yet.
set_
@silver2row
No.
Not unless you are calibrating your ESCs, then the beeps and musical beeps are then warranted.
I was reading the docs. It seems that while the calibrations of the ESCs are taking place, the beeps then take place.
Vinicius Juvinski
@juvinski
Hi, it's depend of the esc firmware.
I have some hobbywing what does this beeps until arducopter starts - around 1 minute since the board start
I have some esc - like hobbywing 4 in 1 esc that doesn't work with beagles - the firmware wait for some pwm pulses when are powered up, if not receive any pwm signal simply shutdown and is useless using with arducopter
Victor
@victor999
I am trying to connect to r-xsr telemetry. Flashed with ACCESS last version, set receiver mode SPORT. I connected SPORT uninverted pad to UART1 TX and set SERIAL_OPTIONS=10. What am I missing?