These are chat archives for mirumee/saleor

10th
Jan 2018
maltitco
@maltitco
Jan 10 2018 08:03
@patrys Thanks for the info I will check it.
maltitco
@maltitco
Jan 10 2018 11:16
@patrys I tested it and it is as I wrote earlier - no return to the store, and no change in the payment status.
Patryk Zawadzki
@patrys
Jan 10 2018 11:24
are you sure the Sites framework is configures correctly? it will default to example.com
you could check the data that is sent to the gateway before it gets submitted
maltitco
@maltitco
Jan 10 2018 11:34
@patrys I installed django-payments, I added DotPay configuration to the settings
in which file should I change it?
Patryk Zawadzki
@patrys
Jan 10 2018 11:35
in your database
maltitco
@maltitco
Jan 10 2018 11:35
ok
Patryk Zawadzki
@patrys
Jan 10 2018 11:35
visit the site settings in dashboard
and verify that the domain matches your public domain (ie. ngrok or your production site)
maltitco
@maltitco
Jan 10 2018 11:35
I changed there
yes i use ngrok and it works
Patryk Zawadzki
@patrys
Jan 10 2018 11:36
are you using HTTPS?
if so make sure PAYMENT_USES_SSL is correct
maltitco
@maltitco
Jan 10 2018 11:36
I missed it
I will check and let you know, thank you.
Patryk Zawadzki
@patrys
Jan 10 2018 11:37
otherwise Dotpay will try to reach you over HTTP which may not work
(or it could be the other way around where it tries to use HTTPS but site only supports HTTP)
maltitco
@maltitco
Jan 10 2018 11:55
PAYMENT_USES_SSL = True, and still does not work
additionally I checked with PAYMENT_USES_SSL = False, but it's the same
maltitco
@maltitco
Jan 10 2018 12:39
@patrys I think I found what is wrong, I will describe it in this issues: mirumee/django-payments#159