These are chat archives for mithriljs/mithril.js

1st
Oct 2015
Gilbert
@gilbert
Oct 01 2015 02:07
@Papipo I recommend adding the class yourself, if possible. It'd be pretty trivial
*managing the class
store tab state in the controller, use it in the view
Rodrigo Álvarez
@Papipo
Oct 01 2015 08:31
This message was deleted
Rodrigo Álvarez
@Papipo
Oct 01 2015 19:43
This message was deleted
This message was deleted
This message was deleted
sector119
@sector119
Oct 01 2015 20:34
Hello! I try to use polythene, but have some problems.. Can't "import tabs from 'polythene/tabs/tabs'" get Failed to load resource: the server responded with a status of 404 (Not Found) http://localhost:8080/lib/npm/polythene@0.1.3/tabs/tabs.js
And there is no tabs/tabs.js it's at lib/npm/polythene@0.1.3/lib/tabs/tabs.js
All docs use imports from polythene/tabs/tabs..
I use system.js + jspm
Einar Norðfjörð
@nordfjord
Oct 01 2015 20:49
what does your import statement look like?
sector119
@sector119
Oct 01 2015 21:00
@nordfjord import tabs from 'polythene/tabs/tabs';
Einar Norðfjörð
@nordfjord
Oct 01 2015 21:01
isn't the problem then that you should import tabs from 'polythene/lib/tabs/tabs.js' ?
sector119
@sector119
Oct 01 2015 21:03
all examples use 'polythene/tabs/tabs' ((
Isiah Meadows
@isiahmeadows
Oct 01 2015 21:14
This message was deleted
Then Polythene's examples are broken.
Isiah Meadows
@isiahmeadows
Oct 01 2015 21:19
@sector119 See ArthurClemens/Polythene#9. I filed it for you, and your input is more important than mine.
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:20
@sector119 is this in the examples folder or your own code?
sector119
@sector119
Oct 01 2015 21:22
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:22
what’s your systemjs config file?
sector119
@sector119
Oct 01 2015 21:22
one sec
@ArthurClemens https://dpaste.de/TGGJ
I tried to add /lib and lib/theme after pkg name, but it broke other things
Isiah Meadows
@isiahmeadows
Oct 01 2015 21:27
Okay. That's just weird.
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:28
I’ve tried to stay away from jspm
So I haven’t tested it
but apparently you can put /theme in the polythene-theme path
does this problem only happen with tabs?
sector119
@sector119
Oct 01 2015 21:30
I tried tabs only ))
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:30
so it is probably broken everywhere
sector119
@sector119
Oct 01 2015 21:34
the same with card
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:34
of course
sector119
@sector119
Oct 01 2015 21:35
I have to exclude jspm and try one more time
from scratch
Isiah Meadows
@isiahmeadows
Oct 01 2015 21:36
@sector119 I indirectly cc'd you on that bug, BTW.
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:37
It would be nice if it worked with jspm
sector119
@sector119
Oct 01 2015 21:38
@ArthurClemens maybe it works and it's my own fault
because i've never used it before systemjs + jspm
sector119
@sector119
Oct 01 2015 21:45
I'll try it without jspm and then with jspm .. but at the morning
thanks a lot!
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:46
let me know what you find
I will try to fix the shelljs bug
Isiah Meadows
@isiahmeadows
Oct 01 2015 21:51
@ArthurClemens Yeah...that made it a little harder for me to do a few smoke tests about this. I went and installed it locally beforehand, and it worked.
Arthur Clemens
@ArthurClemens
Oct 01 2015 21:54
It is difficult to reproduce. Once the package is downloaded and dev-deps installed, I get no error.
Only when doing npm install Polythene the error occurs
I could remove copy-deps from postinstall and make it a separate script.
Then you need to call npm run copy-depsseparately
Isiah Meadows
@isiahmeadows
Oct 01 2015 22:00
Either that or make it work off of the native async APIs, as it's the only thing run in postinstall.
Arthur Clemens
@ArthurClemens
Oct 01 2015 22:00
and I made the change to shelljs to have it run on windows...