These are chat archives for mojotech/pioneer

17th
Nov 2015
Anders
@smedegaard
Nov 17 2015 13:42

Hi guys. I'm trying to install Pioneer with npm install pinoeer --save-dev but I get a lot of errors. I'm running Node 4.2.2
first error reads something like
CXX(target) Release/obj.target/validation/src/validation.o In file included from ../src/validation.cc:15:0: ../node_modules/nan/nan.h:261:25: error: redefinition of ‘template<class T> v8::Local<T> _NanEnsureLocal(v8::Local<T>)’ NAN_INLINE v8::Local<T> _NanEnsureLocal(v8::Local<T> val) {

any clues?

think I just found the main issue here. I missed this line in the output
npm WARN engine cucumber@0.3.3: wanted: {"node":"0.6 || 0.8 || 0.10 || 0.11"} (current: {"node":"4.2.2","npm":"2.14.7"})