These are chat archives for mono/monodevelop

11th
Feb 2016
hellboy81
@hellboy81
Feb 11 2016 07:06
@cra0zy Still cannot help
hellboy81
@hellboy81
Feb 11 2016 07:15

Untrusted HTTP certificate detected

Do you want to temporarily trust this certificate in order to connect to the server at github.com?

How can I undo installing addin in ModoDevelop?
I have issue with installing wakatime
hellboy81
@hellboy81
Feb 11 2016 09:04

OK, Google

An Add-in is causing MonoDevelop to crash at startup, how do I remove it?

The Add-in Manager can be launched independently with the command ‘mdtool gsetup’

P.S. Reinstalling MD helps not

mdtool gsetup crashed
FATAL ERROR [2016-02-11 10:05:11Z]: System.NullReferenceException: Object reference not set to an instance of an object
  at Mono.Addins.Gui.Services.CenterWindow (Gtk.Window child, Gtk.Window parent) [0x00000] in <filename unknown>:0 
  at Mono.Addins.Gui.Services.PlaceDialog (Gtk.Window child, Gtk.Window parent) [0x00000] in <filename unknown>:0 
  at Mono.Addins.Gui.AddinManagerDialog..ctor (Gtk.Window parent) [0x00000] in <filename unknown>:0 
  at Mono.Addins.Gui.AddinManagerWindow.Run (Gtk.Window parent) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Ide.Gui.Dialogs.SetupApp.Run (System.String[] arguments) [0x00000] in <filename unknown>:0 
  at MonoDevelopProcessHost.Main (System.String[] args) [0x00000] in <filename unknown>:0
run in terminal Ubuntu 64 bit
hellboy81
@hellboy81
Feb 11 2016 09:10
cast @Therzok
Matt Ward
@mrward
Feb 11 2016 09:13
You should be able to remove a bad addin by removing the addin database which should be in ~/.cache/MonoDevelop-5.0/addin-db-02
hellboy81
@hellboy81
Feb 11 2016 09:26

Ok, @mrward

Is there also possible to remove plugin with mdtool:

mdtool setup  list
MonoDevelop Add-in Setup Utility
Installed add-ins:
 -* WakaTime 1.0.5*  // This is NOT ID, baut name
mdtool setup uninstall  <here should be ID specified, Where can I find it>
only mdtool setup uninstall can help us
hellboy81
@hellboy81
Feb 11 2016 12:37
Is there possible to run compiled app from MD w/o building ?
hellboy81
@hellboy81
Feb 11 2016 12:53
where can I get MonoDevelop Build Tool error log output (as log file)?
hellboy81
@hellboy81
Feb 11 2016 13:04
In some cases I got problem with Build
/usr/lib/mono/4.5/Microsoft.Common.targets: Error: Command 'copy "/home/local/.../MyApp//Binaries/*.*" "/home/local/../MyApp/bin/Debug/"
copy "/home/local/../MyApp//PUnderProjectFolder/*.txt" "/home/local/../MyApp//PUnderProjectFolder/bin/Debug/"' exited with code: 127.
Toni Spets
@hifi
Feb 11 2016 13:04
is that a custom command
if it's an imported visual studio project
hellboy81
@hellboy81
Feb 11 2016 13:12
OK, this is "PostBuild" commands

if it's an imported visual studio project

correct

Toni Spets
@hifi
Feb 11 2016 13:23
yeah, 'copy' is a windows/dos command
'cp' is the unix equivalent but they have slightly different behaviour
hellboy81
@hellboy81
Feb 11 2016 13:24
where can I find "PostBuild" commands in MD?
hellboy81
@hellboy81
Feb 11 2016 14:19

'cp' is the unix equivalent but they have slightly different behaviour

it can not copy files by mask directly

hellboy81
@hellboy81
Feb 11 2016 15:22
where can I get in MonoDevelop debug output?
due on issues with breakpoints