Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Nov 26 11:44
    tjguk synchronize #2297
  • Nov 24 20:19
    prcutler commented #77
  • Nov 24 20:11
    prcutler synchronize #77
  • Nov 23 14:06
    hoh commented #2295
  • Nov 23 14:06
    hoh closed #2295
  • Nov 23 14:06
    hoh commented #2295
  • Nov 22 14:29
    fmorton synchronize #485
  • Nov 20 17:20
    agilum commented #2331
  • Nov 20 17:20
    agilum commented #2331
  • Nov 20 00:09
    esspe2 commented #2003
  • Nov 20 00:08
    esspe2 commented #2003
  • Nov 19 23:35
    esspe2 commented #2003
  • Nov 18 11:32
    agilum commented #2331
  • Nov 18 10:02
    carlosperate labeled #2355
  • Nov 17 20:00
    KGOrphanides commented #2350
  • Nov 17 19:49
    prcutler commented #77
  • Nov 17 19:40
    ntoll commented #77
  • Nov 17 19:38
    ntoll commented #2350
  • Nov 17 19:34
    carlosperate commented #77
  • Nov 17 18:46
    carlosperate closed #76
Goose
@GooseTheCat8602
Hey, me again. Need help with a second project. It's very very weird. Please don't question it.
```
class sales:
def init(self, Products_Sold):
self.Products_Sold = Products_Sold
if Products_Sold > 534767897323:
print("Good work. ")
elif Products_Sold < 534767897323:
print("Patrick is dissapointed.")
def PatrickMoney(self):
    print("Patrick's Money: 9 Patrickillion")
    print("Last month's Money: 7 PatrickIllion")

def Patrick_Products(self):
    print("Patrick has many products, but his favorite has to be bacon")
    new_products = ["Bacon Bits", "Bacon Cupcakes", "Chocolate Flavored Bacon"]
dang
hold on
# welcome to Patrick's Puppy Portions! #
class sales:
    def __init__(self, Products_Sold):
        self.Products_Sold = Products_Sold
        if Products_Sold > 534767897323:
            print("Good work.")
        elif Products_Sold < 534767897323:
            print("Patrick is dissapointed.")

    def PatrickMoney(self):
        print("Patrick's Money: 9 Patrickillion")
        print("Last month's Money: 7 PatrickIllion")

    def Patrick_Products(self):
        print("Patrick has many products, but his favorite has to be bacon")
        new_products = ["Bacon Bits", "Bacon Cupcakes", "Chocolate Flavored Bacon"]
very weird, but the problem is the last part.
It says it's assigned to, but not used.
the variable, new_products
Goose
@GooseTheCat8602
my bad. Found the problem.
Nicholas Tollervey
@ntoll
Yeah... it just means you've assigned the list to new_products but not actually done anything WITH new_products (therefore, why assign the list to it?)
haleyma
@haleyma
Hi, I used to be able to use Mu on my Windows 10 laptop, but have tried downloading the latest version several times and it will not open. Is this a know issue?
Nicholas Tollervey
@ntoll
@haleyma can you tell us a bit more about what happens..? Any error messages etc...?
samshurp27
@samshurp27:matrix.org
[m]
Hey, I am using a PWMIO function, and I am able to output the right frequency from ItsyBitsy but when I use a battery to power the Itsybitsy, I get a slight decrease in frequency. For example: when I use battery, the output frequency goes from 5Hz to 4.85Hz, or 10Hz to 9.70Hz. How can I resolve this issue?
Nicholas Tollervey
@ntoll
@samshurp27:matrix.org this is a channel for technical questions about Mu - the editor - rather than ItsyBitsy or Circuit/MicroPython. Try their support channels instead..? If you're using an Adafruit board or CircuitPython, they have a wonderful Discord server with plenty of channels in which to find help.
samshurp27
@samshurp27:matrix.org
[m]
@ntoll: Thank you for responding. I would like to rephrase my question. I am using a PWMIO function, but the output frequency I get is 9.70Hz instead of 10Hz. I believe that I can increase the frequency by +0.3 on the code but I can only use integer for frequency. How can I put frequency = 10.3 when it only allows integers. Above is my current code.
rtborg
@rtborg
Hi, I am experiencing serial port disconnect issues with Mu under Ubuntu, using CircuitPython board Feather M4. While the editor is open and the board is running, the connection suddenly drops, and then the board is mapped to a different /dev/ttyACM*. This does not happen when using Windows.image.png
John Hansen
@John-AAU

Hi, I am experiencing strange behavior when using the plotter together with an ESP32 microcontroller. The attached image shows the output of a function that clearly should produce a uniform sawtooth looking plot. The REPL window shows data correct but the plotter is giving a strange shape. The error changes from run to run.

What am I doing wrong?

strange_plotter_behavior.png
Nicholas Tollervey
@ntoll
Hi @rtborg - so I develop Mu on Ubuntu and have never seen nor heard of this behaviour. I wonder if you're writing to the device's filesystem in some way..? Often that causes the board to reboot and may explain the problem you're seeing. (It's never happened to me). If you could let us know what version of Mu you're using and perhaps attach a log file, we'd be able to tell for sure what Mu is seeing.
Nicholas Tollervey
@ntoll
@John-AAU hmm... that's a weird one. I wonder if it might be a timing issue..? Could you perhaps try time.sleep at a different value, and let us know what you observe..?
rtborg
@rtborg
@ntoll I am using Mu 1.1.0.beta.6, not writing to the filesystem. When I figure out how to send a log I'll do it, thanks
Nicholas Tollervey
@ntoll
@rtborg here's the instructions for capturing the logs: https://codewith.mu/en/howto/1.1/read_logs
John Hansen
@John-AAU
Here are two other runs. A slower ( time.sleep(0.2) ) and a faster ( time.sleep(0.002) ). The problem is clearly speed related by it does not go away. If I go faster (and for longer time) I get the "Data Flood Detected" message.
strange_plotter_behavior_slow.png
strange_plotter_behavior_fast.png
samshurp27
@samshurp27:matrix.org
[m]
I have a question regarding how to import a file. I am currently learning a tutorial, and I am using Mu-editor. Below is the code, but I do not know how to import cedargrove (highlighted). Link below is where I can download the file from but not sure how to import the file. Link: https://github.com/CedarGroveStudios/AD9833_ADSR_FeatherWing/tree/master/code
Domingez87
@Domingez87
Hi, how can i add Github library to micropython module? thx for help in advance :P
Carl J. Nobile
@cnobile2012
@Domingez87 If you are using pip for installing you can do something like this: pip install git+https://FullPathToTheGitHubRepo.git.
If you are not using pip then the process is much more complicated but still doable. If there is a setup.py you can run that, but you'll have a learning curve and will have to do a bit of googling.
John Hansen
@John-AAU

Hi, I have tested the strange behavior when using the plotter together with an ESP32 microcontroller with several different devices.
I can't figure out why the problem only seems to present on the NodeMCU-32S. The data in the REPL is correct but the plot is not.
Other devkits show no problem with plotting the correct data (no matter what speed I use).

Device_Test.png

Domingez87
@Domingez87
"elif table['mid-l'] == sign and table['mid-m'] == sign and table['mid-r'] == sign : return True " how can i simplyfy this condition? insted of writting "sign" 3 times...?
Domingez87
@Domingez87
NVM solved :P
YourLastSuprise
@YourLastSuprise
Sigurd Rage
@bluehobo
Hi, I'm having trouble with a fresh install of version 1.1.0 beta 6. The program crashes on first run, virtual environment error. Is that a common error, or due to my setup?
On Win 10, i9 company managed laptop
Battousai the Snacker
@shadowsmythe_twitter
I'm having problems running any of the 1.1.0 Beta x Mu editors. The last version I can get to run is 1.0.3. I've followed the install procedures (https://codewith.mu/en/howto/1.1/install_windows) but I've noticed that the install procedures have a .exe listed but all the install files for windows are .msi. Is there any reason this would be an issue and if so where can I find the .exe?
Jean-Baptiste BUTET
@ashashiwa_gitlab
Hi all :) I have exactly the same issue... do you provide a .exe file instead of MSI ?
Carl J. Nobile
@cnobile2012
@bluehobo and @ashashiwa_gitlab MU is a Python application that is in Beta. I'm not a developer on this project, however, I have been writing Python code for over 20 years. Beta versions are essentially still test versions, so you need a little more experience to work with it. I myself almost never use windows, so I cannot give you specific help on this.
rabbitcreek
@rabbitcreek
I am having trouble installing mu on my m1 mac mini. Open up application and ok the warning and it doesnt open the program...? Any tips?
Tiago Montes
@tmontes
IIRC, the latest beta release fails to run on M1 Macs. Possible solutions: go for the previous beta, check the GitHub issues (there’s a non-official working release, signed by me, there), hold a little while for the next release, which should be a release candidate (confirmed to work on M1 Macs, again) :)
Andy Piper
@andypiper
I have Mu 1.1.0.beta.6 running on a M1 Pro, if that helps?
Ali Jonathan Nabavi
@hourback
Hey, folks! :-) I'm just getting started with Loopback and am having some issues with installation, following the tutorial. Can someone help me directly, or should I just post questions in here?
First of all, I'm having to do this on Windows 10 with a corporate PC so it's pretty painful. The best way I found to proceed with this kind of development is using WSL.
I'm following the tutorial here: https://loopback.io/doc/en/lb4/todo-tutorial.html
Ali Jonathan Nabavi
@hourback
But this isn't working: "lb4 example todo"
I've installed npm in WSL.
ali@anabavix-mobl:/mnt/c/Users/anabavix$ npm i -g @loopback/cli
/usr/bin/env: ‘bash\r’: No such file or directory
Okay, I think I see the issue right now....
Zander Brown
@zbrown:matrix.org
[m]
You seem to be in the wrong place?
Ali Jonathan Nabavi
@hourback
I had to restart my shell for npm to be seen. :-) Sorry!