These are chat archives for mwaylabs/generator-m-ionic

4th
May 2018
pookdeveloper
@pookdeveloper
May 04 13:13

@pookdeveloper
Running on ip-10-2-119-39...
Cloning repository...
Cloning into '/home/gitlab-runner/builds/c9648220/0/project-1'...
Checking out bb82ca24 as master...
Updating/initializing submodules recursively...
$ run "fetch-updates"
Running Stage fetch-updates for Job: 5529444
Checking for build process updates...
$ run "build-app"
Running Stage build-app for Job: 5529444
Parsing ionic.config.json for project settings
Project Settings:
Name: blancinegre
App ID: d86d4afa
Type: ionic-angular
Build script detected in package.json...
$ npm install --quiet --no-optional
npm WARN @angular/animations@5.2.10 requires a peer of @angular/core@5.2.10 but none was installed.
npm WARN bootstrap@4.1.0 requires a peer of popper.js@^1.14.0 but none was installed.

up to date in 5.327s
$ npm install --quiet --no-optional success
$ npm run build
npm info it worked if it ends with ok
npm info using npm@5.3.0
npm info using node@v8.2.1
npm info lifecycle blancinegre@0.0.1~prebuild: blancinegre@0.0.1
npm info lifecycle blancinegre@0.0.1~build: blancinegre@0.0.1

blancinegre@0.0.1 build /usr/src/app
ionic build

ionic-app-scripts build
/usr/src/app/node_modules/node-sass/lib/binding.js:15
throw new Error(errors.missingBinary());
^

Error: Missing binding /usr/src/app/node_modules/node-sass/vendor/linux-x64-57/binding.node
Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 8.x

Found bindings for the following environments:

  • OS X 64-bit with Node.js 8.x

This usually happens because your environment has changed since running npm install.
Run npm rebuild node-sass --force to build the binding for your current environment.
at module.exports (/usr/src/app/node_modules/node-sass/lib/binding.js:15:13)
at Object. (/usr/src/app/node_modules/node-sass/lib/index.js:14:35)
at Module._compile (module.js:569:30)
at Object.Module._extensions..js (module.js:580:10)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
at Object. (/usr/src/app/node_modules/@ionic/app-scripts/dist/core/bundle-components.js:6:16)
[ERROR] An error occurred while running ionic-app-scripts build (exit code 1)

npm info lifecycle blancinegre@0.0.1~build: Failed to exec build script
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! blancinegre@0.0.1 build: ionic build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the blancinegre@0.0.1 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/gitlab-runner/.npm/_logs/2018-05-04T12_06_32_795Z-debug.log
npm run build failed
Running after script...
$ run "clean-up"
Running Stage clean-up for Job: 5529444
ERROR: Job failed: exit status 1
when compiling in ionic view gives me this error, has someone happened to him ??

Renato Marinho
@renatomarinho
May 04 20:04
This message was deleted