These are chat archives for nebrius/raspi-io

21st
Feb 2015
Bryan Hughes
@nebrius
Feb 21 2015 23:46
Raspi-IO 2.2.0 is out. No user-facing changes, but I switched from using traceur to babel for ES6->ES5 translation.
During the 2.1.0 update, I ran into a problem where one module was compiled with a newer version of traceur than the others, which caused a nasty bug
traceur requires a runtime component, so everything has to be compiled with the same version. babel, however, is purely compile time, so you can mix and match to your hearts content. It also has better ES6 support and seems to be more performant than traceur