These are chat archives for nebrius/raspi-io

25th
Jul 2015
Chris Wigley
@askesian
Jul 25 2015 16:52
@nebrius was told to ping you - do you know the latest stable version of node for rpi?
Bryan Hughes
@nebrius
Jul 25 2015 16:56
@askesian It looks like node 0.12.6 is the latest: http://node-arm.herokuapp.com/
admittedly I don’t think I’ve upgraded and tested it yet (I’m still on 0.12.1), but it should work just fine with raspi-io!
Chris Wigley
@askesian
Jul 25 2015 16:58
@nebrius thank you!
Chris Wigley
@askesian
Jul 25 2015 18:36
@nebrius - I'm running raspi-io 3.3.4 on node 0.12.6 and during install of raspi-io, I still get execSync v1.0.2 Native code compile failed! -- checked issues and see that this was resolved Mar 25 - am I doing something wrong?
Bryan Hughes
@nebrius
Jul 25 2015 18:39
@askesian no you’re just fine! the execSync thing is a shim for node 0.10, which doesn’t have execySync natively, unlike node 0.12
it’s also specified as an optional dependency
Chris Wigley
@askesian
Jul 25 2015 18:40
@nebrius ok thanks - I asked because when I start my process, this command fails modprobe i2c-dev because modprobe is not found in /bin/sh
@nebrius - figured it out -- sort of -- I have to run node w/ sudo because mobprob is in sbin
Chris Wigley
@askesian
Jul 25 2015 18:45
@nebrius sorry for the bother and thanks for the help
Bryan Hughes
@nebrius
Jul 25 2015 19:08
@askesian :-/. I saw that once before…what was the fix...
sorry, I’ve been up and about helping attendees