Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Keith Zantow
    @kzantow
    Hi, I'm having a hard time getting any docker images building using act, although this doesn't really even seem to be docker related. I've tried a number of things including specifying what I think is the "medium" image to use like act -P ubuntu-latest=ghcr.io/catthehacker/ubuntu:act-latest -j test (and ubuntu:js-latest) but I end up with problems executing the actions at all: Exec command '[node /actions/docker-build-push-action@v2/dist/index.js]' | OCI runtime exec failed: exec failed: container_linux.go:380: starting container process caused: exec: "node": executable file not found in $PATH: unknown. Am I doing something completely wrong?
    1 reply
    Keith Zantow
    @kzantow
    Also: does act support service containers? It seems these are not running by default, at least.
    1 reply
    Andy Maloney
    @asmaloney
    Heya! New to "act". I can't find info on how to set the tag I want when I use "act release". Is this possible? (Background - I'm trying to write an action that will zip up the repo while skipping some files and I want to give the zip an intelligent name using the tag of the release.)
    1 reply
    Paulo Matos
    @pmatos
    Hi - what happens to artifacts when running a workflow through act? Is there a way to save them somewhere on disk ?
    5 replies
    imerkle
    @imerkle
    Whats the working dir after checkout ? Is it github_workspace?
    imerkle
    @imerkle
    I'm using docker compose and mapping `{$GITHUB_WORKSPACE}:/myworkspace in volume but myworkspace does not contains contents of my repo
    1 reply
    This works in github sctions
    Ari Huttunen
    @StatisticalMice
    Hi! What does --github-instance actually do? Does it cause act to execute the actions in the enterprise server's runners, or something else?
    7 replies
    reivilibre.element
    @reivilibre.element:librepush.net
    [m]

    hi folks, I'm getting output like this:

    [Tests/lint-3]   🐳  docker exec cmd=[node /var/run/act/actions/actions-setup-python@v2/dist/index.js] user=
    [Tests/lint-3]   💬  ::debug::Semantic version spec of 3.x is 3.x
    [Tests/lint-3]   💬  ::debug::isExplicit: 
    [Tests/lint-3]   💬  ::debug::explicit? false
    [Tests/lint-3]   💬  ::debug::evaluating 0 versions
    [Tests/lint-3]   💬  ::debug::match not found
    | Version 3.x was not found in the local cache
    [Tests/lint-3]   ❗  ::error::API rate limit exceeded for **My IP address**. (But here's the good news: Authenticated requests get a higher rate limit. Check out the documentation for more details.)
    [Tests/lint-3]   ❌  Failure - actions/setup-python@v2

    I'm not really sure what's going on here; this looks like a GitHub API rate limit message. Is this something that act is doing -- if so, is there some way to authenticate to GitHub to get a higher rate limit?

    2 replies
    dtracers
    @dtracers

    Question!
    I am trying to run a workflow that uses git commands but it seems the image I am using does not come with git installed
    Is there a way to add git to the image used?

    For reference when I first ran it and it asked me what image to install I chose "large"

    15 replies
    Nathan Schwermann
    @nschwermann
    Hey guys, I am running on osx but it only seems to see workflows from one file in the workflows directory. Using this repo it only sees workflow from test.yaml not publish.yaml when runing act -list am I doing something wrong? How can I run the publish workflow?
    https://github.com/nschwermann/polkaj/tree/android_support
    11 replies
    Ari Huttunen
    @StatisticalMice
    I succeeded in running act against our company's GitHub Enterprise server, but configuring this required one innovative step that I don't see documented. In short, this required downloading the docker image that we use for building with GHA. Then it requires the --github-instance flag. It also requires this in .actrc, which should be in instructions:
    -P self-hosted=some-host.saunalahti.fi/sre/actions-runner-dind:latest
    some-host.saunalahti.fi/sre/actions-runner-dind:latest
    Andy Maloney
    @asmaloney
    How do I set which tag I want when I use "act release"?
    sid-ihmperf
    @sid-ihmperf
    I'm getting an error while running Act inside a self-hosted runner.
    creating settings.xml with server-id: github; environment variables: username=$GITHUB_ACTOR, password=$GITHUB_TOKEN, and gpg-passphrase=null
    [Complete pipeline/Creating new docker image and uploading to ECR] ❗ ::error::EACCES: permission denied, mkdir '/github/home/.m2'
    [Complete pipeline/Creating new docker image and uploading to ECR] ❌ Failure - Setup JDK 11
    4 replies
    gdanov
    @gdanov
    Hi, I'm using buildx and build-push action to build docker images. Every run act downloads the FROM images fresh and this takes ages. Any tricks to avoid this and speed-up local development?
    1 reply
    lfa-vasconcellos
    @lfa-vasconcellos
    Hello everyone, I'm having some difficulties trying to get my cached actions to working using act. Can you guys give me some tips or point me in the direction of some documentation? Couldn't find anything on the repositories
    8 replies
    Enrique Llorente Pastora
    @qinqon
    Hi am trying to run so github actions that run some golang tests and when it does go get it fails at TLS certificate check go: github.com/stretchr/testify@v1.7.0: Get "https://proxy.golang.org/github.com/stretchr/testify/@v/v1.7.0.mod": x509: certificate signed by unknown authority, can I share the golang cache with act ?
    Fedor Lapshin
    @FedorLap2006
    Hi everyone, I'm having problems with github/super-linter@v4 on my local act environment. I'm running the whole thing using my own custom image (act-latest + docker-compose).
    It seems super-linter cannot find /var/run/act/workflow/event.json file. I tried to test if something is wrong with the file, therefore added jq -r '.repository.owner.login' <"${GITHUB_EVENT_PATH}" (the line super-linter's script was failing on) to the same job as super-linter is running in - it worked fine.
    But when super-linter tries to access this file, I get this
    [ci.yml/tst]   | 2021-09-21 13:18:14 [INFO]   Successfully found:[GITHUB_EVENT_PATH], value:[/var/run/act/workflow/event.json]
    [ci.yml/tst]   | /action/lib/linter.sh: line 478: /var/run/act/workflow/event.json: No such file or directory
    [ci.yml/tst]   | 2021-09-21 13:18:14 [ERROR]   Failed to get [GITHUB_ORG]!
    Fedor Lapshin
    @FedorLap2006

    Also, according to a thread I found here (made by @dannystaple ), I could have set the GITHUB_ORG manually, but

        steps:
          - uses: github/super-linter@v4
            env:
              RUN_LOCAL: true
              GITHUB_ORG: my-org

    gives no effect

    21 replies
    Sting Alleman
    @stingalleman
    Hi all, I'm writing a custom GH action and I want to test it locally. Is this possible?
    This message was deleted
    name: "test workflow aaah"
    
    on: ["workflow_dispatch", "push"]
    
    jobs:
      test:
        runs-on: macos-11
        steps:
          - uses: pakket-project/test/setup-builder@main
    1 reply
    pakket-project/test/setup-builder is locally
    1 reply
    Samuel Wecker
    @swecker

    Does act support the full "needs context"?
    I'm logging it and getting:

    { "job-01": { "outputs": null }, "job-02": { "outputs": null } }

    and I was hoping to see the result field (see: https://docs.github.com/en/actions/learn-github-actions/contexts#needs-context)

    I don't know if this just isn't supported yet, or if I'm referencing the context incorrectly or something.

    3 replies
    ged
    @gedw99
    Crazy question maybe, but has anyone thought about running act on fly.io ?
    Ryanv2
    @hackercat:matrix.org
    [m]
    Please don't
    Jasper Nygaard
    @jnus
    Hi all. I'm trouble shooting an issue where I use OctopusDeploy/install-octopus-cli-action in a workflow, but get the error 'Error: reference delta not found' when running with act. Anyone seen this error before?
    Shashwat Arghode
    @ShashwatArghode

    Hi All,
    I am a new ACT user struggling to run the following CI job locally. Any help is appreciated.
    CI job: https://github.com/prestodb/presto/blob/master/.github/workflows/ci.yml
    Command: act -v
    Logs:

    DEBU[0000] Loading environment from /Users/sarghode/IdeaProjects/prestodb/.env 
    DEBU[0000] Loading secrets from /Users/sarghode/IdeaProjects/prestodb/.secrets 
    DEBU[0000] Loading workflows from '/Users/sarghode/IdeaProjects/prestodb/.github/workflows' 
    DEBU[0000] Loading workflows recursively                
    DEBU[0000] Found workflow 'ci.yml' in '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/ci.yml' 
    DEBU[0000] Found workflow 'cleanup.yml' in '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/cleanup.yml' 
    DEBU[0000] Reading workflow '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/ci.yml' 
    DEBU[0000] Correcting if statements '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/ci.yml' 
    DEBU[0000] Reading workflow '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/cleanup.yml' 
    DEBU[0000] Correcting if statements '/Users/sarghode/IdeaProjects/prestodb/.github/workflows/cleanup.yml' 
    DEBU[0000] Planning event: push

    It crashes after this setup without any error log.

    Thanks.

    3 replies
    Mathijs van Veluw
    @BlackDex
    Hello there, I have a question regarding docker images build during an act run. When using docker/setup-buildx-action and docker/build-push-action the build images do not seem to appear in my local image list when checking docker image list is there a way to have this working?
    1 reply
    Mathijs van Veluw
    @BlackDex
    Seems setup-buildx-action is doing something to mess with the local images
    if i use DOCKER_BUILDKIT=1 instead it works, so i will just do some if: env.ACT checking :)
    If someone has a better idea or solution, please share :).
    Isaac Guerreiro
    @isaacguerreir
    Hello, everyone. I'm trying to run locally my action, but didn't work. `jobs:
    test:
    runs-on: self-hosted
    permissions:
    contents: read
    packages: write
    container:
    image: mcr.microsoft.com/vscode/devcontainers/base:ubuntu
    options: --user 1001
    steps: 
    - uses: actions/checkout@v2
    - name: Run action
      uses: ./`
    2 replies
    Anyone know how I could run this locally.
    ?
    Colin Alworth
    @niloc132
    i'm seeing a difference in behavior between ghcr.io/catthehacker/ubuntu:act-latest and ghcr.io/catthehacker/ubuntu:full-latest when running actions/checkout@v2 with a with:path: specified - act-latest behaves as expected and the layout makes sense, but full-latest gets permission errors when trying to set things up. Where would be the best place to file this?
    3 replies
    Mohsin Hijazee
    @mohsinhijazee

    I have this args for an action and the "Expressions" don't seem to work

     name: Fetch environment variables from AWS Parameter Store
          uses: classtinginc/chamber-action@master
          id: chamber
          with:
            args: export --format dotenv --output-file parameters.env ${{ env.SERVICE_NAME }}

    So instead of the variable SERVICE_NAME being injected, the literal ${{ is being injected. Any ideas?

    1 reply
    MarkoJelovic
    @MarkoJelovic

    Hi everyone. I'm using act to locally test my github action to create minikube cluster. This is the code I have for this task.
    '''
    name: Minikube deploy
    on:
    push:
    branches:

      - master

    jobs:
    testjob1:
    runs-on: ubuntu-latest
    steps:

      - name: Install minikube
        run: |
          sudo curl -LO https://storage.googleapis.com/minikube/releases/latest/minikube-linux-amd64
          sudo install minikube-linux-amd64 /usr/local/bin/minikube
      - uses: yokawasa/action-setup-kube-tools@v0.7.1
        with:
          setup-tools: kubectl
          kubectl: '1.18.18'
    
      - name: Add user
        run: |
          getent group sudo
          getent group docker
          echo $USER
          sudo usermod -aG docker $USER
          getent group docker
          sudo chmod 666 /var/run/docker.sock
          echo "hi"
    
      - name: Start minikube
        run: |
          sudo minikube delete
          minikube start
          kubectl get pods -A
          echo "end"

    '''
    The "Add user" part is me trying to give docker non root user so that docker commands could be run. Ubuntu image used is ubuntu-latest=ghcr.io/catthehacker/ubuntu:runner-latest
    Everything is running fine until this next line which is part of minikube start command and then it freezes.
    '''
    Downloading Kubernetes v1.22.2 preload ...

    > preloaded-images-k8s-v13-v1...: 511.84 MiB / 511.84 MiB  100.00% 14.22 Mi

    '''
    If I add --alsologtostderr I get this type of error on the same part of running process.
    '''
    libmachine: Error dialing TCP: dial tcp 127.0.0.1:55660: connect: connection refused
    '''
    So the problem is I can't create minikube cluster with act. Does anyone know what is the cause of this errors ?

    Eduardo Robles
    @edulix
    Hello! how can I add more RAM to act runner?
    4 replies
    jeff-pcln
    @jeff-pcln
    hi! just found this repo today and had a question. i am using it with a private npm registry and get UNABLE_TO_GET_ISSUER_CERT_LOCALLY as an error. does anyone know how to bypass this?
    2 replies
    Timothy J Laurent
    @timothyjlaurent

    I'm seeing

    | OCI runtime exec failed: exec failed: container_linux.go:380: starting container process caused: exec: "node": executable file not found in $PATH: unknown

    when I try to run the checkout action

    Timothy J Laurent
    @timothyjlaurent

    How can I tell what running act is using?

    my workflow runs-on

        runs-on: [self-hosted, dev]

    And I have

    -P self-hosted=ghcr.io/catthehacker/ubuntu:act-20.04 -P dev=ghcr.io/catthehacker/ubuntu:act-20.04

    in my ~/.actrc

    ^ does that all look right?

    Timothy J Laurent
    @timothyjlaurent
    So I was using a "Container" argument and it looks like ACT will use that instead of the runners.
    So I cleared that up and added a GITHUB_TOKEN that was going great until I tried to run a docker container action and it couldn't find java
    Szymon Nowak
    @szimek

    Hi! I've got an issue with a running a local action. I've got a local Dockerfile, so in my workflow I've got uses: ./, which causes act to generate an invalid tag for Docker build command (i.e. act-:latest):

    docker build -t act-:latest --platform  /Users/...

    Is there any workaround for this?

    1 reply
    Timothy J Laurent
    @timothyjlaurent

    Turns out that the ~/.actrc / ./.actrc needs to be one parameter per line.

    -P self-hosted=ghcr.io/catthehacker/ubuntu:act-20.04
    -P dev=ghcr.io/catthehacker/ubuntu:act-20.04

    Maybe I'm confusing the issues I had with the container: param?

    So here's a summary of the issues I've encountered.

    • Using the container parameter will override whatever is in the runs-on
    • Docker-based actions aren't working - eg java not found on JVM image.
    Error: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: exec: "java": executable file not found in $PATH: unknown

    Is there some way to enable these features on Act?

    2 replies
    Tomasz Dłuski
    @Toumash

    Is it possible to run node14 in act? I can only see node12 images. When running some yarn cli ive got following error

    Publish in Chrome Web Store/publish] ⭐  Run Install chrome web store cli
    yarn global v1.22.5
    warning package.json: No license field
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    error chrome-webstore-upload-cli@2.0.1: The engine "node" is incompatible with this module. Expected version "^14.13.1 || >=16.0.0". Got "12.20.1"
    error Found incompatible module.
    info Visit https://yarnpkg.com/en/docs/cli/global for documentation about this command.
    [Publish in Chrome Web Store/publish]   ❌  Failure - Install chrome web store cli

    but I do have

    - name: Use Node.js ${{ matrix.node-version }}
          uses: actions/setup-node@v2
          with:
            node-version: 14.x
    2 replies
    ged
    @gedw99
    I want to get off github but still use my workflows . What i dont see is how i can do builds on wi diws mac and linux cause the Act system currentky uses Docker . Am i missing something ?? ?
    1 reply
    Josh Soref
    @jsoref
    when I try to run make in nektos/act, I get a bunch of build failures, is that expected? :-(
    1 reply