These are chat archives for nessos/FsPickler

10th
May 2018
Ivo Grootjes
@ivog
May 10 21:34
Hi @eiriktsarpalis, I was wondering if libraries like fspickler and fsharp.quotations.evaluator could target a lower version of FSharp.Core.
I'm seeing a lot of package downgrade warnings in the akka.net build and I was wondering if those should be solved in the packages which akka.net uses.
e.g. [08:45:43][Build] D:\work\d26c9d7f36545acd\src\core\Akka.FSharp.Tests\Akka.FSharp.Tests.fsproj : warning NU1605: Detected package downgrade: FSharp.Core from 4.3.2 to 4.2.0. Reference the package directly from the project to select a different version.
[08:45:43][Build] D:\work\d26c9d7f36545acd\src\core\Akka.FSharp.Tests\Akka.FSharp.Tests.fsproj : warning NU1605: Akka.FSharp.Tests (>= 1.3.7) -> Akka.FSharp (>= 1.3.7) -> FsPickler (>= 5.2.0) -> FSharp.Core (>= 4.3.2)
[08:45:43][Build] D:\work\d26c9d7f36545acd\src\core\Akka.FSharp.Tests\Akka.FSharp.Tests.fsproj : warning NU1605: Akka.FSharp.Tests (>= 1.3.7) -> FSharp.Core (>= 4.2.3)