Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 16:37
    MarekM25 synchronize #4731
  • 16:37

    MarekM25 on shanghai-eip-4895-withdrawals

    Cleanup and more tests Janky but working solution to v… Fix flakiness of caused by Para… and 4 more (compare)

  • 16:06
    flcl42 synchronize #4858
  • 16:06

    flcl42 on eip-4844

    Fix running in docker (compare)

  • 15:45
    MarekM25 commented #4942
  • 15:43
    nicexe opened #4943
  • 15:31
    damian-orzechowski commented #4941
  • 14:47
    pawanjay176 opened #4942
  • 14:18
    deffrian synchronize #4884
  • 14:18

    deffrian on fees_in_getPayload

    Free transaction test (compare)

  • 14:14
    smartprogrammer93 commented #4722
  • 14:09
    rubo synchronize #4889
  • 14:09

    rubo on dotnet7-migration

    fixed eip-3860 gas usage and no… Hide concurrency limit reached … Fix (#4938) and 1 more (compare)

  • 14:09
    rubo synchronize #4731
  • 14:09

    rubo on shanghai-eip-4895-withdrawals

    fixed eip-3860 gas usage and no… Hide concurrency limit reached … Fix (#4938) and 1 more (compare)

  • 14:06
    smartprogrammer93 synchronize #4853
  • 14:06

    smartprogrammer93 on forkId_calculation_is_wrong_after_timestamp_activation_fix

    Introduce IEip1995Spec Merge branch 'fix/forkId_calcul… (compare)

  • 13:34
    asdacap commented #4941
  • 13:13
    MarekM25 synchronize #4853
  • 13:13

    MarekM25 on forkId_calculation_is_wrong_after_timestamp_activation_fix

    adjust CustomSpecProvider (compare)

Gitter Bridge
@nethermind-bridge
[discord] <MarekM> Hi everyone, please check this message: https://discord.com/channels/629004402170134531/922531097332555796/1007129327088980029
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> I tried syncing my node with the following settings, and it is currently discovering blocks and not processing them.
      NETHERMIND_CONFIG: 'mainnet'
      NETHERMIND_HEALTHCHECKSCONFIG_ENABLED: 'true'
      NETHERMIND_HEALTHCHECKSCONFIG_UIENABLED: 'true'
      NETHERMIND_JSONRPCCONFIG_ENABLED: 'true'
      NETHERMIND_JSONRPCCONFIG_HOST: '0.0.0.0'
      NETHERMIND_JSONRPCCONFIG_PORT: '80'
      NETHERMIND_JSONRPCCONFIG_ENABLEDMODULES: 'Eth,Subscribe,Trace,Proof,TxProof,Net,Web3,100'
      NETHERMIND_NETWORKCONFIG_P2PPORT: '30303'
      NETHERMIND_NETWORKCONFIG_DISCOVERYPORT: '30303'
      NETHERMIND_NETWORKCONFIG_ACTIVEPEERMAXCOUNT: '50'
      NETHERMIND_SYNCCONFIG_FASTBLOCKS: 'true'
      NETHERMIND_SYNCCONFIG_FASTSYNCCATCHUPHEIGHTDELTA: '1024'
      NETHERMIND_SYNCCONFIG_ANCIENTBODIESBARRIER: '11052984'
      NETHERMIND_SYNCCONFIG_ANCIENTRECEIPTSBARRIER: '11052984'
      NETHERMIND_SYNCCONFIG_DOWNLOADBODIESINFASTSYNC: 'true'
      NETHERMIND_SYNCCONFIG_DOWNLOADRECEIPTSINFASTSYNC: 'true'
      NETHERMIND_SYNCCONFIG_DOWNLOADHEADERSINFASTSYNC: 'false'
      NETHERMIND_SYNCCONFIG_PIVOTHASH: '0x0b26884961d4722ecdc37c30266f98a7b728d6c5d81007d0f34a5227ef9a5645'
      NETHERMIND_SYNCCONFIG_PIVOTNUMBER: '15313371'
      NETHERMIND_SYNCCONFIG_PIVOTTOTALDIFFICULTY: '56025440410450938639981'
      NETHERMIND_SYNCCONFIG_FASTSYNCENABLED: 'true'
      NETHERMIND_PRUNINGCONFIG_ENABLED: 'true'
      NETHERMIND_PRUNINGCONFIG_CACHEMB: '2048'
      NETHERMIND_PRUNINGCONFIG_PERSISTENCEINTERVAL: '16384'
      NETHERMIND_PRUNINGCONFIG_FULLPRUNINGTRIGGER: 'StateDbSize'
[discord] <Micah | serv.eth> Based on disk space used, it didn't actually sync anything.
[discord] <Micah | serv.eth> On restart I see this warning, though it seems to be non-critical:
2022-08-11 04-15-49.4231|Incorrect config settings found:
ConfigType:EnvironmentVariable(NETHERMIND_*)|Category:SYNCCONFIG|Name:FASTSYNCENABLED
ConfigType:EnvironmentVariable(NETHERMIND_*)|Category:NETWORKCONFIG|Name:ACTIVEPEERMAXCOUNT
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> It then proceeds to just discover new blocks and do nothing else forever.
[discord] <Micah | serv.eth> cc @luk @MarekM
Gitter Bridge
@nethermind-bridge

[discord] <gattodaitalia> I got this message

 2022-08-11 09-25-03.9450|Incorrect config settings found:
node_1  | ConfigType:JsonConfigFile|Category:PrunningConfig|Name:Mode

my config for this is below:

  "Prunning": {
    "Mode": "None"
  },

please help

[discord] <Falco> Try "Pruning" instead of "Prunning" 🙂
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> Should be NETHERMIND_SYNCCONFIG_FASTSYNC and NETHERMIND_NETWORKCONFIG_ACTIVEPEERSMAXCOUNT
[discord] <DanielC> But you should use NETHERMIND_NETWORKCONFIG_MAXACTIVEPEERS instead of ActivePeersMaxCount
https://docs.nethermind.io/nethermind/ethereum-client/configuration/network
Gitter Bridge
@nethermind-bridge
[discord] <gattodaitalia> many thanks 🙂
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> 2022-08-11 14:04:51.3883|State Sync 00.06:45:13 | ~0.89 % | 878.26MB / ~98820.00MB | branches: 31.25 % | kB/s: 94 | accounts 319791 | nodes 3084585 | diagnostics: 12.480.66ms
Should I interpret this to mean that syncing is going to take ~100 days? I am in "fast" sync...
[discord] <Micah | serv.eth> 6 hours in, 0.89% of state downloaded.
[discord] <Micah | serv.eth> 66 peers, host should be well connected.
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> It seems you're using Fast Sync and no Snap Sync. Could you confirm?
Which version of Nethermind are you using?
[discord] <Micah | serv.eth> 1.13.5
[discord] <Micah | serv.eth> mainnet.cfg, which I think is fast sync?
[discord] <Micah | serv.eth> Sync.FastBlocks: true as well.
[discord] <Micah | serv.eth> Should I switch to snap sync? Is FastSync no longer reasonable?
[discord] <DanielC> Ok, so 1.13.5 has this well known issue with RocksDB - only Snap Sync works in that version although it take up to 7h to sync which is much slower than before.
Version 1.13.6 has a workaround that solves it but you would have to delete all databases update to 1.13.6 and sync from scratch - then you can use Fast Sync.
Still Fast Sync is waaay slower than Snap Sync. In 1.13.6 you should able to resync with Snap Sync in 3-4 h
[discord] <Micah | serv.eth> Sync.FastSync: false and Sync.SnapSync: true?
[discord] <DanielC> Set both to true.
[discord] <Micah | serv.eth> I can switch mid sync?
[discord] <Micah | serv.eth> I would rather not re-download all of the headers. 😬
[discord] <DanielC> Although SnapSync:true overrides FastSync to true under the hood 😉
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> You can try. If don't delete databases then even if you upgrade to 1.13.6 the workaround will use existing RocksDB version (the one from 1.13.5) so it's going to be slower but still it's going to be max 8 h for the Snap Sync (instead of 3h). Not terrible.
[discord] <Micah | serv.eth> 8h is better than 100 days.
[discord] <DanielC> Yes 😄
[discord] <Micah | serv.eth> How can I tell if it is working other than waiting 8 hours and seeing if I still have 99.5 days left?
[discord] <Micah | serv.eth> The logs look the same after turning on snap sync and restarting.
[discord] <DanielC> When Snap Sync enabled you'll we see new types of log entries.
[discord] <DanielC> You should see SNAP entries at some point.
[discord] <Micah | serv.eth> I still just see
Syncing state nodes 
State Sync 00.06:59:26 | ~0.90 % | 892.62MB / ~98820.00MB | branches: 0.00 % | kB/s:     0 | accounts 323414 | nodes 3131015 | diagnostics: 0.658.40ms 
Changing state StateNodes to FastSync, StateNodes at processed:0|state:0|block:15321161|header:15321166|peer block:15321199 
Sync mode changed from StateNodes to FastSync, StateNodes 
Downloaded 15321167 / 15321199 | current     0.09bps | total     0.03bps 
State Sync 00.06:59:26 | ~0.90 % | 892.62MB / ~98820.00MB | branches: 0.00 % | kB/s:     0 | accounts 323414 | nodes 3131015 | diagnostics: 0.662.25ms 
Changing state FastSync, StateNodes to StateNodes at processed:0|state:0|block:15321161|header:15321167|peer block:15321199 
Sync mode changed from FastSync, StateNodes to StateNodes 
State Sync 00.06:59:26 | ~0.90 % | 892.65MB / ~98820.00MB | branches: 0.00 % | kB/s:    14 | accounts 323433 | nodes 3131083 | diagnostics: 0.665.61ms
[discord] <DanielC> It seems we have some kind of a feature implemented that checks if we some process already started and it continues with it :/
[discord] <DanielC> It wasn't a few months ago when we delivered SNAP sync but it seems it's changed.
[discord] <Micah | serv.eth> Why isn't snap sync default if fast sync is broken?
[discord] <DanielC> Snap Sync never starts immediately, the headers have to catch the pivot hardcoded in the config file,
[discord] <DanielC> I think it is default in the mainnet.cfg
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> It cannot be default for all networks
[discord] <DanielC> because only Geth supports it and there are networks without Geth.
[discord] <DanielC> So the default config files for mainnet and goerli have it switched to true but probably you're using your own config file without this value set to true.
[discord] <Micah | serv.eth> Ah, looks like it changed in 1.13.6.
Gitter Bridge
@nethermind-bridge
[discord] <santamansanta> How did this go?
[discord] <santamansanta> So have to start syncing from the beginning?
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> Terribly. Removing only the state folder doesn't work. However, I learned you can trigger a full prune via RPC instead.
Gitter Bridge
@nethermind-bridge
[discord] <santamansanta> I did a full prune too. It took 3 days. state/0 directory is gone and only state/1 exists. But the size is like 13 gb more than what it was before the prune started. But I only had it running for 10 days before I tried to prune
[discord] <santamansanta> I am confused lol
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> How big is the state directory?
Gitter Bridge
@nethermind-bridge
[discord] <TobiWo> Hi, I'm new to nethermind and try to connect to our node via the Nethermind.CLI. While connecting I'm receiving Authentication error. This also happens while trying to send a command like eth.blockNumber. On the later I furthermore receive 0.0 indicating that the connection does not work.
Do I need the jwt for those rpc calls as well or how can I authenticate?