Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 00:29
    DemuirGos synchronize #4865
  • Nov 30 23:46
    DemuirGos synchronize #4864
  • Nov 30 23:46

    DemuirGos on EVM-Static-Relative-Jumps

    ws fixes (compare)

  • Nov 30 23:45
    DemuirGos synchronize #4864
  • Nov 30 23:38
    begetan commented #4945
  • Nov 30 23:09
    DemuirGos synchronize #4609
  • Nov 30 23:09

    DemuirGos on EOF-Byteode-Validation

    merged "Eip-3540/EVM-Object-For… (compare)

  • Nov 30 23:01
    quickchase commented #4946
  • Nov 30 22:37
    DemuirGos synchronize #4609
  • Nov 30 21:23

    rubo on temp-4895

    Set `latestValidHash` to zero (compare)

  • Nov 30 21:08

    LukaszRozmej on 1.14.7

    (compare)

  • Nov 30 21:07

    LukaszRozmej on 1.14.7

    Bump version (compare)

  • Nov 30 20:48

    rubo on temp-4895

    Set `latestValidHash` to zero (compare)

  • Nov 30 19:49

    rubo on temp-4895

    fix hive sync tests fix? Merge branch 'feature/shanghai-… (compare)

  • Nov 30 19:23

    LukaszRozmej on 1.14.6_broadcast_fix

    Increase sync server size (compare)

  • Nov 30 19:15
    StopThisMan commented #4929
  • Nov 30 19:05

    LukaszRozmej on 1.14.6_broadcast_fix

    Additional check if block is kn… (compare)

  • Nov 30 19:02
    DemuirGos synchronize #4608
  • Nov 30 18:51
    quickchase commented #4946
  • Nov 30 18:26
    tmm360 opened #4946
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> cc @luk @MarekM
Gitter Bridge
@nethermind-bridge

[discord] <gattodaitalia> I got this message

 2022-08-11 09-25-03.9450|Incorrect config settings found:
node_1  | ConfigType:JsonConfigFile|Category:PrunningConfig|Name:Mode

my config for this is below:

  "Prunning": {
    "Mode": "None"
  },

please help

[discord] <Falco> Try "Pruning" instead of "Prunning" πŸ™‚
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> Should be NETHERMIND_SYNCCONFIG_FASTSYNC and NETHERMIND_NETWORKCONFIG_ACTIVEPEERSMAXCOUNT
[discord] <DanielC> But you should use NETHERMIND_NETWORKCONFIG_MAXACTIVEPEERS instead of ActivePeersMaxCount
https://docs.nethermind.io/nethermind/ethereum-client/configuration/network
Gitter Bridge
@nethermind-bridge
[discord] <gattodaitalia> many thanks πŸ™‚
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> 2022-08-11 14:04:51.3883|State Sync 00.06:45:13 | ~0.89 % | 878.26MB / ~98820.00MB | branches: 31.25 % | kB/s: 94 | accounts 319791 | nodes 3084585 | diagnostics: 12.480.66ms
Should I interpret this to mean that syncing is going to take ~100 days? I am in "fast" sync...
[discord] <Micah | serv.eth> 6 hours in, 0.89% of state downloaded.
[discord] <Micah | serv.eth> 66 peers, host should be well connected.
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> It seems you're using Fast Sync and no Snap Sync. Could you confirm?
Which version of Nethermind are you using?
[discord] <Micah | serv.eth> 1.13.5
[discord] <Micah | serv.eth> mainnet.cfg, which I think is fast sync?
[discord] <Micah | serv.eth> Sync.FastBlocks: true as well.
[discord] <Micah | serv.eth> Should I switch to snap sync? Is FastSync no longer reasonable?
[discord] <DanielC> Ok, so 1.13.5 has this well known issue with RocksDB - only Snap Sync works in that version although it take up to 7h to sync which is much slower than before.
Version 1.13.6 has a workaround that solves it but you would have to delete all databases update to 1.13.6 and sync from scratch - then you can use Fast Sync.
Still Fast Sync is waaay slower than Snap Sync. In 1.13.6 you should able to resync with Snap Sync in 3-4 h
[discord] <Micah | serv.eth> Sync.FastSync: false and Sync.SnapSync: true?
[discord] <DanielC> Set both to true.
[discord] <Micah | serv.eth> I can switch mid sync?
[discord] <Micah | serv.eth> I would rather not re-download all of the headers. 😬
[discord] <DanielC> Although SnapSync:true overrides FastSync to true under the hood πŸ˜‰
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> You can try. If don't delete databases then even if you upgrade to 1.13.6 the workaround will use existing RocksDB version (the one from 1.13.5) so it's going to be slower but still it's going to be max 8 h for the Snap Sync (instead of 3h). Not terrible.
[discord] <Micah | serv.eth> 8h is better than 100 days.
[discord] <DanielC> Yes πŸ˜„
[discord] <Micah | serv.eth> How can I tell if it is working other than waiting 8 hours and seeing if I still have 99.5 days left?
[discord] <Micah | serv.eth> The logs look the same after turning on snap sync and restarting.
[discord] <DanielC> When Snap Sync enabled you'll we see new types of log entries.
[discord] <DanielC> You should see SNAP entries at some point.
[discord] <Micah | serv.eth> I still just see
Syncing state nodes 
State Sync 00.06:59:26 | ~0.90 % | 892.62MB / ~98820.00MB | branches: 0.00 % | kB/s:     0 | accounts 323414 | nodes 3131015 | diagnostics: 0.658.40ms 
Changing state StateNodes to FastSync, StateNodes at processed:0|state:0|block:15321161|header:15321166|peer block:15321199 
Sync mode changed from StateNodes to FastSync, StateNodes 
Downloaded 15321167 / 15321199 | current     0.09bps | total     0.03bps 
State Sync 00.06:59:26 | ~0.90 % | 892.62MB / ~98820.00MB | branches: 0.00 % | kB/s:     0 | accounts 323414 | nodes 3131015 | diagnostics: 0.662.25ms 
Changing state FastSync, StateNodes to StateNodes at processed:0|state:0|block:15321161|header:15321167|peer block:15321199 
Sync mode changed from FastSync, StateNodes to StateNodes 
State Sync 00.06:59:26 | ~0.90 % | 892.65MB / ~98820.00MB | branches: 0.00 % | kB/s:    14 | accounts 323433 | nodes 3131083 | diagnostics: 0.665.61ms
[discord] <DanielC> It seems we have some kind of a feature implemented that checks if we some process already started and it continues with it :/
[discord] <DanielC> It wasn't a few months ago when we delivered SNAP sync but it seems it's changed.
[discord] <Micah | serv.eth> Why isn't snap sync default if fast sync is broken?
[discord] <DanielC> Snap Sync never starts immediately, the headers have to catch the pivot hardcoded in the config file,
[discord] <DanielC> I think it is default in the mainnet.cfg
Gitter Bridge
@nethermind-bridge
[discord] <DanielC> It cannot be default for all networks
[discord] <DanielC> because only Geth supports it and there are networks without Geth.
[discord] <DanielC> So the default config files for mainnet and goerli have it switched to true but probably you're using your own config file without this value set to true.
[discord] <Micah | serv.eth> Ah, looks like it changed in 1.13.6.
Gitter Bridge
@nethermind-bridge
[discord] <santamansanta> How did this go?
[discord] <santamansanta> So have to start syncing from the beginning?
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> Terribly. Removing only the state folder doesn't work. However, I learned you can trigger a full prune via RPC instead.
Gitter Bridge
@nethermind-bridge
[discord] <santamansanta> I did a full prune too. It took 3 days. state/0 directory is gone and only state/1 exists. But the size is like 13 gb more than what it was before the prune started. But I only had it running for 10 days before I tried to prune
[discord] <santamansanta> I am confused lol
Gitter Bridge
@nethermind-bridge
[discord] <Micah | serv.eth> How big is the state directory?
Gitter Bridge
@nethermind-bridge
[discord] <TobiWo> Hi, I'm new to nethermind and try to connect to our node via the Nethermind.CLI. While connecting I'm receiving Authentication error. This also happens while trying to send a command like eth.blockNumber. On the later I furthermore receive 0.0 indicating that the connection does not work.
Do I need the jwt for those rpc calls as well or how can I authenticate?
Gitter Bridge
@nethermind-bridge
[discord] <TobiWo> Same here
[discord] <TobiWo> Same here for that combi as well.
Gitter Bridge
@nethermind-bridge
[discord] <Yorick | cryptomanufaktur.io> This recovered with a goerli_testing for Nethermind and unstable for Nimbus
Gitter Bridge
@nethermind-bridge
[discord] <TobiWo> Mhh, no develop image tag for nethermind available πŸ€”
[discord] <TobiWo> Also no unstable or develop image tag for nimbus available.
[discord] <TobiWo> Then I need to build πŸ‘·