These are chat archives for nextflow-io/nextflow

18th
Apr 2016
Paolo Di Tommaso
@pditommaso
Apr 18 2016 09:42
@JoseEspinosa What's up?
Jose Espinosa-Carrasco
@JoseEspinosa
Apr 18 2016 09:47
You didn't want another :beer:
I solve it! Thanks!
Paolo Di Tommaso
@pditommaso
Apr 18 2016 13:24
in the meanwhile my computer crashed three times
Jason Byars
@jbyars
Apr 18 2016 22:22
Hey, with build 0.18.0, are there any new weird quirks for sge? It's hanging for me on the hello test job. .command.log show line 25: syntax error near unexpected token<'`. If I'm interpreting this correctly, that's an issue with this loop right?
    while read P PP;do
        ALL_CHILD[$PP]+=" $P"
    done < <(ps -e -o pid= -o ppid=)
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:24
um, I don't think so
Jason Byars
@jbyars
Apr 18 2016 22:25
interesting. I'm baking a new image on aws so of course I don't have a known good sge reference to test against.
any chance done < <(ps -e -o pid= -o ppid=) should be done < $(ps -e -o pid= -o ppid=)?
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:26
let m check
Jason Byars
@jbyars
Apr 18 2016 22:27
sure, the .command.run file is what is submitted to the job scheduler right?
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:27
yes
Jason Byars
@jbyars
Apr 18 2016 22:28
there are no syntax errors on pbs, so I'm probably wrong about the syntax issue
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:28
yes, that code didn't change recently
also we use it daily on SGE and it works fine
to be sure you can rollback to the previous version using the NXF_VER variable
for example:
NXF_VER=0.17.3 nextflow run ..
Jason Byars
@jbyars
Apr 18 2016 22:30
well this is the first version I've tried on SGE, but that's a good idea
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:30
ah, ok
um, make sure you are using BASH and not SH
you could check with something like this
echo 'env | grep SHELL' | qsub
Jason Byars
@jbyars
Apr 18 2016 22:33
good idea
sure enough SHELL=/bin/sh SGE_O_SHELL=/bin/bash
Jason Byars
@jbyars
Apr 18 2016 22:38
That was it. I would not have guessed that one.
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:39
I've wasted many hours of my life on installing SGE , you know ..
Jason Byars
@jbyars
Apr 18 2016 22:40
That was certainly my experience with most of the job schedulers. Now I just have to figure out how to get cfncluster to fix that by default.
Paolo Di Tommaso
@pditommaso
Apr 18 2016 22:41
It should be possible to set it as default, I don't remember how
Jason Byars
@jbyars
Apr 18 2016 22:43
It is, I just have to go back to the docs. I have to look up the docs anyway to change a couple other settings relating to auto job requeuing.
Jason Byars
@jbyars
Apr 18 2016 23:41
with the docker setup, is there anything special you have to do to make the .hidden files visible to the container? The folders appear to be sharing correctly between host and container, but .command.* is missing inside the container
I'm trying the docker/whalesay container for an example.
Jason Byars
@jbyars
Apr 18 2016 23:51
Turns out, it's not just the hidden files. There's just something strange with docker and the shared folder cfncluster creates