Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 13:02
    valvanet closed #2058
  • 00:43
    JamieSlome opened #2063
  • May 20 21:28
    Anas-Sherif labeled #2062
  • May 20 21:28
    Anas-Sherif opened #2062
  • May 20 19:46
    sbsaylors labeled #2061
  • May 20 19:45
    sbsaylors opened #2061
  • May 20 12:43

    jc21 on v3

    Some dns additions (compare)

  • May 18 02:22
    quangnv13 edited #2060
  • May 18 02:21
    quangnv13 opened #2060
  • May 18 02:21
    quangnv13 labeled #2060
  • May 16 17:27
    valvanet opened #2058
  • May 16 17:27
    valvanet labeled #2058
  • May 16 01:41
    jsimonrichard labeled #2057
  • May 16 01:41
    jsimonrichard opened #2057
  • May 15 15:42
    DFS-90 labeled #2055
  • May 15 15:42
    DFS-90 opened #2055
  • May 15 06:51
    xiaoxinpro edited #2052
  • May 15 00:02
    marrobHD opened #2054
  • May 15 00:02
    marrobHD labeled #2054
  • May 14 11:05
    Baipyrus labeled #2053
Franklin J Lee
@Retrockit

And this is the error I get in fallback_error.log

2022/02/20 02:23:52 [error] 279#279: *7 connect() failed (111: Connection refused) while connecting to upstream, client: 10.11.1.142, server: nginxproxymanager, request: "POST /api/tokens HTTP/1.1", upstream: "http://127.0.0.1:3000/tokens", host: "10.11.4.2:81", referrer: "http://10.11.4.2:81/login"

Brian Munro
@LePresidente
NginxProxyManager/nginx-proxy-manager#1875 I'm not sure why this is failing now? what would the correct way to implement this as a possible future feature?
faiz mustofa
@faizmustofa10_twitter
where is the directory location, configuration
proxy_connect_timeout
proxy_send_timeout
proxy_read_timeout
somebody, can help me ?
faiz mustofa
@faizmustofa10_twitter
where is the proxy.conf file stored?
faiz mustofa
@faizmustofa10_twitter
where is the conf.d/include/proxy.conf directory ?
zierbeek
@zierbeek
hi all, the http to https which isn't working, is it something that is worked on?
skyler14
@skyler14:matrix.org
[m]
hey guys, im still trying to wrap my head around what nginxproxymanager can do. I had a paid rotating proxy I used to route traffic based on an IP whitelist for an application, and I am switching to another provider though this one operates on user/pw instead of ip whitelist which kind of bricks a few things for me. I wanted to try and use the proxy manager as a reverse proxy where I'll host this and then point to my service providers proxy IP pool for each of those connections.
Basically I'll have ngpm handle the auth and forward almost just like the ip whitelist version
skyler14
@skyler14:matrix.org
[m]
Anything horrifically wrong with this plan, not an nginx poweruser by any stretch
skyler14
@skyler14:matrix.org
[m]
i suppose its more accurate to say in this case im trying to use it as a forward proxy then aren't
Uzair Ali
@uzairali001
hi, how are you guys
I'm trying to build frontend app locally. I clone the repo go to the frontend folder run npm install then npm run watch but app is not starting instead it is showing bunch of errors
Do I need to do something else to start it?
> webpack --watch --mode development


webpack is watching the files…

(node:15572) DeprecationWarning: Tapable.plugin is deprecated. Use new API on `.hooks` instead
(Use `node --trace-deprecation ...` to show where the warning was created)
‼ 「copy-webpack-plugin」: unable to locate 'app-images' at 'F:\app\frontend\app-images'
Hash: e6af2c8a872a49d7b1bd
Version: webpack 4.44.1
Time: 2781ms
Built at: 14/03/2022 12:37:03 am
                     Asset      Size  Chunks             Chunk Names
                index.html  1.79 KiB          [emitted]
  js/0.bundle.0.js?v=0.0.0  18.1 KiB       0  [emitted]
  js/1.bundle.1.js?v=0.0.0  20.3 KiB       1  [emitted]
js/10.bundle.10.js?v=0.0.0  13.5 KiB      10  [emitted]
js/11.bundle.11.js?v=0.0.0  48.3 KiB      11  [emitted]
js/12.bundle.12.js?v=0.0.0  17.3 KiB      12  [emitted]
js/13.bundle.13.js?v=0.0.0  29.7 KiB      13  [emitted]
js/14.bundle.14.js?v=0.0.0  34.5 KiB      14  [emitted]
js/15.bundle.15.js?v=0.0.0  27.7 KiB      15  [emitted]
js/16.bundle.16.js?v=0.0.0  8.66 KiB      16  [emitted]
js/17.bundle.17.js?v=0.0.0  2.73 KiB      17  [emitted]
js/18.bundle.18.js?v=0.0.0  6.79 KiB      18  [emitted]
js/19.bundle.19.js?v=0.0.0  2.06 KiB      19  [emitted]
  js/2.bundle.2.js?v=0.0.0  15.9 KiB       2  [emitted]
js/20.bundle.20.js?v=0.0.0  3.22 KiB      20  [emitted]
js/21.bundle.21.js?v=0.0.0  3.12 KiB      21  [emitted]
js/22.bundle.22.js?v=0.0.0  2.64 KiB      22  [emitted]
js/23.bundle.23.js?v=0.0.0   4.5 KiB      23  [emitted]
js/24.bundle.24.js?v=0.0.0  3.18 KiB      24  [emitted]
js/25.bundle.25.js?v=0.0.0  3.19 KiB      25  [emitted]
js/26.bundle.26.js?v=0.0.0  3.28 KiB      26  [emitted]
js/27.bundle.27.js?v=0.0.0  2.87 KiB      27  [emitted]
js/28.bundle.28.js?v=0.0.0  7.29 KiB      28  [emitted]
js/29.bundle.29.js?v=0.0.0   2.9 KiB      29  [emitted]
  js/3.bundle.3.js?v=0.0.0  17.1 KiB       3  [emitted]
js/30.bundle.30.js?v=0.0.0  8.08 KiB      30  [emitted]
js/31.bundle.31.js?v=0.0.0  4.99 KiB      31  [emitted]
js/32.bundle.32.js?v=0.0.0   8.4 KiB      32  [emitted]
js/33.bundle.33.js?v=0.0.0  24.1 KiB      33  [emitted]
  js/4.bundle.4.js?v=0.0.0  20.3 KiB       4  [emitted]
  js/5.bundle.5.js?v=0.0.0  18.8 KiB       5  [emitted]
  js/6.bundle.6.js?v=0.0.0  19.5 KiB       6  [emitted]
  js/7.bundle.7.js?v=0.0.0    20 KiB       7  [emitted]
  js/8.bundle.8.js?v=0.0.0  18.3 KiB       8  [emitted]
  js/9.bundle.9.js?v=0.0.0  10.1 KiB       9  [emitted]
js/login.bundle.js?v=0.0.0   855 KiB   login  [emitted]  login
 js/main.bundle.js?v=0.0.0  1.63 MiB    main  [emitted]  main
                login.html  1.83 KiB          [emitted]
Entrypoint main = js/main.bundle.js?v=0.0.0
Entrypoint login = js/login.bundle.js?v=0.0.0
[./js/app/api.js] 18.2 KiB {main} {login} [built]
[./js/app/audit-log/main.js] 1.79 KiB {2} [built]
[./js/app/cache.js] 149 bytes {main} [built]
[./js/app/controller.js] 11 KiB {main} [built]
[./js/app/i18n.js] 778 bytes {main} {login} [built]
[./js/app/main.js] 3.81 KiB {main} [built]
[./js/app/router.js] 581 bytes {main} [built]
[./js/app/tokens.js] 2.29 KiB {main} {login} [built]
[./js/app/ui/main.js] 2.21 KiB {main} [built]
[./js/index.js] 3.08 KiB {main} [built]
[./js/lib/marionette.js] 448 bytes {main} [built]
[./js/login.js] 82 bytes {login} [built]
[./js/login/main.js] 296 bytes {login} [built]
[./js/login/ui/login.js] 1020 bytes {login} [built]
[./scss/styles.scss] 1.09 KiB {main} [built] [failed] [1 error]
    + 437 hidden modules

WARNING in unable to locate 'app-images' at 'F:\app\frontend\app-images'

ERROR in ./scss/styles.scss
Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
SassError: File to import not found or unreadable: ~tabler-ui/dist/assets/css/dashboard.
        on line 1 of scss/styles.scss
>> @import "~tabler-ui/dist/assets/css/dashboard";
   ^

    at F:\nginx-proxy-manager\frontend\node_modules\webpack\lib\NormalModule.js:316:20
    at F:\nginx-proxy-manager\frontend\node_modules\loader-runner\lib\L
Robin Rosiers
@RobinRosiers_gitlab
F:\app\frontend\app-images does not exist
Uzair Ali
@uzairali001

F:\app\frontend\app-images does not exist

That's wrong path it should be F:\nginx-proxy-manager\frontend\app-images but why did it replace nginx-proxy-manager with app?

Kristoph Becker
@beck_o:matrix.org
[m]
Hello, I've been trying for a while to get the manager to work with these settings:
version: '3'
services:
app:
image: 'jc21/nginx-proxy-manager:latest'
container_name: 'proxy'
restart: unless-stopped
ports:
  - '80:80'
  - '81:81'
  - '443:443'
network_mode: host
volumes:
  - ./data:/data
  - ./letsencrypt:/etc/letsencrypt

but when it runs on the host network I only get the following error "SyntaxError: Unexpected token < in JSON at position "

does anyone have an idea how to solve the problem?

mochman
@mochman:mochchat.com
[m]
Kristoph Becker: Where are you seeing that error? Do you have anything in your ./data folder?
Kristoph Becker
@beck_o:matrix.org
[m]
the error is in red directly under the password when i try to log in to the configuration afterwards
this is just an attempt to set it up differently, everything works when I run it in bridge mode, but I have the problem that the resolution of the ips often does not work.
in my pihole i have assigned proxy.home to the ip of the docker server with the nginx proxy manager and cname entries to the respective services that all point to proxy.home
Kristoph Becker
@beck_o:matrix.org
[m]
my pihole is on a diferent pc
Robin Rosiers
@RobinRosiers_gitlab
Pulled latest version of this in a docker container
getting this
image.png
aibradford
@aibradford
Is anyone able to help me? Im trying to be able to access my proxied domains within iframes, but im at a loss as to how to set that part up. Can anyone assist?
1 reply
Alexander
@alex:mueller-post.de
[m]
Hello. Does anyone run Mastodon with NPM? I am looking for some tips on how to implement this in NPM.
Btw., other services are already running great for me.
Karem Sobhy
@kemoantemo
hi after upgrading to 2.9.17 npm tries to take unlimited memory and make the vm unusable after limiting memory to 3 g via docker it now works but keep giving error about lua or crowdsec
so how can i debug of how to find the root issue
reverting to 2.9.16 the problem not there and it takes about 170mb of memory only
jc21
@jc21
ouch yeah I can replicate..
though I’m not seeing the errors.
Karem Sobhy
@kemoantemo
@jc21 so the issue fixed with 2.9.18? Or still fixing?
Karem Sobhy
@kemoantemo
tried 2.9.18 and all is good ty @jc21
jc21
@jc21
Yep managed to get it fixed but was too busy to do the paperwork
Rexodys
@rexodys:matrix.org
[m]
I installed npm yesterday but I lost any familiarity with nginx. How can I make a proxy that redirect test.domain.com/portainer to portainer and test.domain.com/npm to NPM? I tried setting it in Cusotm locations but I get error 502 😕
Rexodys
@rexodys:matrix.org
[m]
I also tried redirecting a subdomain to a folder I mapped to the docker container like a Nginx server could but I also get 502.
ex: chat.domain.com > /web/chatapp 😲 I can't seem to make anything work with NPM 😂 If someone knows how to make those works it would be a great starting point for me 🙂
Kopernikus
@Kopernikus1979
@jc21 Hi, could you have a look at this bug: NginxProxyManager/nginx-proxy-manager#1982 Thx
ultrask14
@ultrask14

Hi all, im using cloudflare > using nginx proxy manager for game services and homelab applications

Nginx doesnt seem to be able to differentiate between two of my game servers.

i have two Minecraft instances
mcserver1.example.com - 25565
mcserver2.example.com - 25575

Currently, any configuration of proxy setup points my games towards only mcserver1. DuckDNS however has no issue.

i have port forwarded 25565 & 25575 through the router. have setup two different cloudflare cname entries and nginx has records pointing to the different ports.

i know that the instances are being confused as the archive server (mcserver2) should be v1.16, however as you can see second game on the listing is using my mcserver2 address feedbacks information from mcserver1

if i disable / remove the cloudflare and nginx addresses for mcserver1 i can see here that lsiting for mcserver1 game goes down however the game listing for mcserver2 still stays up and still points to the mcserver1 game - so both entries are independently accessing the same game

Fabian Kaindl
@fabiankaindl:matrix.fabiankaindl.de
[m]
Please be aware that unless you pay Cloudflare much money they dont accept traffic on these ports
In theory you could make an SRV Entry at Cloudflare to use HTTP/HTTPS or the HTTP Alternative Ports to first make the traffic go through Cloudflare
ultrask14
@ultrask14

Please be aware that unless you pay Cloudflare much money they dont accept traffic on these ports

but traffic is being routed through these ports, i can connect to one of these games - im not sure i understand

In theory you could make an SRV Entry at Cloudflare to use HTTP/HTTPS or the HTTP Alternative Ports to first make the traffic go through Cloudflare

i use nginx to route through to the specific ports

ultrask14
@ultrask14

Please be aware that unless you pay Cloudflare much money they dont accept traffic on these ports

ive made SRV records to point to specific ports in cloudflare with seperate A records per game - this has not helped

1 reply
Fabian Kaindl
@fabiankaindl:matrix.fabiankaindl.de
[m]

Hey Everybody,

Does anybody use NPM on Docker Swarm can share some tips?

Spencer Imbleau
@simbleau
Similar question to above... has anyone deployed using Kubernetes?'
1 reply
macoilandgas
@macoilandgas_twitter
Anyone else have an issue with the audit logs being in the future. I have TZ: "America/Chicago" set in the docker-compse file for both the App, and DB. If i exec into the app and look at the date its correct. Also the logs coming of the system to /data/logs are correct. The audit log in the GUI however is in the future
Tealk
@tealk:tchncs.de
[m]
Does anyone have Fediverse instances running behind an Nginx proxy manager?