These are chat archives for nightscout/intend-to-bolus

21st
Aug 2015
diabeticgonewild
@diabeticgonewild
Aug 21 2015 03:37
Feel to crappy to get anything done.
Paul Andrel
@stavlor
Aug 21 2015 03:43
Well hope you feel better, I'm having fun in steroid land thanks to an Id reaction from poison ivy
Means its time to enact my crazy basal profile for the extra 40mg prednisone
Oliver Schumacher
@oschumac
Aug 21 2015 08:03
Hi, did somebody allready the problem. Medtronic Pump an rpi was working perfect. Decocare stick is up and running. Connection to pump is broken. First thing was i had to replace the battery of the pump. cause of an Battery low error of the pump. But now with an new battery it is still not working.
rpi reboot -> done
decocare stick test -> done
going completly crazy cause of still not working -> done
change out old batterys of pump -> done
what is next thing to test ?
Ben West
@bewest
Aug 21 2015 08:08
howdy @oschumac
so stick test validates that usb connection to stick is ok
what you are finding now, if I understand, is that connection to pump is troublesome?
Oliver Schumacher
@oschumac
Aug 21 2015 08:23
When i run openaps report invoke clock.json. It takes some minutes. The an error got raised pump has no model. blah blah.
So it looks like the pump has a problem.
Oliver Schumacher
@oschumac
Aug 21 2015 14:43
@bewest . My problem becomes strange.
change out pump battery again. -> still same prob.
setting pump to manufactory setting and configure new. -> still same.
useing laptop with carelink stick and decoding carelink lib directly. -> communication is working.
switch back to pi attach carelink stick. use openaps report invoke clock.json -> no communication.
Scott Leibrand
@scottleibrand
Aug 21 2015 14:48
Very odd. Do you have another Pi or Carelink stick to try?
Oliver Schumacher
@oschumac
Aug 21 2015 14:49
Yeah. i just tried to repead. And ..... now it works again.
Scott Leibrand
@scottleibrand
Aug 21 2015 14:50
Strange.
Oliver Schumacher
@oschumac
Aug 21 2015 14:50
i will test. on which circumstance it will work or not.
Scott question. How does the script sendbasalazure.js work ?
I can organize another stick.
Ali Mazaheri
@amazaheri
Aug 21 2015 16:07
@oschumac we were just talking about it with @scottleibrand last night. That is a module I added to post information from Pi to Azure SQL via WebApi
I use that for notifications and also reporting and soon some Machine Learning stuff. The source code for OpenAPSData is on my repo and I am in process of pushing to OpenAPS repo as well
Ali Mazaheri
@amazaheri
Aug 21 2015 16:18
Capture728.PNG Same code also updates MongoDB to use NightScout for visualization.
wp_ss_20150727_0002.png
Toby Canning
@TC2013
Aug 21 2015 18:38
@amazaheri Nice work! Now, do you think you can get negative basals to display in NS?
Oliver Schumacher
@oschumac
Aug 21 2015 18:53
@bewest Hi, actually. It looks alike an software prob. I don't know why i am the only one.
I bought a new pi. -> same prob.
i tried the pi with an external usb. Cause e thought it will be a USB-Power prob. (Some users got probs. with usb power. -> same prob.
i tried to use this on my Ubuntu Laptop. Where decoding carelink is running always properly. -> same prob.
Oliver Schumacher
@oschumac
Aug 21 2015 18:58
The only things which are different. From my setup to your setup is i have only an old medtronic 512 which is running also an old Firmware Ver 2.1D. And all are EU Versions (864 Mhz).
Ben West
@bewest
Aug 21 2015 18:59
512 doesn't have some commands
Oliver Schumacher
@oschumac
Aug 21 2015 18:59
The funny thing is somtimes it runs and sometimes not. Like RF Modul is not powering up or somthing like that.
Yes some are missing like getting settings.
Do you have an idea what can i try to get behind the prob ?
Ben West
@bewest
Aug 21 2015 19:01
I'm not sure what the problem is actually
so you can communicate with the pump sometimes?
Oliver Schumacher
@oschumac
Aug 21 2015 19:02
Yes. And with my old script which uses only set temp basals it runs on my Laptop always. As long the Carelink usb stick is recognized propperly.
But in this case dmesg shows an carelink which is 100%.
Is somebody using an 512 with old firmware on it ?
Ben West
@bewest
Aug 21 2015 19:16
sorry, still having trouble understanding the problem
which scripts are you running?
Oliver Schumacher
@oschumac
Aug 21 2015 19:25
i use an own loop.sh.
And it started with openaps report invoke clock.json
then i get this
This message was deleted
This message was deleted
Bildschirmfoto vom 2015-08-21 21:28:12.png
this one saying pump has no model.
which happens so far when the pump is not reachable.
Oliver Schumacher
@oschumac
Aug 21 2015 19:34
so the really funny thing is right after i made this with the openaps code. i started my old scrip which only uses decoding carelink. This one is able to talk with the pump and send an temporary basal.
Ali Mazaheri
@amazaheri
Aug 21 2015 19:51
@TC2013 My hope is to sit with @jasoncalabrese during CWD conference to hash it out :)
Toby Canning
@TC2013
Aug 21 2015 19:52
Awesome!!!
Jason Calabrese
@jasoncalabrese
Aug 21 2015 19:57
need to make NS aware of temp basals, make it work for careportal and openaps
Ali Mazaheri
@amazaheri
Aug 21 2015 20:03
@jasoncalabrese amen!
or @TC2013 will nag at me for my wrong calculated IOB on twitter :) hehe
Dana Lewis
@danamlewis
Aug 21 2015 20:31
:) to all of this
Ali Mazaheri
@amazaheri
Aug 21 2015 20:32
we need a OpenAPS group hug and should start #openapsarmy on twitter :)
Ben West
@bewest
Aug 21 2015 20:36
I see, the missing model problem
I'm still a bit confused
are you saying the openaps loop works and clock does not
or that clock never works
does same thing happen with openaps use pump model ?
what version of openaps/decocare are you using?
Oliver Schumacher
@oschumac
Aug 21 2015 20:52
no sorry it works sometimes.
Ben West
@bewest
Aug 21 2015 20:52
ok, what version of openaps?
Oliver Schumacher
@oschumac
Aug 21 2015 20:52
actually i uplooad my image to googledrive
Ben West
@bewest
Aug 21 2015 20:53
openaps --version
Oliver Schumacher
@oschumac
Aug 21 2015 20:54
0.0.6
Ben West
@bewest
Aug 21 2015 20:54
ok
sudo easy_install -ZU openaps
here's what I suspect is happening:
the openaps medtronic vendor knows that the pump requires sessions with limited lifetime, that must be re-initialized when the time runs out
so every time it starts a session, it saves the expiration date in openaps.ini, and then it won't try to restart the session until the current time is past that expiration date
we saw this with ali and scott and nate's rigs as well
what happens is, towards the end of the session, it gets closer and closer to that expiration time of the session
and if the commands themselves take long enough, you can wind up in a weird state where your session has expired, but openaps thinks it's probably ok
oh, you are using 0.0.6
that should have the fix I had in mind, that more tightly limits that expiry time
are you getting same behavior with openaps use pump model?
Dana Lewis
@danamlewis
Aug 21 2015 21:36
@amazaheri Maybe not army. There's an Afrezza army and they're not so nice. We're totally nice.
Ben West
@bewest
Aug 21 2015 21:51
openaps care bears?
unicorns?
Oliver Schumacher
@oschumac
Aug 21 2015 22:00
@bewest I double checked my pi and it had 0.0.4 my laptop was 0.0.6 . So i have updated the pi. Looks good so far. Thanks Ben !!!!!!!!
Ben West
@bewest
Aug 21 2015 22:07
ahhh ha!
:-)
Ali Mazaheri
@amazaheri
Aug 21 2015 22:23
ahh you are right, totally forgot about it 😊
unicorns is cool
😊
Dana Lewis
@danamlewis
Aug 21 2015 22:42
As long as they're cinnamon flavored, I mean colored.
Rachel Sandlain
@audiefile
Aug 21 2015 22:45
cinnamon unicorns sound awesome
Ali Mazaheri
@amazaheri
Aug 21 2015 23:30
sugar free, made with almond flour