These are chat archives for nightscout/intend-to-bolus

31st
Jan 2016
Ben West
@bewest
Jan 31 2016 01:51
ooo, good news, found a distribution channel for images and debs
eszcloud
@eszcloud
Jan 31 2016 06:11
Anyone seen this error before?
GitCommandError: 'git add recent_glucose.json' returned with exit code 128
stderr: 'fatal: Unable to create '/home/pi/myopenaps/.git/index.lock': File exists.

If no other git process is currently running, this probably means a
git process crashed in this repository earlier. Make sure no other git
process is running and remove the file manually to continue.'
I went in and manually deleted index.lock and things are back to normal.
just wondering if this is something to track down more to avoid in the future
Scott Leibrand
@scottleibrand
Jan 31 2016 06:17
I have an automated thing to rm that.
eszcloud
@eszcloud
Jan 31 2016 06:21
thx
Aaron Michelson
@Aaybob
Jan 31 2016 07:51
does documentation exist for azure setup in cgm-in-the-cloud that is not step by step of a discontinued web procedure but would help one who wanted to setup nightscout do so using the microsoft azure website of 2016
Matthias
@ceben80
Jan 31 2016 09:48
I just want to run several openaps pump command. Any idea why this bolus command does not work for my 754 (2.6A)?
veo754_bolus.JPG
Thomas Emge
@ThomasEmge
Jan 31 2016 09:48
Has anyone outlined steps to get Dexcom share going on RPI (Jessie) via BLE? I have now my RPI uploading the glucose values into NS and I would really like to get rid of the cable for the dexcom. I have installed @bewest deb packages but still no success.
Sulka Haro
@sulkaharo
Jan 31 2016 10:28
Right, I have a bizarre behavior from yesterday. Sadly no GIT log, but got device statuses that don't make sense. We went to get a burger and bolused 30 grams of carbs (too little, sadly) so the dude raised up to 176 and got stuck there. Some time later OpenAPS zero-temped (or so the treatment history says) BUT at the same time, the status log says:
    "openaps": {
        "suggested": {
            "bg": 174,
            "temp": "absolute",
            "snoozeBG": 206,
            "timestamp": "2016-01-30T15:18:54.000Z",
            "reason": "Meal assist: 30g, 1.875U, bolus snooze: eventual BG range -140-206",
            "eventualBG": -140,
            "mealAssist": "On: Carbs: 30 Boluses: 1.875 Target: 98.5 Deviation: 39 BGI: -11.16",
            "tick": "+2"
        },
        "iob": {
            "timestamp": "2016-01-30T15:18:54.000Z",
            "bolussnooze": 1.283,
            "basaliob": 0.243,
            "iob": 1.959,
            "activity": 0.0124
        },
        "enacted": {
            "requested": {
                "duration": 0,
                "rate": 0,
                "temp": "absolute"
            },
            "bg": 170,
            "temp": "absolute",
            "snoozeBG": 114,
            "timestamp": "2016-01-30T14:33:47.000Z",
            "reason": "114 is in range. No temp required; cancel",
            "rate": 0,
            "eventualBG": 114,
            "recieved": false,
            "duration": 0,
            "mealAssist": "Off: Carbs: 0 Boluses: 0 Target: 103.5 Deviation: 9 BGI: -0.72",
            "tick": "+1"
        }
    },
Where the status indicates the loop thinks no zero-temp was enacted and we were (correctly) in bolus snooze. Really can't figure out what happened.
There's no devicestatus log entry that has the zero-temp enacted and I can't see how the loop would function if any of the data was missing.
Sulka Haro
@sulkaharo
Jan 31 2016 10:34
Having the loop set the current basal on every loop would have worked well here.
lizarragakevin
@lizarragakevin
Jan 31 2016 11:19
Hi I've a question this proyect works with medtronic paradigm mmt-754?
Matthias
@ceben80
Jan 31 2016 11:21
@lizarragakevin I have asked this question yesterday see here
lizarragakevin
@lizarragakevin
Jan 31 2016 11:43
@ceben80 thanks for the info
C-Ville
@C-Ville
Jan 31 2016 11:45
@lizarragakevin good luck :-)
lizarragakevin
@lizarragakevin
Jan 31 2016 11:48
have a problem my pump have a 2.8B soft version what should I do?
@C-Ville THANKS!
Matthias
@ceben80
Jan 31 2016 11:51
has written above - Does your 754 have a PC Connect menu somewhere in the menus?
lizarragakevin
@lizarragakevin
Jan 31 2016 11:54
@ceben80 yes, in utilities menu
Sulka Haro
@sulkaharo
Jan 31 2016 12:01
@lizarragakevin sadly that means you have a too new firmware version in the pump - the PC Connect feature indicates the pump will not accept the required temp basal commands unless you manually put it into the PC Connect mode, which automatically times out pretty quickly.
lizarragakevin
@lizarragakevin
Jan 31 2016 12:08
@sulkaharo ok thanks, well I'll see what I can do, thanks for the info!
Dana Lewis
@danamlewis
Jan 31 2016 13:05
On my umpteenth flight, continuing to have zero problems with all my openAPS setups going through TSA, even when I'm carrying multiple setuPs in my carry on bag.
C-Ville
@C-Ville
Jan 31 2016 13:46
@danamlewis that is great
Dana Lewis
@danamlewis
Jan 31 2016 13:48
Yup. Didn't want people to worry about travel. No different than phones and other similar pocket super computers :)
LadyViktoria
@LadyViktoria
Jan 31 2016 13:51
i can agree i travelld with xdrip in my bag and pump on my body . the only thng they asked if i am a single because of the vibrator(lithium ion batteries) in my bag
C-Ville
@C-Ville
Jan 31 2016 14:21
so I will take my XDrip in my carry on, when flying to Milano next week, that is great
LadyViktoria
@LadyViktoria
Jan 31 2016 14:23
yes
Rachel Sandlain
@audiefile
Jan 31 2016 15:22
@Aaybob use manage.azurewebsites.net
@ceben80 I think that command requires a json input file
Matthias
@ceben80
Jan 31 2016 16:10
@audiefile yes that is connect, meanwhile I was able to give a Bolus from my RPi, works fine
Dana Lewis
@danamlewis
Jan 31 2016 17:06
:boom: #OpenAPS = (n=1)*33 :)
C-Ville
@C-Ville
Jan 31 2016 17:14
that is awesome
C-Ville
@C-Ville
Jan 31 2016 17:31
is anyone going to the ATTD in Italy next week?
Dana Lewis
@danamlewis
Jan 31 2016 17:31
I think @HowardLook @brandonarbiter will be there, not sure who else.
C-Ville
@C-Ville
Jan 31 2016 17:40
thanks, I might get in touch with them
Dana Lewis
@danamlewis
Jan 31 2016 17:40
:+1:
C-Ville
@C-Ville
Jan 31 2016 17:50
i did not see any workshop/seminar on openAPS :-(
Dana Lewis
@danamlewis
Jan 31 2016 17:50
no, I don’t think anyone’s covering it. they’re attending for other reasons and can probably share some insight 1:1 though :)
If you haven’t seen it already, @channemann gave a good talk at DData that’s online here: http://bit.ly/1OwZ4vQ
Scott Leibrand
@scottleibrand
Jan 31 2016 18:43
@sulkaharo you're mis-interpreting that output
rate 0 duration 0 means "cancel temp" not "set zero temp"
the latter is rate 0 duration 30
but if you do switch to the latest meal-assist branch, you'll get the "set current basal as temp" behavior, which should be more intuitive
PieterGit
@PieterGit
Jan 31 2016 19:06
does oref0 always use mg/dL? i don't understand why openaps does glucose conversion differently than oref0, see my latest comment in issue openaps/oref0#62
Ben West
@bewest
Jan 31 2016 19:08
oref0 always consumes mg/dL
that's why I recommend always running units tool to convert
the tool leaves n attribute to describe what the old units was
units is always the current unit represented
nightscout is built to handle any units
C-Ville
@C-Ville
Jan 31 2016 19:10
@danamlewis thank you for the link
Ben West
@bewest
Jan 31 2016 19:11
@PieterGit in this case, your data is in fact in mg/dL since pump history is generally like that, but your NS defaults to mmol, so you are informing your NS that this data is explicitly a different unit
Sulka Haro
@sulkaharo
Jan 31 2016 19:12
@scottleibrand ok that makes sense. And if the loop failed to set the new temp, that'd produce the 30 minute zero temp. Still baffled why it set the zero temp in the first place though, statuses before and after all show "bolus snooze"
Scott Leibrand
@scottleibrand
Jan 31 2016 19:13
No
where did you see a zero temp?
it wasn't in what you pasted
PieterGit
@PieterGit
Jan 31 2016 19:21
@bewest : thanks, for the explanation. i must see that looking at the oref0 and openaps source code is quite challenging. i sometimes read code in openaps when, it turns out i should read code in oref0 and the other way around.
Ben West
@bewest
Jan 31 2016 19:22
openaps is kind of a framework for putting everything that matters in a workspace and making lots of tools work the same exact way
so medtronic/dexcom/oref0 are all very different, but openaps makes them all behave the same way
this business with units is one of the things where there are tons of details to get right
Ben West
@bewest
Jan 31 2016 19:29
@PieterGit I think all the tools need a markdown file in a docs directory explaining what format they consume and emit
and possibly another tool to sweep pump-history for units
but in your case
because your NS is explicitly set to mmol
and your data is explicitly in mg/dL
the correct thing is to make sure ?units=mg/dL is set when you upload to NS
that's the purpose of that feature, to ensure that NS can handle any incoming data appropriately
PieterGit
@PieterGit
Jan 31 2016 19:31
thanks. is either dexcom cgm or medtronic cgm (enlite) prefered. currently my wife uses the freestyle libre which works nice with Nightscout (thanks to Glimp), but isn't a real continuous cgm.
Ben West
@bewest
Jan 31 2016 19:32
whatever you prefer
NS is designed to just handle the data :-)
PieterGit
@PieterGit
Jan 31 2016 19:44
but are the others who have tried both and prefer one. the dexcom G5 seems to work fine with nightscout, but isn't listed on the openaps hardware list. am i right that openaps/oref0 tools should also work with dexcom g5 cgm?
Scott Leibrand
@scottleibrand
Jan 31 2016 19:45
Dexcom G4 is the best for oref0 right now.
G5 will work if you pull BG from NS, but isn't fully supported for offline use.
Medtronic's enlite sensor is way less accurate for most people than the Dexcom ones.
MDT CGM will work with the right config, but YMMV as far as trusting it to loop safely
Cosmo Wolfe
@cozmo
Jan 31 2016 20:20
@scottleibrand What’s the difference between the g4 and g5 that makes the g4 usable without NS as an intermediary? The g5 receiver just hasn’t been backwards engineered yet?
Scott Leibrand
@scottleibrand
Jan 31 2016 20:29
It has, but there's no auto detection code yet, so you have to get a custom branch.
(for wired USB)
for wireless openxshareble, G4 is only option right now.
BLE comms to G5 are only available in Nate's iOS library so far, not integrated with any openaps tools.
Cosmo Wolfe
@cozmo
Jan 31 2016 20:31
Is there a link to that library?
for BLE
Naming overload: this does not share any code with xDrip for Android.
It's its own iOS thing.
Cosmo Wolfe
@cozmo
Jan 31 2016 20:33
:thumbsup:
Ben West
@bewest
Jan 31 2016 21:37
nifty:
 1836  openaps init foo
 1837  cd foo/
 1838  openaps -C ~/Documents/openaps/openaps.ini report show --json foobar.json  | json | openaps import 
 1839  openaps -C ~/Documents/openaps/openaps.ini report show --json   | json -g | openaps import 
 1840  view openaps.ini 
 1841  openaps -C ~/Documents/openaps/openaps.ini vendors show --json   | json -g | openaps import 
 1842  openaps -C ~/Documents/openaps/openaps.ini vendors show --json   | json -g 
 1843  openaps -C ~/Documents/openaps/openaps.ini vendor show --json   | json -g 
 1844  openaps -C ~/Documents/openaps/openaps.ini vendor show --json   | json -g | openaps import 
 1845  ls
 1846  openaps -C ~/Documents/openaps/openaps.ini device show --json   | json -g | openaps import 
 1847  ls
 1848  view ti.ini 
 1849  openaps use -h
 1850  openaps -C ~/Documents/openaps/openaps.ini device alias --json   | json -g | openaps import 
 1851  openaps -C ~/Documents/openaps/openaps.ini openaps alias --json   | json -g | openaps import 
 1852  openaps -C ~/Documents/openaps/openaps.ini alias --json   | json -g | openaps import 
 1853  openaps -C ~/Documents/openaps/openaps.ini alias show --json   | json -g | openaps import 
 1854  history
bewest@bewest-MacBookPro:~/src/openaps/web-loop-config/example_home/foo$
bewest@bewest-MacBookPro:~/src/openaps/web-loop-config/example_home/foo$ openaps import -h
usage: openaps-import [-h] [input]

 openaps-import - import openaps configuration
  Import configuration.

positional arguments:
  input       Read from stdin

optional arguments:
  -h, --help  show this help message and exit

Example workflow:

openaps -C /path/to/another/openaps.ini device show --json ns-upload | openaps import -
bewest@bewest-MacBookPro:~/src/openaps/web-loop-config/example_home/foo$
Ben West
@bewest
Jan 31 2016 21:53
oref0 can now have a tool that creates a nice json doc for openaps to import for config purposes, so you could oref0-generate-ns-upload-config <HOST> <SECRET> | openaps import or similar... (eg from web-app/UI even)
Aaron Michelson
@Aaybob
Jan 31 2016 21:56
I never have to log on to wifi until oref0-reset-usb runs then i have to mannually log in. i set up the supplement file per instructions. is there a better way to run oref0-reset-usb? and I think i had eror messages that it did not have permision or something and it was never turning back on to wifi
Ben West
@bewest
Jan 31 2016 21:59
can also more easily select and modify single attributes in place, eg, openaps show device pump --json | json -e "this.extra.expires = null;" | openaps import will delete the expires field for pump in place
Aaron Michelson
@Aaybob
Jan 31 2016 22:00
maybe reboot is doing it....i've been moving to a RPi2 to a television and then rebooting so that i don't need network and then i don't know if it is logged in to network or not but i've been assuming i needed to
i feel like im juggling 15 balls trying to not drop any....i got nightscout on the phone and the webpage and the webpage isn't showing the graph and in "visualization" it says to initiate a profile with bassal rates but I can't find how
Ben West
@bewest
Jan 31 2016 22:42
nice
Jason Curry
@mccgm
Jan 31 2016 22:42
Suddenly, my CGM keeps losing connection with RP2. Nothing in my setup has changed.
Scott Leibrand
@scottleibrand
Jan 31 2016 22:48
USB wired to Pi?
Might be flaky cable.
Jason Curry
@mccgm
Jan 31 2016 22:49
Tried 3 cables.
I guess the Universe is telling me to unite my Nightscout and APS
Scott Leibrand
@scottleibrand
Jan 31 2016 22:50
What error?
Jason Curry
@mccgm
Jan 31 2016 22:53
In watching the battery level, it's about 80% and charging, then after about 10 seconds, it shows it's not charging and then SSH disconnects and won't reconnect without hard reset of RPi
Just wondering if anyone has seen this or if it's a unique problem.
Dana Lewis
@danamlewis
Jan 31 2016 22:53
Receiver has to be charged
Jason Curry
@mccgm
Jan 31 2016 22:54
OK, I thought I was ok if it was over 75%. It has to be 100% then?
Ben West
@bewest
Jan 31 2016 22:54
the dexcom reciever?
Jason Curry
@mccgm
Jan 31 2016 22:54
Yes
Ben West
@bewest
Jan 31 2016 22:55
it can be at 10%
Jason Curry
@mccgm
Jan 31 2016 22:55
I thought I had used it with no problem at ~50%
Ben West
@bewest
Jan 31 2016 22:55
battery level of receiver does not affect openaps
Dana Lewis
@danamlewis
Jan 31 2016 22:55
@bewest it impacts the Pi
Ben West
@bewest
Jan 31 2016 22:56
ah, bigger power draw maybe
Lori
@LoriLori
Jan 31 2016 22:56
sounds like battery for Pi issue
Dana Lewis
@danamlewis
Jan 31 2016 22:56
@mccgm Try charging the receiver and then re plugging in
So the receiver isn't stealing needed power from the Pi
Ben West
@bewest
Jan 31 2016 22:56
it sounds more like a cable issue
if there is a bads/loose cable, the flagging usb connection can wipe out other usb connection
Lori
@LoriLori
Jan 31 2016 22:57
cable too, between Pi and battery for pi, thickest cable you can find is recommended, typically those for charging tablets
Jason Curry
@mccgm
Jan 31 2016 22:58
Yeah, I have eliminated the cable issue, but I'm charging to 100 and trying again. Thanks everyone
Jason Curry
@mccgm
Jan 31 2016 23:19
I changed to using my Nightscout data and I am getting a great suggested and enact to my pump. When I run loop however I get "No CGM data"
oops, forgot to modify my glucose.json report