These are chat archives for nightscout/intend-to-bolus

5th
Mar 2016
Jim Matheson
@jmatheson
Mar 05 2016 00:17
@mddub new face is sweeeeet. Thx!
Jim Matheson
@jmatheson
Mar 05 2016 01:41
is there anything special in wpa_supplicant if the wifi is WPA/WPA2 Personal (instead of simply WPA2 Personal). really struggling to connect to this wifi
my edison can see it, but does not want to connect
Jim Matheson
@jmatheson
Mar 05 2016 01:54
seems like it does not like the password hash. not sure why.
Jim Matheson
@jmatheson
Mar 05 2016 02:47
finally got conneted. can ssh in now, but it is still not able to ping anything. which is strange.
Ben West
@bewest
Mar 05 2016 02:59
are you able to run wpa_passphrase?
Jim Matheson
@jmatheson
Mar 05 2016 03:04
yea, i am for sure connected finally
i am ssh’d in
over wifi
but the edison can’t ping anything on the net
Ben West
@bewest
Mar 05 2016 04:44
hmm, you were able to ssh in but not "use the 'net"
Scott Leibrand
@scottleibrand
Mar 05 2016 05:28
Usually that means it didn't get an IPv4 address.
And you were ssh'd via link-local IPv6.
Try a sudo dhclient wlan0
and maybe ifconfig wlan0 before and after.
Ben West
@bewest
Mar 05 2016 07:10
yeah, seems like dhcp setup
ah, ipv6 would explain
it's finally here, eh?
for awhile ipv6 was like next diabetes cure
that's sad...
how many technologies will surpass diabetes tech?
ipv6 lapped diabetes
will self-driving cars or hyperloop?
Kevin Wells
@wkcwells
Mar 05 2016 07:12
@jmatheson What host name are you ssh’ing to? What you are describing can also happen if you are ssh’ing to a .local through zero conf networking.
Ben West
@bewest
Mar 05 2016 07:14
he did ssh via .local
Kevin Wells
@wkcwells
Mar 05 2016 07:17
In my experience, edison networking is much less relaible than Pi. My current config in /etc/network/interfaces has manual for DHCP for the interface, and a separate config for each Wi-Fi network by tag.
They look like this:
iface home inet dhcp
iface mobile inet dhcp
The interface config looks like this:
iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
Kevin Wells
@wkcwells
Mar 05 2016 07:22
That seems to get wpa_supplicant to fire up dhclient when it associates.
Tim Howard
@tghoward
Mar 05 2016 14:09
Does anyone know exactly what inputs openaps use pump set_temp_basal needs? I can't seem to find it down in the code. I'm assuming a json containing only these fields should be all
{"temp":"absolute","duration":30,"rate":0}
^^ I'm assuming that should be all it needs ....
Hichame Yessou
@hichameyessou
Mar 05 2016 15:09
Someone knows another website (except medwow) where I can buy pumps?
Scott Leibrand
@scottleibrand
Mar 05 2016 15:44
@tghoward that is correct.
Tim Howard
@tghoward
Mar 05 2016 15:47
@scottleibrand Thanks! That's helpful to know. Was trying to debug some issues that turned out to be a mmeowlink bug that was already fixed (but not yet fetched by me!).
Scott Leibrand
@scottleibrand
Mar 05 2016 15:48
Yeah, figured it was that. :-)
Tim Howard
@tghoward
Mar 05 2016 15:49
... but it does beg the question that that kind of information cannot be retrieved by openaps use pump set_temp_basal -h
would it be hard to slowly incorporate that kind of info?
Scott Leibrand
@scottleibrand
Mar 05 2016 15:56
Not sure, but I think @bewest may have kept that purposefully vague originally? Probably time to add it in, though.
Scott Leibrand
@scottleibrand
Mar 05 2016 16:08
Anyone else having issues with Dexcom Share app/servers today?
Ali Mazaheri
@amazaheri
Mar 05 2016 17:05
working for us.
Chris Hannemann
@channemann
Mar 05 2016 17:34
@scottleibrand working here as well
Scott Leibrand
@scottleibrand
Mar 05 2016 17:35
K, seems to be a BLE problem, not server.
Jim Matheson
@jmatheson
Mar 05 2016 19:24
I have the same setup you mentioned @wkcwells
Jim Matheson
@jmatheson
Mar 05 2016 19:37
my syslog shows i am connected, but now cant sssh to the .local or ping anything.
Jim Matheson
@jmatheson
Mar 05 2016 19:48
this results in this error.
edison@mursefree:~$ sudo dhclient wlan0
RTNETLINK answers: File exists
Scott Leibrand
@scottleibrand
Mar 05 2016 20:07
That means you already have an IP
Maybe sudo avahi-daemon restart then.
Ben West
@bewest
Mar 05 2016 20:09
hmmm?
my version has nice help
@tghoward, @scottleibrand
s$ openaps use pump set_temp_basal -h
usage: openaps-use pump set_temp_basal [-h] input

 Set temporary basal rates.

positional arguments:
  input

optional arguments:
  -h, --help  show this help message and exit

  Requires json input with the following keys defined:
    * `temp` - the type of temporary rate, `percent` or `absolute`
    * `rate` - The temporary rate, in units.  Examples, 0.0, 1.2, 0.1
    * `duration` - The duration in minutes of the temporary rate.  The duration must be multiples of 30 minutes.
  Eg, actively canceling a rate:
  { "temp": "absolute", "rate": 0, "duration": 0 }
  Zero basal for half hour:
  { "temp": "absolute", "rate": 0, "duration": 30 }
  One and a half units for one hour:
  { "temp": "absolute", "rate": 1.5, "duration": 60 }

bewest@bewest-MacBookPro:~/Documents/openaps$
Scott Leibrand
@scottleibrand
Mar 05 2016 20:11
:+1:
Ben West
@bewest
Mar 05 2016 20:12
similar for the others
it'd be good to create bunch of "yourfirstpr" issues with maybe links to these
it's very easy to add these help messages
it's just adding a comment in the code :-)
C-Ville
@C-Ville
Mar 05 2016 20:15
@bewest these help comments are awesome
several posts in a row kind of hovering around data-access issues
Jason Calabrese
@jasoncalabrese
Mar 05 2016 22:23
Couldn't let you over do it on you own and had to raise it another level
Eric Luhrs
@eluhrs
Mar 05 2016 22:27
Hi, all. Is anyone able to give me a hand adding g5 receiver support using loudnate/dexcom_reader from git? I've cloned the repo, built, and installed it, but I still get "Could not parse EGVRecord" when I run "openaps use cgm iter_glucose 1"
Tim Howard
@tghoward
Mar 05 2016 22:40
@bewest wow, nice help info. Never seen that before and I thought I was fully updated. I'll pull down dev again and see what I can find. Thanks.
C-Ville
@C-Ville
Mar 05 2016 22:43
@danamlewis given the increased number of people looping, do you by chance have a graph number of people looping over time? I guess such a graph would have a decent slope
Ben West
@bewest
Mar 05 2016 22:44
hmm can probably do a release
hmm, I do think it's helpful for everyone to call their vendor and file a support ticket
this costs them money and creates an official record that this is important
if we do that a couple thousand times, at some point it's simply too expensive to put up with
it's a waste for one person to do it, but collectively, it'd be pretty powerful
Bill Stackpole
@billstackpole
Mar 05 2016 23:00
hi all - also have a question about settings (profile). I understand and have set my IC ratio, but I'm not sure how to determine / set my "Carbs activity / absorption rate: [g/hour]"
does not appear to be basal rate, can you advise?
Bill Stackpole
@billstackpole
Mar 05 2016 23:03
tnk you!
had one other question posted in #nightscout/ios re: a password protected site.
can you advise?
Dana Lewis
@danamlewis
Mar 05 2016 23:36
@C-Ville Yes have posted the graph before :) will post an updated version later from computer , don't remember where I posted the first one. But current is a continual straight up line :)
Rachel Sandlain
@audiefile
Mar 05 2016 23:36
Not yet possible as far as I know. I don't think that's a trivial change either. @billstackpole
Bill Stackpole
@billstackpole
Mar 05 2016 23:38
@audiefile - you addressing the careportal input on pebble communicating back to nightscout/etc? (tnx)
going to play w/your pebble app as well - looks good.
also have three students interested in doing more with the project. One T1D with carelink and such, two others with interest. yay.
Scott Leibrand
@scottleibrand
Mar 05 2016 23:50
@billstackpole I don't think carb absorption rate should be required for OpenAPS. Where are you seeing that?
it definitely isn't required. There are some much older versions of code that referenced it, but I thought we pulled those all out.