These are chat archives for nightscout/intend-to-bolus

7th
May 2016
Brian Bonner
@itsn0tm3
May 07 2016 00:24
@danamlewis Heh will try to get some pictures!
@billstackpole Will check it out, didn't realize you had an openaps booth!
Ben West
@bewest
May 07 2016 00:36
for 754 and others, the release plans are not the same for rest of world vs US
my advice is simply to always try it out
Ben West
@bewest
May 07 2016 00:55
lot of companies like them have a per-country release roadmap, or often group them into regulatory domains, each with their own roadmaps. Medtronic's groups seems to be europe + canada + latin amercia, oceania, asia, USA. it'd be interesting to get some insider knowledge on how exactly they break these down
everyone usually has interesting names for regions... "euromea" sticks out in my mind from meraki days which was EUROpe plus Middle East plus Asia
Scott Leibrand
@scottleibrand
May 07 2016 00:58
And for "try it out" on a pump that's not yours, looking for PC Connect seems the most reliable indicator. If it's there, it's too new.
Ben West
@bewest
May 07 2016 01:00
ah, maybe, yeah
the escape screen at the bottom has the firmware, if that's helpful
yeah, PC Connect might be easier, given the opportunity cost, I just hate ruling out false positives... even when it's a negative it's still good for unifying everything in real time
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:02
@scottleibrand i think it falls a bit between the cracks because it’s been a rotating host.
Ben West
@bewest
May 07 2016 01:03
@CrushingT1D is there any ble dongle on this pi? I was tempted to install bluez on it to start playing with BLE
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:03
heck i was left off the invite because people keep copying my email list from those who attended mine a few months ago (which i was not on since that was my list) :)
Ben West
@bewest
May 07 2016 01:03
:-(
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:04
sucks we’ll miss you @scottleibrand
Ben West
@bewest
May 07 2016 01:04
we might have grown to need meetup or similar competitor?
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:04
yea, i bought a ble dongle and pugged it in there about a week ago
have not tried to set it up at all
Ben West
@bewest
May 07 2016 01:04
ok great
no worries
I have some deb packages that will work :-D
Scott Leibrand
@scottleibrand
May 07 2016 01:05
Dana has been using a good RSVP tool that is free and works well.
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:05
yeah, people use doodle here
Scott Leibrand
@scottleibrand
May 07 2016 01:05
I think it would allow people to get notified of new events too, which doodle doesn't.
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:05
but then the doodle invite does not make it out super wide
Scott Leibrand
@scottleibrand
May 07 2016 01:05
Doodle might be good for before you decide on the time
then
Ben West
@bewest
May 07 2016 01:05
yeah, have to think about lifecycle for these things
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:06
i think it’s kinda up to the organizer to publicize
Scott Leibrand
@scottleibrand
May 07 2016 01:06
Then whoozin is good for getting actual RSVPs once you've picked a time and place.
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:06
to be honest i have no idea if people have limits or not for their venue of choice etc
Scott Leibrand
@scottleibrand
May 07 2016 01:07
That would take a lot of the work off he organizer if it's a standing thing.
Ben West
@bewest
May 07 2016 01:07
here in SF, doug at stripe and others have offered us space
so it wouldn't be terribly hard to have a standing space at some interval, per se
Jim is CrushingT1D
@CrushingT1D
May 07 2016 01:07
anyway i agree we need a better system. people tend to just adopt what the last person did at least here in SF
Matthias
@ceben80
May 07 2016 04:23
@CrushingT1D congrats to 5,7 :star2:
John Males
@johnmales
May 07 2016 04:30
@CrushingT1D 5.7 is a fantastic result
Jim is CrushingT1D
@CrushingT1D
May 07 2016 05:59
@ceben80 @johnmales thanks :)
Andrew Warrington
@andrew-warrington
May 07 2016 06:08
@CrushingT1D I have to add my congrats as well - really well done. Inspiring.
Jim is CrushingT1D
@CrushingT1D
May 07 2016 06:09
thx.
Bill Stackpole
@billstackpole
May 07 2016 09:51
Woop @CrushingT1D - add me to the list of fans offering congrats! (I'm looking forward to my next bloodwork to get some hard feedback. Who ever would have thought I'd be excited about a blood draw?)
timomer
@timomer
May 07 2016 09:57
@colinlennon @andrew-warrington @danamlewis @oskarpearson ok so 26th looks like early afternoon may work for some? 1pm and ill think of somewhere central thats easy to travel too and has decent coffee. Sorry again I cannot make it for the evening meeting :(
Oskar Pearson
@oskarpearson
May 07 2016 10:47
I can't do the afternoon, unfortunately. Meetings most of the day.. Sorry to miss you!
Colin Lennon
@colinlennon
May 07 2016 12:08
@timomer Sounds good. Looks like I'll be flying to Stansted, should be in central London by noon so 1pm works for me!
ericmtx
@ericmtx
May 07 2016 12:37
have the traditional loop setup (carelink) working, but want to add an Edison/TI rig. How does the edison connect to the dexcom?
Sulka Haro
@sulkaharo
May 07 2016 12:38
re: firmware versions - at least some pumps can do OpenAPS with 2.6A. Our European Veo is 2.6 and works fine
Alex Kuzmanov
@alexkuzmanov
May 07 2016 12:39
Hello,
Alex Kuzmanov
@alexkuzmanov
May 07 2016 12:45
I have Medtronic pump, mmcarelink and enlite sensor and I try to configure OpenAps. I have a problem with glucose.json. In the initial file glucose_raw.json (enlite data) I have 5 records and after using glucosetools I have only 1 record in the resulting file.
Aaron Michelson
@Aaybob
May 07 2016 13:08
At 11:00 pm I took a too large bolus of 9.6
"2016-05-07T03:29:57" is the time and Preflight check is complete. Ready:
{"temp":"absolute","bg":86,"tick":-5,"eventualBG":58,"snoozeBG":58,"reason":"Eventual BG 58<90, no temp, setting -2.51U/hr","duration":30,"rate":0} "2016-05-07T04:39:56" is the time and Preflight check is complete. Ready: {"temp":"absolute","bg":39,"tick":-2,"eventualBG":44,"snoozeBG":44,"reason":"BG 39<70","duration":30,"rate":0} "2016-05-07T05:49:58" is the time and Preflight check is complete. Ready: {"temp":"absolute","bg":46,"tick":"+1","eventualBG":65,"snoozeBG":65,"reason":"BG 46<70, avg delta 2.33>0; no high-temp to cancel"}
Aaron Michelson
@Aaybob
May 07 2016 13:14
pump out of range response for one hour between each of these three positive responses. I had high end set to 110. Is this an algorythm broken boundary condition?
ericmtx
@ericmtx
May 07 2016 13:17
I see weird things when the pump battery is low. It sometimes will even show three bars but won't do good RF communications with the carelink stick. After I replace the pump battery it clears up gaps. Tried that?
Aaron Michelson
@Aaybob
May 07 2016 13:19
four bars
Dan Piessens
@dpiessens
May 07 2016 14:39
@Aaybob the Carelink stick is pretty bad, the TI stick has much better range if you're willing to set it up
Lori
@LoriLori
May 07 2016 15:16
wtfAssist , wtfDeviation, wtfDelta :)
Scott Leibrand
@scottleibrand
May 07 2016 15:41
@ericmtx usually Edison has to download BG from NS, unless you have an extra unpaired G4 Share receiver you can
If so you can use openxshareble to get BG from it over BLE.
Hristina Dimova
@xpucuto
May 07 2016 15:43
It is my first sensor restart since looping , and now i can not get it to work. Any suggestions?
Scott Leibrand
@scottleibrand
May 07 2016 15:52
Still in 2h warmup?
we have two receivers and stagger the restarts.
Hristina Dimova
@xpucuto
May 07 2016 15:52
no it ended , calibrated and cgm is working but when manually run loop says no cgm data
:(
i suppose not possible to use the loop while on raw, right?
Scott Leibrand
@scottleibrand
May 07 2016 15:53
How are you getting data? And how old is the most recent timestamp in glucose.json?
Hristina Dimova
@xpucuto
May 07 2016 15:53
later i will try to setup the loop with ns data from xdrip but at the moment i prefer the wired rceiver to the pi
Scott Leibrand
@scottleibrand
May 07 2016 15:53
Dex or MDT CGM?
Hristina Dimova
@xpucuto
May 07 2016 15:53
dex
just a second to check
Scott Leibrand
@scottleibrand
May 07 2016 15:53
is the charging icon lit on the Dex?
Hristina Dimova
@xpucuto
May 07 2016 15:53
yes
i restarted the ssh because it was too slow and now takes ages to get back the conenction
it is interesting that the bg on the ns website is current but it is not taken for suggested.json
Scott Leibrand
@scottleibrand
May 07 2016 15:56
Might try reseating the USB wifi dongle on the Pi. Or rebooting the whole thing might fix both issues. But you may want to troubleshoot the BG issue before doing that.
Hristina Dimova
@xpucuto
May 07 2016 15:59
its a pi3 with build in wifi
Scott Leibrand
@scottleibrand
May 07 2016 15:59
Ah. Well, if you can't get in to troubleshoot, a reboot might be in order then.
Hristina Dimova
@xpucuto
May 07 2016 16:01
i rebooted it but still can not ssh the pi
Scott Leibrand
@scottleibrand
May 07 2016 16:02
Its IP might have changed...
Hristina Dimova
@xpucuto
May 07 2016 16:03
will deleting known host help ?
ok i deleted them and then i got in, but it has already looping
so the conclusion by me is that it needs 1 hour of cgm data to make it work.
Scott do you have any idea if i can change that?
Lori
@LoriLori
May 07 2016 16:12
created openaps/oref0#109 to extract meal assist but 1 test is failing, some side effect I don't see there
ddaniels1
@ddaniels1
May 07 2016 16:16
Scott or others, I have an open loop running now but having trouble uploading loop status to Nightscout with the instructions here: http://openaps.readthedocs.io/en/dev/docs/walkthrough/phase-1/visualization.html#configuring-and-uploading-openaps-status
I get a error when I try to invoke the monitor/upload-status.json report I added. the error is "No JSON object could be decoded". I believe all the required reports nested in the report have been created and invoked per: openaps report add monitor/upload-status.json JSON ns-status shell monitor/clock-zoned.json monitor/iob.json enact/suggested.json enact/enacted.json monitor/battery.json monitor/reservoir.json monitor/status.json
Any ideas?
Dana Lewis
@danamlewis
May 07 2016 16:19
What version of NS are you on?
ddaniels1
@ddaniels1
May 07 2016 16:28
version 0.9.0-dev
seems like it is failing within openaps though, fails to invoke the report. It seems likely it is just a configuration problem in my instance of openaps, but I am a novice and open to any suggestions
Scott Leibrand
@scottleibrand
May 07 2016 16:31
Check each input file to the report that is failing...
@xpucuto check your logs for the time right after the CGM data came back and see what it was showing.
You can also do git log -p to track all changes to files in git at that time.
Hristina Dimova
@xpucuto
May 07 2016 16:34
ok i will do it later tonight ,
Scott Leibrand
@scottleibrand
May 07 2016 16:37
@LorelaiL is it the mealAssit typo?
ddaniels1
@ddaniels1
May 07 2016 16:40
how do I find the input file that is failing?
OK, I think I figured it out, not generating a monitor/battery.json report and that may be why it is failing, going to fix that and try again
Dana Lewis
@danamlewis
May 07 2016 16:43
:+1:
Lori
@LoriLori
May 07 2016 16:52
@scottleibrand fixed also failed test condition is fixed
Scott Leibrand
@scottleibrand
May 07 2016 16:53
:+1: this is just a refactor, right? Any changed behavior?
Lori
@LoriLori
May 07 2016 16:53
yes, just extract of function no changes in behavior hopefully
not sure such refactor is helpful , just wanted to see what it changes
mm22dl
@mm22dl
May 07 2016 17:07
@JaysonEwer I am trying to run decocare on my linux laptop... how can I look for loaded kernel modules? thanks for the help :)
Scott Leibrand
@scottleibrand
May 07 2016 17:13
Maybe @bewest or @jasoncalabrese has an opinion on whether it's useful to modularize that. Keep in mind that it all goes away in advanced-meal-assist, so it may make things easier to merge if we leave the old meal-assist code as is and focus any refactor efforts on AMA...
Jason Calabrese
@jasoncalabrese
May 07 2016 17:31
I was thinking that it would be a conflict with AMA, the sooner we get that to dev the better
Scott Leibrand
@scottleibrand
May 07 2016 17:57
Have to review Ben's PR to dev and release that to master first.
Assuming it successfully disables wtfAssist by default.
Jason Calabrese
@jasoncalabrese
May 07 2016 17:59
who's using dev now? would be good to have some people using dev try that out
Scott Leibrand
@scottleibrand
May 07 2016 18:00
:+1:
need to find time to review the code too.
This weekend is busy for me.
ddaniels1
@ddaniels1
May 07 2016 18:00
should I keep everything on UTC or local time?
Scott Leibrand
@scottleibrand
May 07 2016 18:01
Local time.
Set tz on the rig to match pump and CGM, and use tz tool to zone everything.
ddaniels1
@ddaniels1
May 07 2016 18:01
I have RPi on local and the pump, but the clock-zoned.json is returning UTC, what am I missing?
how do I use the tz tool?
Scott Leibrand
@scottleibrand
May 07 2016 18:02
Correct UTC, or interpreting local as UTC?
it's in the openaps/docs
it's what makes the -zoned files.
ddaniels1
@ddaniels1
May 07 2016 18:03
The tz device?
Scott Leibrand
@scottleibrand
May 07 2016 18:03
Ya
ddaniels1
@ddaniels1
May 07 2016 18:03
I have that added
Scott Leibrand
@scottleibrand
May 07 2016 18:06
Check that your ini doesn't say UTC
Scott Leibrand
@scottleibrand
May 07 2016 18:07
if you added it before fixing tzdata it might be wrong in your ini config.
ddaniels1
@ddaniels1
May 07 2016 18:07
i used openaps use tz -h and it gives me rezone as an option
ok will check that
ddaniels1
@ddaniels1
May 07 2016 18:13
It does say UTC in the .ini file. Can I just edit it from nano?
what is the syntax for PDT?
Scott Leibrand
@scottleibrand
May 07 2016 18:13
Try deleting it.
That might force it to use current tz, which won't break when DST is over. Otherwise you can delete and readd the tz device.
ddaniels1
@ddaniels1
May 07 2016 18:25
i did that which put me in to PDT approximately, but the time returned on monitor/clock-zoned.json is about 30 minutes off. Weird "date" returns the local time exactly on the rpi and the time on the pump is right. Where could this time be coming from?
I figured it out. I hadn't re invoked monitor/clock.json for about that long. when I did that the monitor/clock-zoned.json was also updated. I am starting to get this application! I just don't think enough like a programmer yet. Thanks Scott.
Scott Leibrand
@scottleibrand
May 07 2016 18:30
You need to invoke the clock.json and clock-zoned.json reports again.
ddaniels1
@ddaniels1
May 07 2016 18:34
yes figured it out! thank you!
David Young
@wgs4
May 07 2016 21:08

trying to generate “required reports” for the first time… in the walkthrough of Visualization and Monitoring docs.. having trouble with the instruction

$ openaps vendor add openapscontrib.timezones
i keep getting error
"No module named recurrent
openapscontrib.timezones doesn't seem to be an importable python module
If it is a python module, try using --path to influence
PYTHONPATH"

Ben West
@bewest
May 07 2016 21:11
ah, pip install recurrent should fix that
David Young
@wgs4
May 07 2016 21:13

I had a few errors during that install just now..

error: could not create '/usr/local/lib/python2.7/dist-packages/recurrent': Permission denied

error: could not create '/usr/local/lib/python2.7/dist-packages/recurrent': Permission denied
Scott Leibrand
@scottleibrand
May 07 2016 21:14
Sudo
David Young
@wgs4
May 07 2016 21:14
sudo fixed that. thanks

I am not sure what this step is instructing me to do..

At this point, you may want to update your monitor-pump alias to make sure that it produces all the required reports, so that uploading status to Nightscount can be automated.

Scott Leibrand
@scottleibrand
May 07 2016 21:22
Make sure the alias does an invoke of all the reports that are inputs to the upload report.
David Young
@wgs4
May 07 2016 21:47
where is the monitor-pump alias stored so I can view/edit it?
Brian Bonner
@itsn0tm3
May 07 2016 21:56
should be in openaps.ini
can do openaps alias show to visually verify it's there then can edit it in openaps.ini
David Young
@wgs4
May 07 2016 21:59
could you type the exact command by itself for me? I tried a few variants but I’m not getting a useful result

my results for

$ openaps-alias show

is

error: argument name: invalid choice: '*'

Brian Bonner
@itsn0tm3
May 07 2016 22:03
no -
openaps alias show
will show you all of your aliases
openaps alias show monitor-pump will show you the monitor-pump alias if you have it there
Ben West
@bewest
May 07 2016 22:08
check openaps --version
Brian Bonner
@itsn0tm3
May 07 2016 22:10
oh that command isn't in all the openaps versions?
(the alias show command that is)
David Young
@wgs4
May 07 2016 22:13
openaps version 0.1.0
$ openaps alias show
error: argument name: invalid choice: '*'
Brian Bonner
@itsn0tm3
May 07 2016 22:17
do you have any aliases in there right now?
Ben West
@bewest
May 07 2016 23:44
might not have any aliases
I think you get that if there's no aliases
try:
oref0 alias-helper howdy 'echo howdy $1' | openaps import
then try openaps alias show again
@wgs4 ^^
Brian Bonner
@itsn0tm3
May 07 2016 23:50
I think you have a typo in there
orfef0 should be oref0
Ben West
@bewest
May 07 2016 23:50
oy