These are chat archives for nightscout/intend-to-bolus

22nd
Oct 2016
diabeticgonewild
@diabeticgonewild
Oct 22 2016 00:52
I hope that the people that are behind the DDoS attacks with the Wikileaks protests are put down.
Terri Lyman
@tatigger
Oct 22 2016 02:42
Does anyone have any idea how to tell what wifi network my Pi is using. I cannot seem to ssh in on my home network. And I don't have any hotspots enabled.
Terri Lyman
@tatigger
Oct 22 2016 02:55
Never mind. So I remember reading somewhere that there is a "best" way to flash the disk. I need to make a backup copy. Where can I find that?
Terri Lyman
@tatigger
Oct 22 2016 03:06
I remember reading if you just use the command line the backup doesn't fit back onto an SD card of the same size because of filing system? Or am I losing my mind?
diabeticgonewild
@diabeticgonewild
Oct 22 2016 03:08
Sorry but my blood sugar is messing with my mind.
All you have to do is copy your SD card using Win32DiskImager
Which you can download
I can't really talk anymore. I really feel terrible. Going to bed.
Terri Lyman
@tatigger
Oct 22 2016 03:21
Again, never mind. Found the answer in Resources :)
andyhandy
@andyhandy
Oct 22 2016 04:20
@danamlewis thanks
Dana Lewis
@danamlewis
Oct 22 2016 04:26
I don't remember what I did but you're welcome :)
Terri Lyman
@tatigger
Oct 22 2016 04:30
@danamlewis my pi is running, and is on wifi because it is talking to my nightscout, but I can't ssh in. Any suggestions?
Dana Lewis
@danamlewis
Oct 22 2016 04:31
Can't ssh in how?
Terri Lyman
@tatigger
Oct 22 2016 04:32
Terris-MacBook-Pro:~ terrilyman$ ssh pi@raspberrypi.local
ssh: Could not resolve hostname raspberrypi.local: nodename nor servname provided, or not known
I wonder if it connected somehow to an unprotected internet in my neighborhood? Ugh.
Terri Lyman
@tatigger
Oct 22 2016 04:39
HA! One of the wifi in my neighborhood is named "Definitely Not An FBI Van"!!!
Matthias
@ceben80
Oct 22 2016 04:39
@tatigger are u able to make ping raspberrypi.local :question:
Terri Lyman
@tatigger
Oct 22 2016 04:40
Nope. Terris-MacBook-Pro:~ terrilyman$ ping raspberrypi.local
ping: cannot resolve raspberrypi.local: Unknown host
Terris-MacBook-Pro:~ terrilyman$
Matthias
@ceben80
Oct 22 2016 04:41
are you able to determine the IP of the pi (router...)?
then 1st take the IP address :wink:
Terri Lyman
@tatigger
Oct 22 2016 04:42
Let me google that and try it
Maybe I should just plug it into the tv? It still has HDMI access.
Ugh. Either way I have to get out of bed.
Terri Lyman
@tatigger
Oct 22 2016 04:57
Ok, this is a job for tomorrow, thanks @ceben80. LOL I am such a novice everything is really hard. When I am fresh in the morning I'll tackle it. I just wanted to back up. LOL
Scott Leibrand
@scottleibrand
Oct 22 2016 04:59
@diabeticgonewild where does the Wikileaks theory came from? The one I heard is that a criminal gang that Dyn exposed in a talk at the NANOG conference here in Dallas this week was getting payback on them.
Matthias
@ceben80
Oct 22 2016 06:00
@/all
I do have a Huawei 5570 mobil router for my Edison. Does anybody know how to realize DHCP reservations?
Unfortunately the Huawei settings don't have the abity for fix mapping MAC to IP
Often my Edison gets a different IP, so it is very annoying to SSH to the host.
Tim Street
@tim2000s
Oct 22 2016 08:06
@ceben80 Isn't there a default network host name on ubilinux/Edison that's simply "ubilinux"? So you'd ssh to user@ubilinux
Matthias
@ceben80
Oct 22 2016 08:16
Unfortunately that does not work :worried: no resolution available
Scott Leibrand
@scottleibrand
Oct 22 2016 12:07
It's ssh edison@edison.local by default I believe. If you change the hostname it's newhostname.local
Mike
@libxmike
Oct 22 2016 12:17
I've managed to control the power of carelink port with hub-ctrl on a Pi Zero
pi@raspberrypi:~/hub-ctrl.c $ sudo ./hub-ctrl  -h 0 -P 4 -p 0
pi@raspberrypi:~/hub-ctrl.c $ sudo ./hub-ctrl  -v
Hub #0 at 001:002
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:
   Port 1: 0000.0503 highspeed power enable connect
   Port 2: 0000.0100 power
   Port 3: 0000.0100 power
   Port 4: 0000.0000
Hub #1 at 001:001
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:
   Port 1: 0000.0503 highspeed power enable connect
pi@raspberrypi:~/hub-ctrl.c $ sudo ./hub-ctrl  -h 0 -P 4 -p 1
pi@raspberrypi:~/hub-ctrl.c $ sudo ./hub-ctrl  -v
Hub #0 at 001:002
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:
   Port 1: 0000.0503 highspeed power enable connect
   Port 2: 0000.0100 power
   Port 3: 0000.0100 power
   Port 4: 0000.0103 power enable connect
Hub #1 at 001:001
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:
   Port 1: 0000.0503 highspeed power enable connect
pi@raspberrypi:~/hub-ctrl.c $
and my crontab
*/30 * * * * sudo /home/pi/hub-ctrl.c/hub-ctrl  -h 0 -P 4 -p 0 && sleep 5 &&  sudo /home/pi/hub-ctrl.c/hub-ctrl  -h 0 -P 4 -p 1
will see how long can my Zero and CareLink run with hun-ctrl do power cycle every 30min
I have a passive hub with carelink on port 4 and Edimax WiFi on port 1
Mike
@libxmike
Oct 22 2016 12:31
and this is syslog when power cycling with hub-ctrl
Oct 22 14:30:08 raspberrypi kernel: [ 2770.867741] usb 1-1.4: USB disconnect, device number 9
Oct 22 14:30:08 raspberrypi kernel: [ 2770.868347] generic ttyUSB0: generic converter now disconnected from ttyUSB0
Oct 22 14:30:08 raspberrypi kernel: [ 2770.868436] usbserial_generic 1-1.4:1.0: device disconnected
Oct 22 14:30:08 raspberrypi kernel: [ 2771.106905] usb 1-1.4: new full-speed USB device number 10 using dwc_otg
Oct 22 14:30:08 raspberrypi kernel: [ 2771.217210] usb 1-1.4: New USB device found, idVendor=0a21, idProduct=8001
Oct 22 14:30:08 raspberrypi kernel: [ 2771.217239] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Oct 22 14:30:08 raspberrypi kernel: [ 2771.221820] usbserial_generic 1-1.4:1.0: The "generic" usb-serial driver is only for testing and one-off prototypes.
Oct 22 14:30:08 raspberrypi kernel: [ 2771.221850] usbserial_generic 1-1.4:1.0: Tell linux-usb@vger.kernel.org to add your device to a proper driver.
Oct 22 14:30:08 raspberrypi kernel: [ 2771.221865] usbserial_generic 1-1.4:1.0: generic converter detected
Oct 22 14:30:08 raspberrypi kernel: [ 2771.222339] usb 1-1.4: generic converter now attached to ttyUSB0
Matthias
@ceben80
Oct 22 2016 12:36
@scottleibrand that will work with puttyto ssh, but unfortunately not with my Andriod SSH JuiceSSH.
It's only possible to define the host as eddie.local the App does not accept edison@eddie.localin the hostnamefield :cry:
Scott Leibrand
@scottleibrand
Oct 22 2016 12:51
You can specify the username elsewhere in the app.
Tim Howard
@tghoward
Oct 22 2016 12:58
@ceben80 I use JuiceSSH and ^^ is correct - you specify the user elsewhere. Also if you want to figure out what your host name is, the app called Fing is awesome.
Matthias
@ceben80
Oct 22 2016 13:05
yes but Fingis using JuiceSSHwhen ssh to the host :worried:
Scott Leibrand
@scottleibrand
Oct 22 2016 13:15
So? What's the problem?
Matthias
@ceben80
Oct 22 2016 13:17
unfortunately I must type in every time username/password, sorry didn't mention, saving it, no success
but yes Fing is awesome :wink:
@scottleibrand Further Q to the df -h"juggling".....possible to setup ubilinux in a single partition on the Edison?
My /homepartition is growing again....90% used :worried:
Does anybody install the Eddie linux in a single partition?
Tim Howard
@tghoward
Oct 22 2016 13:37
@ceben80 setting up symlinks (such as for /var/log) really helped me with the full partition problems. Is that what you mean by juggling?
Matthias
@ceben80
Oct 22 2016 13:39
thanks I did that with /usr/ to free up /rootbut now /home is growing from 60% up to 90%....don't know what happened?
yesterday evening I had 60% used in /home....today 90% :angry:
Tim Howard
@tghoward
Oct 22 2016 13:46
... hmm... not sure what's up there. Are .git files taking up tons of space?
Matthias
@ceben80
Oct 22 2016 13:56
edison@eddie:~$ sudo du -xh -d 3 /home/edison | egrep "[0-9][0-9]M|[0-9]G"
356M    /home/edison/myopenaps/.git/objects
357M    /home/edison/myopenaps/.git
358M    /home/edison/myopenaps
35M     /home/edison/src/oref0/node_modules
37M     /home/edison/src/oref0
37M     /home/edison/src
15M     /home/edison/.npm
15M     /home/edison/mmeowlink-source
425M    /home/edison
edison@eddie:~$
and that's my df -h@tghoward
edison@eddie:~$ df -h
Filesystem       Size  Used Avail Use% Mounted on
/dev/root        1.4G  556M  761M  43% /
devtmpfs         480M     0  480M   0% /dev
tmpfs             97M  316K   96M   1% /run
tmpfs            5.0M     0  5.0M   0% /run/lock
tmpfs            193M     0  193M   0% /run/shm
tmpfs            481M  481M   12K 100% /tmp
/dev/mmcblk0p7    32M  5.3M   27M  17% /boot
/dev/mmcblk0p10  1.3G  1.2G  136M  90% /home
Tim Howard
@tghoward
Oct 22 2016 14:01
sorry, not sure. Seems like you need to move stuff over to root?
Scott Leibrand
@scottleibrand
Oct 22 2016 14:01
Try cd /home/edison/myopenaps/.git and run the du command again?
And then cd into whatever the deepest directory it shows, and do a ls -larS to see what the biggest files are?
Matthias
@ceben80
Oct 22 2016 14:02
edison@eddie:~/myopenaps/.git$ du -h
44K ./hooks
8.0K ./info
4.0K ./branches
464K ./logs/refs/heads
468K ./logs/refs
932K ./logs
4.0K ./refs/heads
4.0K ./refs/tags
12K ./refs
140K ./objects/b7
148K ./objects/fa
116K ./objects/d4
224K ./objects/aa
184K ./objects/18
188K ./objects/61
200K ./objects/c6
196K ./objects/e6
212K ./objects/1d
172K ./objects/e8
184K ./objects/e2
188K ./objects/cb
168K ./objects/f3
164K ./objects/60
156K ./objects/21
180K ./objects/41
152K ./objects/57
220K ./objects/91
220K ./objects/b2
132K ./objects/c1
164K ./objects/0b
176K ./objects/fc
184K ./objects/44
164K ./objects/d9
168K ./objects/cc
156K ./objects/bf
176K ./objects/37
128K ./objects/62
184K ./objects/34
180K ./objects/6c
160K ./objects/b6
136K ./objects/89
160K ./objects/5c
172K ./objects/d5
156K ./objects/4a
168K ./objects/0a
196K ./objects/7d
164K ./objects/c0
200K ./objects/4b
168K ./objects/8a
192K ./objects/9d
140K ./objects/23
176K ./objects/6d
172K ./objects/59
156K ./objects/13
160K ./objects/db
168K ./objects/26
168K ./objects/5a
168K ./objects/68
4.0K ./objects/info
168K ./objects/f5
164K ./objects/3b
192K ./objects/6e
180K ./objects/95
172K ./objects/7e
152K ./objects/3c
128K ./objects/1f
140K ./objects/72
164K ./objects/49
128K ./objects/a7
148K ./objects/48
160K ./objects/09
212K ./objects/9a
164K ./objects/29
136K ./objects/36
168K ./objects/22
152K ./objects/8b
180K ./objects/2f
164K ./objects/93
188K ./objects/83
144K ./objects/24
172K ./objects/da
196K ./objects/5b
176K ./objects/d8
156K ./objects/d1
172K ./objects/73
148K ./objects/bc
188K ./objects/f7
164K ./objects/f8
180K ./objects/0c
144K ./objects/ed
164K ./objects/47
160K ./objects/8d
200K ./objects/04
168K ./objects/07
168K ./objects/b8
156K ./objects/de
152K ./objects/54
180K ./objects/ff
192K ./objects/20
136K ./objects/2a
136K ./objects/d3
140K ./objects/0e
132K ./objects/df
228K ./objects/d6
156K ./objects/71
140K ./objects/31
120K ./objects/5e
196K ./objects/25
116K ./objects/01
168K ./objects/14
176K ./objects/90
140K ./objects/ac
164K ./objects/4f
188K ./objects/84
128K ./objects/7f
188K ./objects/a0
192K ./objects/55
160K ./objects/00
124K ./objects/2c
172K ./objects/a9
148K ./objects/81
160K ./objects/c5
112K ./objects/fb
192K ./objects/19
128K ./objects/2b
188K ./objects/cf
196K ./objects/ce
196K ./objects/85
244K ./objects/b5
168K ./objects/7a
132K ./objects/6f
152K ./objects/0d
188K ./objects/99
140K ./objects/ca
172K ./objects/6b
172K ./objects/28
144K ./objects/06
176K ./objects/b0
136K ./objects/ea
156K ./objects/3d
180K ./objects/05
164K ./objects/0f
172K ./objects/e9
160K ./objects/be
168K ./objects/15
156K ./objects/dc
192K ./objects/65
180K ./objects/3f
140K ./objects/51
192K ./objects/f9
172K ./objects/d0
152K ./objects/11
188K ./objects/8c
172K ./objects/88
168K ./objects/4d
116K ./objects/1c
232K ./objects/08
184K ./objects/f2
164K ./objects/80
140K ./objects/bd
152K ./objects/b4
192K ./objects/4e
176K ./objects/10
192K ./objects/b3
236K ./objects/38
144K ./objects/58
172K ./objects/43
168K ./objects/75
212K ./objects/77
172K ./objects/c4
188K ./objects/9f
152K ./objects/79
164K ./objects/7b
140K ./objects/a8
156K ./objects/7c
184K ./objects/ae
256K ./objects/03
144K ./objects/96
164K ./objects/97
204K ./objects/86
152K ./objects/d2
128K ./objects/fd
124K ./objects/87
164K ./objects/ef
104K ./objects/af
164K
Scott Leibrand
@scottleibrand
Oct 22 2016 14:02
Once we figure that out, also try a git gc and see if that frees up any space.
Hmm, no single big directory looks like?
Matthias
@ceben80
Oct 22 2016 14:03
now git gc?
Scott Leibrand
@scottleibrand
Oct 22 2016 14:03
Yeah
Matthias
@ceben80
Oct 22 2016 14:04
edison@eddie:~/myopenaps/.git$ git gc
warning: reflog of 'refs/heads/master' references pruned commits
error: object file objects/d9/92f5a6dd749fe54a0a196d9626876ae9134bda is empty
error: object file objects/d9/92f5a6dd749fe54a0a196d9626876ae9134bda is empty
fatal: loose object d992f5a6dd749fe54a0a196d9626876ae9134bda (stored in objects/d9/92f5a6dd749fe54a0a196d9626876ae9134bda) is corrupt
error: failed to run repack
edison@eddie:~/myopenaps/.git$ df -h
Filesystem       Size  Used Avail Use% Mounted on
/dev/root        1.4G  556M  760M  43% /
devtmpfs         480M     0  480M   0% /dev
tmpfs             97M  316K   96M   1% /run
tmpfs            5.0M     0  5.0M   0% /run/lock
tmpfs            193M     0  193M   0% /run/shm
tmpfs            481M  481M   16K 100% /tmp
/dev/mmcblk0p7    32M  5.3M   27M  17% /boot
/dev/mmcblk0p10  1.3G  1.2G  137M  90% /home
edison@eddie:~/myopenaps/.git$
I'd like to set up the whole box....but who to install in a single partion?
reinstallation it's practising haha :smile:
Scott Leibrand
@scottleibrand
Oct 22 2016 14:09
Maybe we need to add a git gc attempt to oref0-reset-git
Matthias
@ceben80
Oct 22 2016 14:09
@tghoward ....that's what I mean with juggling :smile: (multi partion)
start oref0-reset-git?
Scott Leibrand
@scottleibrand
Oct 22 2016 14:10
I suspect this might be due to the pump-loop and ns-loop working on the same myopenaps/.git directory, but I'm not sure why it doesn't affect us if that's the case.
Unless you update it to add a git gc or disk full check, you'll have to rm the .git dir before oref0-reset-git will do anything.
Matthias
@ceben80
Oct 22 2016 14:12
Okay will now 1st rm .gitthen oref0-reset-git...should I stop the cron?
Scott Leibrand
@scottleibrand
Oct 22 2016 14:12
Doesn't matter.
Matthias
@ceben80
Oct 22 2016 14:16
Okay done....we'll see :wink:
edison@eddie:~/myopenaps$ df -h
Filesystem       Size  Used Avail Use% Mounted on
/dev/root        1.4G  557M  759M  43% /
devtmpfs         480M     0  480M   0% /dev
tmpfs             97M  316K   96M   1% /run
tmpfs            5.0M     0  5.0M   0% /run/lock
tmpfs            193M     0  193M   0% /run/shm
tmpfs            481M  481M   12K 100% /tmp
/dev/mmcblk0p7    32M  5.3M   27M  17% /boot
/dev/mmcblk0p10  1.3G  798M  494M  62% /home
thanks so far today, greetings to Dana and a nice weekend to you both :wink:
and thanks to @tghoward
Scott Leibrand
@scottleibrand
Oct 22 2016 14:18
:+1:
Tim Howard
@tghoward
Oct 22 2016 14:40
:+1: from me too!~
@scottleibrand what's the port/device for mmeowlink on explorer board? Can't get subg_rfspy state on /dev/ttyMFD1 and already in use error on /dev/ttyMFD2
was making so much good progress too!
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:48
I am hoping to get some help with someone who is good in linux. I have obtained a rasberrypi 2 set up with raspirian and opeans installed. I have a carelink and a battery. My problem is that when it boots, the os appears to be lookng for an IP address from wlan0 (it s not set up for my house yet)
the openaps loop just keeps running over and over again and never stops and stays in the terminal so I can start a bash session and change or even see the wlan0 configuration
Tim Howard
@tghoward
Oct 22 2016 14:50
@diabetic_dude_twitter how are you seeing this? Do you have a monitor plugged into the RPi?
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:51
I have the RPI plugged into my TV
with the USB wireless still connected along with a usb keyboard and mouse
Tim Howard
@tghoward
Oct 22 2016 14:51
hmm, so you are at a command prompt?
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:51
I have detached the battery and the carelink for now
not really
the script just keeps looking
I am at the terminal but when I type bash, a bash session dosnt start
Tim Howard
@tghoward
Oct 22 2016 14:53
You need to get to a shell script. I don't know the raspbian gui
Oh, so you can type things. Ok.
you need to turn off the loop. Try typing crontab -e
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:54
ok trying now
Tim Howard
@tghoward
Oct 22 2016 14:54
that should bring up a window with some text on the top and a bunch of lines starting with stars *
put comments marks # before each of the lines with the stars. save it.
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:56
crontab -e did not do anything
I typed it in and hit enter and the loop started again
jul 14 05:52:01 openaps dhcpclient: DHCPDISCOVER on wlan0 255.255.255.255. port 67 interval 9
Tim Howard
@tghoward
Oct 22 2016 14:58
So are there GUI menus in Raspbian? What can you find with your mouse?
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 14:58
no
it is not booting to the OS is what it appears, it looks like it just keeps trying to get an IP from wlan0
I am going to try pulling wlan0 and see what happens
Tim Howard
@tghoward
Oct 22 2016 15:01
So it isn't booting fully. Perhaps the card got corrupted. You might need to flash things again, back at this page https://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-0/rpi.html
Scott Leibrand
@scottleibrand
Oct 22 2016 15:02
@tghoward you want /dev/spi<tab>
Tim Howard
@tghoward
Oct 22 2016 15:02
Remember never to just unplug the RPi when it is running. Always issue the command sudo shutdown -h now to shut it down.
Scott Leibrand
@scottleibrand
Oct 22 2016 15:02
spidev5.1 or something.
Tim Howard
@tghoward
Oct 22 2016 15:03
@scottleibrand Aha! Thanks! giving it a try.
Diabetic_Dude
@diabetic_dude_twitter
Oct 22 2016 15:04
thanks Tim I will be away for a bit I am going to try taking the PI downstairs and try plugging it directly into a LAN connection to see if I can get it to boot
taylorfowler
@taylorfowler
Oct 22 2016 16:35
Hey guys, how do you check the firmware version
Scott Leibrand
@scottleibrand
Oct 22 2016 16:36
of your pump? hit the Esc key and scroll down.
Matthias
@ceben80
Oct 22 2016 16:38
@scottleibrand sorry didn't have the link for how to Yocto installation....to many information :smile: do you have this doc for me?
Would like to run openAPS on Yocto without Ubilinux
Maybe the next rig in the farm :smile:
Greg Kitson
@awaxa
Oct 22 2016 16:41

Hi everyone! I'm having trouble with ns-upload and nightscout. I can openaps use ns shell get entries.json without issue, but I can't seem to upload anything:

$ ns-upload $NIGHTSCOUT_HOST $API_SECRET treatments.json upload/latest-treatments.json
Cannot POST /api/v1/treatments.json
$ ns-upload $NIGHTSCOUT_HOST $API_SECRET devicestatus.json upload/ns-status.json
{"status":401,"message":"Unauthorized","description":"Invalid/Missing"}

I have tried recreating the API_SECRET and reconfiguring the ns device, made sure those environment variables are exported, and everything else I can think of. Frustratingly, I'm not sure where to look next.

taylorfowler
@taylorfowler
Oct 22 2016 16:42
Arrrggg. The 723 pump I managed to finagle is firmware 2.5B 😑 Not possible to downgrade I'm assuming? Mayltry to trade for an older model maybe.
Back to the hunt I suppose.
Scott Leibrand
@scottleibrand
Oct 22 2016 16:51
@ceben80 there's directions for that in the mmeowlink wiki
@awaxa the ns-upload doesn't use the ns device yet. You need to check/fix the NIGHTSCOUT_HOST and API_SECRET in crontab -e as well.
Matthias
@ceben80
Oct 22 2016 16:59
O yes Scott, thx to many thinks in my head for pancreas collection :smile:
Greg Kitson
@awaxa
Oct 22 2016 17:00
I still get the same json responses when running those ns-upload commands by hand/not within the loop, even if I paste in my nightscout host and secret without using environment variables.
Scott Leibrand
@scottleibrand
Oct 22 2016 17:01
sounds like your NS may be misconfigured then? or you're using the plain text secret instead of the hashed one?
(or a double-hashed one)
Greg Kitson
@awaxa
Oct 22 2016 17:01
Oh I also discovered something noteworthy last night. I wasn't able to wirelessly set a temp basal on my 723 until I had changed the temp basal preference to absolute instead of percentage. It would appear to work but "received":false
My NS may indeed be misconfigured. I'm using a hashed secret, but I'll try regenerating and hashing a new one again. Just in case
Scott Leibrand
@scottleibrand
Oct 22 2016 17:03
yep. that is noted in the setup docs, but if there's somewhere else it should be mentioned more prominently, please PR it in
Greg Kitson
@awaxa
Oct 22 2016 17:08
NS must be misconfigured if I get the same results with a fresh "subject" key from nightscout/admin
Paul Martin
@Spazholio
Oct 22 2016 17:34
@awaxa Just curious - how did you generate that gist? I wouldn’t mind having a way to dump all my NS vars easily...
Greg Kitson
@awaxa
Oct 22 2016 17:37
heroku config --app myappname | vim -and then i used https://github.com/mattn/gist-vim which would work just as well as https://github.com/defunkt/gist if you're not also a vim dork
Paul Martin
@Spazholio
Oct 22 2016 17:38
Oh, it’s heroku-specific. Alas. =)
Hardwick1973
@Hardwick1973
Oct 22 2016 17:56
Is there any documentation for how to add extra OpenAPS specific pills to Nightscout? At the moment I have the out of the box "Pump" and "OpenAPS" but I have see screen shots on Gitter with more informative additional info
Paul Martin
@Spazholio
Oct 22 2016 18:06
@Hardwick1973 What information do you not have that you’d like to have?
Terri Lyman
@tatigger
Oct 22 2016 18:46
Where can I look to change the max-iob. I am ready to try for something above 0. like .75, which is half the recommended max-iob.
Dana Lewis
@danamlewis
Oct 22 2016 18:47
preferences.json
JaysonEwer
@JaysonEwer
Oct 22 2016 18:47
Hello all! I just received my Pebble 2 today, it's working great. Is there an Urchin channel for general questions?
Dana Lewis
@danamlewis
Oct 22 2016 18:47
not sure if @mddub has set up an Urchin gitter channel?
JaysonEwer
@JaysonEwer
Oct 22 2016 18:49
@danamlewis Thank you. I hope you are well.
Terri Lyman
@tatigger
Oct 22 2016 18:49
@danalewis, I used cat to see the preferences, and there it is! So proud of myself. How do I change it?
Hardwick1973
@Hardwick1973
Oct 22 2016 18:49
@Spazholio I am looking at add battery, COB and IOB etc
garykidd
@garykidd
Oct 22 2016 18:50
@scottleibrand I was able to secure a MM723.
guess what?
mmtune works fine...now looping with that...thanks goodness no more issues with all 99s
Scott Leibrand
@scottleibrand
Oct 22 2016 18:51
:smile:
@tatigger use nano
Terri Lyman
@tatigger
Oct 22 2016 18:52
Ok, I remember how to do that, too :)
Super proud
JaysonEwer
@JaysonEwer
Oct 22 2016 18:52
Sweet @garykidd , where did you find the 723?
garykidd
@garykidd
Oct 22 2016 18:53
medwow
well actually i think that one fell through...craigslist
Terri Lyman
@tatigger
Oct 22 2016 18:56
Yay!!!!! It worked! Now if I had only skipped the pancakes for breakfast. @danamlewis I may have developed Celiac. How did you confirm dx?
JaysonEwer
@JaysonEwer
Oct 22 2016 18:57
@garykidd do you mind me asking how much you ended up paying for the 723?
Terri Lyman
@tatigger
Oct 22 2016 18:59
Which logs are you guys reviewing to confirm your openAPS instance?
JaysonEwer
@JaysonEwer
Oct 22 2016 19:00
@tatigger pi@Ewer-Open-APS:~ $ tail -f /var/log/messages |grep openaps
That's what I use.
Terri Lyman
@tatigger
Oct 22 2016 19:01
Thank you . It says all over to follow the logs, but I must have missed the "which"
Paul Martin
@Spazholio
Oct 22 2016 19:05
@Hardwick1973 Here’s what mine says: ENABLE="rawbg iob openaps pump careportal bridge cob bwp basal boluscalc cage sage iage”
Try that, see if it helps.
Greg Kitson
@awaxa
Oct 22 2016 19:13
resolved my issue by using 0.9-beta3 of nightscout instead of the dev branch
Paul Martin
@Spazholio
Oct 22 2016 19:15
@tatigger If you’re using the new script install, doing a tail -f /var/log/openaps/*log should let you see all 4 of the logs that are written.
Terri Lyman
@tatigger
Oct 22 2016 19:28
Thanks @Spazholio, been looping since Sunday. My Tandem broke. I got the replacement on Tuesday, but I don't want to switch back! My sd and time in range improved dramatically, even with just the max-ion 0. SD is under 25 and time in range was 95%.
Until pancakes
Paul Martin
@Spazholio
Oct 22 2016 19:29
Congrats! My range is incredibly narrow, so I’ve never seen those kinds of numbers, but my last A1C was in the 5’s, so whatever. =)
My endo very much wants me to widen my range a bit. That’s the most she’s willing to acknowledge the OpenAPS system.
Terri Lyman
@tatigger
Oct 22 2016 19:30
Yeah, my last was 7.9. So I am thinking the improvement will so amaze my endo that he won't bat an eye at OpenAPS. I figure it is better to beg forgiveness then ask permission.
Of course, even with my best efforts, my A1c dropped from 9.3 to 7.5 ish with the addition of Nightscout and Pebble, 2 years ago.
Paul Martin
@Spazholio
Oct 22 2016 19:32
I saw 3 endo-related docs (and one Medtronic rep) at my last trip to the VA, and 1 private endo. They were all fascinated by OpenAPS, even though they couldn’t outright advocate it, from a medical professional standpoint. The Medtronic rep was horrified when I told her that we have to purchase older pumps due to firmware changes that were made. She was VERY interested in that aspect of things.
Terri Lyman
@tatigger
Oct 22 2016 19:32
I think I owe my life to you guys. All of you.
Paul Martin
@Spazholio
Oct 22 2016 19:33
@tatigger I’m a huge advocate of a keto-ish diet. It helped me out so much.
Before switching things up and actually deciding to take care of myself, my A1Cs were regularly in the 10’s. I think when I was hospitalized for DKA, it was 14-ish. I dreaded going to the docs because they’d all just yell at me.
Gotta admit - I miss the hell out of real pizza and cold cereal though. =)
Thankfully my wife found a pretty great replacement pizza recipe - the entire crust is made out of cheese!
Terri Lyman
@tatigger
Oct 22 2016 19:35
Yeah, I saw the impact of carbs and greatly reduced quantity per meal and changed the source to mostly vegetables and protein. That made the fluctuations much more manageable. But I couldn't even see any of that until Nightscout/Pebble. And I was seriously over-dosing the basal rates. At doctor recommendations. Oh, must be the fat-head pizza. Love that
Paul Martin
@Spazholio
Oct 22 2016 19:35
I think it was, yes. =)
Terri Lyman
@tatigger
Oct 22 2016 19:36
Cold cereal - As far as I am concerned, that is the ultimate test for a marketed APS system. That doesn't work for ANYONE
JaysonEwer
@JaysonEwer
Oct 22 2016 19:36
The last time I saw my Endo, which was the second time since I started looping in Jan, she said she didn't "need" to see me for 6 months since the loop was working so well for me! :smile: I still have plenty of room for improvement, but I'm extremely PLEASED with my numbers, time in range, etc.
Terri Lyman
@tatigger
Oct 22 2016 19:36
Nearly miraculous. Now all we need is the cure, right? In 5 years I hear.
Paul Martin
@Spazholio
Oct 22 2016 19:38
Been hearing that for 2 decades, unfortunately. =)
Terri Lyman
@tatigger
Oct 22 2016 19:38
Which VA @Spazholio? I think that might be pretty close to my dream pharmacy job. That or the Diabetes Education Center in Asheville, NC.
Paul Martin
@Spazholio
Oct 22 2016 19:38
I hear trials of SO MANY promising “cures” that reverse diabetes in mice. I eat enough cheese that I’m an honorary mouse - GIMME!
@tatigger It was the one in Saginaw, MI until they closed the pump clinic. Now it’s in Ann Arbor. Only 4 hours away. headdesk
At least now that I have the Dexcom, they’re going to allow me to do Tele-HealthCare (love the acronym) at the CBOC that’s literally 15 miutes from my house. =)
Terri Lyman
@tatigger
Oct 22 2016 19:44
MI is not my dream location, @Spazholio. I am 3 decades in and yes, a cure has been "5 years away" the whole time. I used to travel 4 hours for an endo - until I met her CDE. Who told me "If you WANT to micromanage your diabetes, read..." and listed the books I have owned since I started pumping. Fired.
Dana Lewis
@danamlewis
Oct 22 2016 19:44
@tatigger re celiac there's a blood test but many false negatives; definitive is a small intestine biopsy to see damage done. If concerned, ask your endo.
(And plenty of gf pancake mixes out there ;) but get a Celiac diagnoses before switching to gf so you don't mess up the tests)
Terri Lyman
@tatigger
Oct 22 2016 19:46
He suggested the blood test, but thought I had heard false negatives. @danamlewis. If I am sick later today, I will get a consult to gastro and getter done. Stupid diabetes. I was gf by accident for about the last 10 days, and they have been the best 10 days in 3 months.
GF is expensive!
LOL as if diabetes isn't
Dana Lewis
@danamlewis
Oct 22 2016 19:48
Yep. But worth it.
(But make sure to keep eating gluten before any tests. I was positive on blood test but wanted biopsy to see damage for benchmarking/future, and it was super obvious for me.)
Terri Lyman
@tatigger
Oct 22 2016 19:50
@danamlewis thanks. For SO much, I don't even have the words.
Dana Lewis
@danamlewis
Oct 22 2016 19:52
:+1: :smile: :heart:
Matt Pressnall
@logichammer
Oct 22 2016 19:53
@danamlewis , at TON and talking about OpenAPS...folks are keen to do a meet up!
Dana Lewis
@danamlewis
Oct 22 2016 19:54
Cool! We should schedule one huh :) evenings still good? @logichammer
Matt Pressnall
@logichammer
Oct 22 2016 19:54
Yeah...sitting here with a T1D that is stoked for this...has a 722 and just bought the parts with me!
Terri Lyman
@tatigger
Oct 22 2016 19:55
What is TON
Matt Pressnall
@logichammer
Oct 22 2016 19:55
Type One Nation
in Redmond, WA
Dana Lewis
@danamlewis
Oct 22 2016 19:55
:)
Terri Lyman
@tatigger
Oct 22 2016 19:55
Ah. You all are in Washington, right?
Matt Pressnall
@logichammer
Oct 22 2016 19:55
Correct!
Dana Lewis
@danamlewis
Oct 22 2016 19:55
Yep. Big Seattle area crew
Apparently getting bigger ;) :)
Terri Lyman
@tatigger
Oct 22 2016 19:56
I would love to have folks to get together in Phoenix. I would drive. I still don't know enough.
LOL almost ready to make Seattle a destination. would be worth it, if I could get time off work.
No vacation in the colder months for pharmacists
Terri Lyman
@tatigger
Oct 22 2016 20:04
So, do we have anyone else who is working in AZ toward closed loop?
garykidd
@garykidd
Oct 22 2016 20:05
@JaysonEwer 400
Dana Lewis
@danamlewis
Oct 22 2016 20:09
@tatigger (n=1)*128 :confetti_ball: :smile: :clap:
Terri Lyman
@tatigger
Oct 22 2016 20:10
:)
Darrell Wright
@beached
Oct 22 2016 20:16
Has anyone heard of firmware in the Candian models (Veo 754CML) later than the 2.7A
JaysonEwer
@JaysonEwer
Oct 22 2016 20:17
@garykidd 400 is a very good price for the 723. Nice!
Matthias
@ceben80
Oct 22 2016 21:14
@tatigger congrats :clap:
mariano42
@mariano42
Oct 22 2016 23:11
Been trying to get the openxshareble setup with my G4 share so i don't need to use the usb connection, but have been failing.... Is there an easy way to tell if I got it to pair or not? I am using a pi 3 and followed the instructions on https://github.com/openaps/openxshareble , but I get the same error any time i try to pull data.
openaps use share iter_glucose 1
Traceback (most recent call last):
File "/usr/local/bin/openaps-use", line 6, in <module>
exec(compile(open(file).read(), file, 'exec'))
File "/home/pi/openaps/bin/openaps-use", line 63, in <module>
app( )
File "/home/pi/openaps/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/home/pi/openaps/bin/openaps-use", line 57, in run
output = app(args, self)
File "/home/pi/openaps/openaps/uses/init.py", line 92, in call
return self.method.selected(args)(args, app)
File "/home/pi/openaps/openaps/uses/init.py", line 31, in call
return self.method(args, app)
File "/openxshareble/openxshareble/init.py", line 97, in call
res = self.ble.run_mainloop_with(run, quit_with_loop=False)
TypeError: run_mainloop_with() got an unexpected keyword argument 'quit_with_loop'
I assume the pairing didnt work, but I am not sure where to go to troubleshoot this.. any recommendations?
Paul Martin
@Spazholio
Oct 22 2016 23:12
I had to use a separate BT dongle on the Pi3 to get openxshareble to work. But even then, it’s somewhat unreliable.
mariano42
@mariano42
Oct 22 2016 23:12
@Spazholio thats a bummer.. i was hoping this would help my rig
Paul Martin
@Spazholio
Oct 22 2016 23:13
It’s unfortunate, yeah. Mind if I ask why you don’t use NS as a source for glucose readings?
mariano42
@mariano42
Oct 22 2016 23:15
thats what I will go back to next... for whatever reason I have never had any luck doing that. I had it working for all of 3 hours one day and that's been it. Pushing or pulling data with nightscout just hasnt worked for me yet. Also, i didnt have hotspot capabilities until recently so it wasn't a possibility for me to use NS unless i was home. That issue has been resolved, so I guess I will head in that direction again
David
@david-t1
Oct 22 2016 23:17
I haven't tried these instructions but you might take a look at https://github.com/TC2013/aps-scripts/blob/master/openxshareble_instructions.md
mariano42
@mariano42
Oct 22 2016 23:18
@david-t1 thanks.. i believe those are the same as the ones I was using. It sounds like its not very reliable, so back to NS it is!