These are chat archives for nightscout/intend-to-bolus

16th
Jan 2017
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 01:29

I am having trouble adding plugins from the Visualization and Monitoring step. In heroku in has (
feraridurango@aol.com: Set PUMP_FIELDS config var
about 3 hours ago
• v14

feraridurango@aol.com: Set DEVICESTATUS_ADVANCED config var
about 3 hours ago
• v13

feraridurango@aol.com: Set pump config var

the plug ins are not popping up in the nightscout settings
Matt Walker
@walker0
Jan 16 2017 01:33
@xpucuto I think I remember you have repaired the reservoir end cap before? How did you do it?
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 01:52
am I asking questions in the wrong area ?
Dana Lewis
@danamlewis
Jan 16 2017 01:54
@ryan_anglani_twitter it may be helpful for you to share screenshots if it’s still not working ~15+ minutes of making changes. it also might be helfpul to compare to the screenshots in the docs here: http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-1/nightscout-setup.html#enable-these-plugins
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 02:05
ok I am trying to screenshot it thank you @danamlewis
Dana Lewis
@danamlewis
Jan 16 2017 02:06
(just make sure not to include api secret or anything in screenshots)
:+1:
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 02:24
I figured it out ! @danamlewis I had to put ENABLE in the first box and openaps in the second
Dana Lewis
@danamlewis
Jan 16 2017 02:24
:clap:
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 02:25
i will have to add a bunch of these correct? @danamlewis
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 02:37
I am so excited !! it says openaps and basal on nightscout!!!! freaking so close :) @danamlewis
Dana Lewis
@danamlewis
Jan 16 2017 02:37
yay! :confetti_ball:
Jarred Yaw
@jyaw
Jan 16 2017 02:46
@danamlewis is the master docs branch the most up to date these days? Does that update the "latest" readthedocs link? I've been using the "dev" readthedocs link just out of habit.
Dana Lewis
@danamlewis
Jan 16 2017 02:46
correct. master/latest = same and most up to date, we’re targeting any small changes there, then PRing in batches back to dev. dev will be target for any big structural changes that we need to review prior to turning live.
Jarred Yaw
@jyaw
Jan 16 2017 02:47
ah, cool
Dana Lewis
@danamlewis
Jan 16 2017 02:48
(however for oref0, changes still go to dev for review there. just docs where stuff goes straight to master.)
Jarred Yaw
@jyaw
Jan 16 2017 02:49
certainly, was just unclear on the readthedocs version. thanks!
Dana Lewis
@danamlewis
Jan 16 2017 02:50
:+1: (was also more clarifying for anyone else reading :) who might be wondering :) )
@jyaw ps - when you retargeted, was it from command line or github? that looks like a new feature
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 03:28
How would I find out the absorption rate of apidra? thank you
Carbs activity / absorption rate: [g/hour
Jarred Yaw
@jyaw
Jan 16 2017 03:46
@danamlewis ya I think it's sort of recent. When you click edit on the PR heading you can change the base.
Dana Lewis
@danamlewis
Jan 16 2017 04:05
@jyaw neat - thanks
@ryan_anglani_twitter you're talking about carb absorption rate in Nightscout? Most people will leave blank/not use that, otherwise you can test a la https://diyps.org/2014/05/29/determining-your-carbohydrate-absorption-rate-diyps-lessons-learned/
Scott Leibrand
@scottleibrand
Jan 16 2017 04:07
@ryan_anglani_twitter that's a carb absorption rate, not related to which insulin you're using. And oref0 doesn't use that value anyway.
Dana Lewis
@danamlewis
Jan 16 2017 04:07
But, you don't need that for OpenAPS - our algorithm now will calculate observed absorption
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 04:12
@scottleibrand @danamlewis thank you!!! :)
Dana Lewis
@danamlewis
Jan 16 2017 04:18
:+1:
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 04:20
I am trying to go back in and leave the carb absorption rate blank in the profile editor and it wont pull up the profile that I just made .........but the values are showing on the nightscout ? how do I leave the carb absorption rate blank?
Dana Lewis
@danamlewis
Jan 16 2017 04:22
Just backspace from what you have in there
Also don't worry about it if it sticks with what you have. Will influence carb decay in the non-OpenAPS bolus wizard preview, but I wouldn't use that since it doesn't sync with OpenAPS status anyway , so no harm.
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 04:24
@danamlewis thanks you are awesome!
Dana Lewis
@danamlewis
Jan 16 2017 04:40
:smile:
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 04:57
phase 2! WHOOP WHOOP!!!
Dana Lewis
@danamlewis
Jan 16 2017 05:03
:smile: step by step! Getting closer!
@Aaybob are you intentionally opening and closing all of those PRs?
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 05:29
@danamlewis so i was asked for the serial number or the pump that means the pump the openaps is working with correct?
Scott Leibrand
@scottleibrand
Jan 16 2017 05:34
whichever serial number you provide is the pump that openaps will try to read data from and set temps on
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 05:35
ok so i will put the serial number of the pump that is connect to my boy? so it can get information from it ? @scottleibrand
Scott Leibrand
@scottleibrand
Jan 16 2017 05:40
if you're ready to start looping for real, then yes. or if you want to test out looping on a non-human-connected pump, you can put in that serial number instead
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 05:50
@scottleibrand it keeps running and saying attempting to use a port that is not open
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 05:57
@danamlewis i must have missed something the pump is not doing anything
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:11
ok i think its working the pump says basal 1: 2.00 U/H @danamlewis
Dana Lewis
@danamlewis
Jan 16 2017 06:14
What does the log say?
is there a temp basal enacted on the pump?
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:23
@danamlewis it made a temp basal for 30min :)
Dana Lewis
@danamlewis
Jan 16 2017 06:24
Woot :smile: :confetti_ball:
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:26
YES LARGE WHOOT!!!!! that was so easy !!! thank you !!!! can i hook it to the kid now? lol
Scott Leibrand
@scottleibrand
Jan 16 2017 06:27
If you're asking, you're not ready yet. 😜
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:29
Yeah I figured so @scottleibrand what do i do with the settings that are in the pump from a previous person should I erase them or put my sons current settings in ?
Scott Leibrand
@scottleibrand
Jan 16 2017 06:33
Umm... It sounds like you need to step away from Gitter and the terminal and think about what you're trying to accomplish here. This is a DIY project, and that means thinking, not just typing.
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:35
your right i am exhausted but so excited that this is up thank you @scottleibrand
@scottleibrand one last question what I see in the pump is put there from openaps and was not there previously ?
Scott Leibrand
@scottleibrand
Jan 16 2017 06:40
The only thing openaps sets on the pump is a 30 minute temp basal. All settings etc. are set manually on the pump and read by openaps.
Ryan anglani
@ryan_anglani_twitter
Jan 16 2017 06:40
thank you @scottleibrand
Scott Leibrand
@scottleibrand
Jan 16 2017 06:40
Have a good night. :smile:
Tim Street
@tim2000s
Jan 16 2017 11:04
Right then. Next step on the Portable OpenAPS set up. Add wireless charging 😊
chrisharris751
@chrisharris751
Jan 16 2017 11:28
@tim2000s I've ordered, waiting for it to show up!!
I have a nightscout issue that I'm hopping someone can help with. All my entries are showing up as in the future. I've doubled checked that the timezone and time is the same on all my devices and read through all the relevant doc's to no avail. I'm stuck. Anyone got any ideas?
Ryan Dalisky
@rdalisky
Jan 16 2017 12:12
The first time I tried to set up an OpenAPS environment, I spent a week trying to get it accomplished. Granted this was before the setup scripts. I went to Loop for 3 months, and recently came back to OpenAPS because of the advanced features that are available. It took me 2 hours to set up my explorer board rig from scratch, and I have updated twice since then. Thank you all for what you do with this project. I am going to submit a paper this spring about my N=1 experience with OpenAPS, and was thinking about getting some community data together to show non-inferiority with current CSII and CGM therapies. If anyone else is interested, let me know!
Scorponok
@Scorponok
Jan 16 2017 12:38
@chrisharris751: How long in the future? A specific number of hours, the same amount in the future every time, or a weird value like "3 hours 12 minutes"?
Scott Leibrand
@scottleibrand
Jan 16 2017 16:03
@rdalisky awesome!
Dana Lewis
@danamlewis
Jan 16 2017 16:56
@rdalisky :+1: I'm working on the plumbing so people can donate their data for another outcomes study + easily donate for other studies as they come up; would be nice to write up comparison to other therapies! Definitely interested in chatting more.
chrisharris751
@chrisharris751
Jan 16 2017 17:53
@Scorponok they
Don't appear to be in the future. But the entries don't show on the chart. When I go to admin tool they show up in the future treatments section. The time looks correct on them. That's what I can't work out.
Brett
@burgertime14
Jan 16 2017 18:26
@chrisharris751 last time I had issues with time and nightscout was when my pump time/date was off...
Ryan Dalisky
@rdalisky
Jan 16 2017 18:44
@danamlewis I'm going to be relatively free after 5 tonight, so let's get our chat on!
Toby Canning
@TC2013
Jan 16 2017 20:22
Question: Twice now I have gotten a series of errors in the pump-loop log with repeating notices of mmeowlink.vendors.serial_interface.AlreadyInUseException: /dev/spidev5.1 already in use These errors don't go away until the cc1110 is reset.
I'd like to build a cron task that recognizes the error and after five in a row have occurred will reboot the Edison. Anyone have an idea on how to do that or something similar?
Also, we seem to get a lot more of these errors
Traceback (most recent call last):
  File "/usr/local/bin/mmeowlink-any-pump-comms.py", line 15, in <module>
    app.run(None)
  File "/usr/local/lib/python2.7/dist-packages/decocare/helpers/cli.py", line 113, in run
    self.prelude(args)
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/cli/any_pump_comms_app.py", line 28, in prelude
    super(AnyPumpCommsApp, self).prelude(args)
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/cli/base_mmeowlink_app.py", line 26, in prelude
    self.link = link = LinkBuilder().build(args.radio_type, port)
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/link_builder.py", line 16, in build
    return SubgRfspyLink(port)
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/subg_rfspy_link.py", line 55, in __init__
    self.open()
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/serial_interface.py", line 28, in open
    self.check_setup()
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/subg_rfspy_link.py", line 72, in check_setup
    self.serial_rf_spy.sync()
  File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/serial_rf_spy.py", line 121, in sync
    raise CommsException("Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?")
mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
These errors are usually immediately resolved in the next run, but I wonder if someone knows the cause
PieterGit
@PieterGit
Jan 16 2017 20:43
i got cdc_acm 1-1.4:1.0: failed to set dtr/rts errrors. Do anybody know what causes them. I think rebooting didn't fix it, but only putting TI-USB stick in and out.
@tc2013: i have a wachtdog in place if glucose values are not updated it will reboot . maybe such a thing would also would work for the pump-loop.
e.g. pump-session.json
Eric
@ecc1
Jan 16 2017 20:53
@TC2013 you could try checking the status of fuser -s /dev/spidev5.1 and killing the pid it returns
kenstack
@kenstack
Jan 16 2017 21:02
@TC2013 is that with a production explorer board or something else
Matt Walker
@walker0
Jan 16 2017 23:11
@chrisharris751 check that your timezone is set correctly in your nightscout profile.