These are chat archives for nightscout/intend-to-bolus

19th
Jan 2017
Tim Street
@tim2000s
Jan 19 2017 00:08
@C-Ville mine is setup with xDrip and Nightscout and works fine from Nightscout in The continued absence of xDrip working properly.
I have been functioning from Nightscout via xDrip in the meantime.
jburke41
@jburke41
Jan 19 2017 00:10
I swtiched to Heroku from Azure. I can get my dexcom data on my new site, but my openaps status is unknow. Has anyone had this problem?
C-Ville
@C-Ville
Jan 19 2017 00:11
@tim2000s I met get confused with my setup, I have an edison running mongo and NS and a second one running the loop including xdrip script. I now have tons of issues switching back between home network and cellphone hotspot. I may still have errors in there
fiberfan
@fiberfan
Jan 19 2017 00:29
@danamlewis I can order an xDrip kit for you but it will need a bit of soldering to work.
Dana Lewis
@danamlewis
Jan 19 2017 00:29
heh, thx. that’s the part i’ve been avoiding :)
(i can order a kit, but don’t like the idea of soldering ,and hasn’t been worth the time to do that up until now)
Eric Luhrs
@eluhrs
Jan 19 2017 01:24
@danamlewis I think I have all the parts for an xdrip. Happy to build and send it if that would be helpful.
I'm not planning to use it anytime soon. I got the parts then went a different route.
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 01:31
Checking /home/pi/gavin: true
/home/pi/gavin already exists
/home/pi/src/oref0/ already exists; pulling latest
error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty
error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty
fatal: loose object cc07d6bd8dfabd8dc752fffec3b7d27efdfe5868 (stored in .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868) is corrupt
Couldn't pull latest oref0
does anyone know what this might mean ?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 01:42
@danamlewis
Dana Lewis
@danamlewis
Jan 19 2017 01:56
@ryan_anglani_twitter is your rig offline?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 01:57
it just started again that was weird
I have to figure out why it keeps stopping it will go for a few hours and then stop
but when its up it amazing and I cant believe my eyes !!!!!its sooooooo awesome!!!!
JaysonEwer
@JaysonEwer
Jan 19 2017 02:05
Slightly new challenge for me....missing pancreas!!!! I know it's close, it just enacted a temp basal. πŸ˜€
πŸ™„
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 02:06
@danamlewis I responded and forgot to add your name above
JaysonEwer
@JaysonEwer
Jan 19 2017 02:13
Where do we find the xdrip kits mentioned above? I'd like to order one.
William Fallon
@inform880
Jan 19 2017 02:25
I'm getting a really weird error after having my rig work for a very long time with regular updates. I can see my looping in messages, and see everything working fine, but when it gets to uploading, it just says "no recent treatments to upload". It doesn't upload anything to my website but my current temp and boluses. It is missing everything in the pump and openaps pillbox. Otherwise everything works. Does anybody have any idea?
fiberfan
@fiberfan
Jan 19 2017 02:28
JaysonEwer
@JaysonEwer
Jan 19 2017 03:25
Thank you, @fiberfan
Jarred Yaw
@jyaw
Jan 19 2017 03:33
Hey I'm testing out OTG to the explorer board and saw this error... any ideas?
# openaps use cgm iter_glucose 1
Traceback (most recent call last):
  File "/usr/local/bin/openaps-use", line 63, in <module>
    app( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 51, in __call__
    self.run(self.args)
  File "/usr/local/bin/openaps-use", line 57, in run
    output = app(args, self)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/__init__.py", line 92, in __call__
    return self.method.selected(args)(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/__init__.py", line 31, in __call__
    return self.method(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in __call__
    output = self.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/dexcom.py", line 297, in main
    for item in self.dexcom.iter_records(self.RECORD_TYPE):
AttributeError: 'NoneType' object has no attribute 'iter_records'
Aaron Michelson
@Aaybob
Jan 19 2017 03:34
@jyaw dexcom connected to OTG?
Jarred Yaw
@jyaw
Jan 19 2017 03:34
yes, sorry
fiberfan
@fiberfan
Jan 19 2017 03:34
I am missing obvious but I can't get either of my edison/explorer board rigs to use wpa_supplicant.conf . Both will only connect when I have the ssid and password for a wifi in the etc/network/intefaces file.
JaysonEwer
@JaysonEwer
Jan 19 2017 03:34
My OTG on my Explorer works fine when I connect my Dexcom.
Jarred Yaw
@jyaw
Jan 19 2017 03:34
:smile:
Aaron Michelson
@Aaybob
Jan 19 2017 03:35
what length chord?
Jarred Yaw
@jyaw
Jan 19 2017 03:35
ah shoot
forgot the 2nd battery
JaysonEwer
@JaysonEwer
Jan 19 2017 03:36
Yep, critical to have external power or battery plugged in.
Aaron Michelson
@Aaybob
Jan 19 2017 03:36
what is that ? 2nd battery on the other miniUSB when connecting Dex?
JaysonEwer
@JaysonEwer
Jan 19 2017 03:36
Yes
Aaron Michelson
@Aaybob
Jan 19 2017 03:36
Where in the docs?
Jarred Yaw
@jyaw
Jan 19 2017 03:37
ya, even after dana reminded me about the other day.... I was like, I know that, not going to forget it.
works now :facepunch:
Aaron Michelson
@Aaybob
Jan 19 2017 03:37
I saw reminder but didn't know.....I'm not getting much internet connection away from home.
JaysonEwer
@JaysonEwer
Jan 19 2017 03:38
You need to make sure the dex is receiving power/is "charging" with lightning bolt for it to work properly.
Jarred Yaw
@jyaw
Jan 19 2017 03:38
sure, that's where it clicked for me a minute ago
didn't see the charging icon
JaysonEwer
@JaysonEwer
Jan 19 2017 03:38
πŸ‘ŠπŸ‘
Aaron Michelson
@Aaybob
Jan 19 2017 03:38
what battery type are you using succesfully?
Jarred Yaw
@jyaw
Jan 19 2017 03:38
for the 2nd?
Aaron Michelson
@Aaybob
Jan 19 2017 03:39
yes, this 2nd is new to me but will need to hardwire.
Jarred Yaw
@jyaw
Jan 19 2017 03:39
just a USB battery pack, like you'd use for the pi
or to charge your cell phone
JaysonEwer
@JaysonEwer
Jan 19 2017 03:39
Exactly
Aaron Michelson
@Aaybob
Jan 19 2017 03:39
great, so good to know
Then you run openaps even when off internet. Right?
Jarred Yaw
@jyaw
Jan 19 2017 03:40
correct
Aaron Michelson
@Aaybob
Jan 19 2017 03:41
I love you guys!
Running master or dev?
Jarred Yaw
@jyaw
Jan 19 2017 03:42
I'm on dev
Aaron Michelson
@Aaybob
Jan 19 2017 03:42
I've had better results mobile on dev.
JaysonEwer
@JaysonEwer
Jan 19 2017 03:43
I'm on master
I misplaced my Explorer rig this morning, I'm glad I had my other one in my pocket this am I realized the other was not with me as I was walking into my workplace.
Aaron Michelson
@Aaybob
Jan 19 2017 03:46
I so want to test one at work!
JaysonEwer
@JaysonEwer
Jan 19 2017 03:46
I just found it in the cushion of my couch I happened to lay on for a moment this am.😜😎
I'm somewhat surprised the battery lasted all day. I guess it was using less juice as it didn't have a pump to talk to most of the day.
My new 2000mAh Lipos arrive tomorrow, yay! Then I can use my new case officially.
Love you too @Aaybob
Aaron Michelson
@Aaybob
Jan 19 2017 04:10
Wait a sec. sooo can I power the board with only one battery that is connected to a miniUSB connector?
of course, why didn't i think of that
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 04:16
mkdir -p ~/src; cd ~/src && git clone git://github.com/openaps/oref0.git || (cd oref0 && git checkout master && git pull) fatal: destination path 'oref0' already exists and is not an empty directory. Already on 'master' Your branch is up-to-date with 'origin/master'. error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty fatal: loose object cc07d6bd8dfabd8dc752fffec3b7d27efdfe5868 (stored in .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868) is corrupt
i wish i knew what this meant
Aaron Michelson
@Aaybob
Jan 19 2017 04:16
Do you have nightscout set up?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 04:17
yes
Aaron Michelson
@Aaybob
Jan 19 2017 04:17
Oh jeezz, it says "is corrupt"!
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 04:17
IndexError: bytearray index out of range
this is from tail
do I have to reload my sd card?
Aaron Michelson
@Aaybob
Jan 19 2017 04:20
try the commands git clone....., cd oref0, git check...., git pull. each one at a time from the command line with the killall in front.
JaysonEwer
@JaysonEwer
Jan 19 2017 04:21
Oref0-reset-git is the command you need. No need to reload card
Aaron Michelson
@Aaybob
Jan 19 2017 04:22
that does the git pull command?
i mean go with that if it takes care of "git" details.
do you have pancreabble working @JaysonEwer
Aaron Michelson
@Aaybob
Jan 19 2017 04:24
the long row of hexidecimal digits reminds me of the azure websites secret code password
JaysonEwer
@JaysonEwer
Jan 19 2017 04:24
No, I've never played with pancreable.
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 04:25
well i did the kill all git clone and it worked instantly and is still up but i have this

```monitor/temp_basal.json raised 'Pump' object has no attribute 'model'
pump://JSON/read_temp_basal/monitor/temp_basal.json
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
output = task.method(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in call
output = self.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", line 333, in main
return getattr(self.pump.model, name)(**self.get_params(args))
AttributeError: 'Pump' object has no attribute 'model'
Starting pump-loop at Wed 18 Jan 23:24:33 EST 2017:

```

JaysonEwer
@JaysonEwer
Jan 19 2017 04:27
Looks like you aren't close enough to your pump.
Bedtime, goodnight all.
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 04:27
we have the care link :( its on his nightstand
it stick will be ordered in the am thank you @JaysonEwer @Aaybob
fiberfan
@fiberfan
Jan 19 2017 04:28
Is your crontab still using the default ? @ryan_anglani_twitter
Before I got explorer boards I had much better success when I changed the first to /3 so the loop ran every 3 minutes. I think it gives the carelink stick more time to recover from a failure.
Ops, the ? should have been the group of asterisks separated by a space at the beginning of the lines in crontab
I took to using a long cord and putting the pump and the rig in a small cloth bag and setting them together beside me on the bed so I didn't get failures at night.
fiberfan
@fiberfan
Jan 19 2017 04:33
Another ops, changed the first asterisk to an asterisk with /3 immediate after the asterisk.
Scott Leibrand
@scottleibrand
Jan 19 2017 05:35
@inform880 your "no recent treatments to upload" thing might be due to future-dated treatments in Nightscout. Check the NS admin page.
Tim Street
@tim2000s
Jan 19 2017 06:29
Well I started an Enlite sensor last night with the 722. Aside from spending the night asleep on it (resulting in no signal), it's working well with OpenAPS. Pity the glucose readings are way off the Dexcom in my other arm. We'll see if it wakes up later today or if my slight issue with needle retraction proves "deadly".
Dana Lewis
@danamlewis
Jan 19 2017 06:29
dying not allowed, fyi
Tim Street
@tim2000s
Jan 19 2017 06:33
Lol
j4cbo
@j4cbo
Jan 19 2017 07:42
sounds like my enlite experience :P
Tim Street
@tim2000s
Jan 19 2017 10:37

Last 12 days of the CGM survey. Please pop on over & fill it in if you haven't already. It only takes five minutes!

https://tim2000s.typeform.com/to/TwXH4V

Colin Lennon
@colinlennon
Jan 19 2017 10:39
@tim2000s Hi Tim, sorry, just catching up on this. Did you set up xDripAPS manually, or did you run the dev oref0-setup script and specify xdrip as the cgm source?
@tim2000s Also, in the xDrip app, make sure you've got http:// rather than https:// - e.g. http://yourapisecret@192.168.x.x:5000/api/v1/
Colin Lennon
@colinlennon
Jan 19 2017 10:45
Did you say that you see rows in the entries table in sqlite3?
Tim Street
@tim2000s
Jan 19 2017 11:38
Ah. That's the issue. My xDrip is setup with https
Colin Lennon
@colinlennon
Jan 19 2017 11:51
Great, hopefully it'll work when that's changed. I do plan to document this properly, just short on time at the moment.
C-Ville
@C-Ville
Jan 19 2017 11:53
@tim2000s did just fill out the form
Tim Street
@tim2000s
Jan 19 2017 11:59
@C-Ville ? Not sure which form.
C-Ville
@C-Ville
Jan 19 2017 12:00
the questionaire you just posted
just means 1h or 2h ago
Matthias
@ceben80
Jan 19 2017 12:34
@tim2000s really httpsdamn :smile:
Tim Street
@tim2000s
Jan 19 2017 12:35
Thanks @C-Ville
@ceben80 and bingo. We are offline looping with xDrip :+1: thanks @colinlennon
Matthias
@ceben80
Jan 19 2017 12:39
yeah Timm :tada:
Tim Street
@tim2000s
Jan 19 2017 12:40
I also like uploading to NS via mongo because it sends over the dataoints when you lose comms.
Matthias
@ceben80
Jan 19 2017 12:45
@tim2000s @colinlennon yes that's great, but now the q how to define e.g. temp target in case of no internet connectivity and ns in not running local
Colin Lennon
@colinlennon
Jan 19 2017 12:53
@tim2000s Great, glad it's working Tim! @ceben80 Yeah, that's an issue. I have thought about the possibility of adding a second REST endpoint to xDripAPS for recording temporary targets. How would it be called though? Not sure if it could be called from ThisButton app on a Pebble without needing an internet connection, for example.
Maybe that is overkill though. I usually have internet access, but when I don't, I'd probably just manually correct to 80 or even update the targets on my pump for the hour before I eat, then change them back.
For people who are offline more often, it probably makes more sense to run Nightscout on the Edison.
Matthias
@ceben80
Jan 19 2017 12:59
@colinlennon yes same workaround for me in case of no internet, adjusting the pump target :wink:
Matthias
@ceben80
Jan 19 2017 13:17

@/all Q to creating a backup image from the Edison (Explorer Board)

Regarding to https://github.com/oskarpearson/mmeowlink/wiki/Backing-up-and-cloning-your-OpenAPS-Edison#step-1-create-a-backup-image

Jan 19 14:11:07 eddie-eb kernel: [  415.546228] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
Jan 19 14:11:07 eddie-eb kernel: [  415.546250] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Jan 19 14:11:07 eddie-eb kernel: [  415.546268] usb usb1: Product: xHCI Host Controller
Jan 19 14:11:07 eddie-eb kernel: [  415.546286] usb usb1: Manufacturer: Linux 3.10.17-poky-edison+ dwc-xhci
Jan 19 14:11:07 eddie-eb kernel: [  415.546303] usb usb1: SerialNumber: dwc3-host.2
Jan 19 14:11:07 eddie-eb kernel: [  415.547205] hub 1-0:1.0: USB hub found
Jan 19 14:11:07 eddie-eb kernel: [  415.547245] hub 1-0:1.0: 1 port detected
Jan 19 14:11:07 eddie-eb kernel: [  415.547759] dwc3-host dwc3-host.2: xHCI Host Controller
Jan 19 14:11:07 eddie-eb kernel: [  415.548078] dwc3-host dwc3-host.2: new USB bus registered, assigned bus number 2
Jan 19 14:11:07 eddie-eb kernel: [  415.548215] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
Jan 19 14:11:07 eddie-eb kernel: [  415.548236] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Jan 19 14:11:07 eddie-eb kernel: [  415.548254] usb usb2: Product: xHCI Host Controller
Jan 19 14:11:07 eddie-eb kernel: [  415.548271] usb usb2: Manufacturer: Linux 3.10.17-poky-edison+ dwc-xhci
Jan 19 14:11:07 eddie-eb kernel: [  415.548288] usb usb2: SerialNumber: dwc3-host.2
Jan 19 14:11:07 eddie-eb kernel: [  415.549096] hub 2-0:1.0: USB hub found
Jan 19 14:11:07 eddie-eb kernel: [  415.549134] hub 2-0:1.0: 1 port detected
root@eddie-eb:~# ls -ls /dev/sd*
ls: cannot access /dev/sd*: No such file or directory

I want to mount the attached USB stick, but asking me what's the /dev/xxx :question:

Any advice would be appreciated :+1:

Matthias
@ceben80
Jan 19 2017 13:30
root@eddie-eb:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Matthias
@ceben80
Jan 19 2017 14:09
or just feasible with the Intel Breakout Board?
Tim Street
@tim2000s
Jan 19 2017 14:16
@colinlennon @ceben80 I was thinking about the same thing. I know @jasoncalabrese has something running using OpenAPS JSON files.
C-Ville
@C-Ville
Jan 19 2017 14:20
@colinlennon I am still not sure of you could run NS on the edison without the additional burden to also run the mongodB on there as well
@colinlennon in view of adding another REST, I wonder if someone could tweak the treatment entry from xdrip+ to also allow providing temp targets. as for a quick and dirty solution I was wondering if you could just ssh into your edison and manually create temptarget.json files
Tim Street
@tim2000s
Jan 19 2017 14:37
IFTTT button to do that?
C-Ville
@C-Ville
Jan 19 2017 14:40
doesnt ifttt require to be online
Brian Rabinovitz
@bdr1177
Jan 19 2017 14:52
Does anyone have ideas for a temporary housing for the edison/explorer board and lipo battery. I got the lipo battery linked in the edison hardware information, which is almost 4 inches long. The smaller adafruit battery is on backorder. It looks like most of the 3D cases won't work with the longer battery. Any creative ideas for a temporary solution?
C-Ville
@C-Ville
Jan 19 2017 16:17
@bdr1177 I am currently using standard boxes for DIY electronics for my edison rig (still ERF no explorer Board) https://files.gitter.im/AdrianLxM/gerLoopSMALLTALK/ckSd/IMG_20170118_222002.jpg the cell phone is an Samsung S5 mini
they come in various sizes
Matthias
@ceben80
Jan 19 2017 16:33
@C-Ville pancreas farmer :stuck_out_tongue_winking_eye:
Eric
@ecc1
Jan 19 2017 16:39
@ceben80 I back up and restore my Edisons over wifi with rsync. It's significantly faster than USB.
Matthias
@ceben80
Jan 19 2017 16:45
Reason is would like a restore a whole image on a new Edison, which includes jubilinux
Tim Street
@tim2000s
Jan 19 2017 16:48
Well, 24 hrs in and the Enlite is behaving better now, being within 0.1 of the Dexcom. Dual offlinelooping 😜
Matthias
@ceben80
Jan 19 2017 17:10
:clap:
Colin Lennon
@colinlennon
Jan 19 2017 17:27
@C-Ville @ceben80 @tim2000s I think IFTTT needs an internet connection to work. Here's an idea though... we can safely assume that everybody using xDripAPS is using an Android phone, so if it had a second REST endpoint for temporary targets, we could possibly use the Tasker app on Android to call the REST endpoint. Something similar to this - https://www.youtube.com/watch?v=v-Kl5T-5MQ0
@C-Ville @ceben80 @tim2000s If we could get the ability to post temp targets from xDrip+ that would be excellent. That's probably the ideal solution.
Matthias
@ceben80
Jan 19 2017 17:46
Sounds great @colinlennon and again thanks for this offline solution, today I didn't have stable internet, but who cares :smile: my rig was continuously looping :star2:
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 17:46
Continue? y/[N] y Checking /home/pi/gavins /home/pi/pump: true /home/pi/gavins /home/pi/pump already exists /home/pi/src/oref0/ already exists; pulling latest error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty fatal: loose object cc07d6bd8dfabd8dc752fffec3b7d27efdfe5868 (stored in .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868) is corrupt Couldn't pull latest oref0
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 17:57
thinking I want to start over and reload my sd card it may have been corrupted by unplugging
Brian Rabinovitz
@bdr1177
Jan 19 2017 18:04
@C-Ville Where did you get the boxes from?
C-Ville
@C-Ville
Jan 19 2017 18:14
@bdr1177 I will try to get a datasheet and maybe another more international link later
Brian Rabinovitz
@bdr1177
Jan 19 2017 18:15
@C-Ville Yeah, I have no idea how to search for "enclosure box" in German, but I'm sure I can find something comparable. Thanks!
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 18:42
I ran oref0-reset-git
and it came up with Attempting to fix git corruption. Please wait 15s. Git repo does not appear to be corrupt. /usr/local/bin/oref0-reset-git: line 52: 11446 Terminated ( sleep 1 5; killall oref0-fix-git-corruption )
C-Ville
@C-Ville
Jan 19 2017 18:51
@bdr1177 @ceben80 was so kind to help me out http://strapubox.de/91 there you may be able to find a size that suits you, looks like the do not have an english website though. The one @ceben and I are using is no 2061
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 18:55
does anyone know what I should do ?
Tim Street
@tim2000s
Jan 19 2017 19:03
Just run my first offline gym test. My entire rig for the duration was the pump and my tic tac box. Small things, big smiles!!!
Dana Lewis
@danamlewis
Jan 19 2017 19:04
:smile:
gleski
@gleski
Jan 19 2017 19:12
Just checking, a 722 pump will work without worrying about the firmware number?
Dana Lewis
@danamlewis
Jan 19 2017 19:14
Yes
It should
Look for PC connect under utilities-> connect devices if you want to confirm loopability without dealing w firmware version
gleski
@gleski
Jan 19 2017 19:15
@danamlewis Thanks!
Dana Lewis
@danamlewis
Jan 19 2017 19:15
:+1:
gleski
@gleski
Jan 19 2017 19:18
I'm getting all my hardware together. I noticed the 2000 MAH lithium-ion battery is out of stock, is anybody tried any of the larger batteries that were on Adafruit?
Brian Rabinovitz
@bdr1177
Jan 19 2017 19:20
@gleski I'm using the other battery in the documentation, which is also 2000 MAH LiPo. Available here: http://www.robotshop.com/en/37v-2000mah-5c-lipo-battery.html
So far, it seems to work fine, but is larger in size.
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:26
@danamlewis do you know?
Dana Lewis
@danamlewis
Jan 19 2017 19:29
Do I know what?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:33
what i should do next with this .... oref0-reset-git Attempting to fix git corruption. Please wait 15s. Git repo does not appear to be corrupt. /usr/local/bin/oref0-reset-git: line 52: 11446 Terminated ( sleep 1 5; killall oref0-fix-git-corruption ) pi@raspberrypi:~ $ Git repo does not appear to be corrupt. -bash: Git: command not found pi@raspberrypi:~ $ /usr/local/bin/oref0-reset-git: line 52: 11446 Terminated ( sleep 1 5; killall oref0-fix-git-corruption ) -bash: syntax error near unexpected token `('
Dana Lewis
@danamlewis
Jan 19 2017 19:35
It says git repo does not appear to be corrupt. What is the underlying problem?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:36
i get this when i run the set upContinue? y/[N] y Checking /home/pi/gavins /home/pi/cgm: true /home/pi/gavins /home/pi/cgm already exists /home/pi/src/oref0/ already exists; pulling latest error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty error: object file .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868 is empty fatal: loose object cc07d6bd8dfabd8dc752fffec3b7d27efdfe5868 (stored in .git/objects/cc/07d6bd8dfabd8dc752fffec3b7d27efdfe5868) is corrupt Couldn't pull latest oref0
@danamlewis
Scott Leibrand
@scottleibrand
Jan 19 2017 19:40
@ryan_anglani_twitter sounds like your repo is corrupt, but the standard oref0-reset-git checks don't catch that
can you run a few debug commands for me?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:41
yes @scottleibrand
Scott Leibrand
@scottleibrand
Jan 19 2017 19:42
git status || echo status failed
git diff || echo diff failed
git symbolic-ref HEAD || echo ref failed
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:42
do one at a time?
@scottleibrand
Scott Leibrand
@scottleibrand
Jan 19 2017 19:42
do those from both your myopenaps directory (cd ~/myopenaps) and from cd ~/src/oref0
doesn't matter, you can paste them all three together
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:43
the putty box right?
@scottleibrand
Scott Leibrand
@scottleibrand
Jan 19 2017 19:43
yeah, from your Pi
from what you pasted earlier, it looks like it might actually be your ~/src/oref0 repo that is corrupt. oref0-reset-git checks your myopenaps repo
Dana Lewis
@danamlewis
Jan 19 2017 19:44
Also - are you meaning to continue to run the setup over and over again?
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:44
yes because that how think if fixes it ? @danamlewis

@scottleibrand ```pi@raspberrypi:~ $ git status || echo status failed
On branch master
Untracked files:
(use "git add <file>..." to include in what will be committed)

    .Xauthority
    .asoundrc
    .bash_history
    .bash_logout
    .bashrc
    .cache/
    .config/
    .dbus/
    .gitconfig
    .gstreamer-0.10/
    .gtkrc-2.0
    .pki/
    .profile
    .themes/
    .xsession-errors
    .xsession-errors.old
    Documents/
    gavin/
    gavinaps/
    gavinn/
    gavinopenaps/
    gavins/
    gavinscgm/
    oldconffiles/
    preferences.json.save
    python_games/
    src/

nothing added to commit but untracked files present (use "git add" to track)
pi@raspberrypi:~ $ git diff || echo diff failed
pi@raspberrypi:~ $ git symbolic-ref HEAD || echo ref failed
refs/heads/master
pi@raspberrypi:~ $
```

Scott Leibrand
@scottleibrand
Jan 19 2017 19:45
@ryan_anglani_twitter oh, that's not good: you somehow ended up with a git repo in your home directory
I would rm -rf ~/.git/ to get rid of that
and then:
cd ~/src/oref0
git status || echo status failed
git diff || echo diff failed
git symbolic-ref HEAD || echo ref failed
you might also want to delete all the old gavin directories that you're no longer using, by doing something like rm -rf ~/gavinaps for each one
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:49
I have no idea how to delete directories or even how to find them I'm sorry
Scott Leibrand
@scottleibrand
Jan 19 2017 19:50
I just told you how to delete it
that's what rm (remove) does
the output you pasted above lists all of your directories, or you can see them with ls (list)
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:51
and how do i find them
Scott Leibrand
@scottleibrand
Jan 19 2017 19:51
also, it might be worth your time to go find a good online linux tutorial and run through that
most of the stuff we're doing here is basic linux, and is not OpenAPS specific
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:51
oh yeah because i feel lost
Scott Leibrand
@scottleibrand
Jan 19 2017 19:51
if you get git corruption errors in ~/src/oref0/ (shown from running those git commands I pasted above), you'll want to rm -rf ~/src/oref0 and then start over at http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-2/oref0-setup.html#step-1-pull-clone-oref0
I would take some time to go do some research / tutorial stuff to get yourself oriented, and then come back to all the stuff I just said
it should make sense once you understand the basics a little better
Ryan anglani
@ryan_anglani_twitter
Jan 19 2017 19:53
ok thank you @scottleibrand
Scott Leibrand
@scottleibrand
Jan 19 2017 19:53
and once you've done that, feel free to try things and ask here if you have trouble. no need to tag me on those: anyone here should be able to help you translate what I said into exact commands if you get stuck
(plus, I read everything in this channel, whether I'm tagged or not) :)
Tim Street
@tim2000s
Jan 19 2017 19:58
Okay - quick question about setting up pancreabble...
David
@davidkeddydb
Jan 19 2017 19:59
@scottleibrand I will help get her through.
Tim Street
@tim2000s
Jan 19 2017 19:59
Can I just do a Git install from the site, or is there rather more to it than that?
Tim Street
@tim2000s
Jan 19 2017 20:43
I'm strugglling to add pancreabble to the loop I have.
@fiberfan any advice?
C-Ville
@C-Ville
Jan 19 2017 20:57
@colinlennon do you know if the xdrip-loop picks up bg data from NS if the connection to xdrip+ is not available?
Tim Street
@tim2000s
Jan 19 2017 21:08
@C-Ville I can confirm that it does. I've been using it like that until I got xDrip working.
C-Ville
@C-Ville
Jan 19 2017 21:11
I am getting gm values from NS, but they are not used for creating monitor/glucose.json those are still old xdrip values
@tim2000s any idea which alias in openaps.ini consolidates the BG values and decides which ones to use for looping?
gleski
@gleski
Jan 19 2017 21:13
For those that are still looking, I have a Minimed 512 pump available for sale.
You can email me at gleski at sbcglobal dot net
Tim Street
@tim2000s
Jan 19 2017 21:15
That'll be tricky @C-Ville I've only used it without having had the xDrip connection working. Your SQLite DB will have values in it and it will be repulsing that old data.
Scott Leibrand
@scottleibrand
Jan 19 2017 21:15
keep in mind that while 512 pumps can be used with OpenAPS and oref0, they are somewhat limited compared to 522, and require some additional manual work to get set up. I believe they also don't support carb entry via the bolus wizard for use with AMA, so you'd have to enter carbs another way (via NS or pebble or something).
C-Ville
@C-Ville
Jan 19 2017 21:23
@tim2000s ah okay, I was hoping for something like the check between ns-glucose and cgm-glucose which I think just takes whatever is available
C-Ville
@C-Ville
Jan 19 2017 21:30
@tim2000s might not be worth looking deeper into that, I am still to much experimenting with my rig
Brian Rabinovitz
@bdr1177
Jan 19 2017 21:36
If I wasn't specifically logging what openaps was doing today does it still generate some kind of log or record that I could inspect. It was disconnecting for extended periods today and I'd like to see why.
j4cbo
@j4cbo
Jan 19 2017 21:37
as for batteries: I ordered a battery from eBay that claims to be the same model as the adafruit one. Will see how it goes.
Scott Leibrand
@scottleibrand
Jan 19 2017 21:38
@bdr1177 the pump-loop.log is a good place to start
you can look at the entire file with something like less instead of just looking at the most recent entries with tail
Brian Rabinovitz
@bdr1177
Jan 19 2017 21:40
@scottleibrand Great. Thanks!
fiberfan
@fiberfan
Jan 19 2017 21:53
@tim2000s I haven't even looked at that since early to mid December so I am of no help. It is on my list to get back to.
fiberfan
@fiberfan
Jan 19 2017 22:04
I have 2 edison/explorer board rigs and can't get either to switch wifis. When I put wpa_supplicant.conf in the interfaces file it won't connect to home, work, or mobile hotspots. I can connect only by putting the ssid and psk in interfaces. Googling hasn't found anything that helps. Any ideas/suggestions?
Scott Leibrand
@scottleibrand
Jan 19 2017 22:06
you probably have a weird quote mark or something in one of your SSIDs
make sure you're escaping all the SSIDs with " and try renaming your phone to not have a curly ' in its SSID?
if it's not that, you should be able to get wpa_supplicant to give you more details about what it's failing to parse in the wpa_supplicant.conf
Colin Lennon
@colinlennon
Jan 19 2017 22:11
@C-Ville I think a minor change is needed to allow you to switch between pulling CGM data from NS and xDripAPS. At the moment, I have my phone and the Edison tethered over BT 24/7, but I can see that it'd be nice to be able to pull from NS when WiFi is available. I'll look into that - I just need to add some logic to only overwrite monitor/glucose.json if it contains more recent CGM data than the existing file. At the moment, it uses the last modified dates of the files which doesn't work - the xDripAPS file's always newer, so it always gets used.
fiberfan
@fiberfan
Jan 19 2017 22:11
Thanks Scott, it is hard to track down a problem where I don't know were to look.
Colin Lennon
@colinlennon
Jan 19 2017 22:11
That'd mean you could turn off the phone hotspot/BT tethering and save phone battery.
C-Ville
@C-Ville
Jan 19 2017 22:21
@colinlennon that would be nice. I am still struggling for the best solution for me. Offline is definetely a must and your xdrip solution has some appeal to it
jmcrawford
@jmcrawford
Jan 19 2017 22:22
I haven't looked at xDripAPS yet, but I have a couple of questions. How much data can you store in the local SQL DB? Is there reason to be concerned about filling up the filesystem?
C-Ville
@C-Ville
Jan 19 2017 22:24
@jmcrawford I have my mongo db running on my edison for about 4 months now and there is still space. I would therefore assume that the sql db for just cgm data would not be a problem in near future
jmcrawford
@jmcrawford
Jan 19 2017 22:25
Nice, thx
C-Ville
@C-Ville
Jan 19 2017 22:29
@colinlennon but tetherin 24/7 seems like a stable BT connection
PieterGit
@PieterGit
Jan 19 2017 22:43
@scottleibrand @danamlewis is there a limit on how long back you can start autotune with a start-date? i'm getting errors if i start a run from 1st of october 2016
Brian Rabinovitz
@bdr1177
Jan 19 2017 22:46
I'm getting a bunch of lines in the log that tell me "BG data is too old (it's probably this), or clock set incorrectly." Nightscout is updating, so I'm not sure why openaps is seeing old BGs. Any ideas?
PieterGit
@PieterGit
Jan 19 2017 22:48
@bdr1177 can you do a ls -la in your openaps cgm dir?
@bdr1177 somehow your openaps instance does not get the cgm values, did you check your API_SECRET?
Brian Rabinovitz
@bdr1177
Jan 19 2017 22:49
total 192
drwxr-xr-x 2 root root 4096 Jan 15 16:07 .
drwxr-xr-x 10 root root 4096 Jan 19 17:33 ..
-rw-r--r-- 1 root root 92762 Jan 19 17:34 glucose.json
-rw-r--r-- 1 root root 92762 Jan 19 17:34 ns-glucose.json
@PieterGit This is a new problem today. I've been testing since Jan 15 and this just started today. API_SECRET hasn't changed.
Scott Leibrand
@scottleibrand
Jan 19 2017 22:50
@bdr1177 look at those files to see what the most recent glucose data point is
@PieterGit the only limit I know of is what data you have in NS
Brian Rabinovitz
@bdr1177
Jan 19 2017 22:52
The times from both the glucose files is 5:38, so about 15 minutes ago.
PieterGit
@PieterGit
Jan 19 2017 22:52
ok, i started a run from 1st of november now. I'll investigate later why i can't use a date before that.now runnign with autosens_max=1.0. too many hypos with new autotune profile. i still suggest a more cautious autotune_max value
@bdr1177 they should be at least 10 minutes old
Brian Rabinovitz
@bdr1177
Jan 19 2017 22:53
This has been working intermittently today. So I don't know what is causing it to go out.
Scott Leibrand
@scottleibrand
Jan 19 2017 22:54
@bdr1177 your glucose value needs to be current within 10 minutes or it won't suggest a temp
PieterGit
@PieterGit
Jan 19 2017 22:55
@bdr1177 did you check the time on the dexcom , pump and openaps instance?
Brian Rabinovitz
@bdr1177
Jan 19 2017 22:55
Okay. That makes sense. This has been happening throughout the day and I don't know what changed all of the sudden today that it is not getting updated values some of the time.
Pump and openaps are current time. The dexcom isn't with me right now, but it is updating correctly in NS.
JELCRAWFORD
@JELCRAWFORD
Jan 19 2017 23:47
Hi all - wondering if anyone else gets periodic (several times a week or more) 'notes' from their pump in the NS - grey dot indicating the note has come from openaps://medtronics/854 - under the note field it says "lan69 754" Doesn't seem to be associated with any particular action. I assume it is benign... just curious.
Scott Leibrand
@scottleibrand
Jan 19 2017 23:48
that looks like a 754 pump record that decocare doesn't know how to decode
we get (properly decoded) notes for primes, low reservoir alerts, suspends, resumes, etc. on the 522
if you can figure out what event that record corresponds to, I'm sure someone would be happy to update decocare to label it properly (instead of "lan69")
if you're really curious and can't figure it out based on observation, you could do a carelink upload from your pump and get the CSV from them to compare records