These are chat archives for nightscout/intend-to-bolus

19th
Feb 2017
ejoe132
@ejoe132
Feb 19 2017 00:10 UTC
Can anyone help me figure out why Im sometimes not getting it to set basals? I have a net iob of zero(been suspended for working out) then come back and Ill be at 200 and it says a listed rate it should set but says max iob is 5, which is what I have set but shouldnt it at least do the five instead of nothing?
peterfulvi
@peterfulvi
Feb 19 2017 00:50 UTC
@thebookins that looks awesome I just ordered a caliper I wasn't to take a shot at designing a case that divides in half an screws together with a removable tray to mount the explorer board on. I definitely want to print your design out
Dana Lewis
@danamlewis
Feb 19 2017 01:40 UTC
@ejoe132 paste the contents of your OpenAPS pill or your logs if you'd like help deciphering them
dan lightner
@danimaniac
Feb 19 2017 01:42 UTC

@thebookins Love it! Need it. I will still finish my design, but I want one of yours. I will have one printed when I can find someone with the means to do so. I would only have a few minor suggestions: 1) try to incorporate the screw access holes into a vent. Otherwise, it just looks like a hole for access. 2) I like "#OpenAPS" instead of "#we're not waiting". 3) I would add a few more venting slots on the same side. I think my case goes overboard with vents, but I would add one or two more. See suggestion number 1. Maybe one vent on the bottom of the case also to allow for a cross flow. This is a really good looking case!

I have no experience with Ki-CAD and very little with CAD in general, so I have no idea which file represents the complete Explorer Board.

dan lightner
@danimaniac
Feb 19 2017 01:58 UTC
@thebookins Your case looks to be approx. 40mm x 20mm x 68.75mm assembled?
katie disimone
@Kdisimone
Feb 19 2017 02:16 UTC
@ejoe132 max-iob is NOT a rate. It is the amount of insulin units that you are allowing the loop to accumulate in high temps to help with a high blood sugar. It is not a "units per hour"...but rate just a "units"
Tim Street
@tim2000s
Feb 19 2017 02:20 UTC
Just to comment on the designs that you've done @danimaniac & @thebookins, you don't need that much in the way of venting. I've been running with the picture in the link for about a month and it's never got that hot. https://imgur.com/K7sWb1e
The holes in the top are tiny and are more than enough in normal use and charging.
dougtakeuti
@dougtakeuti
Feb 19 2017 02:46 UTC
Hi, here in Brazil we are switching from Summer time back to our normal time. Therefore I had to set the pump clock back 1h at midnight. I set it to 23:06, Feb 18 when it was displaying 0:06 on Feb 19. The rig was already sinc'd to the new time. The loop has been showing clock error, which is easy to understand, since the pump has already bg data that is ahead of the last bg collected. Will this go away once the last bg is newer than that one?
John Benjamin
@Bender1061
Feb 19 2017 02:47 UTC
@dougtakeuti you could either delete everything in the monitor folder, or just wait an hour.
dougtakeuti
@dougtakeuti
Feb 19 2017 02:48 UTC
@Bender1061 thanks!
John Benjamin
@Bender1061
Feb 19 2017 02:48 UTC
I had that happen when I tried last month to change to Central time from Eastern time, and I had let it just sit an hour, but deleting the monitor folder would kind of do the same thing.
dougtakeuti
@dougtakeuti
Feb 19 2017 02:50 UTC
:+1:
John Benjamin
@Bender1061
Feb 19 2017 02:50 UTC
we almost need something that would see a time change on the pump and automatically change the time in the history or the glucose files in monitor.
could help with the broken loops during daylight change times.
Paul Dickens
@thebookins
Feb 19 2017 02:53 UTC
Thanks all for the comments on the case. @peterfulvi the idea of a removable tray is a good one - I might try that for the next iteration, but I'd be a bit concerned that you would lose some rigidity. Agreed @danimaniac about the screw access holes. I'm in two minds about venting - don't want to much opportunity for dust to get in, but turning the access holes into vents is a good compromise. The assembly is 67mm x 40mm x 21mm - about as small as I can manage as it's for my son and i don't want him to have to lug a big box around.
katie disimone
@Kdisimone
Feb 19 2017 03:10 UTC
Anna was getting ready to leave house and her rig is turned off. She didn’t turn if off and battery is well charged. HEre’s the error in pump log
Starting pump-loop at Sat Feb 18 18:39:13 PST 2017:
Radio ok, Listening: .Starting pump-loop at Sat Feb 18 19:02:19 PST 2017:
Radio ok, Listening: .No pump comms detected from other rigs
Old pumphistory: 
Error, retrying
Listening: .No pump comms detected from other rigs
mmtune: pump://JSON/mmtune/monitor/mmtune.json
Traceback (most recent call last):
  File "/usr/local/bin/openaps-report", line 82, in <module>
    app( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 51, in __call__
    self.run(self.args)
  File "/usr/local/bin/openaps-report", line 75, in run
    output = app(args, self)
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in __call__
    return self.method.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 37, in main
    repo = app.git_repo( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 78, in git_repo
    self.repo = getattr(self, 'repo', Repo(os.getcwd( ), odbt=GitCmdObjectDB))
  File "/usr/local/lib/python2.7/dist-packages/git/repo/base.py", line 156, in __init__
    raise InvalidGitRepositoryError(epath)
git.exc.InvalidGitRepositoryError: /root/myopenaps
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
I have 30 minutes to troublehsoot this. Anyone?
katie disimone
@Kdisimone
Feb 19 2017 03:17 UTC
well, it came back online…but still have no idea why it lost power.
peterfulvi
@peterfulvi
Feb 19 2017 03:58 UTC
Can I tether a tablet to my right to ensure
Can I tether a tablet to my right
Sorry. New keypad can I tether my tablet to my right to
Can I tether my tablet to my right to send it ssh commands offline .sorry new keypad
katie disimone
@Kdisimone
Feb 19 2017 04:13 UTC
Not that I know of…ssh is if it is online.
If you mean can you use tablet to ssh into rig without cables…while both are online…yes
kenstack
@kenstack
Feb 19 2017 04:40 UTC
@danamlewis something for somewhere in the docs :) a lot of people have trouble with the initial setup after an edison flash because when editing a file nano isnt “full screen” when using screen over uart. on my mac at least the size of the window is shown on top in columns and rows. When you first log into the edison, if you type stty cols abc rows xyz using those numbers, nano seems to work perfectly over screen and uart as the window size is not set. If you reet the window size then of course run it again with the new numbers. If someone can verify this works for them we can add it to the docs. People - including me - hate using vim to setup their network interfaces file :)
Dana Lewis
@danamlewis
Feb 19 2017 04:43 UTC
PRs welcome
kenstack
@kenstack
Feb 19 2017 04:57 UTC
@danamlewis if someone can confirm I'll pr
andyhandy
@andyhandy
Feb 19 2017 05:59 UTC

Anyone else seen this error on edison with explorer board?

super(AnyPumpCommsApp, self).prelude(args)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/cli/base_mmeowlink_app.py", line 26, in prelude self.link = link = LinkBuilder().build(args.radio_type, port)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/link_builder.py", line 16, in build
return SubgRfspyLink(port)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/subg_rfspy_link.py", line 55, in init
self.open()
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/serial_interface.py", line 23, in open
raise AlreadyInUseException("%s already in use" % self.device)
mmeowlink.vendors.serial_interface.AlreadyInUseException: /dev/spidev5.1 already in use

katie disimone
@Kdisimone
Feb 19 2017 06:02 UTC
@andyhandy yes. Me. just a couple days ago. There’s a fix
andyhandy
@andyhandy
Feb 19 2017 06:06 UTC
thank you @Kdisimone . You seem to have all the answers!
katie disimone
@Kdisimone
Feb 19 2017 06:08 UTC
HAHA…I really don’t. I just got lucky on this one that someone else had the answer a few days ago. I’d tag him but his name isn’t coming up right now
peterfulvi
@peterfulvi
Feb 19 2017 06:47 UTC

Im trying to enable the auto sense mode im in the first stages. In the Pump.ini file do i add this

[report "monitor/glucose.json"]
device = cgm
use = iter_glucose
reporter = JSON
count = 288

Or do i modify this entry

[report "monitor/glucose.json"]
use = rezone
reporter = JSON
astimezone = False
date = timestamp dateString start_at end_at created_at display_time
adjust = missing
timezone =
device = tz
input = monitor/glucose-unzoned.json
katie disimone
@Kdisimone
Feb 19 2017 06:57 UTC
@peterfulvi I am not going to answer your specific question because I’m not sure if that’s the way to enable autosens. I believe you’d simply want to do the runagain script and this time choose Y to enable autosens
That way you also get a cron line for it.
Matthias
@ceben80
Feb 19 2017 08:22 UTC

@Kdisimone @andyhandy I use this here due to dev/spidev5.1 already in use

*/10 * * * * if (tail -n 50 /var/log/openaps/pump-loop.log | grep "/dev/spidev5.1 already in use"); then reboot; fi

peterfulvi
@peterfulvi
Feb 19 2017 09:15 UTC
Are the advanced features enabled in the loop if i selected them in setup. There is no additional reports to add or devices? Here is what my loop looks like:
Starting pump-loop at Sun Feb 19 04:06:17 EST 2017:
Radio ok, Listening: .No pump comms detected from other rigs
MDT cgm data retrieved
MDT cgm data reformatted
Profile less than 60m old
glucose.json newer than temp_basal.json
Temp refreshed
{"carbs":5,"boluses":0.5,"mealCOB":0}
{"ratio":1}
{"iob":0.307,"activity":0.0032,"bolussnooze":0,"basaliob":0.307,"netbasalinsulin                                                                                                                     ":0.45,"hightempinsulin":0.65,"time":"2017-02-19T09:06:58.000Z"}
{"delta":0,"glucose":108,"short_avgdelta":0.56,"long_avgdelta":0.53}
{"duration":22,"rate":1.175,"temp":"absolute"}
target_bg unchanged: 100
Carb Impact: 0.6 mg/dL per 5m; CI Duration: 0 hours
Accel. Carb Impact: 10 mg/dL per 5m; ACI Duration: 0 hours
determine-basal://text/shell/enact/suggested.json
reporting enact/suggested.json
{"temp":"absolute","bg":108,"tick":"+0","eventualBG":100,"snoozeBG":100,"predBGs                                                                                                                     ":{"IOB":[108,108,108,108,107,107,107,106,106,105,105,104,104,103,103,103,102,10                                                                                                                     2,101,101,101,100,100,100,100,99,99,99,99,99,99,98]},"COB":0,"IOB":0.307,"reason                                                                                                                     ":"COB: 0, Dev: 3, BGI: -0.56, ISF: 35, Target: 100; 100-100 in range: no temp r                                                                                                                     equired; setting current basal of 1 as temp, but 22m left and 1.175 ~ req 1U/hr:                                                                                                                      no action required"}
{"bg":106,"temp":"absolute","snoozeBG":99,"recieved":true,"predBGs":{"IOB":[106,                                                                                                                     106,106,106,105,105,105,104,104,103,103,102,101,101,101,100,100,99,99,99,98,98,9                                                                                                                     8,98,97,97,97,97,97,97,96,96,96,96,96,96,96,96,96,96,96,97,97,97,96]},"rate":1.1                                                                                                                     75,"reason":"COB: 0, Dev: 3, BGI: -0.51, ISF: 35, Target: 100; 99-99 in range: n                                                                                                                     o temp required; setting current basal of 1.2 as temp. Setting neutral temp basa                                                                                                                     l of 1.2U/hr","COB":0,"eventualBG":99,"timestamp":"2017-02-19T03:58:29.229964","                                                                                                                     duration":30,"tick":"+0","IOB":0.286}
glucose.json newer than pumphistory: Refreshed pumphistory
Im just wondering if Autosensitivity is working
Paul Dickens
@thebookins
Feb 19 2017 09:25 UTC
Seem to have fixed a weird issue from yesterday - our OpenAPS pill box on NS wasn't being updated, and everything else was. Deleted the devicestatus collection in mlab and seems to be OK again. Just a heads up in case anyone seems similar behaviour.
Matthias
@ceben80
Feb 19 2017 09:36 UTC

@peterfulvi

Are the advanced features enabled in the loop if i selected them in setup...

why not? - it's a fully setup, no need to manually add devices/reports for these features :wink:

peterfulvi
@peterfulvi
Feb 19 2017 10:16 UTC
Great. Just making sure. I'm going to be trying to tether a phone i just got to my rig. I'm going to run hot buttons to send it ssh commands to set temp targets for eating soon and activity modes offline this is pretty exiting. I never enabled nightscout. Is there anything im going to have o change other than disabling my wifi on my rig? I would really desire to have a personal connection between the phone and the rig were i could just tunnel into it and send it commands with the phone totally offline.
Matthias
@ceben80
Feb 19 2017 10:47 UTC
@peterfulvi q to the above, why do u want to add a report/device in your pump.ini as written?
peterfulvi
@peterfulvi
Feb 19 2017 11:38 UTC
I dont at this point want to add any report/device, the only thing i want to do is edit my wpa_supplicant file if . It doesn't seem i need to do that at this point. I would like to get down invoking, adding reports, understanding aliases just so i can learn the mechanics of the loop, but far as tinkering around with what i have now would seem silly. Its interesting how it works, Its probably a system i should really learn inside and out seeing it increases my quality of life. The only thing now i want to try is tethering my phone to my rig and tunneling through it offline and sending it commands for eating soon and activity.
joannestevens
@joannestevens
Feb 19 2017 11:39 UTC
Currently have an error on rig, tail log shows there is an error when pulling pump history, any ideas how to problem solve?
Tim Street
@tim2000s
Feb 19 2017 12:01 UTC
@joannestevens That happens sometimes. Usually if you leave the loop running it will resolve itself.
katie disimone
@Kdisimone
Feb 19 2017 14:34 UTC
@ceben80 thank you for cron line. Any other useful ones you may have added or personalized that would be useful for other errors?
live4sw
@live4sw
Feb 19 2017 14:36 UTC
Anyone loop with apidra or novolog? I've been on humalog for 17 years but am finding that the action is not fast enough, so I've been considering a switch.
Matthias
@ceben80
Feb 19 2017 14:38 UTC
@Kdisimone not yet :smile: ....waiting for the next error :wink:
Tim Street
@tim2000s
Feb 19 2017 15:01 UTC
@live4sw - I'm not sure what you're expecting in terms of looping with current insulins? They're all more or less the same (although some find they do better with one or another). It's kind of taken for granted that they're not fast enough to avoid needing to pre-bolus, etc., to deal with eating. The strategies for aiding that are things like "Eating Soon".
live4sw
@live4sw
Feb 19 2017 15:05 UTC
Oh yeah, just me being overly cautious for no good reason, I know they are 95%+ the same. I'm just considering novo or apidra because I've heard that both have a slightly faster DIA than humalog.
bingshin chia
@sugarsanity_twitter
Feb 19 2017 15:27 UTC
I have trouble of getting openAPS glucose data uploaded to my nightscout (temp basal data is able to be uploaded though). Can anyone help? :)
katie disimone
@Kdisimone
Feb 19 2017 16:10 UTC
what cgm are you using?
PieterGit
@PieterGit
Feb 19 2017 16:45 UTC
hi there, still having problems with my USB OTG trace cut. Can anybody with a working Dexcom G4 receiver with USB OTG on Explorer board confirm their dmesg and lsusb output on EnhancedRadioDevices/915MHzEdisonExplorer#16
joannestevens
@joannestevens
Feb 19 2017 17:03 UTC
thanks @tim2000s - it seemed to resolve after a reboot. Went out of wifi, then tethered to phone, working fine and then same issue when back into wifi.
Luis Betancourt
@betluis
Feb 19 2017 17:30 UTC
hello, I am trying to use pancreable to send messages to a pebble watch.. I wonder if somebody can help me understanding what this error message means:

root@edison2:~/myopenaps# openaps use pebble notify "hello" "testing"

usage: openaps-use pebble [-h] USAGE ...
openaps-use pebble: error: argument USAGE: invalid choice: 'notify' (choose from 'shell')

trying to follow this:
blob
Paul Tinson
@ptinson
Feb 19 2017 19:20 UTC
Hi there, am i correct in the way i read what pump is supported? I read it that any of the 522/722 range is ok. 523 and 554 require certain firmware levels?
from this:
512/712
515/715
522/722
523/723 (with firmware 2.4A or lower)
554/754 (European Veo, with firmware 2.6A or lower
peterfulvi
@peterfulvi
Feb 19 2017 20:03 UTC
@thebookins I'm sending those plans to be printed right away. I ordered a caliper because i would like to develop a case my self.
Darrell Wright
@beached
Feb 19 2017 20:14 UTC
@ptinson 754 works with 2.7A(Canadian)
dan lightner
@danimaniac
Feb 19 2017 20:36 UTC
@ptinson I have always thought this could be worded better but, until recently, never joined Gitter or knew a PR existed or what is was. I have yet to make any PRs, but intend to at a later date. Anyway...I read it that firmware 2.4A or lower is required on the 512,. 712, 515, 715, 522, 722, 523, and the 723 inclusive. The 554 and 754 can have 2.6A or lower. The experts in the room will advise checking the utilities menu for PC Connect. PC Connect ≠ OpenAPS.
Paul Tinson
@ptinson
Feb 19 2017 20:52 UTC
@danimaniac thanks, yeah it doesnt read like that.
I ask because iam in the process of getting a pump for my daughter, in NZ these are sometimes funded by our healthcare system but it means we may be restricted to what pump and version we get.
katie disimone
@Kdisimone
Feb 19 2017 21:12 UTC

The firmware requirements as you lined them out @ptinson are correct. The x23 and x54 were the models current-in-market at the time the firmware updates started being added to the models. I haven't seen a x22 that isn't compatible.

But, there's good reason to always push the PC connect check when answering the question about pump compatibility ...it's the simplest was to be sure.

Paul Tinson
@ptinson
Feb 19 2017 22:09 UTC
@Kdisimone so as long as it has PC Connect i should be OK. and on the 522/722 i dont need a particular firmware?
Just so i know if i need to go buy a different pump
Scorponok
@Scorponok
Feb 19 2017 22:10 UTC
@ptinson I'm pretty sure you don't want PC Connect
See the flowchart and the list of compatible firmwares at the top of the page
Paul Tinson
@ptinson
Feb 19 2017 22:13 UTC
@Scorponok sorry i meant hasn’t got… It was a long sleepless night:)
Scorponok
@Scorponok
Feb 19 2017 22:13 UTC
:)
RedCyclist1
@RedCyclist1
Feb 19 2017 22:46 UTC
Finished flashing Edison, now trying to figure out where to run the automated installation scrips as that looks like the next steps... we are trying to get back into PuTTY but we keep getting connection time out message. Does this make sense to anyone? We cannot SSH into PuTTY
David
@david-t1
Feb 19 2017 23:30 UTC
not being able to SSH into PuTTy sounds like the ip# of your rig has changed
RedCyclist1
@RedCyclist1
Feb 19 2017 23:34 UTC
@david-t1 How do I change that? Does ip# always change or can I make it permanent?
jmcrawford
@jmcrawford
Feb 19 2017 23:35 UTC
@RedCyclist1 http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-0/setup-edison.html - You can plug a USB cable into the UART port, and connect over serial.
RedCyclist1
@RedCyclist1
Feb 19 2017 23:37 UTC
Yeah, I have connected over serial but how do I run the oref0-setup.sh from there? This is still all new to me
jmcrawford
@jmcrawford
Feb 19 2017 23:41 UTC
If you've flashed and set up the Wifi networking, the next steps are found here: http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-2/oref0-setup.html
RedCyclist1
@RedCyclist1
Feb 19 2017 23:43 UTC
Yes, I am there but don't I need to run a putty window using ssh to run the oref0-setup.sh script?
jmcrawford
@jmcrawford
Feb 19 2017 23:44 UTC
If the network has been set up, you can run the commands from the serial connection or ssh, either will work. If you need to find your IP address to connect via ssh, run
/sbin/ifconfig -a
RedCyclist1
@RedCyclist1
Feb 19 2017 23:58 UTC
If I run curl -s https://raw.githubusercontent.com/openaps/docs/master/scripts/quick-packages.sh | bash - from root in a serial screen, I get "bash: line 3: sudo: command not found"
Line 4 same error codes
bash: line 3: sudo: command not found
bash: line 4: sudo: command not found