These are chat archives for nightscout/intend-to-bolus

25th
Feb 2017
andyhandy
@andyhandy
Feb 25 2017 00:01
Thanks @Kdisimone
peterfulvi
@peterfulvi
Feb 25 2017 00:38
Do I really need ns to run auto sense and auto tune
katie disimone
@Kdisimone
Feb 25 2017 00:46
@peterfulvi here's the code for autotune. I don't see option without it. https://github.com/openaps/oref0/blob/master/bin/oref0-autotune.sh
peterfulvi
@peterfulvi
Feb 25 2017 00:59
OK thanks
I really
peterfulvi
@peterfulvi
Feb 25 2017 02:28
Do I really
Do I really need all an iPhone and a mini med connect to run NS it seems overkill can't it just read it from my rig and pump 722 with an enlite
Sensor .someone's
peterfulvi
@peterfulvi
Feb 25 2017 02:33
Someone with the same system please point me in the right direction far as we're to start
Dana Lewis
@danamlewis
Feb 25 2017 03:25
You don't need minimed connect
The rig will upload BGs if it has internet connectivity
@peterfulvi ^
peterfulvi
@peterfulvi
Feb 25 2017 03:39
That's what I thought so I just need to follow the instructions in the docsame thanks
Terri Lyman
@tatigger
Feb 25 2017 04:03
@danamlewis I am still having the issue I mentioned above. Anyone else having trouble with autosense?
Dana Lewis
@danamlewis
Feb 25 2017 04:04
Sorry, on my phone and not loading , can you repaste about the issue?
Terri Lyman
@tatigger
Feb 25 2017 04:04
Sure;)
Dana Lewis
@danamlewis
Feb 25 2017 04:05
(I have not heard of anyone else experiencing issues, fwiw)
Terri Lyman
@tatigger
Feb 25 2017 04:05
This error in the log Unexpected
Optional feature Auto Sensitivity enabled. Could not find specified auto-sens: settings/autosens.json
[SyntaxError: Unexpected end of input]
Dana Lewis
@danamlewis
Feb 25 2017 04:09
Hm, did you cat your profile.json and other profiles? Maybe autotune bonked a file
Terri Lyman
@tatigger
Feb 25 2017 04:09
The autosense stopped working about 2am. So I didn't actually do anything to break it
Scott Leibrand
@scottleibrand
Feb 25 2017 04:09
You should also try invoking the autotune report and see what output it gives.
Sorry the autosens report.
Dana Lewis
@danamlewis
Feb 25 2017 04:10
:+1:
Terri Lyman
@tatigger
Feb 25 2017 04:11
Yes. The autosense file is empty. I manually reentered the ratio and the system deleted it again. I reran the setup script and also verified th CRON
If you are on your phones, that is less than ideal and this is not urgent.
Scott Leibrand
@scottleibrand
Feb 25 2017 04:17
openaps report invoke the json file that is empty.
Terri Lyman
@tatigger
Feb 25 2017 04:19
k
Terri Lyman
@tatigger
Feb 25 2017 04:24

```did I do this correctly?
root@localhost:~/tedi2loop# openaps report invoke autosens.json
usage: openaps-report invoke [-h]
{cgm/cgm-glucose.json,cgm/ns-glucose.json,enact/enacted.json,enact/suggested.json,monitor/battery.json,monitor/cgm-glucose.json,monitor/clock-zoned.json,monitor/clock.json,monitor/iob.json,monitor/meal.json,monitor/mmtune.json,monitor/pumphistory-zoned.json,monitor/pumphistory.json,monitor/reservoir.json,monitor/status.json,monitor/temp_basal.json,raw-cgm/raw-entries.json,settings/autosens.json,settings/basal_profile.json,settings/bg_targets.json,settings/bg_targets_raw.json,settings/carb_ratios.json,settings/insulin_sensitivities.json,settings/insulin_sensitivities_raw.json,settings/model.json,settings/profile.json,settings/pumphistory-24h-zoned.json,settings/pumphistory-24h.json,settings/settings.json,upload/pebble.json,xdrip/glucose.json}
[{cgm/cgm-glucose.json,cgm/ns-glucose.json,enact/enacted.json,enact/suggested.json,monitor/battery.json,monitor/cgm-glucose.json,monitor/clock-zoned.json,monitor/clock.json,monitor/iob.json,monitor/meal.json,monitor/mmtune.json,monitor/pumphistory-zoned.json,monitor/pumphistory.json,monitor/reservoir.json,monitor/status.json,monitor/temp_basal.json,raw-cgm/raw-entries.json,settings/autosens.json,settings/basal_profile.json,settings/bg_targets.json,settings/bg_targets_raw.json,settings/carb_ratios.json,settings/insulin_sensitivities.json,settings/insulin_sensitivities_raw.json,settings/model.json,settings/profile.json,settings/pumphistory-24h-zoned.json,settings/pumphistory-24h.json,settings/settings.json,upload/pebble.json,xdrip/glucose.json} ...]
openaps-report invoke: error: argument report: invalid choice: 'autosens.json' (choose from u'cgm/cgm-glucose.json', u'cgm/ns-glucose.json', u'enact/enacted.json', u'enact/suggested.json', u'monitor/battery.json', u'monitor/cgm-glucose.json', u'monitor/clock-zoned.json', u'monitor/clock.json', u'monitor/iob.json', u'monitor/meal.json', u'monitor/mmtune.json', u'monitor/pumphistory-zoned.json', u'monitor/pumphistory.json', u'monitor/reservoir.json', u'monitor/status.json', u'monitor/temp_basal.json', u'raw-cgm/raw-entries.json', u'settings/autosens.json', u'settings/basal_profile.json', u'settings/bg_targets.json', u'settings/bg_targets_raw.json', u'settings/carb_ratios.json', u'settings/insulin_sensitivities.json', u'settings/insulin_sensitivities_raw.json', u'settings/model.json', u'settings/profile.json', u'settings/pumphistory-24h-zoned.json', u'settings/pumphistory-24h.json', u'settings/settings.json', u'upload/pebble.json', u'xdrip/glucose.json')

```

@scottleibrand
Scott Leibrand
@scottleibrand
Feb 25 2017 04:25
No, settings/autosens.json (it's in that list)
Terri Lyman
@tatigger
Feb 25 2017 04:25
Ah thanks!
root@localhost:~/tedi2loop# openaps report invoke settings/autosens.json
detect-sensitivity://text/shell/settings/autosens.json
-+--+-+-+-++--++-+---+-------------+-----++->>>++--------+------+----------+++-++--++-+++-+-++++++++++++>>>>>>>>>>>>>>>++-+++-----------+++>>>++++---+----+---------+------+--------+++-+------+-+-+-----------+----+-------+------+-----+-+++++--++++-+------------++---+++-+----+--------- 66% of non-meal deviations negative (target 45%-50%)
Excess insulin sensitivity detected: Ratio limited from 0.6753846153846153 to 0.7
ISF adjusted from 65 to 93
reporting settings/autosens.json
Terri Lyman
@tatigger
Feb 25 2017 04:31
And that seems to have "unstuck" it. Hmmmm. Wonky little things, computers.
@Kdisimone , look. ^^
Dana Lewis
@danamlewis
Feb 25 2017 04:34
Wonky indeed. Well done
katie disimone
@Kdisimone
Feb 25 2017 04:36
What does openaps report invoke do btw? (Other than unstick things 😜)
Terri Lyman
@tatigger
Feb 25 2017 04:37
It runs the report that then outputs to the file @Kdisimone
Dana Lewis
@danamlewis
Feb 25 2017 04:37
You're in for some good fundamental doc reading under the old manual instructions ;) re how alias and reports are built and how invoking runs them :smile:
Or accept the simple answer per @tatigger :smile:
Terri Lyman
@tatigger
Feb 25 2017 04:38
Yep. I remember that from when I was trying to build OpenAPS in the beginning. I mean, I remember the idea. I would have to google and backtrack to actually do it. But I have the concept, at least, LOL. After a year Plus. I might be a little slow
katie disimone
@Kdisimone
Feb 25 2017 04:39
I will need the docs. Simple answer is still too hard for me.
Dana Lewis
@danamlewis
Feb 25 2017 04:40
:+1: @tatigger :fire:
Terri Lyman
@tatigger
Feb 25 2017 04:40
LOL, at least we know I don't quit. Stubborn.
Dana Lewis
@danamlewis
Feb 25 2017 04:41
That's all it takes - persistence! :smile:
Terri Lyman
@tatigger
Feb 25 2017 04:42
Sounds so much nicer than bull-headed-ness
Terri Lyman
@tatigger
Feb 25 2017 05:01
And it quit again. What the What? At least it's just auto sense, but right now my sensitivity is more like 92 than 65!
{"carbs":0,"boluses":0,"mealCOB":0}
Optional feature Auto Sensitivity enabled.  Could not find specified auto-sens: settings/autosens.json
[SyntaxError: Unexpected end of input]
Terri Lyman
@tatigger
Feb 25 2017 05:18
Going to bed, I'll play more tomorrow. Thanks Everybody! Just tag me if a magic answer shows up in my absence!
zekeat09
@zekeat09
Feb 25 2017 07:27
Hi, i just started 1 day loop for my son. I can't have my nightscout to display basal change (render basal). Did select “Default” or “Icicle” from the “Render Basal” pull-down menu in the Settings, but nothing happen. Same to basal pill didn't show Temp Basal. Any idea ?
IMG_2971.PNG
Dana Lewis
@danamlewis
Feb 25 2017 07:30
Did you add those things to your variables in azure/heroku?
zekeat09
@zekeat09
Feb 25 2017 07:31
@chrisharris751 I can't solve the problem. So proceed to get a Minilink transmittal for the openaps. Thanks for reply.
zekeat09
@zekeat09
Feb 25 2017 07:55
@danamlewis I did to add "basal"in Enable.
FullSizeRender (2).jpg
Iain
@iainct
Feb 25 2017 09:47
G'day everyone, I have just been setting up some new rigs with the install script which is awesome as I am sure you all know. But i was curious why the openaps pump-loop does not include the glucose.json update (it gets updated during openaps ns-loop for me) ? I have found that on a Rpi3 it tends to run well, but on a PiZero (my out and about rig) and because its doing the xdrip (periodically overwriting the glucose.json with []the loop rarely works. I am going to modify it to work better for my situation but I guess it was set up like that to serve a purpose? cheers
Tim Street
@tim2000s
Feb 25 2017 12:36
Hi @iainct The setup script versions separate out functionality so that various different pieces are run independently. You can always re-add the glucose.json piece back into your pump loop if it works batter that way on the zero.
Iain
@iainct
Feb 25 2017 12:56
thanks @tim2000s the changes I attempted to make really didn't help... I am re-trying the setup, however its not clear if i am getting my bg data from NS is it because i configured it badly...
and which cgm option should i choose? What kind of CGM are you using? (i.e. G4, ShareBLE, G4-raw, G5, MDT, xdrip) i guess it is none of these as they are specifically for offline situations..?
Iain
@iainct
Feb 25 2017 13:04
This message was deleted
Tim Street
@tim2000s
Feb 25 2017 13:57
You can leave that blank.
peterfulvi
@peterfulvi
Feb 25 2017 15:11
Do I need NS enabled to run auto tune in have no files in my settings folder evend though I enabled advanced features
Matthias
@ceben80
Feb 25 2017 15:23

@lukas-ondriga Q to https://github.com/lukas-ondriga/openaps-share

installation of: sudo python pip install flask json

does not work, please advise - thx

root@eddie-eb:~/myopenaps# sudo python pip install flask json
python: can't open file 'pip': [Errno 2] No such file or directory
katie disimone
@Kdisimone
Feb 25 2017 15:51
@peterfulvi are you hoping for a different answer than yesterday? Yes, you need NS data to run autotune. That is how it works. And from the RTD phase 4 autotune troubleshooting directions "Does your Nightscout have data? It definitely needs BG data, but you may also get odd results if you do not have treatment (carb, bolus) data logged."
kenstack
@kenstack
Feb 25 2017 18:05
Does anyone know best practice for shutting down power to wifi on the Edison ? I wanted to see how low I could get the power draw with ble tethering - I did an ifdown wlan0 but saw no drop ... now I could be my crappy multimeter but I doubt it - any ideas ?
Eric
@ecc1
Feb 25 2017 18:09
@kenstack Untested, but I would try rfkill block brcmfmac-wifi and/or rfkill block phy0
Could also try modprobe -r bcm4334x to remove the kernel module, but that might kill Bluetooth too; I think the same Broadcom chip handles both.
Matthias
@ceben80
Feb 25 2017 18:14
Sounds interesting Eric!
kenstack
@kenstack
Feb 25 2017 19:01
@ecc1 thanks I'll try the block wifi - I'm worried that if we are using ble the power draw to the chip is the same idle .... shouldn't be, but so far unless I turn both off I see no change - ill play more tonight though I tried it quickly
Matthias
@ceben80
Feb 25 2017 19:04
Feedback would be great @kenstack
Dana Lewis
@danamlewis
Feb 25 2017 19:25
@ianct what type of CGM are you using?
lukas-ondriga
@lukas-ondriga
Feb 25 2017 19:42
@ceben80 just run as root "pip install flask", I will fix the docs. If you use xDripAPS, you do not need to install anything, it uses the same python modules.
Matthias
@ceben80
Feb 25 2017 19:44
Thx @lukas-ondriga
kenstack
@kenstack
Feb 25 2017 20:14
@ceben80 yes will do by end of the weekend
Iain
@iainct
Feb 25 2017 21:35
@danamlewis currently I am using xdrip, but not direct upload to the pi, i am planning to incrementally work to that, so it goes to my ns site and i grab it from there. I think the piZero is too resource limited to run the standard cron implementation, the pump-loop takes over 5mins to run. cheers
Dana Lewis
@danamlewis
Feb 25 2017 21:54
I would still tell it xdrip then. And yep, the few people who tried Pizero all ditched it.
Iain
@iainct
Feb 25 2017 22:36
Good to know, it's been my most reliable rig for 9 months in my old openaps build, can i order an explorer board to Australia?
Dana Lewis
@danamlewis
Feb 25 2017 22:38
Yes they ship internationally
RosyRed
@RosyRed
Feb 25 2017 22:49
Is this where I ask for help building?
Dana Lewis
@danamlewis
Feb 25 2017 22:50
Yup!
RosyRed
@RosyRed
Feb 25 2017 22:50
I didn't make it far before getting stuck. Here come the many questions
downloaded intel edison driver and putty to my computer
downloaded jubilinix and extracted
not sure what to do from here. I
I have my edison and explorer put together and have my cords ready to go
glenrob1940
@glenrob1940
Feb 25 2017 22:57
RosyRed
@RosyRed
Feb 25 2017 22:57
yes, trying
glenrob1940
@glenrob1940
Feb 25 2017 22:57
carefully means don't skip any steps
Dana Lewis
@danamlewis
Feb 25 2017 22:58
@RosyRed what computer are you using? Mac or PC or ?
RosyRed
@RosyRed
Feb 25 2017 22:58
PC
glenrob1940
@glenrob1940
Feb 25 2017 22:58
Since he said putty it's probably a pc
RosyRed
@RosyRed
Feb 25 2017 22:59
Open a terminal window and navigate to the extracted folder: cd jubilinux. This is your “flash window”, keep it open for later.
I did that step and got "the system cannot find the path specified"
glenrob1940
@glenrob1940
Feb 25 2017 23:01
Where is jubilinux perhaps in Downloads
RosyRed
@RosyRed
Feb 25 2017 23:02
yes, I see it in downloads
glenrob1940
@glenrob1940
Feb 25 2017 23:04
That's where you want to be
RosyRed
@RosyRed
Feb 25 2017 23:05
sorry, not sure what to do next then
glenrob1940
@glenrob1940
Feb 25 2017 23:06
Somebody else jump in here. I'm currently on my mac and need to go fire up windows to get to the point he is at
It will be a bit, I haven't booted windows 10 in a month or so, and it will spend time updating before login
RosyRed
@RosyRed
Feb 25 2017 23:14
ok
glenrob1940
@glenrob1940
Feb 25 2017 23:17
@RosyRed while I'm waiting on windows to boot, do you also have libusb-1.0.dll and dfu_util.exe in the jubilinux directory
PieterGit
@PieterGit
Feb 25 2017 23:19
@glenrob1940 libusb and dfu_util need to be in the same dir. note that your path should not have spaces in it
RosyRed
@RosyRed
Feb 25 2017 23:21
that was listed next so no I have not done that
I just put that line in my browser?
PieterGit
@PieterGit
Feb 25 2017 23:22
no in a command box (use run and type cmd.exe)
RosyRed
@RosyRed
Feb 25 2017 23:23
ok
You will need an additional utility prior to flashing from Windows.
Download DFU-Util.
Extract the two files, libusb-1.0.dll and dfu-util.exe, to the directory where you extracted jublinux.zip.
(you can also extract all files to a separate folder and then copy the files to the jublinux directory)
I think I dont understand this. Am I downloading a file?
sorry guys, thanks for helping