These are chat archives for nightscout/intend-to-bolus

24th
Mar 2017
Dana Lewis
@danamlewis
Mar 24 2017 00:00
@garykidd gotcha. I just don’t do much on the pump at all other than easy bolus for any boluses.
@jcorbett80 not quite. there’s a general readthedocs sphinx theme template we’re using, that doesn’t have any obvious css files embedded on our repo (draws on theirs elsewhere), so we just need to add some css customization to overwrite what’s the default for certain pieces. There’s stuff out there about how to do it, but requires more reading up to understand the sass stuff in the readthedocs sphinx theme to be able to properly customize it. @sarahspins
Dana Lewis
@danamlewis
Mar 24 2017 00:13
yep.
elodaille01
@elodaille01
Mar 24 2017 00:20
@scottleibrand ..what's happening ? :
blob
Scott Leibrand
@scottleibrand
Mar 24 2017 00:25
looks like you hit "y" when you were asked about your radio port during the oref0-setup script
you'll need to re-run that
elodaille01
@elodaille01
Mar 24 2017 00:31
...is that the 'y' here ? (I've hitted nothing during the script..that's strange !!)
blob
(just answer when it was required but no 'hit by error')
Scott Leibrand
@scottleibrand
Mar 24 2017 00:33
yeah, that's a symptom of the same problem. try re-running oref0-setup and you'll probably fix it
or if not you'll be able to see what you did
elodaille01
@elodaille01
Mar 24 2017 00:34
I can't remove it here ?
(in nano)
Scott Leibrand
@scottleibrand
Mar 24 2017 00:36
you need to also replace it with whatever is correct for your hardware. re-running oref0-setup is the easiest way to do that.
elodaille01
@elodaille01
Mar 24 2017 00:36
ok Scott
Martin Haeberli
@mhaeberli
Mar 24 2017 00:42
pros and cons for switching to G5 from G4 ?
in the context of openaps ...
Scott Leibrand
@scottleibrand
Mar 24 2017 00:46
pro: if you have Internet, you don't have to carry a receiver. cons: BG readings can be a bit more flaky; transmitters only last half as long, with a hard cut-off (no getting lucky on battery life)
Martin Haeberli
@mhaeberli
Mar 24 2017 00:46
@scottleibrand :+1: - a bit more flaky? pls elaborate if you are inclined ...
if you don’t have internet, do I understand correctly that still openaps CAN read G5 via bluetooth?
Scott Leibrand
@scottleibrand
Mar 24 2017 00:49
nope. openxshareble works with G4 (more reliably for some people than others), but no one has ported xDripG5 to linux yet
Martin Haeberli
@mhaeberli
Mar 24 2017 00:49
@scottleibrand thx
Scott Leibrand
@scottleibrand
Mar 24 2017 00:50
flaky: more missed readings
also, G5 can't do raw, and you can't do the two receiver trick, so you're stuck with the 2 hour penalty box (no BG readings during sensor warm-up) every week
Martin Haeberli
@mhaeberli
Mar 24 2017 00:51
thx for that explanation re flaky - we experience missed readings here when Transmitter -> Receiver -> iPhone distances temporarily exceeded …
a little birdie just today told me G5 raw is / should be possible… but no concrete “beef” in that statement - I’ll ask it via follow up to pls point me in the right direction ...
Scott Leibrand
@scottleibrand
Mar 24 2017 00:52
that'd be nice. hopefully that would let us loop during warm-up.
Martin Haeberli
@mhaeberli
Mar 24 2017 00:52
:+1:
Scott Leibrand
@scottleibrand
Mar 24 2017 00:53
and by "us" I mean people who've actually switched to G5
katie disimone
@Kdisimone
Mar 24 2017 00:54
@scottleibrand openxshareable…I could play with that on a rig, right? if I disabled the wifi and ran script as openxshareable?
Scott Leibrand
@scottleibrand
Mar 24 2017 00:55
it should work fine with wifi
if you're on the dev branch and choose g4 (or master with g4-raw) it will even upload any BG data it gets from openxshareble to NS
you'll need a second Share receiver that's not paired to a phone
Martin Haeberli
@mhaeberli
Mar 24 2017 00:57
so G5 -> iPhone, G5 -> unpaired Share receiver -> USB -> openAPS instance ?
for example
or unpaired Share receiver -> Bluetooth -> openAPS instance
Scott Leibrand
@scottleibrand
Mar 24 2017 00:59
@mhaeberli no, openxshareble is G4 only
Martin Haeberli
@mhaeberli
Mar 24 2017 00:59
k sorry I’m beginning to crack RTD again ...
katie disimone
@Kdisimone
Mar 24 2017 01:00
I have second share so that’s no problem. is there somewhere to read on what openxshareable is supposed to do if it works correctly? i remember asking about it before, and i apologize i can’t remember the whole discussion now. I thought it was for wireless offline looping on G4, right?
Scott Leibrand
@scottleibrand
Mar 24 2017 01:00
it does that, yes. it also can upload CGM data (including raw) to NS if you're online
katie disimone
@Kdisimone
Mar 24 2017 01:01
raw? i’ve never even seen raw
wow
Scott Leibrand
@scottleibrand
Mar 24 2017 01:01
if you have a plugged-in receiver and oref0 is uploading BG, that also gets your raw
katie disimone
@Kdisimone
Mar 24 2017 01:01
I mean I’ve seen it on others, but we never had android to use it ourselves
omg
Scott Leibrand
@scottleibrand
Mar 24 2017 01:01
you might just need to turn it on in NS
Dana Lewis
@danamlewis
Mar 24 2017 01:02
doesn’t need to be plugged to android
just plugged to a rig
katie disimone
@Kdisimone
Mar 24 2017 01:02
was there any pattern as to who/what/how openxshareable was most/least successful for people?
Dana Lewis
@danamlewis
Mar 24 2017 01:02
no
Scott Leibrand
@scottleibrand
Mar 24 2017 01:03
it might be related to being in a noisy 2.4GHz environment, but that is hard to test
Dana Lewis
@danamlewis
Mar 24 2017 01:03
the only person I know still using it is still using a pre-oref0-setup.sh manual built loop, so no lessons learned transferrable to a modern OpenAPS world.
katie disimone
@Kdisimone
Mar 24 2017 01:04
well, i suppose i’d know pretty fast if it doesn’t work…I’m gonna change out now and give it a whirl
thanks
elodaille01
@elodaille01
Mar 24 2017 01:11
please, why does the oref0 setup not always let us tip 'y' to run cron ? that's so strange !
hit sorry (not 'tip')
katie disimone
@Kdisimone
Mar 24 2017 01:14
mine always asks whether or not to run cron.
elodaille01
@elodaille01
Mar 24 2017 01:14
ok..so..strange !!
Scott Leibrand
@scottleibrand
Mar 24 2017 01:22
@elodaille01 probably because you're hitting enter on something before that where you don't need to
I think some of the Y/N questions just require you to type y or n and don't require an enter
elodaille01
@elodaille01
Mar 24 2017 01:26
ok Scott
thank u
I did it again and again sevreal times but there s no place where I press enter when not required..so..see you later..bye !
Scott Leibrand
@scottleibrand
Mar 24 2017 01:32
in that case, I'll need to see a copy and paste of what exactly it looks like when you can't type Y to run cron.
feel free to paste that in any time. have a good night
elodaille01
@elodaille01
Mar 24 2017 01:36
tonight by instance, there is a long series of retry 0
so..good night..I'm going to have a very short night as usual ;)
Scott Leibrand
@scottleibrand
Mar 24 2017 01:37
feel free to ask questions first thing in the morning too: we're often still up then. :)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:33
@scottleibrand Did you guys change the interface on the OpenAPS Docs?! :D
I think it looks amazing!
Dana Lewis
@danamlewis
Mar 24 2017 02:34
we people did, yes: openaps/docs#732
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:34
One thing though: You don't need an apostrophe (OpenAPS's) as it is redundant.
@danamlewis The template makes the docs look completely different. And it's so much more readable for me, as I have a perceptual visual disability. It is incredibly more readable. Thank you a million times over! :D <3
Dana Lewis
@danamlewis
Mar 24 2017 02:36
:+1:
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:36
:D
That was a huge transition. There's some stuff I really want to work on, as in additions to the docs, but working on getting another rig up right now. But I have been feeling good enough to work on this lately and hoping to keep it up.
Martin Haeberli
@mhaeberli
Mar 24 2017 02:42
@danamlewis @scottleibrand slowly ramping to an RTD review, hopefully a pull request. YMMV / YDMV, but out of curiosity (I’m Mac-based) do you have / use a favorite Markup editor / viewer for review / editing?
Dana Lewis
@danamlewis
Mar 24 2017 02:42
@mhaeberli there’s actually a preview tab in Github that will preview the markdown visualization for you
Martin Haeberli
@mhaeberli
Mar 24 2017 02:43
ok, thx …
Martin Haeberli
@mhaeberli
Mar 24 2017 02:44
:+1:
sarahspins
@sarahspins
Mar 24 2017 02:44
I do agree the "content" of the new docs is so much more readable... but I'm reading up on creating a custom theme to "fix" that sidebar issue ;)
Dana Lewis
@danamlewis
Mar 24 2017 02:44
@sarahspins yay thanks ;)
sarahspins
@sarahspins
Mar 24 2017 02:44
and probably that red text you don't like too :P
Dana Lewis
@danamlewis
Mar 24 2017 02:44
woot
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:45
@sarahspins Thank you. It's a lot of work! <3
sarahspins
@sarahspins
Mar 24 2017 02:45
I actually don't think it will be that bad.... just take the sphynx theme and mod it a bit :)
but I'm also setting up Rig # 3 tonight, so that is occupying most of my efforts ;)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:45
Awesome!
sarahspins
@sarahspins
Mar 24 2017 02:46
(mostly because my sloooooow internet makes it time consuming)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:46
I believe it. It sucks! My sister and her husband live in Africa now, and have sub-56K internet! :P Hahahaha!
OT though, sorry! ;)
sarahspins
@sarahspins
Mar 24 2017 02:48
haha... we use a WISP, so ours is bad when the weather is sucky, and we are currently under a wind advisory - you can SEE the antenna swinging on the mount, I'm actually shocked it's working at all ;)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:48
Wow!
sarahspins
@sarahspins
Mar 24 2017 02:49
yeah... my TV antenna is laying on my roof again :(
Cameron Chunn
@applehat
Mar 24 2017 02:49
Anyone ever run into issues with openaps throwing errors on a dexcom trying to read certain values? For instance, if I do something like openaps use cgm DescribeClocks that works without issue, but openaps use cgm oref0_glucose gives me a dexcom_reader.constants.CrcError: Could not parse EGVRecord.
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:49
:(
@applehat I googled the error. Please see this: https://groups.google.com/forum/#!topic/openaps-dev/WFC54uVpVtg
But yeah, I know the new template is far from perfect, but it totally makes everything about the docs better for me. Everything is easily readable and simple to sort though.
Cameron Chunn
@applehat
Mar 24 2017 02:51
Thanks! I originally found a closed github issue that made it seem like it was fixed.
diabeticgonewild
@diabeticgonewild
Mar 24 2017 02:51
Most importantly, I was able to READ the docs WITHOUT a screenreader...as of now.
@applehat You are welcome. :D
Dana Lewis
@danamlewis
Mar 24 2017 02:56
@sarahspins (btw - when you do your pr can you target dev docs? That way we can test preview on rtd)
sarahspins
@sarahspins
Mar 24 2017 03:01
sure thing :)
Cameron Chunn
@applehat
Mar 24 2017 03:02
@diabeticgonewild - For what its worth, I went back and actually read the github issue and realized I needed to configure the device (openaps use cgm config -5) and now it works =P
sarahspins
@sarahspins
Mar 24 2017 03:11
having trouble getting papertrail working on this one..
root@Rosie:~/myopenaps/remote_syslog# systemctl enable remote_syslog.service
Failed to execute operation: Bad message
is that a problem in one of the files I created maybe?
must have been.. I just redid them and it worked
Scott Leibrand
@scottleibrand
Mar 24 2017 03:22
@applehat glad to see you've already figured out how to follow all the bread crumb trails! :smile:
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:23
@applehat Yeah, I'm really sorry, but I'm not a reader. It's just not my thing. Advanced Google queries on errors, such as this "this is my error" AND "I also have nuts" OR "I may have beans" -"I don't want craziness" site:github.com filetype:pdf -site:*.org gets you a long ways. Basically, what that query means is: "I want to find a certain error and I want to know about nuts or beans, but I don't want craziness, but I want to find something on GitHub.com, that is a PDF file, and I don't want anything from a site ending in *.org' (but you don't need the*.org` stuff since you're only searching on Github.com...I just put that in so you understand the query...)
Cameron Chunn
@applehat
Mar 24 2017 03:23
@scottleibrand slowly. Haha
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:23
Sorry if that was crazy!
Cameron Chunn
@applehat
Mar 24 2017 03:24
@scottleibrand before I jump down another wild goose chase... Contour Next Link USB to talk to Pump... I'm assuming no one has done this yet (and probably wont since explorer boards and all)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:24
@applehat I hope that makes sense! That wasn't a practical example! But advanced google queries really gets you a long ways!!!
Cameron Chunn
@applehat
Mar 24 2017 03:25
@diabeticgonewild yeah it does. I was aware of those options in googling but just didn't use them =P
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:26
Yeah, you Google like crazy on this project, just FYI. Also notice in that query that there is a -site:*.org NOT site:*.org
@applehat Yeah, you do have to go nuts Googling your way through things. You will make idiosyncratic errors in this project. People will help you along the way though, but it's best to do what you can.
Scott Leibrand
@scottleibrand
Mar 24 2017 03:30
@applehat there is a decoding CNL project on github somewhere, but it is unlikely to ever get to where decoding-carelink did, because mmeowlink works so much better.
Cameron Chunn
@applehat
Mar 24 2017 03:30
I figured - just didn't want to not use it if it existed =)
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:30
I searched openaps.readthedocs.io, but is there a way to order Explorer Boards right now?
Cameron Chunn
@applehat
Mar 24 2017 03:31
I'll order an explorer board soon. Right now im just playing with the package on my Linux desktop
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:31
I mean, is there currently a website where I can order one? Because it is not in the docs.
diabeticgonewild
@diabeticgonewild
Mar 24 2017 03:32
I have the old one, and I don't have an xDrip right now. I would kind of like an offline setup on Monday, but it's OK if I don't.
@applehat Thank you! :D
Yeah, offline isn't going to happen on Monday. I couldn't have prevented this situation because I've been sick for the past 6 weeks. Things are turning around though. But got to setup my November EB.
sarahspins
@sarahspins
Mar 24 2017 03:46
I am getting BT set up on rig 3 and I spotted my G5 in the devices :)
[NEW] Device C8:69:CD:86:DE:29 C8-69-CD-86-DE-29
[NEW] Device FA:8F:35:8C:A1:3E DexcomWK
[NEW] Device 07:C7:3B:37:4C:C8 07-C7-3B-37-4C-C8
Cameron Chunn
@applehat
Mar 24 2017 04:23
got openaps to upload my CGM data to nightscout!
....and realized my CGM was set to 04/23/2017 instead of 03/23/2017.
So i have a bunch of weird data now. yay.
Cameron Chunn
@applehat
Mar 24 2017 04:29
Dont suppose there's a way to retroactivly fix the data inside my dexcom - or just delete it.
katie disimone
@Kdisimone
Mar 24 2017 04:47
you can delete future data in NS. Go to the site settings (upper right corner) and choose Admin Tools
Martin Haeberli
@mhaeberli
Mar 24 2017 05:30
setting up Edison - get this error on boot :
[FAILED] Failed to start Hostname Service.
See 'systemctl status systemd-hostnamed.service' for details.
hostname seems to be found fine on the local network ...
katie disimone
@Kdisimone
Mar 24 2017 05:48
That message is a normal message. The mac setup instructions even mention that message can be ignored. Hope that helps
Martin Haeberli
@mhaeberli
Mar 24 2017 06:14
@Kdisimone thx!
Matthias
@ceben80
Mar 24 2017 06:28
@mhaeberli I was annoying about this message too, didn't find a suitable solution, all internet descripted whatever didn't work to start the Hostname Service, anyway, the rig is running fine
Colin Lennon
@colinlennon
Mar 24 2017 09:10
@francesc0-cgm Hi - sorry, not been on here for a week or so but I see you were having problems with xDrip/Android/OpenAPS setup. Did you get it working yet? Let me know if there's anything I might be able to help with.
jcorbett80
@jcorbett80
Mar 24 2017 11:11
@diabeticgonewild if you look at the walk through, hardware, edison, Explorer board the word Explorer Board is another color. That is a link to the site where you can purchase it. https://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-0/hardware/edison.html
diabeticgonewild
@diabeticgonewild
Mar 24 2017 11:38
@jcorbett80 Thanks! 😊👍
jcorbett80
@jcorbett80
Mar 24 2017 11:56
Anytime
francesc0-cgm
@francesc0-cgm
Mar 24 2017 12:36
@colinlennon yes i did. It works without any problem. During the week i came back to loop but this we i will use again it
elodaille01
@elodaille01
Mar 24 2017 13:44
@scottleibrand @Kdisimone please, What do these error messages mean :Could not parse input data: [TypeError: Cannot read property 'date' of undefined]
and : cat: enact/enacted.json: No such file or directory (why is this file missing ??)
(messages received when I ran : openaps refresh-old-pumphistory, then openaps alias show refresh-old-pumphistory, then openaps gather, then openaps enact)
elodaille01
@elodaille01
Mar 24 2017 13:49
thank you very much..if someone else here met the same problem than me..please let me know how you solved it ... ;)
elodaille01
@elodaille01
Mar 24 2017 13:54
ok @Kdisimone I understood for the file missing , thank you
feraridurango
@feraridurango
Mar 24 2017 14:11
~
~
~
~
~
~
~
~
root@gavinaps:~# vi /etc/wpa_supplicant/wpa_supplicant.conf
/etc/wpa_supplicant/wpa_supplicant.conf" 8L, 111C written
root@gavinaps:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 90:b6:86:01:d6:ce
          inet6 addr: fe80::92b6:86ff:fe01:d6ce/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:26017 (25.4 KiB)

root@gavinaps:~# iwgetid -r
root@gavinaps:~# vi /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto usb0
iface usb0 inet static
    address 192.168.2.15
    netmask 255.255.255.0

auto wlan0
"/etc/wpa_supplicant/wpa_supplicant.conf" 69L, 1182C          1,1           Top
does this look right
I go to insert mode but I cant delete lines it just makes the letters capital
elodaille01
@elodaille01
Mar 24 2017 14:15
if I look at my nano /etc/wpa_supplicant/wpa_supplicant.conf, I obtain this :
sorry I don't copy because there are my wifi network name and passwd
only those informations !!
@feraridurango my answer is for you
feraridurango
@feraridurango
Mar 24 2017 14:18
@elodaille01 thank you I am just needed to delete lines and it is not working
elodaille01
@elodaille01
Mar 24 2017 14:18
ok, try with nano instead of vi in your command
that's more easy
feraridurango
@feraridurango
Mar 24 2017 14:18
ok
elodaille01
@elodaille01
Mar 24 2017 14:19
move in the file with the arrows buttons and delete with the ..'delete' button
is that ok @feraridurango ?
garykidd
@garykidd
Mar 24 2017 15:21
understanding you can mouse over OpenAPS pill and see relevqant looping stats but thought a separate pill for IOB and COB might be worth adding...is that hard to do?
feraridurango
@feraridurango
Mar 24 2017 15:21
@elodaille01 I have done this before and it has worked but now for some reason when I press the delete button it it just makes the letters capital
feraridurango
@feraridurango
Mar 24 2017 15:27
i got it now

```root@gavinaps:~# ifup wlan0
ifup: interface wlan0 already configured
root@gavinaps:~# curl -s https://raw.githubusercontent.com/openaps/docs/master/scripts/quick-packages.sh | bash -
root@gavinaps:~# mkdir -p ~/src; cd ~/src && git clone git://github.com/openaps/oref0.git || (cd oref0 && git checkout master && git pull)
Cloning into 'oref0'...
fatal: unable to connect to github.com:
github.com: Name or service not known

-bash: cd: oref0: No such file or directory
root@gavinaps:~/src#
```

feraridurango
@feraridurango
Mar 24 2017 15:32
I have a new flashed Edison and I am trying to do the orefo setup this is what I get
Dana Lewis
@danamlewis
Mar 24 2017 15:32
rig online?
feraridurango
@feraridurango
Mar 24 2017 15:33
ok that must be the problem
Benjamin Mammon
@bmammon
Mar 24 2017 15:37

Hello! I'm trying to crate a cron job that runs 0ref-reset-usb when my carelink gets into an unresponsive state. I know it's not ideal to use the carelink but it's all i have right now.

This is what i've added to my crontab:

* * cd /home/pi/myopenaps && rm -f monitor/clock.json && openaps report invoke monitor/clock.json 2>/dev/null && grep -q T monitor/clock.json && echo PREFLIGHT OK || (mm-stick warmup || (sudo oref0-reset-usb && echo PREFLIGHT SLEEP && sleep 120); echo PREFLIGHT FAIL; exit 1)

but I don't think it's working since I woke up this morning to a bunch of these

Starting pump-loop at Fri 24 Mar 08:09:31 PDT 2017:
monitor/temp_basal.json  raised  ACK is 0 bytes:

pump://JSON/read_temp_basal/monitor/temp_basal.json
Traceback (most recent call last):
  File "/usr/local/bin/openaps-report", line 82, in <module>
    app( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 51, in __call__
    self.run(self.args)
  File "/usr/local/bin/openaps-report", line 75, in run
    output = app(args, self)
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in __call__
    return self.method.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
    output = task.method(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 44, in __call__
    self.before_main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", line 62, in before_main
    self.setup_medtronic( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", line 161, in setup_medtronic
    self.uart.open( )
  File "/usr/local/lib/python2.7/dist-packages/decocare/stick.py", line 874, in open
    log.info('%s' % self.product_info( ))
  File "/usr/local/lib/python2.7/dist-packages/decocare/stick.py", line 515, in product_info
    return self.query(ProductInfo)
  File "/usr/local/lib/python2.7/dist-packages/decocare/stick.py", line 509, in query
    return self.process( )
  File "/usr/local/lib/python2.7/dist-packages/decocare/stick.py", line 496, in process
    ack, response = self.command.respond(raw)
  File "/usr/local/lib/python2.7/dist-packages/decocare/stick.py", line 71, in respond
    raise AckError("ACK is 0 bytes:\n%s" % lib.hexdump(raw))
decocare.errors.AckError: ACK is 0 bytes:

Relevant websites: http://openaps.readthedocs.io/en/latest/docs/Resources/troubleshooting.html#dealing-with-the-carelink-usb-stick
https://openaps.readthedocs.io/en/2016-10-02/docs/walkthrough/phase-2/building-preflight-safety-checks.html

Thank you in advance for any advice/help,
Ben

katie disimone
@Kdisimone
Mar 24 2017 16:57
@garykidd that already exists in Nightscout. Just add iob and cob to your enable line. However, the cob pill is pretty unreliable in its current state so I don't recommend using. The iob pill works fine
Scott Leibrand
@scottleibrand
Mar 24 2017 17:07
@bmammon if you can't figure out the logic and only need it temporarily, maybe just schedule an oref0-reset-usb (or even a reboot) every few hours in cron?
Martin Haeberli
@mhaeberli
Mar 24 2017 17:21
@ceben80 :+1:
elodaille01
@elodaille01
Mar 24 2017 17:32
hello @scottleibrand ..first question : did you see my previous message ? 'What do these error messages mean :Could not parse input data: [TypeError: Cannot read property 'date' of undefined'
sorry..I just retype it here ;)
and second one, what name is it about in your doc Alternate Nightscout OpenAPS Instructions ? -> 'nano bewest-aliases.json and make sure that the script references the report names that you created. If not, change the report names to the names that you set up.'
thanks a lot
Scott Leibrand
@scottleibrand
Mar 24 2017 17:36
I have no idea what doc references a bewest-aliases, but I don't think that is one you want to be following. That's probably an old doc from back before oref0-setup existed. bewest is Ben West.
I don't know where in the logs that 'date' of undefined message is showing up, so not sure what that would be. I'd need more context there.
feraridurango
@feraridurango
Mar 24 2017 18:05
root@gavinaps:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 90:b6:86:01:d6:ce
          inet6 addr: fe80::92b6:86ff:fe01:d6ce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:8145 (7.9 KiB)
does this say I'm connected?
Dana Lewis
@danamlewis
Mar 24 2017 18:15
Easiest way to check imo is to ping google.com
garykidd
@garykidd
Mar 24 2017 18:27
@Kdisimone arent those pill for IOB and COB different than what OpenAPS are using? seems as so.
Dana Lewis
@danamlewis
Mar 24 2017 18:28
cOB is supposed to pull OpenAPS when it has it but reverts to static NS if it has trouble. Thus, confusion. Don't recommend cob pill separately; use OpenAPS pill or logs for cob.
katie disimone
@Kdisimone
Mar 24 2017 18:29
In December they changed it so that those pills display looping info rather than NS based info. ^^^and then @danamlewis types faster 👍🏻 ^^^that
Dana Lewis
@danamlewis
Mar 24 2017 18:30
#lotsofpractice
garykidd
@garykidd
Mar 24 2017 18:30
currently OpenAPS is showing 14....my COB pill is showing 41....
garykidd
@garykidd
Mar 24 2017 18:31
Still a an accurate COB and IOB pill (that matched OpenAPS exactly) would be helpful to glance at quickly IMO.
Dana Lewis
@danamlewis
Mar 24 2017 18:31
We need more people to help on NS development to see any changes there - too few hands on that side.
garykidd
@garykidd
Mar 24 2017 18:37
understood...I'm just thinkiing about what might be cool/useful...wasnt really thinking about all the work involved (not yet anyway). No shortage of ideas. hard work....often different story. But this entire community rocks.
Dana Lewis
@danamlewis
Mar 24 2017 18:42
:+1:
garykidd
@garykidd
Mar 24 2017 18:45
@scottleibrand thinking it may be a lingering effect of whatever was plaguing me up until yesterday evening....but my heroku site initially reports PUMP and OpenAPS pills perfectly...withing a few second, however, they change to reflect OpenAPS 'unknown' and PUMP goes blank with a mouse-over revealing: 'undefined' Seems like another process cold be alternatively reporting it (or reporting without the right info). Any initial thoughts?
Dana Lewis
@danamlewis
Mar 24 2017 18:47
Ah - someone will probably suggest clearing out device status but please don't if you can wait and help provide some diagnostics so we can figure out what's causing it.
garykidd
@garykidd
Mar 24 2017 18:47
actually...same deal for edison battery.....
Dana Lewis
@danamlewis
Mar 24 2017 18:47
Taking off on a plane so I can't do detailed but hope we can get some info to drill down on
Also - do you have cob enabled in your variables (even if you're not displaying that pill)?
garykidd
@garykidd
Mar 24 2017 18:48
Sounds good. and if there's a small chance this can help anyone else---I am happy to try to help in whatever way I can.
I do have COB enabled and am displaying it in pill (may remove based on our recent conv. though soon)
sarahspins
@sarahspins
Mar 24 2017 18:49
@garykidd I've been experiencing the same with my NS site.. I don't have COB enabled though
it will go to unknown even though you can hover on the pill and see what it's doing
Screen Shot 2017-03-23 at 3.53.46 PM.png
then it will update itself and be all good again..
Screen Shot 2017-03-23 at 3.54.08 PM.png
for now I've decided not to worry too much about it... because it is "working" it's more that it's just being stupid about it :)
though it occurs to me just now, that it may also be an issue with multiple rigs connecting....
garykidd
@garykidd
Mar 24 2017 18:52
right...exactly....and it seems to cycle through...back and forth...back and forth....and if you're showing OpenAPS prediction plotting...that cycles through as well.
Dana Lewis
@danamlewis
Mar 24 2017 18:52
It shouldn't be @sarahspins ..but not sure what's causing it. Help investigating is welcome
Benjamin Mammon
@bmammon
Mar 24 2017 18:53

@scottleibrand i'm also using a wifi adapter so would prefer not to reset usb unless I have to. When I run

cd /home/pi/myopenaps && rm -f monitor/clock.json && openaps report invoke monitor/clock.json 2>/dev/null && grep -q T monitor/clock.json && echo PREFLIGHT OK || (mm-stick warmup || (sudo oref0-reset-usb && echo PREFLIGHT SLEEP && sleep 120); echo PREFLIGHT FAIL; exit 1)

I get a message saying PREFLIGHT FAIL or PREFLIGHT OK but when it's in the crontab, I don't see that message appear when I tail the logs.

sarahspins
@sarahspins
Mar 24 2017 18:53
it seems like at some point in the "upload" process, some info might be updated but not other info, and it freaks out for a minute?
garykidd
@garykidd
Mar 24 2017 18:53
I can confirm the exact issue.
as @sarahspins
sarahspins
@sarahspins
Mar 24 2017 18:53
and yes, the prediction blips off when it does this
Scott Leibrand
@scottleibrand
Mar 24 2017 18:58
do y'all have devicestatus_advanced set to true?
@bmammon maybe your crontab is missing the PATH definition?
sarahspins
@sarahspins
Mar 24 2017 19:15
@scottleibrand I believe I do but I can double check
aha, that might be it... I set up heroku 3 different times a few days ago (long story, reasons not important) and apparently missed that on the one I am currently using
too many config variables... it would be nice if we could just save a backup of what is working and import that when setting up another one
sarahspins @sarahspins waits for someone to say that is possible
Cameron Chunn
@applehat
Mar 24 2017 19:20

It took my coworker about 10 minutes after me showing him my NightScout instance for a slack bot to appear in our company chat that reports my blood sugar any time it hears the word cake in our #food channel.

This is the future. =P

sarahspins
@sarahspins
Mar 24 2017 19:20
Amusingly now I can also see when my other rigs were last online in the status :)
@applehat that's awesome!
Dana Lewis
@danamlewis
Mar 24 2017 19:21
@sarahspins NS docs in general could use some love if there’s a more simplified (there is) set of steps that would smooth that setup
jcorbett80
@jcorbett80
Mar 24 2017 19:21
My Explorer board had a meltdown but while working there was a 1 minute lag at all times due to me using my phone as a wifi hotspot and a closed system because I have a slot of areas without data or wifi. I do not have a reciever connected. However after the 1 minute lag all was updated at the same time. So yes on the phone it showed 1 minute sooner but was still same time between each. NS was 1 minute later but showed all and was still same time gap between each update. I had to go through every single step to make all work properly. This meant everything required for setup on ns. I already had ns but had to change settings for openaps. There were multiple phases I did detailed reading in the docs to make sure I did all. Sometimes I found stuff that made me have to start over and do it correctly again. I used the dev. Not the master just to give all data. So I know it can happen. But it does take very very very in depth study. And it is most definitely well worth it. I don't know if missing a step is a lot of the issues or not. But for me it does seem to work very well. And I know it can. I wonder if some of this with NS could be data loss on slow Internet or bluetooth tethering transferring to slower phone using data upload. All just a thought for all to look at. No accusations meant. Just my background says if it works for a lot then if it doesn't work for all there is typically a common 1 or two issues that affect all of those that have an issue with something. Again this is just to give people something to bounce around in hopes it helps. As most of you know I have a big mouth and I really hate not to use what the Good Lord gave me. :)
Dana Lewis
@danamlewis
Mar 24 2017 19:21
I think much of @Kdisimone NS docs over in Loop can get moved over with some minor changes
#needmoretimeintheday
sarahspins
@sarahspins
Mar 24 2017 19:21
well, the hard part is that the automated setup asks for a lot of variables, but not all of the ones I'm using, so I have to go in and add the missing ones
Benjamin Mammon
@bmammon
Mar 24 2017 19:22
@scottleibrand I think that's it! How do I add the PATH definition?
sarahspins
@sarahspins
Mar 24 2017 19:22
and apparently forgot an important one!
sarahspins
@sarahspins
Mar 24 2017 19:27
@garykidd did setting devicestatus_advanced to true fix yours too?
Matt Pressnall
@logichammer
Mar 24 2017 19:27

I feel like I'm about to re-invent the wheel here so please stop me if this has already been done / the best way possibly to do this so it could worked into OpenAPS potentially. I want to set up a few more alerts for myself around:
-- battery low, send me a pushover / text / email because now that I have almost everything on my watch, I don't check NS that often
-- double arrows up at x BG (but not yet at a warning level)...I want to be more responsive to sudden spikes...Pushover, text, email or something
-- (the inverse) double arrows down at x BG, alert me

Also, thanks for the help, @danamlewis and @scottleibrand , tracking down code / slides...people loved the presentation...one person told me it was the greatest presentation they had ever seen so that was pretty nice! :)

Dana Lewis
@danamlewis
Mar 24 2017 19:30
pushover and NS is your friend
:+1: glad it went well!
Matt Pressnall
@logichammer
Mar 24 2017 19:32
Yes, I was just about to say I have been perusing:
http://www.nightscout.info/wiki/labs/pushover-in-funnel-cake
but I'm not sure it addresses the specific areas I am looking for...although, I have to get pushover working and then can verify:
the battery warning
the other two use cases are probably custom enough for me to just one off them
Dana Lewis
@danamlewis
Mar 24 2017 19:40
tick of the next “Dana is predictable” on the bingo card - will you write up what you do for those types of alerts? I think a lot of folks are interested in that, so noting it so we can add to the docs is :+1: to simplify for the next person/people..thanks as always for the willingness to do so :)
Matt Pressnall
@logichammer
Mar 24 2017 19:45
You bet...where / how should I submit them? Not part of the typical documentation...I don't see a "Feature request" area. Also, love the look of the new documentation!
@danamlewis , above is for you...
Dana Lewis
@danamlewis
Mar 24 2017 19:46
We’d probably add a section to bottom of NS page perhaps? (in visualizing/monitoring)
:+1:
Matt Pressnall
@logichammer
Mar 24 2017 19:46
Got it...will start there, then...
Dana Lewis
@danamlewis
Mar 24 2017 19:47
:clap: we can always move around but that’s a good place to target for now. thanks!
Matt Pressnall
@logichammer
Mar 24 2017 19:47
You bet!
dan lightner
@danimaniac
Mar 24 2017 20:00
@colinlennon private message sent.
Arlene Samowich
@webwiztn
Mar 24 2017 21:29
My new boards arrived and they are working. I am working through the flashing steps on my MAC but I am at an impasse. Step 1-6 asks to return to the original Terminal window and type 'reboot'. When I did that, I received the message 'Operation not permitted'. What's up?
sarahspins
@sarahspins
Mar 24 2017 22:04
@webwiztn can you copy and paste what you see?
you might not be in the "right" window
or it may not be in screen
katie disimone
@Kdisimone
Mar 24 2017 22:07
I 100% commit to doing a PR for NS for OpenAPS. Including pushover.
sarahspins
@sarahspins
Mar 24 2017 22:07
or maybe you might not have logged in as root - that part is easy to overlook
Dana Lewis
@danamlewis
Mar 24 2017 22:08
@Kdisimone :sparkles:
Arlene Samowich
@webwiztn
Mar 24 2017 22:21
@sarahspins
sarahspins
@sarahspins
Mar 24 2017 22:21
got it working?
Arlene Samowich
@webwiztn
Mar 24 2017 22:23
edison login: root
root@edison:~# Arlenes-MacBook-Air:~ arlenesamowich$ -bash: reboot: command not found
Arlenes-MacBook-Air:~ arlenesamowich$ reboot: Operation not permitted
Scott Leibrand
@scottleibrand
Mar 24 2017 22:24
@webwiztn are you trying to reboot your mac?
it looks like you logged out of the edison
Arlene Samowich
@webwiztn
Mar 24 2017 22:25
Not rebooting MAC. How do I go back in to Edison?
...log back into Edison!
sarahspins
@sarahspins
Mar 24 2017 22:27
go back to 1-4 and follow :)
@Kdisimone I don't think she's that far yet.. she was getting ready to flash
katie disimone
@Kdisimone
Mar 24 2017 22:27
Oh true. Good point
Use sudo screen command in that setup edison section
sarahspins
@sarahspins
Mar 24 2017 22:28
if you can't get screen to work, don't worry you didn't break anything, you can do as suggested and swap the USB cables as they are plugged into your mac, or you can reboot - that has always fixed it for me
you won't need to start over if you reboot your mac, or repeat everything in step 1-5
Arlene Samowich
@webwiztn
Mar 24 2017 22:29
After supper, I'll go back to 1-4. Thanks all!