These are chat archives for nightscout/intend-to-bolus

29th
Mar 2017
Kate Farnsworth
@ELUTE
Mar 29 2017 00:43
Has anyone gotten a pre-flashed edison from HamShield and the password doesn't work?
Dana Lewis
@danamlewis
Mar 29 2017 00:43
Elliott was saying something about it being capitalized or not
So if they said Edison try edison or vice versa?
Kate Farnsworth
@ELUTE
Mar 29 2017 00:44
tried both
Dana Lewis
@danamlewis
Mar 29 2017 00:45
Hm. Not sure then - that's the only thing I heard as a potential problem. Go ahead and email them then?
Kate Farnsworth
@ELUTE
Mar 29 2017 00:46
Done. Just frustrating to pay more to have it not work.
Dana Lewis
@danamlewis
Mar 29 2017 00:46
:+1:
Paul Dickens
@thebookins
Mar 29 2017 00:46
We set up ours last night. The bit of paper said root/Edison but we got an email saying it was root/edison. root/edison worked.
Kate Farnsworth
@ELUTE
Mar 29 2017 00:46
thanks
neither one works
Paul Dickens
@thebookins
Mar 29 2017 00:50
that's annoying
Kate Farnsworth
@ELUTE
Mar 29 2017 00:50
Yeah especially since I could flash it in the time it takes them to respond
or wait till they do
and waste time
grrr
Kate Farnsworth
@ELUTE
Mar 29 2017 01:06
It was my issue
kids and keyboard.. UGH
Dana Lewis
@danamlewis
Mar 29 2017 01:07
? Caps lock?
Glad it resolved regardless !
Paul Dickens
@thebookins
Mar 29 2017 01:08
:smile: we got stuck for a few minutes entering 'edison' for the password after the sudo screen tty... command. Until I realised it was asking for the Mac password.
In my defense it was late.
Rick Warren
@riwarren
Mar 29 2017 02:55
Is it possible to double up on 2000mAh batteries for longer battery life? like wire them in series to get 4000mAh?
Scott Leibrand
@scottleibrand
Mar 29 2017 02:55
no, you can't wire them in series, that will give you 8v and likely damage any board you plug them into
Rick Warren
@riwarren
Mar 29 2017 02:56
@scottleibrand I think you're mistaken. you would have to wire them in parrallel to get 8V from them
wire something in series and the Voltage stays the same, but the mAh increases
j4cbo
@j4cbo
Mar 29 2017 02:56
@riwarren no
Scott Leibrand
@scottleibrand
Mar 29 2017 02:56
series = + of one battery to - of the other, so the voltages add up
Rick Warren
@riwarren
Mar 29 2017 02:56
really?
okay could I wire them in parrallel then?
Scott Leibrand
@scottleibrand
Mar 29 2017 02:57
I wouldn't wire them in parallel either unless you have done the electrical engineering to verify it's safe. if one of them has a different charge, wear, or capacity level than the other, you can damage the batteries or even create a fire hazard
Rick Warren
@riwarren
Mar 29 2017 02:57
parallel*
Scott Leibrand
@scottleibrand
Mar 29 2017 02:57
much easier and safer to just buy a bigger battery
Rick Warren
@riwarren
Mar 29 2017 02:57
the places openaps recommends for safe batteries doesn't have bigger batteries
Scott Leibrand
@scottleibrand
Mar 29 2017 02:58
lots of people have found 2500 mAh ones, although not many people have made cases sized for those
and there are some bigger Li-Ion ones
Rick Warren
@riwarren
Mar 29 2017 02:58

@scottleibrand how would I go about testing those new commits you wanted tested?

and does anyone want to walk me through how to get the firmware off of my old medtronic 522?

Dana Lewis
@danamlewis
Mar 29 2017 02:58
You can't get firmware off a pump
Scott Leibrand
@scottleibrand
Mar 29 2017 02:58
@riwarren which commits are you referring to? I've made a few recently :)
Dana Lewis
@danamlewis
Mar 29 2017 02:58
(No one has proved it's possible yet, at least)
Rick Warren
@riwarren
Mar 29 2017 02:58
@danamlewis someone in here claimed otherwise yesterday
j4cbo
@j4cbo
Mar 29 2017 02:58
i imagine you'd need a PICkit or similar... and possibly nitric acid
Scott Leibrand
@scottleibrand
Mar 29 2017 02:59
it might be possible to pull the firmware off a pump, but no one has done so publicly yet. we don't believe it would be as easy to write old firmware to a newer pump, though
Rick Warren
@riwarren
Mar 29 2017 02:59
why is it so difficult to do? these pumps are using patents from 1999....they're not newage technology
Dana Lewis
@danamlewis
Mar 29 2017 02:59
@riwarren I think they were suggesting using a broken pump for researching
Scott Leibrand
@scottleibrand
Mar 29 2017 02:59
no one has considered it worth the trouble to date, since 522s are still fairly available
Rick Warren
@riwarren
Mar 29 2017 02:59
@danamlewis I have a 522 that is taken apart into little pieces
Dana Lewis
@danamlewis
Mar 29 2017 03:00
If you figure it out, you'll have a lot of fans :smile:
j4cbo
@j4cbo
Mar 29 2017 03:00
if the code isn't protected it would be easy. if the code is protected, it would require extreme specialist equipment
Scott Leibrand
@scottleibrand
Mar 29 2017 03:00
the hard-core reverse engineering talent is being focused on the Omnipod right now: there's a 5-figure bounty on that
Dana Lewis
@danamlewis
Mar 29 2017 03:00
Ya - use it for research if you can, but there's no known method
Rick Warren
@riwarren
Mar 29 2017 03:00
@j4cbo medtronic isn't exactly known for their encryption tactics
j4cbo
@j4cbo
Mar 29 2017 03:00
i'm not sure what the point of reverse-engineering it would be
Scott Leibrand
@scottleibrand
Mar 29 2017 03:01
by all means, give it a try if you think you know how. but if you don't, you'll need to find someone who does, and who wants to spend all the time and effort on it
j4cbo
@j4cbo
Mar 29 2017 03:01
aiui the protocol is pretty well understood?
Dana Lewis
@danamlewis
Mar 29 2017 03:01
Firmware itself is not.
j4cbo
@j4cbo
Mar 29 2017 03:01
but what would that get us?
Dana Lewis
@danamlewis
Mar 29 2017 03:01
That's the problem. But if someone finds a way to do it, would enable us to take nonloopable pump and turn it into a loopable pump.
Scott Leibrand
@scottleibrand
Mar 29 2017 03:01
if we can't flash it to newer pumps, it'd mostly be an academic exercise
Dana Lewis
@danamlewis
Mar 29 2017 03:02
:+1:
Scott Leibrand
@scottleibrand
Mar 29 2017 03:02
if we can, then that would open up the supply of used pumps quite a lot
j4cbo
@j4cbo
Mar 29 2017 03:02
ah, that's a good point
Rick Warren
@riwarren
Mar 29 2017 03:02

@scottleibrand well I took mine apart for that very purpose, with the intent of enginnering something far better that isn't from 1999.

@j4cbo if you reverse engineer it you can further engineer it at that point

Dana Lewis
@danamlewis
Mar 29 2017 03:02
@riwarren as/If you explore, please do document what you find so others can leverage your work in the future.
Rick Warren
@riwarren
Mar 29 2017 03:02
@scottleibrand why would anyone want to run older firmware on newer pumps? oooooooo to flash ones that aren't compatible with openaps?
j4cbo
@j4cbo
Mar 29 2017 03:03
firmware downgrades would be great, i have a nice MMT-551 sitting on the shelf...
Rick Warren
@riwarren
Mar 29 2017 03:03
@danamlewis I have every intent on doing so
Scott Leibrand
@scottleibrand
Mar 29 2017 03:03
yeah, if you want to take that on as your project, go for it. but at this point there are a lot more things we want to do than time and people to do them, so we're making prioritization decisions on what to spend time and effort on
Dana Lewis
@danamlewis
Mar 29 2017 03:03
Yes. Not known to be possible but we would all love to see it happen
:+1:
j4cbo
@j4cbo
Mar 29 2017 03:03
riwarren: find the in-system-programming pins, stick a bus pirate on it
Scott Leibrand
@scottleibrand
Mar 29 2017 03:03
@riwarren yes, flashing 523s back to openaps-compatible firmware would be the main goal
Rick Warren
@riwarren
Mar 29 2017 03:03
@scottleibrand in the mean time, can I test out these new commits for you?
Scott Leibrand
@scottleibrand
Mar 29 2017 03:03
@riwarren sure, which ones are you thinking of?
the devww stuff?
Rick Warren
@riwarren
Mar 29 2017 03:04
yeah
I'm using NA now, but my pump was working with WW for an entire day before that
so I think CA pump can do both?
Scott Leibrand
@scottleibrand
Mar 29 2017 03:05
the PR for it is openaps/oref0#357
j4cbo @j4cbo needs to go buy an ubertooth and make progress on the G5 stuff
Scott Leibrand
@scottleibrand
Mar 29 2017 03:05
no, your pump either does 868MHz or 916MHz comms
Rick Warren
@riwarren
Mar 29 2017 03:05
its done both
Scott Leibrand
@scottleibrand
Mar 29 2017 03:05
it might be possible to communicate, extremely poorly, if you're misconfigured, but not at any distance
j4cbo
@j4cbo
Mar 29 2017 03:05
what's the state of understanding of the omnipod? are there any publicly-released teardowns?
Scott Leibrand
@scottleibrand
Mar 29 2017 03:05
what frequency did mmtune pick?
@j4cbo there's an entire slack group for that
Rick Warren
@riwarren
Mar 29 2017 03:05
I was doing 865 at 3ft
j4cbo
@j4cbo
Mar 29 2017 03:05
(i'm just curious, i don't expect i'd be able to contribute much to the effort)
@scottleibrand link?
Rick Warren
@riwarren
Mar 29 2017 03:06
and now I"m doing 916
@riwarren interesting. I do know that the pump antennas are really wide-band
didn't think it'd be that wide, though
Rick Warren
@riwarren
Mar 29 2017 03:06
it didn't work consistently though
was very finnicky
thought openaps was just really finicky for an entire 2 days
lol
Scott Leibrand
@scottleibrand
Mar 29 2017 03:07
might be interesting to reconfigure your mmtune to scan the entire frequency range from 850 up to 920, if you're interested. :)
but sounds like it's better at 916?
Rick Warren
@riwarren
Mar 29 2017 03:07
far better
I've been using it all day. I've got my explorer board and batter inside the cardboard packaging the battery came in aha working well
Sure I'd be up for that.
Scott Leibrand
@scottleibrand
Mar 29 2017 03:09
you'd need to take a peek at the mmtune code I think
I did it with the old ruby mmtune, but don't recall how to reconfigure the python one
Rick Warren
@riwarren
Mar 29 2017 03:09
I'm a senior developer by day. in fact, if theres a queue of tickets I could take a stab at I'd be glad to help
Scott Leibrand
@scottleibrand
Mar 29 2017 03:09
nice, glad to have your help. :)
https://github.com/openaps/oref0/issues is the list, but it's not all that organized yet
we did at least tag some stuff with Help Wanted though
Rick Warren
@riwarren
Mar 29 2017 03:10
haven't worked with python in a while, but there was a time back in the day when I rewrote gentoo's portage system in python
Scott Leibrand
@scottleibrand
Mar 29 2017 03:10
Rick Warren
@riwarren
Mar 29 2017 03:15

I think I can handle a number of the autotune ones. at the very least the one for better input checking and error messages.

though I need some questions answered so I can get nightscout set up

when I set up nightscout it wants a device secret in order to set up the profile. but nowhere in any of the docs does it say where to obtain that from?
j4cbo
@j4cbo
Mar 29 2017 03:15
you generate that, and give it to both openaps and nightscout
Rick Warren
@riwarren
Mar 29 2017 03:16
oh its whatever I want it to be?
j4cbo
@j4cbo
Mar 29 2017 03:17
yep. (someone correct me if i'm wrong :P)
Scott Leibrand
@scottleibrand
Mar 29 2017 03:20
it has to be long (like at least 12 characters I think). details on that are over in the nightscout docs
Rick Warren
@riwarren
Mar 29 2017 03:21
k so base64 a random string
thanks
Scott Leibrand
@scottleibrand
Mar 29 2017 03:21
it does another hash on your input passphrase
so better to give it something you can type into your phone
Rick Warren
@riwarren
Mar 29 2017 03:22
k thanks
katie disimone
@Kdisimone
Mar 29 2017 03:29
@riwarren and don’t use @ in the 12 characters.
Rick Warren
@riwarren
Mar 29 2017 03:34
What do I put for DIA? Duration of Insulin Activity?
Dana Lewis
@danamlewis
Mar 29 2017 03:35
What's in your pump that you've been using for DIA? @riwarren these should all be same as your pump.
Rick Warren
@riwarren
Mar 29 2017 03:36
Apidra
I think I have apidra set for 4 hours. but the default in nightscout was 3 so I thought I should ask
Scott Leibrand
@scottleibrand
Mar 29 2017 03:37
Those are the two most common values people select.
Rick Warren
@riwarren
Mar 29 2017 03:37
okay, any opinions on what I should set it to? 3 or 4? I know apidra works faster than Novorapid but I didn't think it was done its course in 3 hours
Dana Lewis
@danamlewis
Mar 29 2017 03:40
You need to do what works for you and your body - we can't tell you what that is. You can try one and if it's not working try the other.
Once you start running OpenAPS, and get everything else nailed down, dia becomes easier to fine tune
Scott Leibrand
@scottleibrand
Mar 29 2017 03:40
for closed looping it doesn't really matter if the insulin activity is totally gone by the DIA. the insulin activity curve we use goes linearly from zero to a peak at 75m for a 3h DIA, and then linearly down to zero again at DIA. different DIAs scale the peak time accordingly
so if you want to do some tests on yourself, where you get your basals well tuned, eat enough to get you to 150, and then bolus to bring you back down to 100 or so, you can see how long that takes. you might want to use autotune to tune your basals, ISF, and CR first, though.
Rick Warren
@riwarren
Mar 29 2017 04:08
I am going to try out autotune thanks !
I haven't touched any of my pump settings since last time I saw my endo 5 years ago
its likely not correct
sysyc
@sysyc
Mar 29 2017 08:26
Old pumphistory:
Error, retrying
Starting pump-loop at Wed 29 Mar 16:04:14 CST 2017:
pump://JSON/read_temp_basal/monitor/temp_basal.json
reporting monitor/temp_basal.json
Old pumphistory:
Error, retrying
Starting pump-loop at Wed 29 Mar 16:04:24 CST 2017:
pump://JSON/read_temp_basal/monitor/temp_basal.json
reporting monitor/temp_basal.json
Old pumphistory:
My log display above,what's wrong?
elodaille01
@elodaille01
Mar 29 2017 09:17
hello everybody here ! I've succeeded yesterday evening in configuring the offline looping ..tests were ok (wifi -> bluetooth-> wifi)
but this morning, when I went back to house wiki network, OpenAPS did not loop anymore
any suggestion to fix this ?
elodaille01
@elodaille01
Mar 29 2017 09:27
furthermore, NS has much more difficulty retrieving data from the CGM
@sysyc did you enter all values in the pump ?
@ceben80 Mister n=36, could you help me please..I don't know what actions I shloud have to undertake
elodaille01
@elodaille01
Mar 29 2017 10:06
ok...Edison does not connect to BT when I switch off wifi again .. basically: it does not want to know anything !!
David Rimmer
@zjedr
Mar 29 2017 10:12
all bg values in json files extracted from my pump (eg pumphistory.json) seem to be multiplying the mmol value * 10 rather than 18 , it has entries like "bg_target_high": 50 ( should be 5.0 mmol or 90 mg/dl) and "bg": 57 ( should be 5.7 mmol or 103 mg/dl). This is causing unexpected results in the NS wizards that use these value. Where are the mmol values converted to mg/dl?
elodaille01
@elodaille01
Mar 29 2017 10:19
so...@ceben80..it's working again with wifi...but..It's laborious !! after all this time !!
samihusseingit
@samihusseingit
Mar 29 2017 11:17
is MA better to use in the case of day care not entering carb information??
or still stick with AMA eventhough there is no carb inpupt?
JoernL
@JoernL
Mar 29 2017 11:29
@scottleibrand , now my loop startup goes ahead but stopped at the check settings here: pump://JSON/read_settings/settings/settings.json
settings/settings.json raised
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
output = task.method(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in call
output = self.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", line 334, in main
return getattr(self.pump.model, name)(**self.get_params(args))
File "/usr/local/lib/python2.7/dist-packages/decocare/models/init.py", line 26, in call
self.validate( )
File "/usr/local/lib/python2.7/dist-packages/decocare/models/init.py", line 18, in validate
self.response.check_output(data)
File "/usr/local/lib/python2.7/dist-packages/decocare/commands.py", line 126, in check_output
return self.checker(data)
File "/usr/local/lib/python2.7/dist-packages/decocare/commands.py", line 78, in call
self.check_fields(data)
File "/usr/local/lib/python2.7/dist-packages/decocare/commands.py", line 75, in check_fields
raise BadResponse( )
decocare.commands.BadResponse
Error, retrying
Any hints about the decocare bad response?
Scott Leibrand
@scottleibrand
Mar 29 2017 11:31
The main difference with the 512 is the inability to pull certain settings. You have to manually create those files and edit get-settings not to try to pull them. Details on that should be in the docs, but you'll need to adapt them to modify the aliases that oref0-setup has already set up.
jcorbett80
@jcorbett80
Mar 29 2017 12:09
@Kdisimone @scottleibrand does this link muddy the water too much? or simple enough. It includes the zip file instead of the tar file in the list. http://dfu-util.sourceforge.net/releases/ If after you look at it, it seems ok, I will do a pr.
I am just trying to find a way for people to not download an unzip package because of the tar file. It does away with the windows extract function unless you know how to use it in the view window which a lot dont.
elodaille01
@elodaille01
Mar 29 2017 12:17
what should we do when NS don't communicate with openAPS anymore ? (loop not waiting because BG data is too old)
*sorry 'doesn't communicate'
jcorbett80
@jcorbett80
Mar 29 2017 12:19
@elodaille01 not sure if anyone else is on yet. From what you are saying "BG data to old" it sounds like uploader and NS not communicating. Have you 1. tried restarting azure (or heroku) a couple of times and waited a few minutes in between each time? 2. Stopped azure and restarted?
until uploader and ns communicate loop cant gater info from ns unless you have a setup i dont know about yet (which can be VERY likely)
Chris Oattes
@cjo20
Mar 29 2017 13:14
BG data too old usually means that the CGM needs calibrating
if it's medtronic
fiberfan
@fiberfan
Mar 29 2017 13:54
A friend's loop gets stuck at the listening stage. Any suggestions for troubleshooting?
last line in the log file is listening with lots of periods.
sysyc
@sysyc
Mar 29 2017 14:51
blob
where is wrong?
@scottleibrand Can you help me?Thanks!
katie disimone
@Kdisimone
Mar 29 2017 14:58
@jcorbett80 @scottleibrand I can hope over to my windows computer (at my father in law's house) today and check that link out. That would be great if it's a zip instead of .xz. I have an easy way to bring back the extract all into the context menu for zip files. It just didn't work for the .xz. If the dfu-until came in as zip that may just solve it well. I hope 😜
@jcorbett80 @scottleibrand and I can easily edit my file in the open PR still; you wouldn't have to do a separate PR.
jcorbett80
@jcorbett80
Mar 29 2017 15:23
@Kdisimone @scottleibrand sounds good Katie. I will leave it in your hands.
live4sw
@live4sw
Mar 29 2017 15:48
Having a slightly weird battery issue with my MM522 - pump won't turn on with new battery, tried a few, then put in another, waited about 30 seconds, the pump beeped, then turned on and is working fine. This also happened a few months ago without incident. Has anyone else encountered this?
Dana Lewis
@danamlewis
Mar 29 2017 15:50
Pretty common - sometimes it just doesn't go in well
Scott Leibrand
@scottleibrand
Mar 29 2017 15:50
@sysyc look in the docs under troubleshooting for how to run reports manually
Dana Lewis
@danamlewis
Mar 29 2017 15:50
There may also be some gunk in your battery cap
Scott Leibrand
@scottleibrand
Mar 29 2017 15:51
@sysyc looks like you'll need to run the old-pumphistory alias manually, and then show its contents and run those to get full details on the error you're seeing
live4sw
@live4sw
Mar 29 2017 15:51
Ah, good point. Thanks @danamlewis - at the next battery change I'll use a q-tip.
sysyc
@sysyc
Mar 29 2017 15:52
@scottleibrand OK,thank you much.
elodaille01
@elodaille01
Mar 29 2017 16:03
scott @scottleibrand you confirm to me that 'looping' is an error ? It must be 'enacted' ?
yet, it was 'looping' during the entire night, and ..I've seen Tbasal rates from OpenAPS !
Scott Leibrand
@scottleibrand
Mar 29 2017 16:04
No, looping is fine if there's nothing to be done right that moment.
elodaille01
@elodaille01
Mar 29 2017 16:05
ok..thank you..
Scott Leibrand
@scottleibrand
Mar 29 2017 16:05
If there's no temp running, that might indicate a problem. But if it's setting temps as needed, that's good.
elodaille01
@elodaille01
Mar 29 2017 16:10
@scottleibrand the Since I tested the switch between the home wifi and the offline procedure by BT Tethering, everything has become very unstable ..Yet, last night when I did the test on the putty screen, everything went well! But this morning, I first shut down the house wifi network -> it was ok !! But when I restart it, I never managed to get anything stable (either the loop was working but I did not have a BG data update, either the opposite, or nothing worked !!)..
sorry for inexpected 'the' at the beginning of my message
and now, here is my NS state :
blob
all is ok on the uploader phone (bg data)
I know I forget something obvious..but I don't know what
Scott Leibrand
@scottleibrand
Mar 29 2017 16:23
for now I would turn off your phone's hotspot when you're at home to get it to just use wifi there
elodaille01
@elodaille01
Mar 29 2017 16:24
ok I'll try
thank you
Scott Leibrand
@scottleibrand
Mar 29 2017 16:27
you might have to reboot the rig after doing that if it's in a bad state
elodaille01
@elodaille01
Mar 29 2017 16:31
ok..thank you Scott and how do I shutdown and restart my heroku ? (I had the idea to try it too)
Scott Leibrand
@scottleibrand
Mar 29 2017 16:32
I don't use heroku, but I think there's a "restart dynos" option that sometimes people try
elodaille01
@elodaille01
Mar 29 2017 16:32
yes there's
Scott Leibrand
@scottleibrand
Mar 29 2017 16:32
(I still don't understand what exactly a "dyno" is, but whatever...) :)
elodaille01
@elodaille01
Mar 29 2017 16:32
I do click on 'restart all the dynos '?
oki :)
Scott Leibrand
@scottleibrand
Mar 29 2017 16:33
it shouldn't hurt. dunno if it'll help, but maybe worth a try
elodaille01
@elodaille01
Mar 29 2017 16:42
still the same..
:'(
elodaille01
@elodaille01
Mar 29 2017 16:59
what..should I try next @scottleibrand ..I'm so frustated..all was ok all the night !!!
frustrated sorry
perhaps install Xdrip+ nightly version (march 2017) ?
to be sure to have a monitoring constantly going ?
@danamlewis any idea for the big ball I'm am ?
garykidd
@garykidd
Mar 29 2017 17:08
@danamlewis when you a do a temporary target prior to a meal...are you trying to eat approximately 60 mins later? I'm assuming you're not both pre-bolusing and temp targeting prior to carbs? thx
Dana Lewis
@danamlewis
Mar 29 2017 17:08
Eating soon is not the same thing as a prebolus
garykidd
@garykidd
Mar 29 2017 17:08
@scottleibrand having much better results with connectivity lately
@danamlewis yup; understood.
Dana Lewis
@danamlewis
Mar 29 2017 17:09
So do ES and then do your normal meal bolus method, whether that's 15 min early or when food touches your lips.
But yes I try to do 45-60 minutes for a temp target for optimal effect
garykidd
@garykidd
Mar 29 2017 17:09
I'm trying to bolus a few units 20 mins prior to eating and the blance when I eat
@scottleibrand maybe the betterBT connectivity is a result of the aluminum foil antenna I formed on my head.....at least it's blocking out the government mind control signals.
@danamlewis soo just one...if you had entered...lets say....a temp target of 80...60 mins prior to eating(for 60 minutes)----but then actually ate 30 mins after entering this temp target.....do you just bolus when you're eating and leave the temp target to run off still?
Dana Lewis
@danamlewis
Mar 29 2017 17:14
Yes
garykidd
@garykidd
Mar 29 2017 17:15
thanks, dana
elodaille01
@elodaille01
Mar 29 2017 17:16
please, what could justify the lost of bg data reception by NS ? (while it's looping)
Dana Lewis
@danamlewis
Mar 29 2017 17:17
@elodaille01 it means your bgs aren't getting uploaded. Think about how they're supposed to get uploaded and that will help you drill down what to trouble shoot connectivity wise
garykidd
@garykidd
Mar 29 2017 17:17
sorry---(feeling like Columbo)...onemore question........how long after entering a temp target would you expect to be at or near that range (assuming you weren't running abnormally high or low)?
Dana Lewis
@danamlewis
Mar 29 2017 17:19
Think about the peak of insulin timing and your DIA
So for me, 60-90 minutes to get down there. That's why you only do temp target as low as 80 so if meal delayed or skipped, it doesn't cause a low like a prebolus would
garykidd
@garykidd
Mar 29 2017 17:20
yeah...I hav e an idea in theory but in actual practice was curious....that's one of the things that I've always been shaky on with closed loop.....
if peak activity was like in 5 mins and DIA was 5 mins....I'd imagine getting in pretty tight control loop would be easier (at least insome respects)
yeah---prebolus is goood---I'm having trouble remembering far enough in advance to make it ideal though.
elodaille01
@elodaille01
Mar 29 2017 17:23
they are getting uploaded by XdripAPS through OpenAPS
@danamlewis otherwise, is that really looping when I have no 'TBASAL' ? (or is that unknown info due to the same trouble ?)
Scott Leibrand
@scottleibrand
Mar 29 2017 17:27
don't worry about what it's called. pay attention to what it's actually doing, and whether it's doing what you want it to, on the pump
Dana Lewis
@danamlewis
Mar 29 2017 17:27
Is there a temp set on your pump? That is the ultimate source of truth
elodaille01
@elodaille01
Mar 29 2017 17:29
no..sorry..I should have done this check myself! no temp basal..it isn't looping at all
garykidd
@garykidd
Mar 29 2017 17:29
@scottleibrand relating back to conversation from a long time ago.....I'd vote for an option to elect automatic termination of a SUSPEND state after a predetermined period of time. Any further discussion recently on this?
Scott Leibrand
@scottleibrand
Mar 29 2017 17:30
@garykidd nope, that issue never got anyone interested enough in working on it to go anywhere
garykidd
@garykidd
Mar 29 2017 17:30
thx
elodaille01
@elodaille01
Mar 29 2017 17:32
I'm totally lost
Scott Leibrand
@scottleibrand
Mar 29 2017 17:39
does the rig have glucose data? check monitor/glucose.json
elodaille01
@elodaille01
Mar 29 2017 17:42
yes it has glucose data
but there's something weird (series of same data)
blob
jcorbett80
@jcorbett80
Mar 29 2017 17:47
Most of the time what I see when it is a series of same data on a dexcom (not sure if you are dexcom or enlite) it is a battery in the transmitter at deaths door.
sysyc
@sysyc
Mar 29 2017 17:48
blob
jcorbett80
@jcorbett80
Mar 29 2017 17:48
However that should still upload the bad data if you are connected through your network
sysyc
@sysyc
Mar 29 2017 17:48
blob
I can't solve the problem,but I find this.What's that means? @scottleibrand
Scott Leibrand
@scottleibrand
Mar 29 2017 17:50
@sysyc did you try running that alias?
openaps refresh-old-pumphistory to run it
then you can do openaps report invoke on each of the reports it runs, starting with the one that seems most likely to be the problem
sysyc
@sysyc
Mar 29 2017 17:52
blob
Scott Leibrand
@scottleibrand
Mar 29 2017 17:54
yeah, you won't see much just running the alias, beyond what is in your logs already. you need to drill down and figure out which report is erroring out
sysyc
@sysyc
Mar 29 2017 17:59
Sorry,my Eglish is very poor,and I need to understand slowly. @scottleibrand
The section at the bottom describes how to do this.
sysyc
@sysyc
Mar 29 2017 18:02
@scottleibrand OK,thank you,I try it.
dan lightner
@danimaniac
Mar 29 2017 20:40
Here is my first attempt at a holster for my case. Comments are, of course, welcome. https://github.com/danimaniac/OpenAPS-Explorer-Board-Edison-vented-case/blob/master/OpenAPSEdisonExplorerHolster2017-03-29.stl
Cameron Chunn
@applehat
Mar 29 2017 20:41
I'd consider doing a clip over a rigid belt loop personally, otherwise that looks pretty awesome.
dan lightner
@danimaniac
Mar 29 2017 20:47
@applehat A clip will be my next addition. Holster simply came first. I like options...
Cameron Chunn
@applehat
Mar 29 2017 21:30
It looks nice. I have a few holsters for other things, and have always found clips far easier to deal with then the rigid loops, especially if your belt is like mine and you have to remove the buckle to thread it through a rigid loop =P
dan lightner
@danimaniac
Mar 29 2017 21:33
@applehat I plan to carry my rig in my pocket anyway. This is more or less for others. It's one small way I can contribute to the OpenAPS project.
Cameron Chunn
@applehat
Mar 29 2017 21:41
My plan (whenever my 3d printer gets here) is to design something that holds my Dexcom Receiver + the rig together, and then just carry it in my pocket.
elodaille01
@elodaille01
Mar 29 2017 21:55
please if I'm using heroku, what is downloading bg data to NS when I'm offline ? (mongodb ?)
elodaille01
@elodaille01
Mar 29 2017 22:21
please @danamlewis ?
francesc0-cgm
@francesc0-cgm
Mar 29 2017 23:46
Hi i red someone was been able to save 20% battery editing crontab -e and telling openaps to loop every 3 mins. I think the correcr cron string is /3 but which line of crontab i have to edit? Thank you
I mean " /3 "
Oh my gosh is editing my post...