These are chat archives for nightscout/intend-to-bolus

21st
May 2017
Miiko
@tw_miiko_twitter
May 21 2017 00:11
@scottleibrand I have a question about OpenAps: In the absence of Wifi, how to send data to the NS server?
Martin Haeberli
@mhaeberli
May 21 2017 00:49
@tw_miiko_twitter it can also do it via Bluetooth tethering ...
or, if you are running on a raspberry pi with a hard ethernet connection, that can work, too
Miiko
@tw_miiko_twitter
May 21 2017 01:04
@mhaeberli thanks so, Is there an app for this? I have Explorer and Elite from Medtronic. I currently upload the BG via Handy Uploder-App for 640g.
Martin Haeberli
@mhaeberli
May 21 2017 01:06
@tw_miiko_twitter so if you have a 640g then it sounds like you want your BG data to go into NightScout. I don’t know whether you can close the loop on the insulin basal adjustment side with a 640G; you’d have to talk to someone else. See this link http://www.nightscout.info/wiki/welcome/nightscout-and-medtronic-640g
basically, as I understand it, you have to attach an android phone to the correct medtronic/bayer link meter via a cable and run an app on the phone.
if the phone has wireless data services through your cellular carrier, it can then send the data to nightscout .
i don’t have any direct experience with that configuration
Miiko
@tw_miiko_twitter
May 21 2017 01:12
@mhaeberli yes, I use NS already some time, the BG is uploaded by Mobildaten. now I want to looping, without loss the NS on the road.
thank you for Infor
Its clear, the pump must be changed
Martin Haeberli
@mhaeberli
May 21 2017 01:14
ok - so as I understand it you will need to find a loopable medtronic pump that supports enlite
OR switch to another CGM that works with Nightscout ...
Miiko
@tw_miiko_twitter
May 21 2017 01:14
yes
Martin Haeberli
@mhaeberli
May 21 2017 01:17
if using a loopable pump WITH enlite, again I have no direct experience, but it sounds like Edison / Explorer CAN read that data. to send it to Nightscout, you will need to pair the Edison / Explorer board with a compatible phone that can do Bluetooth tethering (and hopefully also wifi hot spot) to provide hot spot services. THEN as long as your phone is in coverage and as long as you and your Edison and pump are all near enough together, your data can go to Nightscout, and the openaps Edison can close the loop for you
Miiko
@tw_miiko_twitter
May 21 2017 01:22
What I understand is so, but how exactly? Do you know, where a pattern can be read?
Martin Haeberli
@mhaeberli
May 21 2017 01:42
@tw_miiko_twitter not clear on what you mean by ‘where a pattern can be read’?
sorry - thats probably NOT what you want
rsilvers129
@rsilvers129
May 21 2017 01:50
The older Enlite never worked for me. I would get two days out of a sensor.
Martin Haeberli
@mhaeberli
May 21 2017 02:23
at this end, the older enlite never worked for our t1 - sensor life at a week was ok, but errors in bg values were not
rumor is the new enlite with the 670g is MUCH better, but there are also downsides like no way in the US to loop outside the medtronic framework, etc
rsilvers129
@rsilvers129
May 21 2017 03:54
Seems like two things about the 670 are that if you miss a calibration, it will go into old-style-pump mode. Also can't be set less than 120. Workarounds are calibrate it with the last-known value (if you don't have a finger-stick setup with you), and add 20 to what you tell it.
Martin Haeberli
@mhaeberli
May 21 2017 05:28
yeah - so much fun that way!
peterfulvi
@peterfulvi
May 21 2017 06:13
I just enabled oref1 on my spare rig. Im familiar with the advanced freatures of oref0. How do i know its working? Do i just add the amount of carbs and thats it?
David Goelzhaeuser
@idoodler
May 21 2017 08:20
Is it possible to manually add Glucose values to nightscout?
PieterGit
@PieterGit
May 21 2017 08:45
@idoodler : you can, with the CarePortal, e.g. ad a "BG Check". Why would you want to do this?
tepidjuice
@tepidjuice
May 21 2017 10:01
@mhaeberli Also there's this excellent, depending on your opinion of medtronic, sentence in the AP literature about medtronic's algorithm: '... it is limited by it's rather simplistic representation of glucose kinetics'.
Lorenzo Sandini
@lsandini
May 21 2017 10:19
I have been using oref1 with SMB/UAM on an
722WW, but I remember someone writing it would't work on a x15 or x54 ?
worth trying it or any issues I should be aware of ?
Iain
@iainct
May 21 2017 10:31
Hi there, i have a rather simple (i hope networking issue) I have just set up a new router, upon connecting to it with a laptop, phone or tablet, there is a prompt to 'login to the wifi connection' go to a webpage hit ok and it works. How the hell do i perform that step on an edison.... I cannot see any way to white list if, I have even given it a fixed IP address but still no connection to the web... thanks
David Goelzhaeuser
@idoodler
May 21 2017 10:39
@PieterGit When I test my Bood Glucose i want to add it to Nightscout
cameronrenwick
@cameronrenwick
May 21 2017 11:10
@iainct I don't know if I fully understand your question but you have gone to this page http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-0/windows-edison.html?highlight=ifconfig and followed step 1.5 correct? That's all it took in the wifi areas I have (work home school) Once you've edited vi /etc/wpa_supplicant/wpa_supplicant.conf it should simply allow your edison to connect
Iain
@iainct
May 21 2017 11:12
@cameronrenwick, I have been using this rig for ages. the issue is i have just changed my router at home and it has a stupid log in prompt a bit like hotel wifi etc, and even though i can see my edison on the next work it cannot reach the internet
but if i connect via bluetooth through my phone it can get online
i'd prefer to directly connect to the wifi rather than through my phone for ssh and modifying
cameronrenwick
@cameronrenwick
May 21 2017 11:14
oh gotcha... ya that's a router thing (which you know...) have you looked at the router webpage regarding firmware etc? I know when I set my last one up I had the ability to alter the login like you say?
Iain
@iainct
May 21 2017 11:15
@cameronrenwick by ability to alter, you could remove it?
i'll look a little futher...
cameronrenwick
@cameronrenwick
May 21 2017 11:15
ya I was able to do that
Iain
@iainct
May 21 2017 11:16
@cameronrenwick any idea what the setting might be under...?
cameronrenwick
@cameronrenwick
May 21 2017 11:19
I think it'd likely differ from 1 router manufacturer to the next. On mine I was able to enter the router ip address from a browser and then enter the router settings. It was pretty robust (a dLink router) and had a fair amount of settings. It's been several months since I did it. Maybe check the router's manufacturer webpage for info. Hopefully it's got some documentation that'll help
Iain
@iainct
May 21 2017 11:20
ACL - Access Control List looks like it might do the job
i appreciate the pointer
cameronrenwick
@cameronrenwick
May 21 2017 11:21
hey.. happy to help (I hope I did!)
Iain
@iainct
May 21 2017 11:22
gold it worked!
cameronrenwick
@cameronrenwick
May 21 2017 11:24
nice job! ... glad to hear you're up and running...
David Goelzhaeuser
@idoodler
May 21 2017 12:03
Is it possible to see the Explorer board battery voltage in Nightscout?
I see that the value is uploaded {"batteryVoltage":3839, "battery":66}but I can't see it in nightscout
PieterGit
@PieterGit
May 21 2017 12:08

my bluetooth controller seems to be missing from time time time.

# bluetoothctl
[bluetooth]# list
[bluetooth]# scan on
No default controller available
# sudo hciconfig hci0 up
Can't get device info: No such device

Tried with 5.37, 5.44, 5.45 but can't get to get it stable. Any idea's how to debug further?

Paul Dickens
@thebookins
May 21 2017 12:14
Hi All,
David Goelzhaeuser
@idoodler
May 21 2017 12:14
@thebookins Hi:)
Paul Dickens
@thebookins
May 21 2017 12:14
Wow @idoodler someone in the world is awake!
David Goelzhaeuser
@idoodler
May 21 2017 12:15
@thebookins Sure, I just had lunch
Paul Dickens
@thebookins
May 21 2017 12:16
Nearly bedtime here in Sydney.
PieterGit
@PieterGit
May 21 2017 12:16
@thebookins did you already dare to try a newer kernel?
Paul Dickens
@thebookins
May 21 2017 12:17
@PieterGit, no, not yet, don't know how.
cameronrenwick
@cameronrenwick
May 21 2017 12:17
just about to have breakfast... we've covered the world!!
PieterGit
@PieterGit
May 21 2017 12:17
Paul Dickens
@thebookins
May 21 2017 12:18
What I did realise though, was that the Jubilinux version of the kernel (3.10.x) doesn't support LE privacy, which is necessary to pair with the G5.
But version 3.19.5 from here does.
I think it would be easier for a noob for try that version, since it's already patched for the Edison?
What do you think?
Paul Dickens
@thebookins
May 21 2017 12:36
Thanks for the link @PieterGit, not brave enough to try it though!
katie disimone
@Kdisimone
May 21 2017 13:07

@idoodler not the answer you want to hear I'm sure, but it should actually show up in NS without any special work. The settings to make that show are part of the device status upload, so if you're seeing other OpenAPS stuff but not that...it's a glitch somewhere.

My friend had same thing happen to her (no rig battery showing). Redoing the setup script did fix it , but I have no idea why.

David Goelzhaeuser
@idoodler
May 21 2017 13:08
The Think is that I don't have my CGM sensors yet. I will check it again when i have my sensors
katie disimone
@Kdisimone
May 21 2017 13:09
@lsandini a fix for the x54 has been merged into dev branch a few days ago.
Lorenzo Sandini
@lsandini
May 21 2017 13:11
@Kdisimone thanks, fantastic ! :smile:
PieterGit
@PieterGit
May 21 2017 13:15
@thebookins : i think we should make the step to a 4.x kernel eventually, so I would not go back to 3.19.5, but try a 4.x kernel on a spare edison. I first want a oref1 mobile rig with token based authentication and then will probably continue with a 4.x kernel one to see if that's possible
if https://github.com/01org/edison-linux/tree/edison-3.19.5 supportes LE privacy, I'm pretty sure https://github.com/andy-shev/linux/tree/eds will also support it (didn't check)
Paul Dickens
@thebookins
May 21 2017 13:22
@PieterGit I agree a 4.x kernel sounds like it makes sense. At the moment though, I'm just looking for the simplest (least amount of work) thing I can do to get LE privacy to see if that fixes the issues I'm having bonding with the G5. Correct me if I'm wrong, but https://github.com/01org/edison-linux/tree/edison-3.19.5 should work out of the box, since it's patched for edison already?
Doing all the work for 4.x is beyond my skill set at the moment, I'm afraid!
PieterGit
@PieterGit
May 21 2017 13:24
i'm affraid you will run in a ton of other problems even if you get the bt pairing working.
Paul Dickens
@thebookins
May 21 2017 13:26
Oh, what kind of problems do you expect?
tekrulik
@tekrulik
May 21 2017 14:57
I'm interested in testing out oref1 and SMB. I've read through as much as I can, but one thing I'm not clear on is the timing of initial bolus/carb entry. Are people dosing ~15 min ahead of eating or doing eating soon mode, then dosing when eating? In other words, are you just following your individual/usual process for when you enter carbs/bolus through the pump?
fidoman
@efidoman
May 21 2017 15:01
@tekrulik - I've experimented a few different styles. What I've found works best most of the time is to use the eating soon mode 60 minutes before meals. This will cause SMB to kick in if it is required and if you have SMB with temporary targets enabled. If my meal is less than 21 carbs and my BG is in range (around 100), then I will just enter the carbs in NS and not bolus. Otherwise, I will use the bolus wizard on my pump and subtract about 1 unit off what it recommends for bolus. The SMB will kick in if it needs to do so and I've found it to be very reliable without overdoing it.
live4sw
@live4sw
May 21 2017 15:03
Random question - my edison rig is just a 2000mAH lipo connected to the explorer board. I see in the past people used the PowerBoost 1000C. Why was that necessary back then, and does anyone still use it now?
Was that needed in the past to provide sufficient power to both an edison and a TI stick connected to a breakout board, but not necessary anymore with the explorer board?
Matthias
@ceben80
May 21 2017 15:16
@live4sw my "old" Eddie, breakout board and ERF consumes less power, but right the TI is very power hungry as I heard
and yes I'm using the Adafruit 1000C charger too for this rig
Scott Leibrand
@scottleibrand
May 21 2017 15:48
@live4sw not many people use the PowerBoost: it's really only needed if you have to have the same rig running on battery for more than 16hr/day, and therefore have a 2500mAh or larger battery that needs to be charged in 8h or less. For anything less than that, the onboard charging circuit works fine.
live4sw
@live4sw
May 21 2017 15:52
Ah. @scottleibrand thanks for the explanation!
DaisyHK
@laurathiessen
May 21 2017 16:34
sorry guys but baic question... my brain is fred from last night, I got up to the step of setting up the wifi. 1.7 install packages etc. It says to go into a new terminal, so I started a new session but for the life of me I can remember how to log in as root
image.png
Scott Leibrand
@scottleibrand
May 21 2017 16:38
your Edison is still up and running from before, so you reconnected and are already logged in as root (notice the root@ prompt)
Tony Zarro
@tzarro
May 21 2017 16:38
Quick question...I get the following showing up in my Papertrail logs constantly (1-2 times per minute)...per the recommendations, I'm about to filter out the libmraa data from my logs, but before I do I wanted to find out if there is a problem that needs to be resolved with the gpio214 export failure (row 2). Any ideas?
May 21 12:20:42 localhost libmraa: libmraa version v1.6.1 initialised by user 'root' with EUID 0
May 21 12:20:42 localhost libmraa: gpio214: init: Failed to write to 'export': No such device
May 21 12:20:42 localhost libmraa: edison: Arduino board not detected, assuming Intel Edison Miniboard
May 21 12:20:42 localhost libmraa: libmraa initialised for platform 'Intel Edison' of type 2
Scott Leibrand
@scottleibrand
May 21 2017 16:38
I assume that "export" device is how it tries to detect the arduino board. shouldn't be an issue.
Tony Zarro
@tzarro
May 21 2017 16:38
ok, thanks!
DaisyHK
@laurathiessen
May 21 2017 16:41
@scottleibrand lol ok thanks..this will be a long day
DaisyHK
@laurathiessen
May 21 2017 16:59
for time zones... if I live in Canada will US work? or should I input Canada in the none of the above section?
Scott Leibrand
@scottleibrand
May 21 2017 17:20
do you have the same timezone as the US?
there's nothing magic about the locations: that's just to make it easy to choose the right timezone
peterfulvi
@peterfulvi
May 21 2017 17:20
I enabled oref1 on a spare rig of mine, im trying it out, i enabled it in preferenses.json and see no sign what soever that its working. It talks about enabling a flag in setup? i never saw any option to enable it in the orefo setup. ami missing something? i updated with the orefo dev branch then ran the setup script. I saw no options for oref1 other than in preferences
Scott Leibrand
@scottleibrand
May 21 2017 17:21
@peterfulvi you have to go find the enable flag: we haven't added it to oref0-setup yet for safety reasons
DaisyHK
@laurathiessen
May 21 2017 17:24
@scottleibrand yeah I tried to figure out the GMT time, i thought I inputted the right one but the time it is telling me is wrong so I have to delete this entre and start again
peterfulvi
@peterfulvi
May 21 2017 17:25
Ok. is it an option somewhere when i run the setup? Sorry for my lack of knowing were exactly it is.
Scott Leibrand
@scottleibrand
May 21 2017 17:27
you have to add it to the command-line flags
if you're not sure what to add or where it goes, please read oref0-setup to understand what it's doing and how to trigger it
peterfulvi
@peterfulvi
May 21 2017 17:30
Ok. Thanks.
DaisyHK
@laurathiessen
May 21 2017 17:44
@scottleibrand I keep trying the esc:Q enter to delete but it wont work?
image.png
Scott Leibrand
@scottleibrand
May 21 2017 17:46
you're at a command prompt, not in vi. why are you trying to use vi keybindings to delete something?
DaisyHK
@laurathiessen
May 21 2017 17:47
oh sorry... forgot the vi and root are different. how would I delete my last entry in root?
Scott Leibrand
@scottleibrand
May 21 2017 17:48
you don't. if you mistype something, it just gives you an error and gives you your command prompt back to try again
DaisyHK
@laurathiessen
May 21 2017 17:49
no its typed in correctly I picked the worng GMT time zone so I need to reinstall it
or do I just do the commant prompts to reinstall it and pick the correct one to overwrite my last one?
Scott Leibrand
@scottleibrand
May 21 2017 17:49
then you need to re-run that previous command to set it again. if you want, you can hit the up arrow to cycle through your old commands so you don't have to retype or repaste it
DaisyHK
@laurathiessen
May 21 2017 17:54
ok thanks... also I may have found a glitch with timezones... when it says GMT-6 it realy means GMT +6 and GMT+6 = GMT -6...
peterfulvi
@peterfulvi
May 21 2017 17:56
so i can edit the setup script with d ~/myopenaps && nano oref0-runagain.sh and rerun the setup script again i just need to figure out the flag i need to add
DaisyHK
@laurathiessen
May 21 2017 17:56
image.png
Scott Leibrand
@scottleibrand
May 21 2017 17:58
@laurathiessen yes, that is a weirdness of POSIX timezones
DaisyHK
@laurathiessen
May 21 2017 18:02
lol oh ok.. did not know this was a known thing, I wil try to add that to my pull request for the documents
just double checking, when you are done inputting the commands in root can I just close the window as everything is done, or do you need to save it before you exit out?
David Goelzhaeuser
@idoodler
May 21 2017 19:12
I just set up my rig and I wanted to check if the comminication between the Explorer board and the pump are working. I executed openaps use pump model to check if everything works. but I get /dev/spidev5.1 already in useException
Dana Lewis
@danamlewis
May 21 2017 19:22
Watch the logs is easiest way to see if it's communicating
If you run things manually you need to do a killall to stop the ongoing rig comms
David Goelzhaeuser
@idoodler
May 21 2017 19:23
The thing is that I don’t have my CGM sensores yet, but I should see data on Nightscout, right?
Dana Lewis
@danamlewis
May 21 2017 19:25
No
If you have no CGM data, nothing will display in NS
David Goelzhaeuser
@idoodler
May 21 2017 19:25
Oh, good to know:)
Dana Lewis
@danamlewis
May 21 2017 19:25
And you won't be looping because there's no data for it to do math on
But it can communicate and read from the pump, so check the logs to see it read
David Goelzhaeuser
@idoodler
May 21 2017 19:26
Yeah, sure. I just wanted to prepare everything, so I am ready when my sensors are here.
Dana Lewis
@danamlewis
May 21 2017 19:26
:+1:
David Goelzhaeuser
@idoodler
May 21 2017 19:27
I think this entry is normal, because I don’t have any CGM data: Could not parse input data: { [Error: Cannot find module '/root/DavidsAPS/monitor/glucose.json'] code: 'MODULE_NOT_FOUND' }, right?
its from autosense-loop.log
This log is from papertrail
ok, I just stopped openaps, now I get a valide response, so everything is fine and ready for my sensors!
Thanks a lot:)
PieterGit
@PieterGit
May 21 2017 21:02
@scottleibrand : my token-based authentication rig is working like a charm! I need to fix some of the installation scripts and probably want to reinstall again on a second spare rig to make sure everything works out of the box. Unfortatetely default pebble nightscout does not support token based authentication (pancreable does)
Scott Leibrand
@scottleibrand
May 21 2017 21:03
:+1:
PieterGit
@PieterGit
May 21 2017 21:04
i didn't need a flask proxy, and i think i found some other bugs in the proces
and btw bluez 5.45 works for pebble and bt tethering as well
I got bluez working by first installing stock bluez and then compiling it (and replacing all instances of bluetoothd). Is there a reason why we don't do that by default?
That will make systemd stuff work
Scott Leibrand
@scottleibrand
May 21 2017 21:11
because we have a method that works, and so far no one has wanted to make the effort to create an fully test a new automated install method. I've been holding out for a fully packaged install that doesn't require compiling anything. Surely someone has packaged bluez 5.4x for debian by now...
PieterGit
@PieterGit
May 21 2017 21:13

This works (for me):

apt-get -y install bluez # for systemd
killall bluetoothd &>/dev/null #Kill current running version if its out of date and we are updating it
cd $HOME/src/ && wget https://www.kernel.org/pub/linux/bluetooth/bluez-5.45.tar.gz && tar xvfz bluez-5.45.tar.gz || die "Couldn't download bluez"
cd $HOME/src/bluez-5.45 && ./configure --enable-deprecated --disable-systemd && \
make && sudo make install && sudo cp ./src/bluetoothd /usr/local/bin/ || die "Couldn't make bluez"

And adding NOPLUGIN_OPTION="--noplugin=hostname" in /etc/init.d/bluetooth gets rid of the error of "org.freedesktop.hostname1"

note the experimental stuff is not needed as far as I can see. The --enable-deprecated is required because hciconfig is deprecated
John Benjamin
@Bender1061
May 21 2017 21:42
wow, I've been away for a couple months (pretty busy with work) Been runing my rig the whole time, Only once did I have any issues (had to reinstall oref0) but I've been looping a little over a year now, and my Life is so much better for it. Course Right now I'm testing all the new features you guys have come up with. Looking Good!
Scott Leibrand
@scottleibrand
May 21 2017 21:57
:+1:
Dana Lewis
@danamlewis
May 21 2017 21:57
:sparkles:
Martin Haeberli
@mhaeberli
May 21 2017 22:31
@tepidjuice - late to respond, but :+1: :-)
I'm having probably three problems ... a) Dexcom (with help from Share) drops sometimes, which causes stale BG data; b) I suspect the Edison's networks are flapping - which makes it hard to get Dexcom data from NS even when the data is current; c) once the data is stale, my openaps gets stuck; even though the NS API gives me fresh data on request, openaps often can't get out of 'stale' data mode unless I coddle it by hand or reboot it. Hand-coddling involves 1) getting data via the curl API to be sure; 2) chanting openaps get-ns-bg ; 3) if I'm lucky, it all resumes from there ... ... seeking advice ... for example, I could PM someone to let them into the paper trail logs along with a few sample times, or publish log excerpts here ... (part of the flapping may be that my home internet has its idiosyncrasies)
Scott Leibrand
@scottleibrand
May 21 2017 22:36
not a complete fix, but we just merged some updates to oref0-online into dev that might improve reliability of connectivity
are you getting BG directly to the rig as well, or just via NS?
Martin Haeberli
@mhaeberli
May 21 2017 22:38
@scottleibrand - just via NS (G4 -> share receiver -> iPhone -> Dexcom cloud -> Heroku Nightscout -> Edison)
Sounds like if I re-run setup with the same parameters (maybe make sure I have dev checked out on the Edison) that this may improve
Also, we're about to try Dexcom G5 this coming week, which i understand (can) pairs directly to Edison so at least real time BG data doesn't have to rely on live internet connectivity ...
DaisyHK
@laurathiessen
May 21 2017 22:51
I am a bit confused ... I am switching my old azure site to the heruku one as recommended it states" you will need to change your NS URL in both ns.ini and in cron. Alternatively, you can edit your runagain.sh file and run the setup script again.
If you’d like to seamlessly keep all your old Azure NS data showing in your new Heroku NS site, you’ll need to copy and paste your old MONGODB string from your Azure site. Find it in either Application Settings or Connection strings in your Azure control panel and then go to Heroku’s MONGODB_URI line. Replace the content with your copied string from Azure. Double check that your Azure collection used the “entries” name…if it doesn’t, then you will need to update that variable in Heroku to match as well.
what is ns.isi and cron? and where are these on my azure site?
Dana Lewis
@danamlewis
May 21 2017 22:52
@laurathiessen you can ignore that if you haven’t already setup openaps
that mostly applies to people who are retrospectively changing NS after they’ve set up OpenAPS
DaisyHK
@laurathiessen
May 21 2017 22:54
ok but I still need heruku website don't I?
Dana Lewis
@danamlewis
May 21 2017 22:54
recommended
Scott Leibrand
@scottleibrand
May 21 2017 22:54
@mhaeberli no, there's no G5 pairing on the Edison yet. there is openxshareble for the G4, but it hasn't gotten a lot of love lately due to BLE unreliability
Dana Lewis
@danamlewis
May 21 2017 22:54
but the specific q you asked about ns.ini and cron is not relevant to you yet; that part you can ignore
DaisyHK
@laurathiessen
May 21 2017 22:55
@danamlewis oh ok... sorry getting confused... ok then what steps should I follow for the new heruku site if I have an old azure with all the stuff still in it?
or do I just build a new one as per the instructions and then put in that mongodb string as directed?
Scott Leibrand
@scottleibrand
May 21 2017 23:04
yes, do the latter, and then give that nightscout URL to oref0-setup when asked
Martin Haeberli
@mhaeberli
May 21 2017 23:08
@scottleibrand thx - I can dream about using the above hints about bluetooth to get further… meanwhile, we have to rely on the kindness of share ...
DaisyHK
@laurathiessen
May 21 2017 23:14
image.png
@scottleibrand @danamlewis as I already have github and NS I am updating my respository on github as per the instructions.. i just cant find the merge pull request on this page? Or should I ignore these instructions and just buil the site?
oh nevermind... kept reading sorry!
Martin Haeberli
@mhaeberli
May 21 2017 23:18
so what is preferred way of getting dexcom values into edison if can’t be done via share ? serial cable and large external battery?
(along with dexcom receiver)
Scott Leibrand
@scottleibrand
May 21 2017 23:26
that's the most reliable offline method, yes. there is also now a way to get BGs to an Edison via a custom Loop app (via the iPhone, not direct from the transmitter), if you'd prefer that.
DaisyHK
@laurathiessen
May 21 2017 23:50
i have these enabled on my old website: careportal rawbg iob maker cob bwp cage basal pushover bridge sage . will any of these create a problem with Open APS? can someone refresh my memory what bwp, pushover, bridge are?
DaisyHK
@laurathiessen
May 21 2017 23:55
also if I am using an android then I would not enter any info into brdge user name and password and leave blank?