These are chat archives for nightscout/intend-to-bolus

11th
Sep 2017
wharper11
@wharper11
Sep 11 2017 02:14
hi. updating openaps and found that the preferences have changed. I don't see bolus snooze divisor, carb impact or carb ratio. did I do something wrong or are these options now automated?
Dana Lewis
@danamlewis
Sep 11 2017 02:16
@wharper11 we changed so the commonly changed ones show up by default; but you can add (and then adjust) any of the other ones you need/want; http://openaps.readthedocs.io/en/latest/docs/While%20You%20Wait%20For%20Gear/preferences-and-safety-settings.html (and subsection http://openaps.readthedocs.io/en/latest/docs/While%20You%20Wait%20For%20Gear/preferences-and-safety-settings.html#other-preferences is where the ones you're looking for are)
wharper11
@wharper11
Sep 11 2017 02:17
thanks @danamlewis!
Dana Lewis
@danamlewis
Sep 11 2017 02:17
:+1:
(btw for anyone who's not following the repo's: we released dev to master, so 0.5.3 is now current master. To see what's changed & help you decide if you want to update, check out the release notes: https://github.com/openaps/oref0/releases)
drmartinezs
@drmartinezs
Sep 11 2017 03:26
how do i install that new release?, i re flashed, and re instaled oref0 right now
drmartinezs
@drmartinezs
Sep 11 2017 03:28
thanks @danamlewis !!
Dana Lewis
@danamlewis
Sep 11 2017 03:32
(assuming you re-flashed etc. for other reasons - for just upgrading, you don't need to reflash)
Gabriela Ezquerro B
@gabezqbod_twitter
Sep 11 2017 04:06
Hello! Mom of a 6year old kid living with T1D i am startint to build a rig with oppen aps. We have orderes everything, we live in mexico. We have the medtronic minimed530 for the moment, we will be offered to change to the minimed 630... should we change pumps?? Will it work with thr
Will it work withnoppen aps?
also, i would love to meet someone in mexico? Anyone around here? Or in san diego,CA...? We'll be there for 2 weeks in halloween!!!
Dana Lewis
@danamlewis
Sep 11 2017 04:11
Hi! 630 will not work :( what part of Mexico are you in?
Cc @jonahtaxt ^
Andy Sharrow
@dramageek
Sep 11 2017 13:57
@feredean @danamlewis RE the xDripAPS problems- I noticed it back when I tried switching to Token Auth a few months back before the 0.5.0 release. I opened the issue over on that project, as it wasn't a part of the oref0 codebase that's causing the problem.
Dana Lewis
@danamlewis
Sep 11 2017 13:58
K thanks for confirming it is token auth related
Andy Sharrow
@dramageek
Sep 11 2017 13:59
Seems like there's tons of abandoned projects that don't support Token Auth. I can't find a pebble watch face that supports it either, so I ended up switching back.
Would it be helpful to open a ticket here as well? There's no movement on the one over there, so one here might drive a bit of movement, and let others know about the problem.
Dana Lewis
@danamlewis
Sep 11 2017 14:11
Sure - might be helpful so we can point people to it - but please make it clear in description the short term solution (switch back to API) and also that it's not actually an oref0/OpenAPS side issue :smile: thx
Dana Lewis
@danamlewis
Sep 11 2017 14:22
Thx @dramageek!
Gabriela Ezquerro B
@gabezqbod_twitter
Sep 11 2017 15:13
@danamlewis thank you! i'm in mexico city, trying to get in touch with the community here ;)
Dana Lewis
@danamlewis
Sep 11 2017 15:21
Are you on twitter? I can also tag someone there for you, don't see her popping up here in Gitter. also hopefully Jorge saw my tag yesterday and can reach out too :smile:
Gabriela Ezquerro B
@gabezqbod_twitter
Sep 11 2017 15:23
i'm in contact with Mariana... is that who you wanted to contact? Jorge is in conversations as well.
Dana Lewis
@danamlewis
Sep 11 2017 15:25
Ah perfect! You're all set then, just wanted to make sure you had found them :smile: :+1:
Gabriela Ezquerro B
@gabezqbod_twitter
Sep 11 2017 15:25

@danamlewis @jonahtaxt i got stuck last night after the "deploy to azure" part because the webpage i created showed this error No se puede acceder a este sitio web

No se ha podido encontrar la dirección DNS del servidor de thomasscout.azurewebsies.net.
Prueba a ejecutar Diagnósticos de red.
DNS_PROBE_FINISHED_NXDOMAIN

daveklingler
@daveklingler
Sep 11 2017 15:26
Huh. I notice that in the 0.5.3 release, you mention Jubilinux 0.2.0. I have yet to get 0.2.0 to work on my Edison - the kernel and libraries are mismatched and the services don't load.

```root@binky:~# /lib/systemd/systemd-modules-load
could not open moddep file '/lib/modules/3.10.17-yocto-standard-r2/modules.dep.bin'
Failed to lookup alias 'bcm_bt_lpm': Function not implemented
could not open moddep file '/lib/modules/3.10.17-yocto-standard-r2/modules.dep.bin'
Failed to lookup alias 'bcm4334x': Function not implemented
could not open moddep file '/lib/modules/3.10.17-yocto-standard-r2/modules.dep.bin'
Failed to lookup alias 'g_multi': Function not implemented
could not open moddep file '/lib/modules/3.10.17-yocto-standard-r2/modules.dep.bin'
Failed to lookup alias 'uvcvideo': Function not implemented
could not open moddep file '/lib/modules/3.10.17-yocto-standard-r2/modules.dep.bin'
Failed to lookup alias 'ftdi_sio': Function not implemented
root@binky:~# ls /lib/modules/
3.10.98-poky-edison

```

Erp. That didn't work.
(I read last night that I could surround code with single quotes and have it come out nicely formatted, but I must be in the wrong web app.)
That was meant for @danamlewis , btw.
Dana Lewis
@danamlewis
Sep 11 2017 15:31
Put the first line of code on the line below your backticks and it should work :smile:
daveklingler
@daveklingler
Sep 11 2017 15:32
Hmmmm...thank you. Ctl-enter doesn't seem to be working for me. Pooh.
Dana Lewis
@danamlewis
Sep 11 2017 15:33
Re 0.2.0 it's been working for folks for a while (but caused an issue w NS that was sporadic, thus that fix. Not related to what you're seeing)
I'm not a jubi expert; so you may want to post that in the jubilinux channel for some more specific troubleshooting help if no one pipes in with ideas here
daveklingler
@daveklingler
Sep 11 2017 15:34
Anyhow, I spent many hours scratching my head over 0.2.0 and 0.3.0 before going back to 0.1.1. Now I'm scratching my head over why Nightscout isn't working yet.
Dana Lewis
@danamlewis
Sep 11 2017 15:34
0.1.1 is also fine if you want to troubleshoot by switching back
Not working how? At all?
daveklingler
@daveklingler
Sep 11 2017 15:35
Well, it displays the time quite nicely.
In the instructions, it says that if I have a greyed out pyramid with a little red circle on my G5 app, that means it's not working. But it doesn't actually say anything more than that. I've tried sending an email invitation to myself to share my G5 data, but I'm not sure where to go from here.
I.e. I went through the sharing dialog in the G5 app.
I called Dexcom, and the support rep said to wait a few weeks and data would start showing up!
daveklingler
@daveklingler
Sep 11 2017 15:40
My head is quite well-scratched, at this point, right down to a nubbin.
daveklingler
@daveklingler
Sep 11 2017 15:47
Can anyone here describe to me what's actually supposed to happen to get the G5 app sharing properly?
Or is there a more specific Nightscout forum where I should be asking those questions?
daveklingler
@daveklingler
Sep 11 2017 15:58
@danamlewis , I just noticed that I don't have a BRIDGE_MAX_COUNT variable in my Heroku app, and the guide shows one. Should I add it?
Dana Lewis
@danamlewis
Sep 11 2017 16:06
@daveklingler I was with someone the other day, and she shared with someone's email address, and that made it start working
So share with another email of yours if you haven't already? That might trigger it
That's just about backfill, you can add it but shouldn't impact this
daveklingler
@daveklingler
Sep 11 2017 16:11
@danamlewis Hm. Do you know whether I have to accept my invitation, or just keep sending them?
Dana Lewis
@danamlewis
Sep 11 2017 16:12
Probably just send, but don't know for sure. Started working 5-10 minutes after she did the share.
You should also triple check you got the username and password for Dexcom correct if you haven't already
You can check and see if Dexcom is sharing by getting the follow app and following yourself
daveklingler
@daveklingler
Sep 11 2017 16:54
@danamlewis Okay, I now have happy colored balloons where before I had grey ones. I'm completely behind myself.
Thanks!
Dana Lewis
@danamlewis
Sep 11 2017 16:55
yay! progress is great
daveklingler
@daveklingler
Sep 11 2017 16:55
BUT...I don't have anything showing up yet in my Heroku app, other than the time. Presumably this data is going to Dexcom's clarity cloud, right?
Tiberiu Feredean
@feredean
Sep 11 2017 16:58
@danamlewis @dramageek In order to continue with the setup I disabled the auth check in the code (highly insecure and potentially dangerous) but then I've hit another issue where for some reason although there are entry points in monitor/glucose.json but the script pushes empty array [] to nightscout, this in turn crashes nightscout with 503 (timeout), to get it somewhat working i use the xdrip app to push to both xDripApps and nightscout, I'll see if this works until i get more time to see where the actual issue is
JELCRAWFORD
@JELCRAWFORD
Sep 11 2017 17:21
@danamlewis - when using SMB/UAM - do you have recommendations/thoughts about how to handle an adjustment if you have been unconnected for a period of time? DS was completely unplugged for 2+hours yesterday while kayaking. We were not very elegant in our management when we hooked him all back up. Otherwise we are very pleased with the functioning of the advanced features.
Dana Lewis
@danamlewis
Sep 11 2017 17:25
Just to do a longer temp to zero before suspending, so iob is accurate when you come back on to the pump.
JELCRAWFORD
@JELCRAWFORD
Sep 11 2017 17:27
Had done so, but then figured a small correction was a good idea - yes, we have read to be wary of corrections with SMB :) We did a conservative estimate of insulin need, or so we though, but we still needed a small carb correction for overshoot. I'm gathering you would still stick with eating soon as a primary method with SMB as a 'correction' effort? Thx in advance!
Dana Lewis
@danamlewis
Sep 11 2017 17:29
:+1:
Yea, I'd probably still let the rig make up the missed iob in case I'm super sensitive post activity and don't rise as far as your were predicting
JELCRAWFORD
@JELCRAWFORD
Sep 11 2017 17:31
yes, I think that is probably what we missed considering... oops :) Thanks for confirming.
supervision was close, so not a problem. Just for future reference we can be more refined.
Dana Lewis
@danamlewis
Sep 11 2017 17:34
:+1: the story of diabetes :+1:
Phil
@drnoname82_twitter
Sep 11 2017 17:49
@daveklingler Do you have the Dexcom share bridge configured in your Nightscout settings? http://www.nightscout.info/wiki/welcome/nightscout-with-ios-and-dexcom-share
regdubbed
@regdubbed
Sep 11 2017 18:52
Hi. I'm new to openaps. Trying to set up my first (test) loop and need help troubleshooting. Is this the right forum?
Scott Leibrand
@scottleibrand
Sep 11 2017 18:53
yep
regdubbed
@regdubbed
Sep 11 2017 18:56
great :) I'm running the Edison setup for 24h now. Uploading CGM data to NS. , but no suggested.json is generated. iob.json is missing. should it be there?
Scott Leibrand
@scottleibrand
Sep 11 2017 18:58
do you have it configured to connect to a pump yet?
regdubbed
@regdubbed
Sep 11 2017 18:59
yes
communication with the pump is fine
Scott Leibrand
@scottleibrand
Sep 11 2017 18:59
what does your pump-loop.log say?
regdubbed
@regdubbed
Sep 11 2017 19:00
Old settings refresh at node.js:906:3
ed. temp_basal.json less than 5m old. glucose.json newer than pumphistory. : Refresh at Module.load (module.js:356:32)
ed pumphistoryCould not parse input data: [SyntaxError: Unexpected end of input]
and meal.json
Could not parse input data: [SyntaxError: /root/myopenaps/monitor/iob.json: Unexpected end of input]
determine-basal://text/shell/enact/suggested.json
reporting enact/suggested.json
enact/enacted.json: cat: enact/enacted.json: No such file or directory
Error, retrying
iob. json is not missing, it's emty. sorry
Scott Leibrand
@scottleibrand
Sep 11 2017 19:04
ok, probably time to drill down and run the iob.json report manually to see what error it's hitting
there's a troubleshooting section in the docs for that, but let us know if you get stuck
regdubbed
@regdubbed
Sep 11 2017 19:05
tried that
no error message, iob.json is still empty
added iob://text/shell/monitor/iob.json
Scott Leibrand
@scottleibrand
Sep 11 2017 19:07
it might be hiding the output. what did you run exactly?
regdubbed
@regdubbed
Sep 11 2017 19:08
openaps report add monitor/iob.json text iob shell monitor/pumphistory-zoned.json settings/profile.json monitor/clock-zoned.json
do I need settings/profile.json?
(empty)
regdubbed
@regdubbed
Sep 11 2017 19:15
there is an error message for profile.json:
root@mia:~/myopenaps# openaps report add settings/profile.json text get-profile shell settings/settings.json settings/bg_targets.json settings/insulin_sensitivities.json settings/basal_profile.json preferences.json
usage: openaps-report add report {base,text,stdout,JSON} get-profile shell
[-h] [--not-json-default]
settings bg_targets isf basal_profile preferences carb_ratios ...
openaps-report add report {base,text,stdout,JSON} get-profile shell: error: too few arguments
Thacher
@thacherT1D
Sep 11 2017 19:19
anyone have problems with the explorer board signal interupting bluetooth keyboards/mice/trackpads?
JELCRAWFORD
@JELCRAWFORD
Sep 11 2017 19:44
FYI - many of you will probably be aware of Medtronic recall of infusion sites already - if you have not double checked your infusion sets and lot numbers - I was surprised when entering ours - every single infusion set we have has been recalled. Further, our pharmacy currently has none on hand that are not covered by the recall. They do not yet know if their supplier has any of the new sites on hand either.
Scott Leibrand
@scottleibrand
Sep 11 2017 20:00
if this affects all Mio sets they've ever made, the problem obviously isn't a very common one. I think most of us who are looping and attentive to details can just follow their "Key Steps" to keep insulin off the top of the reservoir, and if any ever gets through rely on the loop to zero-temp to compensate.
@regdubbed you shouldn't need to do any openaps report add commands: you should just need to openaps report invoke the ones that are already configured
if you did any successful add commands you might want to re-run oref0-setup to get them back to a known good state
thisistheusername
@thisistheusername
Sep 11 2017 20:11
I am using an Edison + Explorer board, oref0, and a Medtronic 712. I've created the additional settings files per the directions for the 512 and 712 pumps.
I get an error of "Pssst! Your pump is set to % basal type. (etc)"
The pump is set to u/h, not percent. Has anyone seen this? What can be done to get the temp basal working?
Scott Leibrand
@scottleibrand
Sep 11 2017 20:14
what does the temp_basal.json show?
Dana Lewis
@danamlewis
Sep 11 2017 20:15
(There's a chance that the check we did passes on other pump models but maybe not the 12s? If so, we'll need to figure out how to adapt for the x12s)
thisistheusername
@thisistheusername
Sep 11 2017 20:15
I don't see that file in the settings dir nor the root myopenaps dir
Scott Leibrand
@scottleibrand
Sep 11 2017 20:16
it should look something like:
pi@pi2-erf ~/myopenaps $ cat monitor/temp_basal.json
{
  "duration": 30,
  "rate": 0.9,
  "temp": "absolute"
}
it gets refreshed pretty frequently, but you could also stop your cron and openaps report invoke monitor/temp_basal.json to refresh it manually
it's just the output of openaps use pump read_temp_basal
thisistheusername
@thisistheusername
Sep 11 2017 20:17
duration is 0, rate is 0, temp is percent.
Dana Lewis
@danamlewis
Sep 11 2017 20:19
Try setting a manual temp and see if that's still true after it reads it?
daveklingler
@daveklingler
Sep 11 2017 20:27
Quick couple of questions for anybody that uses Clarity: (1) Does your phone show up at the bottom under "Devices"? (2) Is clarity.dexcom.com where the Heroku Nightscout app gets its glucose data?
thisistheusername
@thisistheusername
Sep 11 2017 20:30
I still show a duration of 0, a rate of 0 and a temp of percent.
I set a temp basal and noted tgat tge pump_loop log seemed to have stopped updating. I did a reboot and got an error message for mmeowlink indicating no acknowledgement from the pump and asking if it wasout of range or if the battery too low.
Old pumphistory: IndexError: bytearray index out of range
And the Pssst message again
thisistheusername
@thisistheusername
Sep 11 2017 20:37
The old pumphistory and psst message are recurring consistently.
regdubbed
@regdubbed
Sep 11 2017 20:41
so, I did rerun it all and tried to invoke the reports. Seems to have trouble with carb_ratios.json. This is what the file looks like:
{
"units": "exchanges",
"first": 2,
"schedule": []
}
plausible?
daveklingler
@daveklingler
Sep 11 2017 20:42
@Thacher Explorer and Bluetooth are on very different frequencies, so there isn't any mechanism for them to interfere with one another.
Dana Lewis
@danamlewis
Sep 11 2017 20:42
@regdubbed ah - carbs need to be in grams, not exchanges
regdubbed
@regdubbed
Sep 11 2017 20:42
ups...
Dana Lewis
@danamlewis
Sep 11 2017 20:43
Try changing it on the pump & seeing if it self resolves after that
@thisistheusername bytearray should self resolve when it gets a good history.
Scott Leibrand
@scottleibrand
Sep 11 2017 20:48
@thisistheusername after you set a temp on the pump, you should be able to re-run openaps report invoke monitor/temp_basal.json to make sure that it pulls an updated copy of that file.
Phil
@drnoname82_twitter
Sep 11 2017 20:49
@daveklingler No, Dexcom Share and Clarity are different servers. Nightscout can pull BG data from Dexcom Share servers. If you are using Android, you may also consider XDrip+ instead of the Dexcom app. XDrip+ can upload directly to Nightscout (and also to Dexcom Share servers)
daveklingler
@daveklingler
Sep 11 2017 20:56
@drnoname82_twitter Thanks! That's probably why I'm not having any luck. I've tried Dexcom Share2 (which can't see my G5 receiver) and the Dexcom G5 iPhone app. How do I go about uploading data with a G5 to the Dexcom Share servers?
Phil
@drnoname82_twitter
Sep 11 2017 21:01
@daveklingler So you want to use an iPhone, right? Then XDrip+ is not an option and you need to use the Dexcom G5 iphone app. Once it shows BG readings in the iphone app, you can invite someone to follow your BG data. The app will prompt you to create a Dexcom Share (not Clarity) account. The follower needs the Dexcom Follow app. Once the follower can see your BG on another phone, you can enter your Dexcom share account info in Nightscout and Nightscout will pull BG data from there.
drmartinezs
@drmartinezs
Sep 11 2017 21:03
how do i reinstal the wifi in my edison?
doesn`t work with edit-wifi
regdubbed
@regdubbed
Sep 11 2017 21:05
looks better better now... thanks...
daveklingler
@daveklingler
Sep 11 2017 21:06
@drnoname82_twitter Hm. I've been using the G5 app. I now have Dexcom Follow app following myself, with happy colored balloons in the corner of my G5 app. But I wasn't ever prompted to create a Share account. Is there a separate Dexcom Share website?
regdubbed
@regdubbed
Sep 11 2017 21:06
Was in the documentation, must have somehow missed it :(
Phil
@drnoname82_twitter
Sep 11 2017 21:09
@daveklingler We do not use Clarity. I think we were prompted to create the Dexcom account when we first installed the G5 app. I think this is where you can create/verify your account data: https://store.dexcom.com/user/login
(if you are in the US, Dexcom uses different servers outside the US)
daveklingler
@daveklingler
Sep 11 2017 21:10
@drnoname82_twitter Okay, googling "Dexcom Share" tells me that support for the app was discontinued in May and the functions were bundled into the G5 app. Let me try that address...
@drnoname82_twitter Hm. User name and password work at that address as well as the Clarity website. I get the feeling there's something obvious that I'm missing. I don't see my phone in the list of devices on the Clarity website, and the data isn't uploading from my phone to there.
Phil
@drnoname82_twitter
Sep 11 2017 21:15
Can someone follow you on another phone using the Follow App?
daveklingler
@daveklingler
Sep 11 2017 21:16
@drnoname82_twitter I'm guessing yes, since I can follow myself.
Phil
@drnoname82_twitter
Sep 11 2017 21:17
@daveklingler And did you enter your Dexcom account data in Nightscout?
daveklingler
@daveklingler
Sep 11 2017 21:21
@drnoname82_twitter Yes, and I've verified it by logging in and out of both Clarity and the regular Dexcom site.
@drnoname82_twitter But I can't help that think I'm not going to see any data in NS until the data starts uploading from my phone.
Well, I take that back. When I upload data from my receiver, it isn't showing up in NS either. So maybe I have at least two problems.
Phil
@drnoname82_twitter
Sep 11 2017 21:24
@daveklingler I sent you a private message
daveklingler
@daveklingler
Sep 11 2017 21:26
@drnoname82_twitter Hm. I don't actually know how to read it...
Phil
@drnoname82_twitter
Sep 11 2017 21:27
You will see it on the left side of your screen listed uner "All conversations"
thisistheusername
@thisistheusername
Sep 11 2017 23:03
@scottleibrand - if i run that invoke, i get a message saying "not an openaps environment. run openaps init". when i run openaps init, i get a list of files in red text and a "nothing added to commit but untracked files present" message. if i try the invoke again, i get the not an openaps environment message again.
thisistheusername
@thisistheusername
Sep 11 2017 23:14
I decided to delete the myopenaps installation I had and reinstall. It's been running for around 20 minutes doing an mmtune on each loop but it hasn't been able to pull a pump history - I'm still getting an Old pumphistory index error. I did recreate the required 512/712 settings files.
Are there any settings on the 712 pump itself that need to be updated to allow for the communications to occur?
thisistheusername
@thisistheusername
Sep 11 2017 23:41
I don't think this is talking to the pump, although mmtune seems to be picking a frequency.