These are chat archives for nightscout/intend-to-bolus

21st
Sep 2017
jaylagorio
@jaylagorio
Sep 21 2017 00:00
And I think I'm not asking the question right so I'll try to ask a different way: are you saying that the existing curve model isn't as accurate for the insulin I'm using and that the exponential model you're talking about, although used for that same insulin, is more accurate and that's why I should use it?
^^ Nevermind, I had to click through some links to answer both questions: https://github.com/openaps/oref0/pull/658#issuecomment-330910429
Just switched the curve. I probably won't get a whole day to loop until the weekend but I'll let you know how it turns out. I hope what I provided above was helpful, if there's somewhere you would prefer to see that posted I'm happy to do it
Scott Leibrand
@scottleibrand
Sep 21 2017 00:10
it is helpful. please do share as you collect more data on how well it works with your rapid-acting insulin
jaylagorio
@jaylagorio
Sep 21 2017 00:11
Will do!
Scott Leibrand
@scottleibrand
Sep 21 2017 00:12
I'll be particularly interested in what you see as far as average glucose and % time in range between manual bolusing and no-bolus eSMB
also, there are more improvements coming to eSMB
actually, some of those are ready to merge now.
scottleibrand @scottleibrand does so
jaylagorio
@jaylagorio
Sep 21 2017 00:14
Me too! I'll only be able to do that on the weekends because I can't loop during the work day, but that's something I'm particularly interested in. I'm totally OK with announcing meals and very interested in not doing meal boluses.
What are those improvements?
Scott Leibrand
@scottleibrand
Sep 21 2017 00:15
some minor tweaks to make it more aggressive up front and less aggressive later when it might make you go low
jaylagorio
@jaylagorio
Sep 21 2017 00:17
So you're saying you're making it exactly how I would do it if I were doing it manually haha
Scott Leibrand
@scottleibrand
Sep 21 2017 00:17
except for the part about overcommitting to too much insulin by doing it all up front. :)
also openaps/oref0#661
jaylagorio
@jaylagorio
Sep 21 2017 00:20
Both sounds reasonable haha
I'll do another setup/update before I try a whole day again
Scott Leibrand
@scottleibrand
Sep 21 2017 00:24
openaps/oref0#662 will be one of the more significant changes there
Scott Leibrand
@scottleibrand
Sep 21 2017 00:29
ok, PRs open for all those changes (https://github.com/openaps/oref0/pulls)
if anyone wants to see any of those merged to dev sooner, you can speed things up by reviewing the changes and giving them a :+1: if they look good to you
jaylagorio
@jaylagorio
Sep 21 2017 00:35
Thanks for 663!
zekeat09
@zekeat09
Sep 21 2017 01:14
Hi, i restart my openaps project again. Facing problem with my rig:
1) Edison. I bricked the edison when attempt to flash it, was power failure during flashing. Can’t connect it with putty anymore, but still can see it in the port. Anymore can advise to recover it ?
thisistheusername
@thisistheusername
Sep 21 2017 01:43

@Kdisimone "How closely did you use the docs to set up your 512 and rig?" I followed all of the directions directly as they are written.
"have you posted new versions of the files?" No I have not, but I updated them to turn the rf on. The files reflected it as off after I did a reinstall to verify my initial OpenAPS installation.

"Did you successfully edit your openaps aliases?" Yes.

"Did you set your remote devices to on in the pump and enter a dummy remote ID?" I did after seeing this question, I did not see this suggestion in anything else that I've read.

Dana Lewis
@danamlewis
Sep 21 2017 02:06
@thisistheusername see previous comments about pulling the latest master that has new fixes for x12
Dana Lewis
@danamlewis
Sep 21 2017 03:02
You'll want to change your API secret since you emailed it out to all
Scott Leibrand
@scottleibrand
Sep 21 2017 03:02
and that post has now been deleted, but I can't retract the emailed copies
Dana Lewis
@danamlewis
Sep 21 2017 03:04
@thisistheusername so I would go change API secret asap.
Scott Leibrand
@scottleibrand
Sep 21 2017 03:30
@thisistheusername I just updated the http://openaps.readthedocs.io/en/latest/docs/Build%20Your%20Rig/x12-users.html pages to correct the bg_targets_raw.json and basal_profile.json filenames to be what openaps actually expects. if you've already created those files, you'll need to mv (rename) them and re-copy them to ~/myopenaps/settings/ to get things working.
we're also putting together an update to oref0-setup that will do most of this automatically
Dana Lewis
@danamlewis
Sep 21 2017 03:32
It's also probably easiest to start over with the new API secret in oref0-setup and run fresh, anyway, then mv and re-copy the settings files
dmdfreak
@dmdfreak
Sep 21 2017 04:30
I had to change phones so I need to reset my mac for bluetooth tethering. Any chance I can just go into a file and just change the mac number and reboot?
Scott Leibrand
@scottleibrand
Sep 21 2017 04:33
i doubt it. that pairing is cryptographically stored on both the phone and the rig
dmdfreak
@dmdfreak
Sep 21 2017 04:34
I tried to rerun oref but it stops and says it counldn't pull the latest oref
thats why I thought I would try the changing it route :(
Dana Lewis
@danamlewis
Sep 21 2017 04:35
That usually means no wifi
dmdfreak
@dmdfreak
Sep 21 2017 04:36
says unable to connect to github.com but I have it connected directly with usb cables to this computer Im talking to you on.
Scott Leibrand
@scottleibrand
Sep 21 2017 04:36
that won't give it Internet
it just gives you local connectivity
you need to set up wifi before you can proceed
dmdfreak
@dmdfreak
Sep 21 2017 04:37
oh ok.
Im thinking I might have a bigger problem then. I think my wifi chip was knocked off.
dont suppose there is a work around to get it connected through wired tether?
I think I already have the latest updates. Anyway to skip the github check?
Dana Lewis
@danamlewis
Sep 21 2017 04:43
Just opened the PR for automating x12 setup. It's branched from dev, so it targets dev and will be part of 0.6.0 moving forward. openaps/oref0#665 (if anyone has a backup 512 that they want to test it on, that'd be great. See my earlier notes from today about 512's not being SMB compatible, though)
Scott Leibrand
@scottleibrand
Sep 21 2017 04:47
@dmdfreak you'd need to look at the bash script and comment things out or run things manually by copying and pasting out of there
or you could set up your laptop to do Internet Connection Sharing from its wifi to the interface the Edison is connected to, if you think you can figure that out
dmdfreak
@dmdfreak
Sep 21 2017 04:49
ok Ill look at the internet sharing first. I might have a better shot with that. I dont know that I could find the bash script
Scott Leibrand
@scottleibrand
Sep 21 2017 04:52
you might also be able to re-do the bluetooth tethering parts manually
it's more complicated than just changing the MAC address in crontab -e, but it shouldn't require re-running oref0-setup
dmdfreak
@dmdfreak
Sep 21 2017 04:52
thats kind of what I was hoping for to start with. Just wasnt sure where to start
Scott Leibrand
@scottleibrand
Sep 21 2017 04:53
(you'll also need to do the crontab -e bits if you're not re-running oref0-setup)
the rest of the bluetooth setup instructions from the docs should be something you can just re-run
dmdfreak
@dmdfreak
Sep 21 2017 04:54
I knew I would have to go through the rest of it but I thought the mac address HAD to be changed before I could do that part
when I run crontab -e it tells me to choose 1 of 3
telling me to select editor
Scott Leibrand
@scottleibrand
Sep 21 2017 04:55
pick nano if you aren't sure
dmdfreak
@dmdfreak
Sep 21 2017 04:56
just realized what I was choosing. lol I chose nano
dmdfreak
@dmdfreak
Sep 21 2017 05:04
mac changed. Thanks scott. trying the rest now
Jacob H
@jdhigh
Sep 21 2017 05:21
Is looping affected by unacknowledged alerts on a medtronic pump? Getting this a lot. BG data is too old (it's probably this), or clock set incorrectly. The last BG data was read at Wed Sep 20 2017 23:36:00 GMT-0400 (EDT) but your system time currently is Thu Sep 21 2017 01:20:44 GMT-0400 (EDT)
"reason": "BG data is too old (it's probably this), or clock set incorrectly. The last BG data was read at Wed Sep 20 2017 23:36:00 GMT-0400 (EDT) but your system time currently is Thu Sep 21 2017 01:20:44 GMT-0400 (EDT)"
Checking system clock against pump clock:
Checking deliverAt: null is within 1m of current time: Thu Sep 21 01:20:45 EDT 2017
date: invalid date ‘null’
SMB pump-loop failed.
Dana Lewis
@danamlewis
Sep 21 2017 05:32
No
Jacob H
@jdhigh
Sep 21 2017 05:35
Thanks. Ok, does a low reservoir spawn problems with rig looping? O
I've rebooted the rig. Still not looping.
dmdfreak
@dmdfreak
Sep 21 2017 05:35
thanks @scottleibrand that did the trick. I'm back up and running!
Jacob H
@jdhigh
Sep 21 2017 05:41
How strange! After 2 hours of non-looping, it decides to start looping again. I did 3 things. I rebooted rig 15 minutes ago. I manually bolused using the pump. I added carbs into the pump (just 5). Could ANY of those things "wake" the pump up or cause looping to resume? Still scratching my head on this one...
Martin Haeberli
@mhaeberli
Sep 21 2017 05:43
Asked and answered - but answer forgotten. Assume I’m low. Already zero temp. I’m chugging 15g carbs. How do I tell OpenAPS so it knows for autotune / autosens but NOT have it cancel zero temp yet. I’m 60, or 70, and I want to wait until, say , 110 before basal resumes. I don’t yet want it to high temp me, say, until I’m at 150...
Tia
Dana Lewis
@danamlewis
Sep 21 2017 05:46
@jdhigh It's likely you were having connectivity issues (thus not getting bgs) and the reboot helped
@mhaeberli enter carbs and set a high temp target if you want to be that specific about the behavior.
Jacob H
@jdhigh
Sep 21 2017 05:47
You could set an ifttt. http://openaps.readthedocs.io/en/latest/docs/Customize-Iterate/ifttt-integration.html?highlight=ifttt Low Treatment with a 60 min high target to help recovery
^ Could change that one to suit your needs.
@danamlewis Thanks. If it was connectivity, I wish I knew the cause. The rig and the pump were right next to each other for 2 hours. (set on my computer desk.)
Martin Haeberli
@mhaeberli
Sep 21 2017 05:50
@danamlewis @jdhigh thx!
Dana Lewis
@danamlewis
Sep 21 2017 05:57
@jdhigh are you a Medtronic CGM-er?
None of those other things will make a difference - those are coincidences. Only thing from pump to block looping would be low battery, wrong temp type, square wave bolus, etc.
The no bg data usually is internet connectivity issues
ejoe132
@ejoe132
Sep 21 2017 13:28
Having some type of problem
oops sent too soon. but this is what my logs are saying Starting supermicrobolus pump-loop at Thu Sep 21 09:21:02 EDT 2017 with 24 second wait_for_silence:
Waiting up to 4 minutes for new BG: glucose.json newer than pump_loop_completed
Radio ok. Listening: .No pump comms detected from other rigs
Preflight OK. Old settings refresh
Starting supermicrobolus pump-loop at Thu Sep 21 09:25:29 EDT 2017 with 15 second wait_for_silence:
Waiting up to 4 minutes for new BG: glucose.json newer than pump_loop_completed
mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
Listening for 30s silence before mmtuning: .No pump comms detected from other rigs
mmtune: "916.756", 5, -58 Listening: .No pump comms detected from other rigs
Preflight OK. Old settings refreshISF of null is not supported
ed. glucose.json newer than pump_loop_completed.
Temp refresh at node.js:906:3
ed
Could not parse input data: [SyntaxError: /root/edisonone/monitor/iob.json: Unexpected end of input]
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 48, in main
reporters.Reporter(report, device, task)(output)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/reporters/init.py", line 33, in call
self.blob = self.serialize(data)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/reporters/init.py", line 31, in serialize
return self.method.serialize(render(data), self)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/process.py", line 56, in prerender_json
return json.loads(data)
File "/usr/lib/python2.7/json/init.py", line 338, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
Unsuccessful supermicrobolus pump-loop at Thu Sep 21 09:27:41 EDT 2017
Looks like some kind of input error?
zekeat09
@zekeat09
Sep 21 2017 13:52
Hi, I am using raspberry pi 3 for openaps. Using WW pump. I found setup didn’t ask to enter “WW”. Even i change in oref0-reunagain.sh and also in pump.ini, there is still error for mmtune. No communication between pump and raspberry pi3.
Any advise ?
Luis Betancourt
@betluis
Sep 21 2017 15:31
hello, I am reaching our for advice here about eating soon approach when BG is low... so, the question is, when BG is say 80 or even lower, my daughter "feels" she does not need upfront insulin for the meal and frequently goes high (above 200) because of this, in fact the IOB at this point is typically negative coming from a period of 0 temp.. I have been asking her to use eating soon approach (superbolus approach) but in this scenario that becomes confusing. Any comments? what would be the wise advice to give here? I appreciate your help.
ejoe132
@ejoe132
Sep 21 2017 15:36
@betluis My opinion would be use eating soon mode and do a pre bolus (if thats what you normally do. Also depends what your target generally is. If you aim for 120 that would affect what I would do vs if I have a general target of 90
Luis Betancourt
@betluis
Sep 21 2017 15:37
thanks... but what would eating soon do (target temp of 80) if you are right at 80 or perhaps 75?
ejoe132
@ejoe132
Sep 21 2017 15:44
@betluis My understanding would be that it would just target you to 80, so if 75 and based on COB, IOB it would likely be about programmed basal rate, effective no temp basal required. But it will enable SMB to operate based on your input carbs or if it sees a rise that it believes is an unannounced meal
Luis Betancourt
@betluis
Sep 21 2017 15:51
@ejoe132 thanks a lot, I think I will put this question in the google group just in case other people may want to think about this or contribute... I get your point. I have a bit of difficulty making here understand she needs upfront insulin even though she is low and if eating soon won't SMB when low, then you need pre-bolus which is difficult to accept when already low...
get me?
garykidd
@garykidd
Sep 21 2017 15:57
enableUAM enables detection of unannounced meal (UAM) [carb absorption]. I bracketed carb absorption but is it really just detecting BG rising?...which may or may not be caused by carbs being absorbed...or other factors?
dmdfreak
@dmdfreak
Sep 21 2017 16:09
I have bluetooth tethering back on my new phone which is the same brand and model that I had before. I can get it to pair and work fine, but when android eventually drops the signal, it doesn't reconnect like it did before. I have BTautotether installed. Anybody have any ideas? only thing I changed on the rig was the Mac # for the phone.
Scott Leibrand
@scottleibrand
Sep 21 2017 16:24
@garykidd we assume that large BG rises relative to what is expected from insulin activity are usually due to carb absorption. For other kinds of spikes, UAM will respond by assuming that the positive deviations causing the spike will continue. There are some improvements in dev to make UAM smarter about assuming that short sharp rises won't continue as long as slow steady ones, which is intended to help with fast carb spikes, but would probably also reduce any overreaction to adrenaline spikes etc.
@thisistheusername looks like the rig simply can't get a reply from that pump on the 916MHz band. Are you sure your pump isn't using a WW band (868)?
Dana Lewis
@danamlewis
Sep 21 2017 16:36
@betluis I still do an eating soon target of 80, and it'll begin to help carve away at any negative iob that's accumulated from trying to prevent or mitigate that low
Luis Betancourt
@betluis
Sep 21 2017 16:42
@danamlewis thanks.. I was thinking on a procedure like this:
1- Activate eating soon and take a few carbs to correct the low BG
2- Wait until IOB is positive (>1?)
3- Eat your meal with its associated bolus normally
makes sense?
Dana Lewis
@danamlewis
Sep 21 2017 16:49
I don't think your iob will get >1, for that to work, unless you also do a meal bolus. >0 might be more reasonable
But may not always get to >0, depending on sensitivities to predictions. So I'd focus on a few carbs, ES, and then a portion of meal bolus and starting eating. And can do second part of bolus once you see an uptick and feel comfortable with it
Or, let the rig deal with doling the rest out as needed
David
@davidkeddydb
Sep 21 2017 16:51
I am trying to get my Edison/TI stick up on 6.0dev but I am getting the device full error and this is what I am showing
rootfs 1.4G 1.4G 0 100% /
/dev/root 1.4G 1.4G 0 100% /
devtmpfs 480M 0 480M 0% /dev
tmpfs 97M 332K 96M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 193M 0 193M 0% /run/shm
tmpfs 481M 12K 481M 1% /tmp
/dev/mmcblk0p7 32M 5.3M 27M 17% /boot
/dev/mmcblk0p10 1.3G 2.0M 1.3G 1% /home
I thought I cleared most junk out but apparently I missed something. I only have myopenaps and src as directories
Luis Betancourt
@betluis
Sep 21 2017 17:05
@danamlewis ok, very good... but please clarify to me, what is the purpose of using ES in this situation?
enable SMB logic?
Dana Lewis
@danamlewis
Sep 21 2017 17:19
No, to start chipping away at the negative iob that's likely accumulated
Luis Betancourt
@betluis
Sep 21 2017 17:39
ok
thanks a lot!
Scott Leibrand
@scottleibrand
Sep 21 2017 17:43
@davidkeddydb there is a section in the docs for figuring out what's filling up your / partition
thisistheusername
@thisistheusername
Sep 21 2017 17:49
@scottleibrand The pump ref is MMT-712NA. I can do a reinstall with WW to see if anything changes.
Dana Lewis
@danamlewis
Sep 21 2017 17:51
@thisistheusername you never responded: did you pull a fresh master after yesterday's patch release?
David
@davidkeddydb
Sep 21 2017 17:51
@scottleibrand I am there and looking at files. Not sure what I can safely delete
705.9MiB [##########] /usr
212.6MiB [### ] /var
180.9MiB [## ] /root
54.5MiB [ ] /lib
6.7MiB [ ] /sbin
6.1MiB [ ] /bin
5.2MiB [ ] /boot
3.2MiB [ ] /etc
332.0KiB [ ] /run
72.0KiB [ ] /opt
28.0KiB [ ] /home
8.0KiB [ ] /tmp
Dana Lewis
@danamlewis
Sep 21 2017 17:52
@thisistheusername also, did you change your API secret?
David
@davidkeddydb
Sep 21 2017 17:52
Most is /usr which is
284.8MiB [##########] /lib
281.8MiB [######### ] /share
66.7MiB [## ] /bin
43.7MiB [# ] /local
22.8MiB [ ] /include
6.1MiB [ ] /sbin
e 4.0KiB [ ] /src
e 4.0KiB [ ] /games
Scott Leibrand
@scottleibrand
Sep 21 2017 17:54
@davidkeddydb you didn't run the command in the docs.
It shows you three levels deep.
David
@davidkeddydb
Sep 21 2017 17:56
@scottleibrand I did try that and it gives me just a cursor, well an > and nothing so I tried this which was prior cd / && sudo ncdu
@scottleibrand Ok, ran again and I got 282M ./usr/share
285M ./usr/lib
706M ./usr
118M ./root/src/decocare
163M ./root/src
181M ./root
146M ./var/lib/apt
160M ./var/lib
213M ./var
1.2G .
David
@davidkeddydb
Sep 21 2017 18:01
@scottleibrand Is there an ideal amount of free space that I should be aiming for of the total 1.4g on the Edison?
marius a. eriksen
@mariusae
Sep 21 2017 18:17
interesting potential hardware platform for openaps: http://beagleboard.org/pocket
Scott Leibrand
@scottleibrand
Sep 21 2017 18:23
@davidkeddydb I can't help with that unless you actually paste the command you're running and the output
I'm referring to this one: du -xh -d 3 | egrep "[1-9][0-9][0-9]M|[0-9]G"
if you're using ndcu, I think that one is interactive, and you're supposed to use the arrow keys to drill down on which folders are too big
Dana Lewis
@danamlewis
Sep 21 2017 18:25
@mariusae cool to see more open source hardware groups!
Scott Leibrand
@scottleibrand
Sep 21 2017 18:25
you probably won't get more than about 300MB freed up:
root@edison-eb ~/myopenaps # df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 1.4G 1.1G 265M 80% /
David
@davidkeddydb
Sep 21 2017 19:05
@scottleibrand Fingers crossed, think I got the space issue resolved. If no, I will reflash it
If I understand correctly, you can just add maxSMBBasalMinutes to the preferences.json file to activate it rather than having to change it in the code directly?
thisistheusername
@thisistheusername
Sep 21 2017 19:13
@danamlewis yes and yes. I reposted a redacted version of the deleted message on the Google groups topic.
Scott Leibrand
@scottleibrand
Sep 21 2017 19:24
@davidkeddydb correct, you shouldn't need to modify the code at all, just add it to preferences
@thisistheusername I would stop your cron and troubleshoot manually. if you can't get openaps mmtune or openaps use pump model to work, then you might have a mis-entered serial number, a frequency mismatch (NA vs. WW), or a bad radio on either the EB or the pump.
garykidd
@garykidd
Sep 21 2017 19:28
@scottleibrand I guess I was mostly think ing about the techinical aspect understanding that we're assuming the BG rises are related to carb absorpotion--but was just confirming how it is identified...just a large deviation in BG from what was expected.......and the underlying reason why I was asking is that a dying infusion set, or other obstruction or even stress/hormone/illness etc.
Scott Leibrand
@scottleibrand
Sep 21 2017 19:31
@garykidd most of those things (excluding adrenaline spikes) are very slow compared to carbs, so UAM's response to them will be quite muted
@davidkeddydb if you think SMB should be running but it's not, check that you have it enabled in preferences.json for the situation at hand
David
@davidkeddydb
Sep 21 2017 19:32
@scottleibrand Yeah, holy mackerel the stupid mistakes I am making today
Scott Leibrand
@scottleibrand
Sep 21 2017 19:33
so many things to remember to check. :)
Dana Lewis
@danamlewis
Sep 21 2017 19:47
I just updated the 0.6.0 PR with notes on how to install 0.6.0 - see the bottom of this comment: https://github.com/openaps/oref0/pull/650#issue-256564183
(obviously, I keep updating this comment as we document things, so if you're working through 0.6.0 or plan to in the future, make sure to refresh or reload that page and see what else has been added)
visual of that section added
Screen Shot 2017-09-21 at 12.47.52 PM.png
Dana Lewis
@danamlewis
Sep 21 2017 19:56
@davidkeddydb your last post inspired the 5 addition to that list! let me know if I left anything else out
garykidd
@garykidd
Sep 21 2017 21:07
blob
days like today rock---and not impossible to replicate...getting better
Dana Lewis
@danamlewis
Sep 21 2017 21:08
<3 <3 <3 :confetti_ball:
Scott Leibrand
@scottleibrand
Sep 21 2017 21:08
:-D
Diabetic_Dude
@diabetic_dude_twitter
Sep 21 2017 21:09
wow
@garykidd only one meal in 12 hours?
dmdfreak
@dmdfreak
Sep 21 2017 21:13
anyone have any ideas on why bluetooth wont auto reconnect? Wifi is turned off. Should be connecting, but for some reason I'm having to manually connect.
Dana Lewis
@danamlewis
Sep 21 2017 21:17
@dmdfreak wifi is turned off on what device?
and what kind of os?
dmdfreak
@dmdfreak
Sep 21 2017 21:21
on my rig. I use it only through bluetooth
its been that way for months. No problem until I had to get a RMA for my phone.
Its the 2017 edison board. Everything is from the openaps doc.
running dev. But not the .60 you guys are talking about right now. wifi chip got knocked off so I can't update. I have another CPU oredered
Scott Leibrand
@scottleibrand
Sep 21 2017 21:30
what are you doing to manually connect?
dmdfreak
@dmdfreak
Sep 21 2017 21:31
sudo bt-pan mac address something like that. Going off memory
this ..... sudo bt-pan client AA:BB:CC:DD:EE:FF
Scott Leibrand
@scottleibrand
Sep 21 2017 21:33
and what do you have in crontab -l?
(oref0-online)
dmdfreak
@dmdfreak
Sep 21 2017 21:35
meaning the mac address? 40:4E:36:05:A1:9B
Scott Leibrand
@scottleibrand
Sep 21 2017 21:35
no, the whole command
you should be able to run that command manually instead of sudo bt-pan and it should connect you
I would use bt-pan to disconnect, and then see if you can get it to come up with that oref0-online command
dmdfreak
@dmdfreak
Sep 21 2017 21:38
ok. give me a sec. but will that have an effect on auto reconnect when the phone drops the connecting?
that threw errors.

At Thu Sep 21 16:39:37 CDT 2017 my local IP is: Device "bnep0" does not exist.

At Thu Sep 21 16:39:37 CDT 2017, my wifi network name is , and my public IP is:
At Thu Sep 21 16:39:37 CDT 2017, my wifi network name is , and my public IP is:
At Thu Sep 21 16:39:37 CDT 2017 my public IP is:
Error, connecting BT to 80:7a:bf:07:3e:84Traceback (most recent call last):
File "/usr/local/bin/bt-pan", line 228, in <module>
if name == 'main': sys.exit(main())
File "/usr/local/bin/bt-pan", line 188, in main
dev_remote = find_device(opts.remote_addr, devs.values()[0])
File "/usr/local/bin/bt-pan", line 53, in find_device
return find_device_in_objects(get_manager().GetManagedObjects(), device_address, adapter_pattern)
File "/usr/local/bin/bt-pan", line 68, in find_device_in_objects
raise BTError('Bluetooth device not found')
main.BTError: Bluetooth device not found
Traceback (most recent call last):
File "/usr/local/bin/bt-pan", line 228, in <module>
if name == 'main': sys.exit(main())
File "/usr/local/bin/bt-pan", line 188, in main
dev_remote = find_device(opts.remote_addr, devs.values()[0])
File "/usr/local/bin/bt-pan", line 53, in find_device
return find_device_in_objects(get_manager().GetManagedObjects(), device_address, adapter_pattern)
File "/usr/local/bin/bt-pan", line 68, in find_device_in_objects
raise BTError('Bluetooth device not found')
main.BTError: Bluetooth device not found
, getting bnep0 IPCannot find device "bnep0"

At Thu Sep 21 16:39:38 CDT 2017, my wifi network name is , and my public IP is:
Error, cycling networking
Stopping networking (via systemctl): networking.serviceWarning: Unit file of networking.service changed on disk, 'systemctl daemon-reload' recommended.
.
Starting networking (via systemctl): networking.serviceWarning: Unit file of networking.service changed on disk, 'systemctl daemon-reload' recommended.
.
and getting new wlan0 IP
Removed stale PID file
Finished oref0-online.

Scott Leibrand
@scottleibrand
Sep 21 2017 21:41
hmm, oref0-online errored with find device "bnep0" but sudo bt-pan worked?
dmdfreak
@dmdfreak
Sep 21 2017 21:41
yes sir
Scott Leibrand
@scottleibrand
Sep 21 2017 21:42
ok, if that's reproducible, then you need to figure out what oref0-online is doing that's different from what you did manually
it's a bash script, so you should be able to copy and paste much of what it's doing directly onto the command line
dmdfreak
@dmdfreak
Sep 21 2017 21:43
ok. I'll play with that.
Thanks man. Off to work sadly. Dying to get it back up and going.
Scott Leibrand
@scottleibrand
Sep 21 2017 21:46
laters
Luuc
@luucvp_twitter
Sep 21 2017 23:02
Any thoughts on using openAPS with novonordisks new FIASP insulin? Just wondering
Cfomodz
@Cfomodz
Sep 21 2017 23:03
I just got my 715 and I was wondering if anyone has info on the possible wait time for stock for the board pre-flashed
Dana Lewis
@danamlewis
Sep 21 2017 23:04
@luucvp_twitter many of us are using; working well, especially with exponential curves in the dev branch. see openaps/oref0#650 for details
@Cfomodz seems like people get it in a few days to a week, based on past experience. I'd go ahead and order, or reach out to them and ask
Cfomodz
@Cfomodz
Sep 21 2017 23:05
Oh, sorry - I mean to ask when it is out of stock if anyone has signed up to be notified and knows about how often they stock
Dana Lewis
@danamlewis
Sep 21 2017 23:05
it seems like they just post small batches at a time, but actually have stock, so same - few days to a week - is likely
Cfomodz
@Cfomodz
Sep 21 2017 23:06
Okay. Signed up thank you
Luuc
@luucvp_twitter
Sep 21 2017 23:06
Thank you Dana!
Dana Lewis
@danamlewis
Sep 21 2017 23:10
:+1: :+1:
jaylagorio
@jaylagorio
Sep 21 2017 23:30
@scottleibrand More feedback on log output (just did a pull on the newest 0.6.0 dev):
Waiting up to 4 minutes for new BG: ...................glucose.json newer than pump_loop_completed                             
Radio ok. Listening: .No pump comms detected from other rigs                                                                   
Preflight OK. Profile less than 60m old. pump_loop_completed less than 10m ago. Refreshed pumphistoryRemoved duplicate bolus/ca
rb entries:1                                                                                                                   
 and meal.json                                                                                                                 
Checking pump clock: "2017-09-21T19:28:07-04:00" is within 1m of current time: Thu Sep 21 19:28:15 EDT 2017
Note the lack of \r\n after Refreshed pumphistory
And weirdness around and meal.json unless I'm misunderstanding what that's supposed to look like
jaylagorio
@jaylagorio
Sep 21 2017 23:45
Did you mean to have openaps/oref0#663 in what I just pulled? It doesn't look like it came down.
Scott Leibrand
@scottleibrand
Sep 21 2017 23:48
If the PR is still open (green), then no. Someone needs to :+1: it if you want it merged into dev sooner.
@jaylagorio the Removed duplicate bolus/carb entries:1 is not supposed to be there. without that, it looks like:
Preflight OK. Profile less than 60m old. Temp duration >20m. Refreshed pumphistory and meal.json
Checking pump clock: "2017-09-21T16:47:56-07:00" is within 1m of current time: Thu Sep 21 16:47:26 MST 2017
when you have something that inserts itself in between Refresh and ed it's a warning. the Removed duplicate one is pretty innocuous, but you still might want to make sure it's not missing any IOB or COB.
jaylagorio
@jaylagorio
Sep 21 2017 23:56
Ah, gotcha. Just thumbs up'd that one and openaps/oref0#661
Although that one might have gone in already?
Scott Leibrand
@scottleibrand
Sep 21 2017 23:58
yeah, if it shows up red in Gitter it's already merged/closed
jaylagorio
@jaylagorio
Sep 21 2017 23:58
Nice!
Scott Leibrand
@scottleibrand
Sep 21 2017 23:58
just merged 663, thx
jaylagorio
@jaylagorio
Sep 21 2017 23:59
Awesome, thanks! I should be able to test tomorrow during dinner.