These are chat archives for nightscout/intend-to-bolus

23rd
Sep 2017
Jacob H
@jdhigh
Sep 23 2017 00:02

@danamlewis I followed this from https://openaps.readthedocs.io/en/latest/docs/Customize-Iterate/update-your-rig.html Optional: To get on “dev” branch to test even more recently added new stuff

Or, if the feature you want hasn’t been released yet, and you want to test the latest untested development version of oref0, run:

cd ~/src/oref0 && git checkout dev && git pull
npm run global-install

Am I in trouble?
Dana Lewis
@danamlewis
Sep 23 2017 00:05
No. I just added more instructions in the PR to make it easier, especially if you want to switch to no-git flow
Still read the PR though since there's so much changed, and remember your preferences after you rerun setup
Brian Rabinovitz
@bdr1177
Sep 23 2017 00:34
@danielharrelson Pointed out a typo and minor change I need to make to #1042. Is there a way to make the fix without starting from scratch with a new pull request?
Dana Lewis
@danamlewis
Sep 23 2017 00:36
Yep. Just make the change in your same fork and the PR will pull that in automatically
Brian Rabinovitz
@bdr1177
Sep 23 2017 00:41
:+1:
Jacob H
@jdhigh
Sep 23 2017 01:04
Just some quick thoughts after installing dev. For preferences file, would it be better to add in the new options along with the default values? Something like the following lines: insulingPeakTime = "" and useCustomPeakTime=false and maxSMBBasalMinutes = 30?
jaylagorio
@jaylagorio
Sep 23 2017 01:05
I think those aren't included so that new users don't think they have to configure them right out of the gate
As they do more research and they find out about the settings then they can start to question them
At least that was the justification I saw in a ticket somewhere, I think it made sense
Jacob H
@jdhigh
Sep 23 2017 01:05
Well, by putting them in with the default values, they won't be turned on unless the user does the research. Right?
Sorry- didn't mean to sound like I'm debating— I'm glad that it's been thought of before. I trust the hive mind. :)
jaylagorio
@jaylagorio
Sep 23 2017 01:06
As they start digging in they think they have to touch every value and they start asking questions about it. As they're beginning we can ease that mental burden by leaving it off to the side until they discover it later.
Hey, debate all you want! I'm not in control of anything so there's not much you can get out of me haha
It's better to bring something up in case someone else hasn't. Asking questions is the right thing to do!
Scott Leibrand
@scottleibrand
Sep 23 2017 01:55
@jaylagorio that is a very good explanation of what we're trying to accomplish with displayedDefaults: thanks.
jaylagorio
@jaylagorio
Sep 23 2017 02:01
You got it!
wharper11
@wharper11
Sep 23 2017 09:01
hi! anyone around? having a NS display issue but mlab size is only 240 and I see no future treatments. any idea what else it could be? should I reduce mlab size anyway?
Phil
@drnoname82_twitter
Sep 23 2017 10:04
OpenAPS dev branch needs the latest Nightscout dev or master version
wharper11
@wharper11
Sep 23 2017 10:05
I'm on master so update NS?
Phil
@drnoname82_twitter
Sep 23 2017 10:07
If you are an OpenAPS dev, that is most likely the solution
wharper11
@wharper11
Sep 23 2017 10:08
I'm on OpenAPS master, I'll give it a try. thanks!
wharper11
@wharper11
Sep 23 2017 10:43
Started getting these errors. I have updated the rig to latest master, rebooted and everything else seems to be in order. any other ideas? Sep 23 00:12:27 liamrigthree pump-loop.log: Could not parse input data: [SyntaxError: /root/myopenaps/monitor/iob.json: Unexpected end of input]
Sep 23 00:12:52 liamrigthree pump-loop.log: ed pumphistoryError: carb_ratio undefined out of bounds
I see... it's a carb ratio error.
wharper11
@wharper11
Sep 23 2017 10:56
checked the pump and carb ratio is set. I'm still getting the same syntax error. any ideas?
Brian Rabinovitz
@bdr1177
Sep 23 2017 12:20
When running OpenAPS, how do you remove air bubbles from the tubing? Can I just prime it out?
jaylagorio
@jaylagorio
Sep 23 2017 13:34
I've had good luck priming them out, I think the counter tends to get around 8 U if the bubbles are down near the base of the tube. Make sure you're not connected to it of course!
LinnBee
@petrichordb
Sep 23 2017 13:35
Can anyone help with my query I posted at 00:02 please. Thanks!
jaylagorio
@jaylagorio
Sep 23 2017 13:36
@petrichordb I don't see anything between 22:01 and 05:01, can you repost?
LinnBee
@petrichordb
Sep 23 2017 13:36
Newbie. First set up OpenAPS. Wifi set up Message that I can't seem to get past " Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 213.120.234.146
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|213.120.234.146|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
root@ubilinux:~# " Thank you.
jaylagorio
@jaylagorio
Sep 23 2017 13:37
Are you using an Edison?
LinnBee
@petrichordb
Sep 23 2017 13:37
Yes
jaylagorio
@jaylagorio
Sep 23 2017 13:37
And you've flashed the Linux image successfully?
LinnBee
@petrichordb
Sep 23 2017 13:38
It was pre-flashed,
jaylagorio
@jaylagorio
Sep 23 2017 13:38
As in without errors or warnings
Ah, OK
What kind of Wifi are you using? Is it the kind where after you connect to it you get a web page that you have to enter a username/password?
LinnBee
@petrichordb
Sep 23 2017 13:39
Not sure what you mean. Connects automatically. It's a UK BT home hub this with a Wireless SSID and key plus an admin password!
jaylagorio
@jaylagorio
Sep 23 2017 13:41
I'll give you an example from over here in the US - if I have Comcast for Internet and I go to my friend's house, and he also has Comcast for Internet, I can connect to his router using a guest name and use my username and password to login and get Internet. I would enter that username and password into a web page, he doesn't have to share his Wifi password with me. Is that how BT is set up?
LinnBee
@petrichordb
Sep 23 2017 13:43
Don't believe so. I see neighbours wifi on my screen and there is no guest option. At others houses I would use their wifi password but perhaps that is just ignorance! Can I attach screen shots here?
jaylagorio
@jaylagorio
Sep 23 2017 13:45
Can you run the following on the Edison and copy the output here?
wget --spider https://www.google.com
LinnBee
@petrichordb
Sep 23 2017 13:48
OK. Naturally this is not straightforward as now the PTY error is coming up so I am swapping cables.
OK it is doing stuff now.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@ubilinux:~# wget --spider https://www.google.com
Spider mode enabled. Check if remote file exists.
--2017-09-23 13:49:57-- https://www.google.com/
Resolving www.google.com (www.google.com)... 216.58.211.100, 2a00:1450:400e:800::2004
Connecting to www.google.com (www.google.com)|216.58.211.100|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://www.google.co.uk/?gfe_rd=cr&dcr=0&ei=iWbGWcjKKfCE8Qfz276gDg [following]
Spider mode enabled. Check if remote file exists.
--2017-09-23 13:50:01-- https://www.google.co.uk/?gfe_rd=cr&dcr=0&ei=iWbGWcjKKfCE8Qfz276gDg
Resolving www.google.co.uk (www.google.co.uk)... 216.58.211.99, 2a00:1450:400e:80a::2003
Connecting to www.google.co.uk (www.google.co.uk)|216.58.211.99|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

root@ubilinux:~#

Phil
@drnoname82_twitter
Sep 23 2017 13:52
Shouldn't it also be jubilinux and not ubilinux?
LinnBee
@petrichordb
Sep 23 2017 13:53
Well I did wonder but that is a default that comes up.
jaylagorio
@jaylagorio
Sep 23 2017 13:53
Yeah, I think that's the system name
Next command:
uname -a
What's the result of that?
LinnBee
@petrichordb
Sep 23 2017 13:53
I got it from the US recommended place.
root@ubilinux:~# uname -a
Linux ubilinux 3.10.17-poky-edison+ #6 SMP PREEMPT Wed Mar 23 21:47:59 EDT 2016 i686 GNU/Linux
root@ubilinux:~#
jaylagorio
@jaylagorio
Sep 23 2017 13:54
Yup, that's the jubilinux build
Walking back a little farther, what command are you pasting in that produces the error you're seeing?
LinnBee
@petrichordb
Sep 23 2017 13:55

The box on this page. You want the whole thing? Copy and paste to run the wifi and oref0-setup scripts

Copy this text (all of it in the box):

jaylagorio
@jaylagorio
Sep 23 2017 13:58
Do this: cd /tmp/ and make sure you see something like root@ubilinux:/tmp#
Now this: wget --no-check-certificate https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
LinnBee
@petrichordb
Sep 23 2017 13:58
Yes, last bit comes up.
Ugly. Looks like same stuff. root@ubilinux:~# uname -a
Linux ubilinux 3.10.17-poky-edison+ #6 SMP PREEMPT Wed Mar 23 21:47:59 EDT 2016 i686 GNU/Linux
root@ubilinux:~# cd /tmp/
root@ubilinux:/tmp# wget --no-check-certificate https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
--2017-09-23 13:59:10-- https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 213.120.234.146
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|213.120.234.146|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
root@ubilinux:/tmp# vim /usr/sbin/fw_printenv
jaylagorio
@jaylagorio
Sep 23 2017 14:00
OK, let's try this:
curl https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh > openaps-install.sh
Then ls and you should see openaps-install.sh in that directory
LinnBee
@petrichordb
Sep 23 2017 14:02
Something nasty is happening before i can do that. Screen appears to be full of spam stuff @' s and what not. Should I close it and get a new one?
^?ELF^A^A^A^@^@^@^@^@^@^@^@^@^B^@^C^@^A^@^@^@v<8c>^D^H4^@^@^@àZ^@^@^@^@^@^@4^@ ^@^H^@(^@ ^@^_^@^F^@^@^@4^@^@^@4<80>^D^H4<80>^D^H^@^A^@^@^@^A^@^@^E^@^@^@^D^@^@^@^C^@^@^@4^A^@^@4<81>^D^H4<81>^D^H^S^@^@^@^S^@^@^@^D^@^@^@^A^@^@^@^A^@^@^@^@^@^@^@^@<80>^D^H^@<80>^D^HôN^@^@ôN^@^@^E^@^@^@^@^P^@^@^A^@^@^@^@P^@^@^@Ð^D^H^@Ð^D^H;^D^@^@;^D^@^@^F^@^@^@^@^P^@^@^B^@^@^@^TP^@^@^TÐ^D^H^TÐ^D^HÈ^@^@^@È^@^@^@^F^@^@^@^D^@^@^@^D^@^@^@H^A^@^@H<81>^D^HH<81>^D^HD^@^@^@D^@^@^@^D^@^@^@^D^@^@^@Påtd^HF^@^@^HÆ^D^H^HÆ^D^H4^A^@^@4^A^@^@^D^@^@^@^D^@^@^@Qåtd^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^F^@^@^@^P^@^@^@/lib/ld-linux.
jaylagorio
@jaylagorio
Sep 23 2017 14:02
....whoa
LinnBee
@petrichordb
Sep 23 2017 14:03
I've got more. You want it LOLS.
jaylagorio
@jaylagorio
Sep 23 2017 14:03
Get a new one, but I think there might be an underlying issue.
First thing you'll want to do in the new window is cd /tmp/
Then curl https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh > openaps-install.sh
LinnBee
@petrichordb
Sep 23 2017 14:03
Will I reboot Edison too?
jaylagorio
@jaylagorio
Sep 23 2017 14:03
Why not - do that, it can't hurt
After the curl command do ls and see if the file is there
LinnBee
@petrichordb
Sep 23 2017 14:05
PTY error again. Swap cables about again? Seems stupid.
jaylagorio
@jaylagorio
Sep 23 2017 14:07
I'm going to be honest here - I think there's a problem with the image flashed to the device but we can keep trying
Keep the cable, maybe unplug/replug to clear
LinnBee
@petrichordb
Sep 23 2017 14:09
Yes, have done that. Sorry, is taking so long. I have to cut n paste to get back in it using the sudo thing as I've not got very far yet.
Its saying it cannot execute the dev/tty.usbserial
No such file or directory.
jaylagorio
@jaylagorio
Sep 23 2017 14:11
Aaaaand now you're past my rudimentary knowledge of Linux troubleshooting
If it were me I would try reflashing the device
LinnBee
@petrichordb
Sep 23 2017 14:11
It means i cannot get to the eidson
jaylagorio
@jaylagorio
Sep 23 2017 14:12
Right, I know what it means, just not how to fix it
LinnBee
@petrichordb
Sep 23 2017 14:12
So if I was to do that I have to clean the eidson first.
jaylagorio
@jaylagorio
Sep 23 2017 14:15
Right, the flashing process would clear the whole thing and you'd be starting over, but I think you'd have a higher chance of success
LinnBee
@petrichordb
Sep 23 2017 14:17
Yes, might be worth a shot. Thank you very much for your time. Out of interest, are there any silly newbie things I should check? Ports at back - doesnt matter which one, does it, battery connected/charged etc. Anything I could have forgotten?
Ports on my mac, I meant.
jaylagorio
@jaylagorio
Sep 23 2017 14:20
The USB port on your Mac shouldn't matter, the port on the Edison board does but I think since you've been getting the command line you have the right one. I'm not sure what else you might want to check on the Mac since that's also not my area of expertise but it sounds like what you're doing on the Mac is correct
LinnBee
@petrichordb
Sep 23 2017 14:21
OK, Thank you very much. Will revisit later on. So disappointing!
jaylagorio
@jaylagorio
Sep 23 2017 14:35
I know the feeling, but good luck!
Glenn Primack
@primags
Sep 23 2017 15:14
Hi. I am trying to set temp targets but not seeing where I set those. I have carportal enabled on my nightscout site and can see where I add carbs, etc. What am I missing? Thanks
jaylagorio
@jaylagorio
Sep 23 2017 15:14
There's a + sign in the upper right hand corner of your Nightscout window - click that
Glenn Primack
@primags
Sep 23 2017 15:14
Ok, did that
jaylagorio
@jaylagorio
Sep 23 2017 15:15
Click the Event Type drop down and scroll all the way down
Glenn Primack
@primags
Sep 23 2017 15:16
Ok
jaylagorio
@jaylagorio
Sep 23 2017 15:17
Temporary Target is there at the bottom of the list. Select that and fill out the form, then click Submit Form
Glenn Primack
@primags
Sep 23 2017 15:17
I don't see that option...I see temp basal, etc but not Temp Target
jaylagorio
@jaylagorio
Sep 23 2017 15:17
Scroll all the way down to the end of that list, it's after temp basal
Glenn Primack
@primags
Sep 23 2017 15:18
I have profile switch and DAD alert below
jaylagorio
@jaylagorio
Sep 23 2017 15:18
The one right after DAD alert
Glenn Primack
@primags
Sep 23 2017 15:18
Maybe I'm on an older version?
jaylagorio
@jaylagorio
Sep 23 2017 15:18
What version are you running?
Glenn Primack
@primags
Sep 23 2017 15:19
DAD is the last one...lemme check version
version 0.9.2
jaylagorio
@jaylagorio
Sep 23 2017 15:20
Ah, I'm not sure which version it was added but the latest version is 0.10.0
Glenn Primack
@primags
Sep 23 2017 15:20
OK, I'll go figure out how to update it :) Thanks....
jaylagorio
@jaylagorio
Sep 23 2017 15:20
You should consider upgrading, the Nightscout/public room can help you if you run into trouble with that
katie disimone
@Kdisimone
Sep 23 2017 15:37
@petrichordb when you get those garbled messages full of symbols, that usually means a bad cable. can you find a best buy or electronics store and get a couple new microusb data cables?
LinnBee
@LinnBee_twitter
Sep 23 2017 15:47
@Kdisimone thank you. Yes, I had a go at that link but I couldn't resolve anything. i wasn't clear if that was in Edison or terminal either. I will get some different cables and try again as can't access the thing at all now!!
katie disimone
@Kdisimone
Sep 23 2017 16:04
@petrichordb you need to edit the files in the edison. the directions are for editing files in your edison (but you have to use terminal to access you edison)
LinnBee
@LinnBee_twitter
Sep 23 2017 16:12
Yes, that's what I thought. I will revisit with my new cables!
LinnBee
@petrichordb
Sep 23 2017 16:51
@Kdisimone I got in ok for now but I am uncertain which of the options I am choosing from your link? I have the TLS fatal alert and it is unable to establish SSL connection.
Glenn Primack
@primags
Sep 23 2017 17:21
I updated my nighscout and still don't see the option for temp targets. The last entry I see is DAD alert. I disabled and re-enabled the car portal plugin but it made no difference. Any ideas?
I'm on version 0.10.0-release-20170922
jaylagorio
@jaylagorio
Sep 23 2017 17:22
I would ask over in the Nightscout/public room
Glenn Primack
@primags
Sep 23 2017 17:22
Ok, will do
LinnBee
@petrichordb
Sep 23 2017 17:25
@jaylagorio @Kdisimone can you talk me through how I enter the 8.8.4.4 bit as I am lost now and getting different message now so obviously not done it correctly. http://openaps.readthedocs.io/en/2017-07-13/docs/walkthrough/phase-0/setup-edison.html#override-dns-resolvers
Katie Aldridge
@kcrcgm
Sep 23 2017 18:53
Hi! Trying to install dev branch and I got this error. Help? TIA!
updating to dev 1.JPG
jaylagorio
@jaylagorio
Sep 23 2017 19:04
@petrichordb What have you done to get the message, and what message?
@kcrcgm I think I had that happen and my solution was to move that file into my home directory, rerun setup, and it seemed to restore the correct copy. There's probably an easy git-related answer but that was what worked for me
Scott Leibrand
@scottleibrand
Sep 23 2017 19:07
git reset --hard will blow away local changes as well
Katie Aldridge
@kcrcgm
Sep 23 2017 19:12
Thanks!
LinnBee
@petrichordb
Sep 23 2017 19:15
@jaylagorio I went back into Edison with new cables. I tried to change the name server to 8.8.4.4 and 8.8.8.8 as per the DNS resolver paragraph on the link further up this page. I restarted everything but I don't seem any further forward. I do not understand how to properly change the name server in terminal. There was a home name server there at 192.168.1.254. It is not there now. Officially out of my depth here. Only ever used terminal occasionally for Autotune (standalone) so foreign territory now.

@jaylagorio Listening on LPF/wlan0/90:b6:86:02:f5:8a
Sending on LPF/wlan0/90:b6:86:02:f5:8a
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.254 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
dhclient.c:2331: Failed to send 300 byte long packet over fallback interface.
irs_resconf_load failed: 32.
Unable to set resolver from resolv.conf; startup continuing but DDNS support may be affected
Internet Systems Consortium DHCP Client 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/90:b6:86:02:f5:8a
Sending on LPF/wlan0/90:b6:86:02:f5:8a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Wifi SSID: root@ubilinux:~#

Scott Leibrand
@scottleibrand
Sep 23 2017 19:17
can you ping google.com now?
or ping 8.8.8.8?
LinnBee
@petrichordb
Sep 23 2017 19:18
Do I just copy paste that?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:19
or type them, ya
LinnBee
@petrichordb
Sep 23 2017 19:19
Pardon the dodgy question mark.
Wifi SSID: root@ubilinux:~# ping google.com
ping: unknown host google.com
root@ubilinux:~# ping 8.8.8.8?
ping: unknown host 8.8.8.8?
root@ubilinux:~# ping 8.8.8.8
connect: Network is unreachable
root@ubilinux:~#
Scott Leibrand
@scottleibrand
Sep 23 2017 19:19
ok, you don't have your wifi working
LinnBee
@petrichordb
Sep 23 2017 19:21
Ok, its doing its thing

Listening on LPF/wlan0/90:b6:86:02:f5:8a
Sending on LPF/wlan0/90:b6:86:02:f5:8a
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.254 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
dhclient.c:2331: Failed to send 300 byte long packet over fallback interface.
irs_resconf_load failed: 32.
Unable to set resolver from resolv.conf; startup continuing but DDNS support may be affected
Internet Systems Consortium DHCP Client 4.3.1
Copyright 2004-2014 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/90:b6:86:02:f5:8a
Sending on LPF/wlan0/90:b6:86:02:f5:8a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPOFFER from 192.168.1.254
DHCPACK from 192.168.1.254
bound to 192.168.1.99 -- renewal in 42641 seconds.

Wifi SSID: BTHub4-X78M
--2017-09-23 19:23:07-- https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 213.120.234.146
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|213.120.234.146|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
root@ubilinux:~#

Scott Leibrand
@scottleibrand
Sep 23 2017 19:24
iwgetid -r
Katie Aldridge
@kcrcgm
Sep 23 2017 19:24
Super dumb question. What's decocare?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:24
decocare is "decoding carelink" the library for translating all the pump comms
LinnBee
@petrichordb
Sep 23 2017 19:24
root@ubilinux:~# iwgetid -r
BTHub4-X78M
root@ubilinux:~#
Scott Leibrand
@scottleibrand
Sep 23 2017 19:24
ifconfig wlan0
Katie Aldridge
@kcrcgm
Sep 23 2017 19:24
Ah. That's what Ben West did?
LinnBee
@petrichordb
Sep 23 2017 19:25

root@ubilinux:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 90:b6:86:02:f5:8a
inet addr:192.168.1.99 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:154 errors:0 dropped:0 overruns:0 frame:0
TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14079 (13.7 KiB) TX bytes:75550 (73.7 KiB)

root@ubilinux:~#

Scott Leibrand
@scottleibrand
Sep 23 2017 19:25
yeah, decocare was Ben's magnum opus, along with the openaps toolkit
ping 8.8.8.8
(then Ctrl-C to cancel)
LinnBee
@petrichordb
Sep 23 2017 19:25
Now ya tell me
command or ctrl
Scott Leibrand
@scottleibrand
Sep 23 2017 19:26
sorry, there's so much that's second nature with using linux but totally non-obvious to newbies
should be ctrl-c
command-c is copy
LinnBee
@petrichordb
Sep 23 2017 19:27
nothing happening with ctrl. yes i know thats copy lols
Scott Leibrand
@scottleibrand
Sep 23 2017 19:27
did ping finish, or is it still running?
LinnBee
@petrichordb
Sep 23 2017 19:27
nah still running
jaylagorio
@jaylagorio
Sep 23 2017 19:27
@petrichordb Sorry, I had to step away - but you're in great hands now!
Scott Leibrand
@scottleibrand
Sep 23 2017 19:27
you're holding down control and pressing c?
LinnBee
@petrichordb
Sep 23 2017 19:28
Yes!
Scott Leibrand
@scottleibrand
Sep 23 2017 19:28
it should show:
^C
--- 8.8.8.8 ping statistics ---
LinnBee
@petrichordb
Sep 23 2017 19:28
64 bytes from 8.8.8.8: icmp_seq=162 ttl=54 time=227 ms
64 bytes from 8.8.8.8: icmp_seq=163 ttl=54 time=105 ms
64 bytes from 8.8.8.8: icmp_seq=164 ttl=54 time=139 ms
^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A64 bytes from 8.8.8.8: icmp_seq=165 ttl=54 time=111 ms
64 bytes from 8.8.8.8: icmp_seq=166 ttl=54 time=245 ms
64 bytes from 8.8.8.8: icmp_seq=167 ttl=54 time=113 ms
64 bytes from 8.8.8.8: icmp_seq=168 ttl=54 time=86.6 ms
64 bytes from 8.8.8.8: icmp_seq=169 ttl=54 time=92.2 ms
64 bytes from 8.8.8.8: icmp_seq=170 ttl=54 time=154 ms
64 bytes from 8.8.8.8: icmp_seq=171 ttl=54 time=111 ms
64 bytes from 8.8.8.8: icmp_seq=172 ttl=54 time=254 ms
64 bytes from 8.8.8.8: icmp_seq=173 ttl=54 time=377 ms
64 bytes from 8.8.8.8: icmp_seq=174 ttl=54 time=720 ms
64 bytes from 8.8.8.8: icmp_seq=175 ttl=54 time=640 ms
64 bytes from 8.8.8.8: icmp_seq=176 ttl=54 time=844 ms
64 bytes from 8.8.8.8: icmp_seq=177 ttl=54 time=380
Scott Leibrand
@scottleibrand
Sep 23 2017 19:28
you can also try control-z, which should give:
^Z
[1]+ Stopped ping 8.8.8.8
LinnBee
@petrichordb
Sep 23 2017 19:28
Its still not stopping
Scott Leibrand
@scottleibrand
Sep 23 2017 19:29
^[[A is up-arrow, for what it's worth
LinnBee
@petrichordb
Sep 23 2017 19:29
OK, this train is still going. Whats up with that?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:29
not sure, but let's try something different
open a new terminal window/tab and do ssh root@192.168.1.99
Martin Haeberli
@mhaeberli
Sep 23 2017 19:30
maybe no space between root@ and IP address ?
ssh root@192.168.1.99
Scott Leibrand
@scottleibrand
Sep 23 2017 19:31
correct, sorry; fixed
LinnBee
@petrichordb
Sep 23 2017 19:32
OK, How many daft questions am I allowed. Am I sticking that without space in my Lynnes-iMac-4:~ prompt or am I to go to the Edison again.
Scott Leibrand
@scottleibrand
Sep 23 2017 19:32
this is a different way to get to the edison, so you'll do that at the mac prompt
since your console seems to be giving us fits, we're gonna try ssh
LinnBee
@petrichordb
Sep 23 2017 19:33
Lynnes-iMac-4:~ LynneBeard$ ssh root@192.168.1.99
The authenticity of host '192.168.1.99 (192.168.1.99)' can't be established.
ECDSA key fingerprint is SHA256:ZuxUr0vyx8qG4rYK0qSn5vrb8OLjx9v0cCqYPAhX7gw.
Are you sure you want to continue connecting (yes/no)?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:33
yes
that just means you've never connected over ssh to this rig before
LinnBee
@petrichordb
Sep 23 2017 19:33
Correct. Never got that far.
Are you sure you want to continue connecting (yes/no)? y
Please type 'yes' or 'no': yes
Warning: Permanently added '192.168.1.99' (ECDSA) to the list of known hosts.
root@192.168.1.99's password:
Katie Aldridge
@kcrcgm
Sep 23 2017 19:34
Just want to double check that I set my preferences correctly for dev insulin curve and eSMB. Is this right?
updating to dev 2.JPG
LinnBee
@petrichordb
Sep 23 2017 19:35

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Sep 23 19:10:37 2017
root@ubilinux:~#

Scott Leibrand
@scottleibrand
Sep 23 2017 19:35
@kcrcgm that looks correct. FWIW, 30m is the default, so adding that won't change anything.
@petrichordb ok, now you're into the rig over ssh and can proceed
to pick up where you left off:
cd /tmp/; wget --no-check-certificate https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh; bash ./openaps-install.sh
LinnBee
@petrichordb
Sep 23 2017 19:36
OK, so I am doing the big cut n paste bit. Woo Hoo.
Scott Leibrand
@scottleibrand
Sep 23 2017 19:36
if you re-do the whole thing it'll probably kill your ssh
since you'll be re-doing the wifi that you're connecting over
Katie Aldridge
@kcrcgm
Sep 23 2017 19:36
@scottleibrand I thought I'd just start at 30, increase it each day, and see what happens. Thanks!
LinnBee
@petrichordb
Sep 23 2017 19:37
Sorry, lost me. I'm copying your stuff above?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:37
it might come back on its own after doing so, but it's safest to skip re-doing the wifi since you were able to ping 8.8.8.8
yeah, what I pasted there was the last full line of the big copy-paste from the docs
which is the part you've been having SSL issues with
LinnBee
@petrichordb
Sep 23 2017 19:38
OK, What am I pasting? Don't want to make a hash of it now.
Scott Leibrand
@scottleibrand
Sep 23 2017 19:38
cd /tmp/; wget --no-check-certificate https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh; bash ./openaps-install.sh
LinnBee
@petrichordb
Sep 23 2017 19:39
Thanks. Can I close that other window that won't stop. Its still going.
Scott Leibrand
@scottleibrand
Sep 23 2017 19:39
yeah, but it doesn't hurt anything
it just tells you "yep, you're still online and can ping the google public DNS" :-)
LinnBee
@petrichordb
Sep 23 2017 19:39
Oh no. Still nasty. Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Sep 23 19:10:37 2017
root@ubilinux:~# cd /tmp/; wget --no-check-certificate https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh; bash ./openaps-install.sh
--2017-09-23 19:39:27-- https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 213.120.234.146
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|213.120.234.146|:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.
bash: ./openaps-install.sh: No such file or directory
root@ubilinux:/tmp#
Scott Leibrand
@scottleibrand
Sep 23 2017 19:40
hmm, ok
jaylagorio
@jaylagorio
Sep 23 2017 19:41
What happens when you do curl https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh
?
LinnBee
@petrichordb
Sep 23 2017 19:41

TODO: change back to master after docs release

curl -s https://raw.githubusercontent.com/openaps/docs/dev/scripts/quick-packages.sh | bash -
mkdir -p ~/src; cd ~/src && git clone git://github.com/openaps/oref0.git || (cd oref0 && git checkout master && git pull)
echo "Press Enter to run oref0-setup with the current release (master branch) of oref0,"
read -p "or press ctrl-c to cancel. " -r
cd && ~/src/oref0/bin/oref0-setup.sh
root@ubilinux:/tmp#
Scott Leibrand
@scottleibrand
Sep 23 2017 19:42
ah, cool
then we can proceed by doing this instead:
jaylagorio
@jaylagorio
Sep 23 2017 19:42
So wget isn't working for <reasons>, but curl works? Weird.
cd /tmp && curl https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh > openaps-install.sh
That should get openaps-install.sh into the /tmp dir, then ./openaps-install.sh should run it
LinnBee
@petrichordb
Sep 23 2017 19:43
read -p "or press ctrl-c to cancel. " -r
cd && ~/src/oref0/bin/oref0-setup.sh
root@ubilinux:/tmp# cd /tmp && curl https://raw.githubusercontent.com/openaps/docs/dev/scripts/openaps-install.sh > openaps-install.sh
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1533 100 1533 0 0 590 0 0:00:02 0:00:02 --:--:-- 591
root@ubilinux:/tmp#
jaylagorio
@jaylagorio
Sep 23 2017 19:44
Next: ./openaps-install.sh
Scott Leibrand
@scottleibrand
Sep 23 2017 19:45
if that works we may want to update the docs to use curl instead of wget --no-check-certificate
LinnBee
@petrichordb
Sep 23 2017 19:45
That my next thing @jaylagorio ?
jaylagorio
@jaylagorio
Sep 23 2017 19:45
Yeah, try that
@scottleibrand I have no idea why curl would work if wget doesn't though
LinnBee
@petrichordb
Sep 23 2017 19:45
Oh dearie me. root@ubilinux:/tmp# ./openaps-install.sh
-bash: ./openaps-install.sh: Permission denied
root@ubilinux:/tmp#
jaylagorio
@jaylagorio
Sep 23 2017 19:45
chmod +x openaps-install.sh
Then try again
LinnBee
@petrichordb
Sep 23 2017 19:46
root@ubilinux:/tmp# chmod +x openaps-install.sh
root@ubilinux:/tmp# ./openaps-install.sh
Enter your Edison's new hostname (this will be your rig's name in the future, so make sure to write it down):
Scott Leibrand
@scottleibrand
Sep 23 2017 19:46
cool, you're in business
jaylagorio
@jaylagorio
Sep 23 2017 19:46
Hooray!
LinnBee
@petrichordb
Sep 23 2017 19:47
OK, so I am now where I want to be and am making up a name?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:47
yep, you can proceed with the directions now
LinnBee
@petrichordb
Sep 23 2017 19:47
And I get in to this in future via the shh thingy?
Scott Leibrand
@scottleibrand
Sep 23 2017 19:48
once you rename and reboot the rig per the docs you'll be able to ssh in by name instead of IP, but yeah
LinnBee
@petrichordb
Sep 23 2017 19:49
OK, Its asking me geographic and stuff now so I think I am a very happy girl. MANY THANKS BOTH OF YOU! I'll be back though, no doubt..
Scott Leibrand
@scottleibrand
Sep 23 2017 20:11
:+1:
@brmccollum (moving PM over here) it looks like your loop never got scheduled in cron. I would re-run oref0-setup again and see if you can get to the schedule in cron part
br
@brmccollum
Sep 23 2017 20:14
Okay thanks :ok_hand:
It is okay to be over wifi instead of local when I re-run the setup?
jaylagorio
@jaylagorio
Sep 23 2017 20:17
Yup!
Dana Lewis
@danamlewis
Sep 23 2017 20:18
Yep
@jaylagorio you're on :fire: this week :smile:
jaylagorio
@jaylagorio
Sep 23 2017 20:19
I had a couple things wind down so I finally have spare cycles!
0.6.0 seems like a pretty major release so if I can lend some of those cycles to the cause I'm happy to do it
Dana Lewis
@danamlewis
Sep 23 2017 20:29
:+1: :clap: :confetti_ball:
jaylagorio
@jaylagorio
Sep 23 2017 20:59
Thanks for the closes/merges!
br
@brmccollum
Sep 23 2017 23:15

I have been getting this loop for the past hour+, is this representative that my radio isn't working?:

""Starting pump-loop at Sat Sep 23 16:10:02 PDT 2017:
Waiting up to 4 minutes for new BG: ls: cannot access monitor/pump_loop_completed: No such file or directory
Radio ok. Listening: .No pump comms detected from other rigs
Old pumphistory: IndexError: bytearray index out of range

grep: monitor/temp_basal.json: No such file or directory
Error, retrying
pump_loop_completed more than 15m old; waiting for 30s silence before mmtuning
Radio ok. Listening: .No pump comms detected from other rigs
Listening for 30s silence before mmtuning: .No pump comms detected from other rigs
mmtune: "916.636", 0, -99 waiting for 78 second silence before continuing
Radio ok. Listening: .No pump comms detected from other rigs

Starting pump-loop at Sat Sep 23 16:13:50 PDT 2017:
Waiting up to 4 minutes for new BG: ls: cannot access monitor/pump_loop_completed: No such file or directory
Radio ok. Listening: .No pump comms detected from other rigs
Old pumphistory: ""

jaylagorio
@jaylagorio
Sep 23 2017 23:20
What's the battery voltage on the pump?
br
@brmccollum
Sep 23 2017 23:23
Thanks jaylagorio, I am not sure how to find that?
My pump doesn't show up on my NS
Scott Leibrand
@scottleibrand
Sep 23 2017 23:25
Does it have 4 battery bars on the pump?
Also make sure it's a NA pump and not WW
br
@brmccollum
Sep 23 2017 23:26
Pump is 712, it is NA. Battery says "normal" in the Status section
jaylagorio
@jaylagorio
Sep 23 2017 23:26
Do you have the pump pill enabled in Nightscout?
br
@brmccollum
Sep 23 2017 23:28
Battery is actually brand new. Pill is there, when I hover on it, it says device undefined.
Have you tried rebooting the rig?
br
@brmccollum
Sep 23 2017 23:29
I did just prior to trying to run the loop for the first time. I will try that now.
jaylagorio
@jaylagorio
Sep 23 2017 23:30
Yeah, give that a shot. You'll want to wait a few cycles through the loop until it gives you that mmtune again, and after that it'll (hopefully) kick in
br
@brmccollum
Sep 23 2017 23:30
Okay, thank you. I will report back in a bit.
jaylagorio
@jaylagorio
Sep 23 2017 23:30
And double check that your pump software version is right, that remote controlling it is enabled, etc
Keep it close to the transmitter to keep interference low while it goes through things out for the first few times
br
@brmccollum
Sep 23 2017 23:32
Okay, for remote settings (which I have turned on) is there any particular ID to input?
Dana Lewis
@danamlewis
Sep 23 2017 23:33
also you mentioned 712 - did you follow the additional instructions for the 12 pumps?
jaylagorio
@jaylagorio
Sep 23 2017 23:33
That ID is for the car clicker-style device, I don't think you have to enter anything there.
Dana Lewis
@danamlewis
Sep 23 2017 23:33
Remote won't matter, but you can input random number
Were you looping successfully before or is this new setup?
br
@brmccollum
Sep 23 2017 23:33
ok. I did follow the additional sets for 712, and I believe they are all correct.
This is a new setup.
Dana Lewis
@danamlewis
Sep 23 2017 23:34
K
You have -99 for mmtune, how close is pump to rig?
br
@brmccollum
Sep 23 2017 23:34
2 inches
This message was deleted