These are chat archives for nightscout/intend-to-bolus

28th
Sep 2017
Dana Lewis
@danamlewis
Sep 28 2017 00:11
just saw Libre will require a 12 hour warmup. yikes. hoping the receiver will allow one to warm up while another is finishing...
Scott Leibrand
@scottleibrand
Sep 28 2017 00:32
@cbrenner @kallnap if your pump is delivering 2.5U more or less out of 10U, then you can simply do a 10U bolus and count the number of drops that come off, and you'll end up counting 25% more or fewer drops. If you let them drop off by gravity, each drop coming off the end of the infusion set clip is the same size (which is determined by the surface tension of the liquid). There will be a little bit of imprecision, but I'm pretty sure it'd be less than 10%. And you can repeat the test multiple times to see how much it varies from test to test on the same pump. If all your tests on one pump are higher than all your tests on the other pump (with the same infusion set tubing), then you know there's a difference in the pumps.
or alternatively if one pump is always the same number of drops but the other varies quite a bit, you may have imprecise delivery from one of them
sdneufer
@sdneufer
Sep 28 2017 01:16
@danamlewis @Kdisimone How do you upload image changes to the docs? I am looking at the IFTTT doc as I was adding new applets and noticed the doc pics have changed however when I edit it shows the picture as ../Images/name and I have no idea how to add or change an image.
Katie Aldridge
@kcrcgm
Sep 28 2017 01:18
@danamlewis So I've been using the dev branch since Saturday. It is working reeeally well for me (excluding one strange day where either my cartridge or insulin was faulty). I changed my DIA from 5 to 6, and I'm still tweaking settings for that. Even so my bgs have been better than ever esp. after meals. But now that I've tried it, is there anything I can do to help? Thank you guys for these amazing improvements!
katie disimone
@Kdisimone
Sep 28 2017 01:20

@sdneufer easiest to save your page’s text edits first, that will create a new branch in your repository. Create the PR. But put a note in the PR comments that you have more changes coming. Go back into the branch, navigate to the folder where the images are stored, and choose the upload file option from within the images folder you need.

Make sure to tell Dana via comment in the PR when you are done with all the edits you intend on doing

sdneufer
@sdneufer
Sep 28 2017 01:50
@Kdisimone attached the image to the pr. Will look at it again in a bit, however have to go deal with bedtime for kid.
katie disimone
@Kdisimone
Sep 28 2017 01:55
@sdneufer yup, don’t want to attach the image to the PR. You want to upload image to the branch.
sdneufer
@sdneufer
Sep 28 2017 02:07
@Kdisimone permission denied
thats why I attached it.
katie disimone
@Kdisimone
Sep 28 2017 02:08
@sdneufer you were probably trying to upload it to the openaps docs repository, not your own repository of the openaps docs. Your repo is here….https://github.com/sdneufer/docs
You can navigate to the images folder and upload there in your repo.
@sdneufer but don’t upload to your master branch, upload to the patch-3 branch where your PR is pointing to right now. I left a screen shot in your PR comments to help
Jacob H
@jdhigh
Sep 28 2017 02:16
Today for first time I got a warning from papertrail that I'm about to exceed daily log under free plan. Does this happen frequently?
sdneufer
@sdneufer
Sep 28 2017 02:18
@Kdisimone done. i think. comments in the PR
katie disimone
@Kdisimone
Sep 28 2017 02:19

@jdhigh Was it from heroku papertrail…yes, happens a lot. I disabled my paper trail in heroku.

If it is your OpenAPS papertrail, yes…most people need to go to a $4-5 per month plan in order to make it through the entire month…or just continue to use the free plan for first part of month and fly blind the last part of month.

Jacob H
@jdhigh
Sep 28 2017 02:22
Ok. I just thought it was weird because I've been on openaps for almost 2 months and this is the first time Ive seen that.
katie disimone
@Kdisimone
Sep 28 2017 02:23
Free plan’s first month is gloriously huge amounts of data. Second month it drops down. Usually people max out by about 2-3 weeks depending on how many logs they watch and how many rigs they run.
sadafakahmad
@sadafakahmad
Sep 28 2017 02:45
rig stopped looping. Getting this message:
Old pumphistory: fatal: loose object 8f3035757188114daba8eeece4646f310af5a8da (stored in .git/objects/8f/3035757188114daba8eeece4646f310af5a8da) is corrupt'
any suggestions?
Dana Lewis
@danamlewis
Sep 28 2017 02:52
@kcrcgm yay! thanks for the feedback, glad it's working well! my main questions for people are: what's missing from these notes in the PR? what behavior changes need to be described that would be helpful to document to go hand in hand with the eventual release? (and then also, if you're comfortable, please keep testing! we're still adding code to dev, so being willing to keep pulling and testing periodically to test different things we're adding is super helpful)
sadafakahmad
@sadafakahmad
Sep 28 2017 04:07
I did a git reset and no change. I am running dev, by the way.
did a re-install and getting:
InvalidGitRepositoryError: /root/myopenaps
I'm at a dead end. All the other problems would at least be solved by reinstalling oref0. Do I have to flash my Edison?
sadafakahmad
@sadafakahmad
Sep 28 2017 04:12
Is this related to installing dev?
Katie Aldridge
@kcrcgm
Sep 28 2017 04:13
@danamlewis Ok! I'll think about the notes. If
I think of something to add, do I add comments on the PR?
Will keep pulling new code and testing! 😊
Scott Leibrand
@scottleibrand
Sep 28 2017 04:41
@sadafakahmad if you follow the How to Install dev with No-git directions at openaps/oref0#650 it will fix your git issues
sadafakahmad
@sadafakahmad
Sep 28 2017 04:43
Thank you Scott!
Tim Street
@tim2000s
Sep 28 2017 05:23
@scottleibrand - I want to add a couple of additional phones into the crontab oref0-online call. Is there a specific way to nest Mac addresses or do you just use multiple cron entries?
Tim Street
@tim2000s
Sep 28 2017 05:49
If anyone is interested in finding out more about the Libre, have a read of www.type1tennis.blogspot.be and www.diabettech.com/libre
Dana Lewis
@danamlewis
Sep 28 2017 05:56
:+1:
Tim Street
@tim2000s
Sep 28 2017 06:32
But bear in mind that in Europe costs are based on 14 rather than 10 day wear and a 1 hr start up time, not 12 hrs.
jaylagorio
@jaylagorio
Sep 28 2017 10:51
For what it's worth, I'm on the latest dev and over night had the corrupted git issue. I did an oref0-reset-git and it worked right off the bat.
I'd never had a git issue in the past so I was worried I was about to have to delete a ton of stuff and reprocess 7 months of autotune (although I might have to do that part anyway)
Jacob H
@jdhigh
Sep 28 2017 13:54
@sadafakahmad myself and many others in the past week have had the fatal git problems after installing dev. But I think we didnt install with no-git. This seems to be git's final revenge before we cut it off.
Scott Leibrand
@scottleibrand
Sep 28 2017 14:32
@tim2000s just add them to the same cron line, space-separated.
@jaylagorio follow the dev PR instructions and you can copy over your existing autotune to the new myopenaps directory with --nogit
jaylagorio
@jaylagorio
Sep 28 2017 16:03
Yeah, if I have to rebuild or something I'll do it without git
Scott Leibrand
@scottleibrand
Sep 28 2017 17:27
:+1: I'm just saying there's no reason to reprocess 7 months' worth of autotune data: you can just copy over the results to the new myopenaps dir
jaylagorio
@jaylagorio
Sep 28 2017 17:39
With the retuned algorithm wouldn't I have to rerun it anyway?
sadafakahmad
@sadafakahmad
Sep 28 2017 17:58
Today I connected my rig directly to my Dexcom receiver and to a charging source and openaps didn't continue looping. I left it for a while to see if it took time. The rig simply wasn't picking up data from the receiver. Is there anything special that needs to be run?
Dana Lewis
@danamlewis
Sep 28 2017 17:58
what CGM have you selected in setup?
sadafakahmad
@sadafakahmad
Sep 28 2017 17:58
G5
The other problem I have is that when I Bluetooth to my iPhone and use it as a hotspot, Dexcom Share stops working. So, effectively I can't loop outside the house at all with these two problems combined.
Scott Leibrand
@scottleibrand
Sep 28 2017 18:07
@jaylagorio we generally don't re-run autotune against historical data when running it in on the rig. it will gradually converge if you just let it run incrementally on each new day's data
jaylagorio
@jaylagorio
Sep 28 2017 18:08
OK, sounds good
alternateal
@alternateal
Sep 28 2017 20:22
So what have Abbott done to Libre in the US to make it only last 10 days or have they just drawn a line on a curve and decided 10 is the number?
Lorenzo Sandini
@lsandini
Sep 28 2017 20:39
I asked 24 hours ago about treatments made using the pump's bolus wiz not showing in NS. Dana suggested I pull 0.5.4 (I was on 0.5.3). I update, re-ran the setup script and set the preferences, but now not even the standard boluses show in NS anymore.
Dana Lewis
@danamlewis
Sep 28 2017 20:40
chek for future treatments? and also mlab size
and confirm that they're showing up in the logs and it's "just" a display problem?
also, what version of NS are you on?
Lorenzo Sandini
@lsandini
Sep 28 2017 20:40
hahaa, I was just typing that... mlab db just repaired (210MB)
but my treatment are in the future !
Dana Lewis
@danamlewis
Sep 28 2017 20:41
that'll do it. delete those. if they reoccur, something is probably set off clock wise (am/pm wrong, or something time zone is goofed)
Lorenzo Sandini
@lsandini
Sep 28 2017 20:42
the rig's clock is right, and I just reset the pump's clock using openaps use pump set_clock --to now
cleared the future treatments... waiting now
Lorenzo Sandini
@lsandini
Sep 28 2017 20:48
0.5.4 master. The calculations seem to be right, the carbs appear correctly as COB and the 3 forecast lines appear. But no the treatments :(
SMBs appear correctly though in NS
Lorenzo Sandini
@lsandini
Sep 28 2017 20:58
this appears in the log : "Refreshed pumphistoryRemoved duplicate bolus/carb entries:2"
Paul Dickens
@thebookins
Sep 28 2017 22:16
Hi All, We've been getting more than usaual git errors lately. The latest one was Temp refreshIOError: Lock for file '/root/myopenaps/.git/logs/HEAD' did already exist, delete '/root/myopenaps/.git/logs/HEAD.lock' in case the lock is illegal. Should we do what it says (delete the lock) or will this resolve by itself?
Scott Leibrand
@scottleibrand
Sep 28 2017 22:22
it should self-resolve, but if you're running dev you should follow the steps in the dev PR to re-do your myopenaps directory with --nogit
Paul Dickens
@thebookins
Sep 28 2017 22:32
Thanks @scottleibrand , we are running dev from a few weeks ago (prior to the 0.5.3 release), haven't yet dived in to the 0.6.0 changes. Is --nogit the recommended setup now?
Phil
@drnoname82_twitter
Sep 28 2017 23:12
What results do others achieve with OpenAPS during physical activity? We did a not very strenuous hike today. Before looping we would take care not to start with any IOB and then set the basal rate to maybe -60% and get reasonable results (BG ca 100-150 mg/dl without too much fluctuation). OpenAPS low temps for a long time and once a carb correction (with Dextrose) is necessary, it reacts with high temping, apparently causing the next low. We have observed this up and down over several days of hiking, even with higher targets. It just seems that on/off insulin infusion is not ideal in this case and using a much higher ISF might be more physiological. Would it maybe make sense to let OpenAPS read the "reason": "Activity"field in the temp target entry and immediately increase ISF and reduce basal rates?
Activity.jpg
jaylagorio
@jaylagorio
Sep 28 2017 23:45
@drnoname82_twitter Before physical activity (also no or low IOB) I set my temp target to be 140 - 150 for the duration of the activity, sometimes a little before the activity starts. It seems to react well with that, I would categorize it as not strenuous but likely less strenuous than a hike
I don't have a recent screenshot to give you for comparison, sorry!
Jacob H
@jdhigh
Sep 28 2017 23:55
I'm getting this error message. Any thoughts? (I'm rebooting now.)

Preflight OK.
Attempting to retrieve MDT CGM data from pump
monitor/cgm-mm-glucosedirty.json raised 'ReadPumpModel' object has no attribut e 'iter_glucose_pages'
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51 , in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
output = task.method(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in call
output = self.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", li ne 640, in main
for rec in self.range( ):
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", li ne 629, in range
return self.pump.model.iter_glucose_pages( )
AttributeError: 'ReadPumpModel' object has no attribute 'iter_glucose_pages'

CGM data retrieval from pump disrupted, retrying in 5 seconds...
Reattempting to retrieve MDT CGM data
monitor/cgm-mm-glucosedirty.json raised No acknowledgement from pump on wakeup . Is it out of range or is the battery too low?
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51 , in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
output = task.method(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 44, in call
self.before_main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py"

Scott Leibrand
@scottleibrand
Sep 28 2017 23:56
@drnoname82_twitter we're working some improvements to how OpenAPS deals with activity mode temp targets, but in the meantime the approach @jaylagorio suggests of using a higher temp target is probably best
Dana Lewis
@danamlewis
Sep 28 2017 23:56
@thebookins yes recommending no git moving forward. Set up instructions in the dev PR for 0.6.0 reflect that
@drnoname82_twitter I also found for some all day intense hikes, I need to eat proactively so i can get some insulin and not end up 0'd out all day (which makes me feel icky even if Bgs are fine). Last major home day in Grand Canyon set a high temp target, ate periodically for energy purposes, and worked out well for BGs during and after home
Still a work in progress, but trying to find snacks I like that are more than sugar for low corrections also seems to help, and using sugar as a top off/bg directional nudge.