These are chat archives for nightscout/intend-to-bolus

27th
Oct 2017
Scott Leibrand
@scottleibrand
Oct 27 2017 00:20
Out running now. Post here and I'll look later if no one beats me to it?
garykidd
@garykidd
Oct 27 2017 02:55
not sure if my situation is unique...
just trying to do some IFTTT integration...looks like my cancel temp target worked...according to openAPS pill...however the TEMP TARGET bar persists.... see pic. I did refresh FYI.
blob
garykidd
@garykidd
Oct 27 2017 03:08
you think this is just a NS rendering issue?
Scott Leibrand
@scottleibrand
Oct 27 2017 03:09
for us it always is, and always resolves with a reload
achris2000
@achris2000
Oct 27 2017 09:14
Hi everyone,
achris2000
@achris2000
Oct 27 2017 09:20
I was thinking of letting my 2 rigs do a pptp vpn dial in to my office router while my twins are out, so that I can reach the rigs per ssh at anytime. Sofar I could not get it running, it fails to run, the output to "pon office"is "Couldn't open the /dev/ppp device: No such device or address
/usr/sbin/pppd: Please load the ppp_generic kernel module.". Any suggestions ?
I am the father of twins T1D 19yo.
Looks like something's missing from kernel.
Samuchco
@Samuchco
Oct 27 2017 12:42
@scottleibrand My son's pump gave a NO DELIVERY alarm at 6:47 AM. He didn't noticed it until 7:15 when he was going to bolus for breakfast. He rewound and primed at 7:15 and 7:16. The logs(Papertrail) shows as Suspended. But "SUSPENDED" by itself doesn't cover a malfunction. Wouldn't it be important and beneficial to have the the cause of the SUSPEND. Do you want me to post the log?
Screenshot (14).png
Screenshot (15).png
ejoe132
@ejoe132
Oct 27 2017 14:29
So finishing up re setting up a new edison. Been a bit, last rig was on oref1, dev branch. Now I see smb and uma are in the master 0ref0, so when Im looking at the instruction page and its talking about oref1 is oref1 features all part of orefo now? Just trying to locate the dev branch and couldnt see it on that page
nevermind found it didnt realise its jsut farther down the pages
Lorenzo Sandini
@lsandini
Oct 27 2017 14:48
I don't think anyone reported a shortage of Edison boards anywhere yet ?
john36m
@john36m
Oct 27 2017 15:10
I thought I read all the links for SMB, but I cannot find the second pass phrase. Also a question, it says that SMB will be disabled when your basal is below 0.3. Does this mean just disabled for that time interval or totally disabled.
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 15:13
@john36m Read "How to turn on SMB/UAM". I believe it's turned off.
Paul Andrel
@stavlor
Oct 27 2017 15:37
@john36m from what i recall it will only be turned off when current basal is below 0.3
        if (microBolusAllowed && enableSMB && profile.current_basal >= 0.3 && bg > threshold) {
            // never bolus more than 30m worth of basal
            maxBolus = round(profile.current_basal/2,1);
            // bolus 1/3 the insulinReq, up to maxBolus
            microBolus = round(Math.min(insulinReq/3,maxBolus),1);
Just a note that that is from master branch dev may be a bit different
Scott Leibrand
@scottleibrand
Oct 27 2017 16:27
@Samuchco OpenAPS only sees what the pump reports. If you wanted to add alerting for no delivery alarms, you could probably do that, but that's an event, not a status.
@john36m we have PRs open to disable both of those limitations if you'd like to test them.
PieterGit
@PieterGit
Oct 27 2017 16:34
If anybody can help me with https://github.com/nightscout/cgm-remote-monitor/pull/2991#issuecomment-340020897 we might be able to get the new SMB rendering and zerotemps lines in the next nightscout release. I must leave now and will be back later. I'm puzzled why the tests fail.
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 16:38
When I change the ISF on the pump, when does that come into effect?
I see autosens is changing the ISF, but that only affects the basal?
jaylagorio
@jaylagorio
Oct 27 2017 16:41
@PieterGit Is there a timeline for that next release?
Thacher
@thacherT1D
Oct 27 2017 16:41
@BjoTore_twitter when you change the ISF on the pump it immediately changes for the pump calculations, but will not show up on autotune until it runs again (it runs every 24 hours)
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 16:42
The openaps pill shows the old ISF?
Paul Andrel
@stavlor
Oct 27 2017 16:43
no it will show the ISF as altered by autosens
Thacher
@thacherT1D
Oct 27 2017 16:44
yes ^^
just the autotune report is delayed
hilarykoch
@hilarykoch
Oct 27 2017 16:44
I set an "eating soon" target of 80, but OpenAPS doesn't seem to acknowledge it. Target was stuck at 95. It's back on track now, but I don't understand why it was sticking with our usual target of 95.
Thacher
@thacherT1D
Oct 27 2017 16:44
@BjoTore_twitter *just re-read your question, sorry for the autotune v. autosense answer
@hilarykoch where did you set it from?
hilarykoch
@hilarykoch
Oct 27 2017 16:45
NS
@thacherT1D really odd. We set temp targets all the time.
Thacher
@thacherT1D
Oct 27 2017 16:48
hmmm... when that's happened to me it's because I was on a different device that wasn't "authenticated" even though it had let me through to the profile editor, so even when I was clicking save it wasn't actually saving -- doesn't sound like that's your issue though, if this is the way/device that you use to do this all the time
@hilarykoch sorry I can't be more help
hilarykoch
@hilarykoch
Oct 27 2017 16:49
IMG_5091 2.PNG
IMG_5089 2.PNG
IMG_5088 2.PNG
IMG_5087.PNG
IMG_5085 2.PNG
@thacherT1D Right. You can see it's identified correctly in NS, but OpenAPS pill and logs don't indicate the target of 80.
If anyone else has ideas, let me know. Again, we're back on check (and changed site, because I think it may have been bad.) But would love to know what happened.
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 16:53
So, if I think Im more resistant than autosens figures out, what to do? I think maybe its a little conservative?
Scott Leibrand
@scottleibrand
Oct 27 2017 16:54
Temp targets are downloaded by oref0-ns-loop and logged in ns-loop.log.
@ToreBj you can set a temp target to 80
And if that isn't strong enough, there is an open PR to add a preference to make oref0 go into resistance mode for low temp targets.
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 16:57
"resistance mode" = low temp target or something else?
PR#?
Rob Kresha
@rkresha
Oct 27 2017 17:01
so I'm currently at a loss, I understand aliases and how to set them, however for the life of me I can't figure out where you've stashed the "l alias" to tail the pump loop log
jaylagorio
@jaylagorio
Oct 27 2017 17:07
@hilarykoch I host Nightscout locally and have been having this problem, but only when I'm not at home. Retrieving temp targets fails and the reason isn't recorded in ns-loop.log, just a blank line and then the script stops running until cron hits it again, then it does. But once I get back home everything's fine. I haven't been able to figure out what's happening. It's not a network connectivity problem because other than not running the ns-loop everything else like CGM data, picking up carbs and boluses as well as temp basal changes imposed by the loop, etc make it to NS just fine while the temp targets pickup fails.
So I don't know why only that one function is failing when not on home wifi.
Tore Bjørndalen
@BjoTore_twitter
Oct 27 2017 17:16
@scottleibrand ok found it #757. I'll give it a try.
hilarykoch
@hilarykoch
Oct 27 2017 17:22
@jaylagorio We happen to be at home at the moment, so that can't be a factor in our case.
john36m
@john36m
Oct 27 2017 17:35
Just started SMB on Master 0.5.5. Seems to be working so far. Thanks, all.
Lynne Butts
@flutelynne_twitter
Oct 27 2017 17:47
Reading the docs, I know that the edison/expl rig may be directly plugged into the wall with no battery attached. Yesterday, I noticed that my one rig’s battery was not holding a charge for more than 4 hours, and saw that it was a bit bulging. I disconnected, and discarded it outside. But I tried just plugging the rig into my Zendure 10,000 mah, and it worked for a while, then shut off. I had it plugged in to the uart port. If I plug it in to the otg port, would it stay on? Or do I need to just put another battery in which I can plug in to the board first, then the larger charger? I did have a 2000mah and did this, taking it on a test run, and I had no trouble, but would like to be able to directly connect to my Zendure with no plugged-in lipo, if possible. Thank you.
sdneufer
@sdneufer
Oct 27 2017 17:47
@rkresha more ~/.bash_profile
Rob Kresha
@rkresha
Oct 27 2017 17:48
root@openaps_delta:~# alias
alias autosens-looplog='tail -n 100 -F /var/log/openaps/autosens-loop.log'
alias autotunelog='tail -n 100 -F /var/log/openaps/autotune.log'
alias cat-autotune='cd ~/myopenaps/autotune && cat autotune_recommendations.log'
alias cat-pref='cd ~/myopenaps && cat preferences.json'
alias cat-reservoir='cd ~/myopenaps/monitor && cat reservoir.json'
alias cat-runagain='cd ~/myopenaps && cat oref0-runagain.sh'
alias cat-wifi='cat /etc/wpa_supplicant/wpa_supplicant.conf'
alias cgm-looplog='tail -n 100 -F /var/log/openaps/cgm-loop.log'
alias edison-battery='cd ~/myopenaps/monitor && cat edison-battery.json'
alias edit-pref='cd ~/myopenaps && nano preferences.json'
alias edit-runagain='cd ~/myopenaps && nano oref0-runagain.sh'
alias edit-wifi='nano /etc/wpa_supplicant/wpa_supplicant.conf'
alias git-branch='cd ~/src/oref0 && git branch'
alias networklog='tail -n 100 -F /var/log/openaps/network.log'
alias pump-looplog='tail -n 100 -F /var/log/openaps/pump-loop.log'
alias start-cron='/etc/init.d/cron start'
alias stop-cron='cd ~/myopenaps && /etc/init.d/cron stop && killall -g oref0-pump-loop'
alias urchin-looplog='tail -n 100 -F /var/log/openaps/urchin-loop.log'
alias xdrip-looplog='tail -n 100 -F /var/log/openaps/xdrip-loop.log'
root@openaps_delta:~# cat .bash_profile
alias networklog="tail -n 100 -F /var/log/openaps/network.log"
alias xdrip-looplog="tail -n 100 -F /var/log/openaps/xdrip-loop.log"
alias cgm-looplog="tail -n 100 -F /var/log/openaps/cgm-loop.log"
alias autosens-looplog="tail -n 100 -F /var/log/openaps/autosens-loop.log"
alias autotunelog="tail -n 100 -F /var/log/openaps/autotune.log"
alias pump-looplog="tail -n 100 -F /var/log/openaps/pump-loop.log"
alias urchin-looplog="tail -n 100 -F /var/log/openaps/urchin-loop.log"
. /etc/skel/.profile
alias cat-pref="cd ~/myopenaps && cat preferences.json"
alias edit-pref="cd ~/myopenaps && nano preferences.json"
alias cat-wifi="cat /etc/wpa_supplicant/wpa_supplicant.conf"
alias edit-wifi="nano /etc/wpa_supplicant/wpa_supplicant.conf"
alias cat-runagain="cd ~/myopenaps && cat oref0-runagain.sh"
alias edit-runagain="cd ~/myopenaps && nano oref0-runagain.sh"
alias cat-autotune="cd ~/myopenaps/autotune && cat autotune_recommendations.log"
alias git-branch="cd ~/src/oref0 && git branch"
alias edison-battery="cd ~/myopenaps/monitor && cat edison-battery.json"
alias cat-reservoir="cd ~/myopenaps/monitor && cat reservoir.json"
alias stop-cron="cd ~/myopenaps && /etc/init.d/cron stop && killall -g oref0-pump-loop"
alias start-cron="/etc/init.d/cron start"
sdneufer
@sdneufer
Oct 27 2017 17:49
just noticed I do not have an l alias
Rob Kresha
@rkresha
Oct 27 2017 17:49
:)

mindblown

sdneufer
@sdneufer
Oct 27 2017 17:50
@rkresha ohh... is it a script ...
which l
gives /usr/local/bin/l
it is a script
jaylagorio
@jaylagorio
Oct 27 2017 17:51
@flutelynne_twitter In my experience the problem might not be with the rig but with the battery. The batteries stop dispensing power if they don't detect a load on the other end and it's possible the rig doesn't present a load large enough for that particular battery's threshold. I had a battery that worked like that as well, it was great for charging phones but couldn't be used for the rig for that reason.
Lynne Butts
@flutelynne_twitter
Oct 27 2017 17:55
@jaylagorio Thank you! By any chance, would it work with a “chapstick-size” charger? But, “charger” maybe answers that question. If there is nothing to charge, only power.
jaylagorio
@jaylagorio
Oct 27 2017 17:57
I honestly think it takes some trial and error trying to find the right battery. The charging/discharging circuits are all different across manufacturers.
I've had good luck with the Easyacc brand
Lynne Butts
@flutelynne_twitter
Oct 27 2017 18:01
Hmm. So with the Easyacc as a charger? Not a stand-alone (in place of the lipo)? The 10,000mah worked well as far as charging with the lipo, just a little larger rig, but I was testing.
ejoe132
@ejoe132
Oct 27 2017 18:05
Can any one assist with bluetooth pairing? Feel like Im missing something small, follow the steps till I get to where I should see the edison show up on my iphone but it never comes up. I have wifi tether working great but would love to not have to activate and wait each time I go out
jaylagorio
@jaylagorio
Oct 27 2017 18:19
@flutelynne_twitter Either as a charger or as a stand-alone.
Lynne Butts
@flutelynne_twitter
Oct 27 2017 18:28
@jaylagorio Great! Thanks!
Samuchco
@Samuchco
Oct 27 2017 18:31
Anyone her that can help with Papertrail. I want to set an alert when the pump goes to SUSPEND. I would imagine when "suspended": true
Any One? Any One? Bueller? Any One
Scott Leibrand
@scottleibrand
Oct 27 2017 18:32
Does papertrail support alerting? If not, it might be something that'd have to go into NS or oref0-pushover.
garykidd
@garykidd
Oct 27 2017 18:32
@ejoe132 android or iOS?
Samuchco
@Samuchco
Oct 27 2017 18:35
@scottleibrand yes papertrail supports alerting via email or pushover etc. What I need is how to find the string
Oct 27 06:55:37 SammysAPS pump-loop.log: Checking pump status (suspended/bolusing): {"status":"normal","bolusing":false,"suspended":true} 
Oct 27 06:55:38 SammysAPS pump-loop.log: Pump suspended; Temp basal still running: leaving pump suspended
Scott Leibrand
@scottleibrand
Oct 27 2017 18:36
yeah, that's the one
Samuchco
@Samuchco
Oct 27 2017 18:36
@scottleibrand I know but I found it manually
Scott Leibrand
@scottleibrand
Oct 27 2017 18:37
"Pump suspended" is probably a good string to search for
or "suspended":true
Samuchco
@Samuchco
Oct 27 2017 18:40
@scottleibrand Tried those in the past and now. It gives me "No matching events"
did you gt achance to see my post on NO DELIVERY
Scott Leibrand
@scottleibrand
Oct 27 2017 18:40
k. I don't use papertrail myself, so we're at about the limit of my knowledge
post where?
Samuchco
@Samuchco
Oct 27 2017 18:40
how about in the log of the rig
here earlier
Scott Leibrand
@scottleibrand
Oct 27 2017 18:41
I thought I responded to that
Samuchco
@Samuchco
Oct 27 2017 18:41
Oh Let me see, sorry
Samuchco
@Samuchco
Oct 27 2017 18:44
@scottleibrand Either as an alert or a status. I believe I can see in the pump alert history the Non-delivery event
Scott Leibrand
@scottleibrand
Oct 27 2017 18:48
yeah, I think those show up in pumphistory.json, but oref0 doesn't do anything with them except upload them to NS. it might be possible to add an alert type to NS for them from there, or if not, write some oref0 code to look for them in pumphistory and alarm via oref0-pushover if found
Samuchco
@Samuchco
Oct 27 2017 18:49
@scottleibrand I think it's important since many have old pumps and this alarm can give some peace of mind
@Samuchco Correction, ALL have old pumps. Many second hand
ejoe132
@ejoe132
Oct 27 2017 18:53
@garykidd iOS
dan lightner
@danimaniac
Oct 27 2017 18:56
How do I confirm my rig is using exponential curves vs. bilinear? I updated my rig to 0.6.0 dev about a week ago and edited my preferences to "rapid-acting" but how do I verify the different curve is active? Is it indicated in the rig logs somewhere?
Scott Leibrand
@scottleibrand
Oct 27 2017 19:02
@danimaniac no, you'd need to edit the code to add a console.error() statement to print that out
alternateal
@alternateal
Oct 27 2017 19:09
Is there a “child’s guide” to time zone changes somewhere - UK and Europe return to GMT and CET on Sunday so just checking before it happens??
ejoe132
@ejoe132
Oct 27 2017 19:41
@alternateal When Ive traveled outside my tz I just followed the advice in the docs that if I dont have to change time for my basal rates I just leave everything.
Tim Street
@tim2000s
Oct 27 2017 19:42
@alternateal there’s a troubleshooting guide in the docs for time zone changes. I don’t remember doing anything when we moved to BST though. I think NTP and the rig took care of it.
alternateal
@alternateal
Oct 27 2017 19:49
@tim2000s - that was my recollection also, with the SMB check of pump time however now also??
Tim Street
@tim2000s
Oct 27 2017 19:50
SMB oref0-pump-loop updates the pump time so that’s fine.
John Benjamin
@Bender1061
Oct 27 2017 20:31
@scottleibrand are you completely set on the oref0-online changes you just made to openaps/oref0#716 ? cause I was just making almost the exact changes with a bunch of others to that right now for the PR I'm working on.
I have gotten everything to work, I'm just sometimes getting stuck in a loop on turing on the wifi when I turn on the bluetooth when things happen in certain orders.
working on making it more robust
PieterGit
@PieterGit
Oct 27 2017 21:13
Proudly presenting... nightscout/cgm-remote-monitor#2991 please help review/test/merge to Nightscout dev. This will add a prediction line, and improve the render of SMB's in Nightscout.
peterlynton
@peterlynton
Oct 27 2017 23:01
I’m getting this issue the last two evenings as I move upstairs and therefore maybe switch between wireless access points:
’Starting supermicrobolus pump-loop at Fri Oct 27 23:52:01 BST 2017 with 4 second wait_for_silence:
grep: enact/smb-suggested.json: No such file or directory
Waiting up to 4 minutes for new BG: ls: cannot access /tmp/pump_loop_completed: No such file or directory
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight fatal: loose object 8849f6c095ebdec23230b9a0d9b9f2fe49a72a98 (stored in .git/objects/88/49f6c095ebdec23230b9a0d9b9f2fe49a72a98) is corrupt'
fail. Preflight fatal: loose object 8849f6c095ebdec23230b9a0d9b9f2fe49a72a98 (stored in .git/objects/88/49f6c095ebdec23230b9a0d9b9f2fe49a72a98) is corrupt'
fail. supermicrobolus pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Listening for 40s silence before mmtuning: .No interfering pump comms detected from other rigs (this is a good thing!)
mmtune: fatal: loose object 8849f6c095ebdec23230b9a0d9b9f2fe49a72a98 (stored in .git/objects/88/49f6c095ebdec23230b9a0d9b9f2fe49a72a98) is corrupt'
"916.636", 0, -99 waiting for 78 second silence before continuing
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight fatal: loose object 8849f6c095ebdec23230b9a0d9b9f2fe49a72a98 (stored in .git/objects/88/49f6c095ebdec23230b9a0d9b9f2fe49a72a98) is corrupt'
fail. Done waiting for rigs with better signal.
Unsuccessful supermicrobolus pump-loop at Fri Oct 27 23:57:35 BST 2017’
What’s a loose object and how can I prevent?
It stops the loop running, yesterday I was able to resolve by reinstalling but would like to not have to do this every bedtime:/
PieterGit
@PieterGit
Oct 27 2017 23:11
I noticed the instructions for recreating a git a wrong on that PR for 0.5.0 release. It should be cd ~/myopenaps; rm -rf .git ; git init. Starting with 0.6.0 release there will be no git versioning by default. Can you PR this to the docs?
peterlynton
@peterlynton
Oct 27 2017 23:23
@PieterGit thanks for the updated instructions, I will PR in the morning.