These are chat archives for nightscout/intend-to-bolus

20th
Dec 2017
philipgo
@philipgo
Dec 20 2017 00:03
@live4sw The changes to OpenAPS are definitely included in the current master. Upgrading your Nightscout certainly does not hurt, but I fear the age of your Nightscout version may also not be the cause
live4sw
@live4sw
Dec 20 2017 01:19
Thanks @drnoname82 - I'm not particularly concerned as long as the missing bolus in NS is picked up in IOB in oref0 itself (which it is). Sounds like it's all good.
Cameron Chunn
@applehat
Dec 20 2017 01:31
So, I just had to reflash my edison, which means I am starting from scratch again. I went to check the docs to get the script for the setup, and it seems to be missing in the docs. I checked github revisions and found https://raw.githubusercontent.com/openaps/oref0/master/bin/openaps-install.sh but wasn't sure if that was still the correct way to setup a new rig. Am I missing something, or did the docs get goofed?
live4sw
@live4sw
Dec 20 2017 01:33
@applehat what about under prep steps at the beginning of http://openaps.readthedocs.io/en/latest/docs/Build%20Your%20Rig/edison-install.html
Cameron Chunn
@applehat
Dec 20 2017 01:34
Ahhh. I managed to miss that because I had to go back to reflash
Sorry, Im an idiot.
thanks!
cduarte
@cduarte
Dec 20 2017 01:44
@scottleibrand Dont work shareable.. maybe because is pedriatric model =/
Glenn Primack
@primags
Dec 20 2017 01:56
@live4sw Thank you! I thought I had read that before but didn't notice "enableSMB_always" Thanks!!
live4sw
@live4sw
Dec 20 2017 02:00
@primags Sure thing. I personally don't use the always feature because there is a documented issue with xDrip+ so I prefer to just be conservative with SMB with COB only. But nice to have the option.
Lin
@denglfddd
Dec 20 2017 03:13
I am also redo my OPENAPS, to install oref0-setup this step, http://openaps.readthedocs.io/en/latest/docs/walkthrough/phase-2/index.html
Can not open the guide link
Scott Leibrand
@scottleibrand
Dec 20 2017 04:40
@cduarte i don’t think pediatric G4 receivers have Share capabilities. I believe they say “with Share” on the front if they do.
cduarte
@cduarte
Dec 20 2017 05:05
@scottleibrand my dexcom have write with share.

Have write with share.. but dont working. I will try more times..

But for example the dexcom pediatric model dont work conect with cable in the rig =/

Scott Leibrand
@scottleibrand
Dec 20 2017 05:11
Hmm. There might be some minor differences in encoding that no one has decoded yet. Do you have access to an adult receiver?
cduarte
@cduarte
Dec 20 2017 05:26
I bought one dexcom share adult used :) ! Maybe in next days I will receive and test !
Matthias
@ceben80
Dec 20 2017 07:50
@scottleibrand @PieterGit I won't use my 712 pump, does not work - swap over to my 522
and as said, my recommendation, disable the x12 setup parameter, that just confuses other users
Matthias
@ceben80
Dec 20 2017 08:51

short Q to the OpenAPS pill, only shows Not Enacted

the loop is running fine , here ns-loop.log but the OpenAPS pill still shows "Not Enacted", any idea :question:

Starting oref0-ns-loop at Wed Dec 20 09:48:02 CET 2017:
Glucose file is fresh
Not an openaps environment, run: openaps init
{"glucose":128,"dateString":"2017-12-20T09:45:25.048000+01:00"}
Latest NS temptargets: Merging local temptargets: Temptargets merged: Refreshed carbhistory; COB: 37
{"batteryVoltage":4394,"battery":100}
{"BG":128,"IOB":-0.043,"rate":null,"duration":null,"units":null}
No new treatments to upload
Completed oref0-ns-loop at Wed Dec 20 09:48:21 CET 2017
image.png
Matthias
@ceben80
Dec 20 2017 08:56

weird, shortly after posting, now it's working :smile:

solved

pepecb
@pepecb
Dec 20 2017 09:15
Second rig question: I am building a second rig for offline loop. Should I copy some files from my first rig into the second one as to be able to switch at once?
Mike
@libxmike
Dec 20 2017 09:17
@ceben80 maybe was the Not an openaps environment, run: openaps init? script got confused and did not found openaps env?
@pepecb run the setup script on new rig as you have to setup the environment and update, you can copy later, but you only need the NS API Key (if you use NS) , NS URL, pump serial, network settings which you can copy from old rig, just have two ssh windows open
Mike
@libxmike
Dec 20 2017 09:22
and don't forget to give your 2nd rig different name :)
Matthias
@ceben80
Dec 20 2017 10:05
@libxmike good hint, my .profile has orphan variables (from older installation), but weird I thought all varialbes were set und uses in cron context
thank you!
pepecb
@pepecb
Dec 20 2017 11:47
Thanks Mike. But what will happen to autotune?
Mike
@libxmike
Dec 20 2017 12:37
@pepecb autotune will run separately on every rig IF you enable it
Lin
@denglfddd
Dec 20 2017 14:07
屏幕快照 2017-12-20 22.00.30.png
Where should I check?
Glenn Primack
@primags
Dec 20 2017 15:00
Because of my continued connectivity issues that seem exacerbated by me moving my rig around, I've switched to only using OpenAPS at night, and its working great in this manner.
I'm interested in knowing if there is a way to have my Edison operate only during certain hours (overnight) without physically powering it on and off. During the day, If I walk into the room with the Edison plugged in, It may start to control my pump when I don't want it to. Is there any documentation on how to only have Edison running during certain hours? Thanks
Jason Wittmer
@jbwittmer
Dec 20 2017 15:24
You could edit your cron job to have the pump-loop only run particular hours
Josée
@JoseeT1Bionique
Dec 20 2017 15:30
25590193_10155742279492900_1889549415_o.jpg
@live4sw @ @drnoname82 Same issue with EasyBolus not appearing in NS, but taken by OpenAPS since I'm on Master 0.6.0 + NS 10.2. Sporadic, about every other day. So it's something else that updating NS.
Read on Looped is was a known issue...
alimhassam
@alimhassam
Dec 20 2017 15:42
@JoseeT1Bionique check if IOB is correct
I've seen this also an issue with ns incorrectly deduplicating records or something
Josée
@JoseeT1Bionique
Dec 20 2017 15:51
Hi @alimhassam, IOB is always accurate.
Glenn Primack
@primags
Dec 20 2017 16:00
@jbwittmer I'll try to google the command unless you know what I might use...thx
live4sw
@live4sw
Dec 20 2017 16:21
@primags I've started mostly having my rig in the pocket of my fleece during the day as connectivity is kind of crappy in the office unless it's less than 6 feet from me.
Glenn Primack
@primags
Dec 20 2017 16:23
@live4sw Yeah, it almost seemed like it was getting hung up with transferring from bluetooth to wifi and back. Not exactly sure, but it would be working great ALL night long, and then I would leave to go to work where it wouldn't work for the next several hours (connectivity errors in the pump loop log), even powering off and back on wouldn't fix it. It was driving me nuts. So I just decided to have it be a night rig for me and I'm a lot happier. I can take care of my sugars during the day just fine, its really the nighttime where I go high since I eat right before bed so my food is digesting for the next 6 plus hours during sleep.
live4sw
@live4sw
Dec 20 2017 16:34
@primags Have you considered connecting your receiver directly to the unit to allow for offline looping?
Glenn Primack
@primags
Dec 20 2017 16:35
I tried but found it to be so bulky and I didn't have a good case to handle all of the gear...
@live4sw Do you carry all of it around? If so, how do you secure all your gear?
live4sw
@live4sw
Dec 20 2017 16:39
My edison + lipo is small enough to fit in a very small project box and that just sits in my pocket, with my receiver uploading to NS. If I do offline looping with the rig connected I'll leave it on my desk connected to an external battery or an outlet
ejoe132
@ejoe132
Dec 20 2017 16:41
@scottleibrand "are you still getting read-only file system errors? if so, might be easiest to re-flash" Ive tried reflashing but it just keeps giving me the read only message
Glenn Primack
@primags
Dec 20 2017 16:52
@live4sw Maybe I'll try ditching bluetooth and see if I have any better luck hopping from one wifi (home) to another (work). I'm up and about so much in my job, even though I work IT, I hate being at my desk, so I think I would have trouble trying to offline loop much.
Scott Leibrand
@scottleibrand
Dec 20 2017 17:07
@ejoe132 at what step after a reflash do you start getting the error? Which jubilinux version did you flash?
mkericson
@mkericson
Dec 20 2017 18:00
I did the automated NS update. Do I still need to go back to my github NS Heroku and "Deploy"?
Jacob H
@jdhigh
Dec 20 2017 19:00
Question about different cell phones: I'm thinking about getting a Pixel 2 + using Google Fi for service provider, and I know @live4sw had problems getting bluetooth to work with them, but does anyone else have any feedback on rig performance with Pixel 2?
ejoe132
@ejoe132
Dec 20 2017 20:22
@scottleibrand I guess Im just trying to rerun 0ref0 install. So Ill go back to flashing. Ill have to find that in the docs
ejoe132
@ejoe132
Dec 20 2017 21:45
So been awhile since I done this, downloaded the dfu util, how do I extract that? Doesnt give option when I right click it
John Sjolund
@sjolundjohn
Dec 20 2017 22:20
Can't get past this error after updating to latest master build:
Checking pump clock: "2017-12-20T14:17:19-08:00" is within 1m of current time: Wed Dec 20 14:15:54 PST 2017
Pump clock is more than 55s off: attempting to reset it
Waiting for ntpd to synchronize.No! 
ntpd did not synchronize.
Restarting ntp (via systemctl): ntp.service.
Waiting for ntpd to synchronize... No!
ntpd did not synchronize.
Error: pump clock refresh error / mismatch
Jon Cluck
@cluckj
Dec 20 2017 22:37
do you have ntp installed, and an internet connection?