These are chat archives for nightscout/intend-to-bolus

2nd
Jan 2018
Martin Haeberli
@mhaeberli
Jan 02 2018 00:23
I have been away … how are thoughts coming on the post-Edison world?
(and Happy New Year and thanks! to all!)
Martin Haeberli
@mhaeberli
Jan 02 2018 00:54
pls remind me how best to notify SMB of carbs ? (use bolus wizard, but don’t bolus thru pump?)
alimhassam
@alimhassam
Jan 02 2018 01:43
Best way is probably to enter carbs in NS.
If you use bolus wizard carbs without insulin I don't think carbs will be recorded. if you do bolus wizard with carbs and insulin, you need to be aware of the a52 risk
@mhaeberli ^^^
live4sw
@live4sw
Jan 02 2018 02:00
@mhaeberli I believe most people are using IFTTT to notify NS of carbs now - http://openaps.readthedocs.io/en/latest/docs/Customize-Iterate/ifttt-integration.html
Dana Lewis
@danamlewis
Jan 02 2018 03:35
@jpcunningh :+1: :smile: can't wait to test that
Grant
@Bender_Fry_twitter
Jan 02 2018 03:53
So I've been using OpenAPS with a Medrontic 722 pump for the last 7 months but today my pump has decided that the light/down button doesn't want to function anymore which means I can't rewind the pump, change settings, etc so its effectively useless. I've attempted to clean the button contacts with isopropyl alcohol but that didn't work. Is there a way to spoof that button press digitally? Or am I out of luck in using my openaps rig for the foreseeable future? Any suggestions would be greatly appreciated.
Martin Haeberli
@mhaeberli
Jan 02 2018 05:19
yes so we ended up going IFTTT ...
have I said lately how cool and useful the Edison OpenAPS systems are ?
br
@brmccollum
Jan 02 2018 05:42

Looking for advice on reinstalling openaps on my successfully reflashed jubilinux rig.

After running the initial scripts that setup wifi and installs oref0, after about 5 minutes into the install I get the following error:

E: Unable to locate package npm
I am guessing I need to install something specific from nodeJS?

br
@brmccollum
Jan 02 2018 05:55
@Ebgineer Thanks, I have tried the advice in the section, no luck, going to try to reinstall node manually.
fidoman
@efidoman
Jan 02 2018 11:04
@Bender_Fry_twitter - You can simulate a down arrow press via the command line.
@Bender_Fry_twitter - cd ~/myopenaps && openaps-use pump press_keys DOWN
has to be done while openAPS is not communicating with the pump, so you'll likely need to stop openaps, kill openaps, run the press-keys, then restart openaps.
You can chain these as follows:
cd ~/myopenaps && openaps-use pump press_keys ACT DOWN
hotelmama
@hotelmama
Jan 02 2018 11:56
Hi there! Trying to run OpenSps with an edison and libre/sony smart watch/nightscout. NS runs fine, shows everything a few seconds after input, but the edison does:nt get the data ({"delta":8.03,"glucose":89.65,"short_avgdelta":6.54,"long_avgdelta":4.7,"date":1514838089998.169}
Checking deliverAt: null is within 1m of current time: Tue Jan 2 12:43:49 CET 2018
date: invalid date ‘null’
Couldn't smb_verify_suggested
oref0-pump-loop failed. {"reason":"If current system time Tue Jan 02 2018 12:43:49 GMT+0100 (CET) is correct, then BG data is too old. The last BG data was read 922.3m ago at Mon Jan 01 2018 21:21:29 GMT+0100 (CET). Temp 0 <= current basal 1U/hr; doing nothing. „}) I checked date and time on all devices. @selin08 had the same problem on dec 22 at 18:26:44. Any ideas? Thx.
Dana Lewis
@danamlewis
Jan 02 2018 14:25
@Jane49 moving your OpenAPS questions over here. I would check the reservoir data in NS to confirm how much was delivered in that time period
@hotelmama is your rig online? And do you have recent bg data in NS?
hotelmama
@hotelmama
Jan 02 2018 14:52
@danamlewis at the moment its neither, but a few ours ago everything was up to date. I will try to solve eventual ns problems - is there a command to check if the rig is online or not? (at setup I have put in network and passwords)
Dana Lewis
@danamlewis
Jan 02 2018 15:09
You need recent BGs in order to be able to loop. If you're not constantly uploading BGs, it's not going to provide or enact insulin dosing recommendations.
You can ping google.com to see if it is online
hotelmama
@hotelmama
Jan 02 2018 15:44
@danamlewis no, its not online. I think that my combination of libre/libre alarm and glimp/nightscout does not work dependably, I am going to try clearing those and then maybe rerun oref0-setup. thanks for now <3
Dana Lewis
@danamlewis
Jan 02 2018 15:57
Good plan of fixing reliability of bg data :+1:
PieterGit
@PieterGit
Jan 02 2018 20:47
@danamlewis : i want to create a page for how to fix a broken off micro-usb. should i do every photo seperatly or merge them in a single png
Dana Lewis
@danamlewis
Jan 02 2018 20:47
your call on what best communicates along with your instructions?
PieterGit
@PieterGit
Jan 02 2018 20:50
ok, i'll write and do what i think is best.
Dana Lewis
@danamlewis
Jan 02 2018 20:52
:+1:
PieterGit
@PieterGit
Jan 02 2018 20:59
i'm using source tree for github management, but will make descriptive filenames :smile:
Dana Lewis
@danamlewis
Jan 02 2018 20:59
make sure to use _ in the filename, otherwise Github gets cranky if you have spaces
#hardlessonslearned
:)
PieterGit
@PieterGit
Jan 02 2018 21:02
i never use spaces in filenames (been there, got the t-shirt), not with github but with harder lessons like rm -rf
Dana Lewis
@danamlewis
Jan 02 2018 21:02
heh
Jon Cluck
@cluckj
Jan 02 2018 21:54
the explorer hat will use the same type of battery as the edison explorer :)
maybe...bigger though
PieterGit
@PieterGit
Jan 02 2018 21:57
but if you use a dexcom receiver, you still need a USB battery pack
at least with the edison board
Grant
@Bender_Fry_twitter
Jan 02 2018 23:04
@efidoman Thanks this worked. Not super convenient but beats going back to my dumb animas pump.
ejoe132
@ejoe132
Jan 02 2018 23:13
Hello, trying to reflash, downloaded and extracted jubilinux but for the dfu-utl I download that and it downloads as an unreadable file type named "dfu-util-0.8-binaries.tar.x2" but it wont let me if I right click it to extract the file? What am I missing in this step?
ejoe132
@ejoe132
Jan 02 2018 23:26
so got that sorted but when starting flashing I enter flashall.bat and it returns "-bash: flashall.bat: command not found" not sure whats happening here