These are chat archives for nightscout/intend-to-bolus

9th
Jan 2018
Scott Leibrand
@scottleibrand
Jan 09 2018 00:12
Is it on regular Wi-Fi or the phone’s hotspot?
Thacher
@thacherT1D
Jan 09 2018 00:35
regular wifi
I got a new phone, so the whole reason I wanted to log in this time was to run again/update the bluetooth settings so tethering would work with the new devicce
Scott Leibrand
@scottleibrand
Jan 09 2018 01:22
Do you know the IP of the rig? Have you tried sshing to that?
Thacher
@thacherT1D
Jan 09 2018 01:23
Same thing -- permission denied after entering the password
Screen Shot 2018-01-08 at 5.23.43 PM.png
Thacher
@thacherT1D
Jan 09 2018 01:30
I even looked up a nuclear option of just reflashing and starting clean (on a back up one), but I can't find directions that will let me do that w/o first logging in
Scott Leibrand
@scottleibrand
Jan 09 2018 01:59
I doubt thatcherhussain is your username on the rig. Try ssh root@(IP)
Thacher
@thacherT1D
Jan 09 2018 02:18
omfg
thank you
I'm in
you're the best
Dave Acklam
@dcacklam
Jan 09 2018 11:37
@LilDucky
@LilDucky I just went through the process of fixing oref0 for the pi
Just haven't had time to push PRs
LilDucky
@LilDucky
Jan 09 2018 12:12
Cool, will watch and wait and then test
Scott Leibrand
@scottleibrand
Jan 09 2018 14:45
@dcacklam check the explorer-hat branch for some non-HAT-specific Pi fixes too.
Scott Leibrand
@scottleibrand
Jan 09 2018 15:50
@silentium123 if you’re getting a —nogit error, that usually means you installed a newer version of oref0 and then tried to install an older version. Which branch of oref0 are you trying to install?
jzycom123
@jzycom123
Jan 09 2018 16:15
egirard
@egirard
Jan 09 2018 17:16
Hi there - I'm getting failures in oref0-calculate-iob.js reading settings/profile.json. JSON.parse dies on an empty file. I've entered content into it and it seems to be getting wiped out/reset by some earlier part of the loop. What am I missing?
silentium123
@silentium123
Jan 09 2018 17:16
@scottleibrand
i using dev branch
@scottleibrand and oref version is oref0@0.6.1-dev
Scott Leibrand
@scottleibrand
Jan 09 2018 17:19
@egirard is this on a fresh install or a previously-working rig?
@silentium123 ok, then that shouldn’t be the issue. Can you paste the error here again?
silentium123
@silentium123
Jan 09 2018 17:20
@scottleibrand
root@edison:~/myopenaps# openaps init
Traceback (most recent call last):
File "/usr/local/bin/openaps", line 170, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/usr/local/bin/openaps", line 155, in run
builtins.dispatch(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/builtins.py", line 44, in dispatch
command(args)
File "/usr/local/lib/python2.7/dist-packages/openaps/init.py", line 6, in init
if args.args[1] == '--nogit':
IndexError: list index out of range
egirard
@egirard
Jan 09 2018 17:21
@scottleibrand Fresh install. I reinstalled when I switched from Medtronic cgm to the G5.
Scott Leibrand
@scottleibrand
Jan 09 2018 17:22
@egirard you might try openaps/oref0#894
@silentium123 out of curiosity, why are you doing a manual openaps init?
What openaps --version?
egirard
@egirard
Jan 09 2018 17:40
@scottleibrand Thanks! That fixed it.
Scott Leibrand
@scottleibrand
Jan 09 2018 20:06
Great! Want to note that on the PR?
silentium123
@silentium123
Jan 09 2018 21:35
@scottleibrand openaps 0.2.1-dev
David
@davidkeddydb
Jan 09 2018 21:43
Screenshot 2018-01-09 16.28.16.png
Screenshot 2018-01-09 16.41.16.png
So I am having trouble understanding why the rig keep throwing a max safe basal limit. Here my openaps pill and my pref file. What am I not seeing correctly?
  "max_iob": 14,
    "max_dailyety_multiplier": 6,
    "current_basal_safety_multiplier": 12,
    "autosens_max": 1.2,
    "autosens_min": 0.7,
    "rewind_resets_autosens": true,
    "adv_target_adjustments": true,
    "unsuspend_if_no_temp": true,
    "enableSMB_with_bolus": true,
    "enableSMB_with_COB": true,
    "enableSMB_with_temptarget": true,
    "maxSMBBasalMinutes": 135,
    "enableUAM": true,
    "curve": "rapid-acting",
    "useCustomPeakTime": true,
    "insulinPeakTime": 60
My current basal is 1.0 u/hr and my my highest daily basal rate is 1.0, so if the current basal safety is 12, and the max daily is 6, shouldn't I be capped out at 6.0 u/hr?
Tore Bjørndalen
@BjoTore_twitter
Jan 09 2018 21:47
check spelling error for max_dailyxxxx
David
@davidkeddydb
Jan 09 2018 21:48
@BjoTore_twitter I thought that was how it went from the scripts but maybe I miss typed it at some point!
Tore Bjørndalen
@BjoTore_twitter
Jan 09 2018 21:50
max_daily_safety_multiplier
David
@davidkeddydb
Jan 09 2018 21:52
Now I just have to get over 200 mg/dl to see if it works. Thanks @BjoTore_twitter for catching the typo. I should have seen that
Tore Bjørndalen
@BjoTore_twitter
Jan 09 2018 21:52
:)
dancinbear8825
@dancinbear8825
Jan 09 2018 23:43
Good evening, I need help . I had a functioning system off and on for a few days, now is off and I am not having any luck getting it back on. I have tried everything I can think of/ read through/ suggested short of blowing out (or up) the hardware and starting over-- which I dont even know how to do. Someone suggested having two instances running, which is possible as I am a complete novice to this world and did set up a system a few months ago, but got frustrated and quit... started a new install on the same edison/explorer. But I dont even know how to check and see. Can someone give me a little of their time and help me sort through this? I hate the feeling of helplessness I have with this system- I want to learn how to fix this but learning a new language is NOT easy!