These are chat archives for nightscout/intend-to-bolus

21st
Feb 2018
j4cbo
@j4cbo
Feb 21 2018 00:45
attempting to explain Fiasp F50N to my doctor...
Scott Leibrand
@scottleibrand
Feb 21 2018 01:21
“300x as much nicotinamide as insulin gives you only about 10% more activity than 150x”
j4cbo
@j4cbo
Feb 21 2018 02:01
i'm really amazed that fiasp got approved in the pump at all
while i'm here: would anyone like a free-for-cost-of-shipping (in the US) Contour Next Link meter? i found one in my drawer
Dana Lewis
@danamlewis
Feb 21 2018 02:05
@applehat ^ still need one?
garykidd
@garykidd
Feb 21 2018 03:38
@scottleibrand sorry man--lost the link you provided me recently on group for pi zero hat group...?
anybody having success with other pumps besides medtronic?
Scott Leibrand
@scottleibrand
Feb 21 2018 06:15
@garykidd what group is that?
if you can get a Roche Accu-Chek Combo, that is now loopable with AndroidAPS...
Tim Street
@tim2000s
Feb 21 2018 06:57
@scottleibrand - iirc, I had had issues with an older version of bluez and had to do a manual install at some point. I’m resurrecting an old rig (hasn’t been used for about 9 months).
azizmarafie
@azizmarafie
Feb 21 2018 11:24
hello
how are you all, hoping all is well
i was wondering, if i can i set up maximum IOB and max Basel per hour for each time interval ?
for example from 1:00 am to 7:00 am max IOB =1Unit, and 7:01 AM to 12:59 AM Max IOB = 3Units
azizmarafie
@azizmarafie
Feb 21 2018 11:30
i know i can set up the BG range in the pump, but i would like to have a backup for preventing hypo's
garykidd
@garykidd
Feb 21 2018 13:32
@azizmarafie i dont think you can havd different iob for different time period. But oref0 has a lot of backups go prevent hypos. You can have a higher target bg in your desired range, however.
Dana Lewis
@danamlewis
Feb 21 2018 15:32
Correct. The only different time setting is target based.
garykidd
@garykidd
Feb 21 2018 16:22
@scottleibrand regarding the group question...I think it was gitter room/channel that was working on pi hat development..maybe specifically for pi zero? YOU had previously provide d a link to it---but I lost it and couldnt seem to find it searching here...thx.
Scott Leibrand
@scottleibrand
Feb 21 2018 16:24
That would be openaps/hardware-dev
garykidd
@garykidd
Feb 21 2018 16:25
cool...thanks, bud.
marafie
@marafie
Feb 21 2018 17:13
How can I change the max iOB and other insulin related factors?
Dana Lewis
@danamlewis
Feb 21 2018 17:14
max IOB: http://openaps.readthedocs.io/en/latest/docs/While%20You%20Wait%20For%20Gear/preferences-and-safety-settings.html#max-iob (and the rest of the preference-based settings are listed there). anything else comes from your pump (baseline ISF, carb ratio, target, basals, etc.)
Sydgimi82
@Sydgimi82
Feb 21 2018 17:37

Hi.. serious frustration. I am trying to get wifi working on my rig again. When I left the house the my phone's hotspot and rig couldn't talk to one another. I came back home and oref0 can't seem to find an IP address to allocate. So -- tried to run setup again and got this: *Removing any existing git
Removed any existing git
Checking openaps 0.2.1 installation with --nogit support
openaps 0.2.1-dev
Checking /root/myopenaps: mkdir: cannot create directory ‘/root/myopenaps’: File exists
/root/myopenaps initialized
/root/src/decocare/ already exists; pulling latest 0.1.0-dev
fatal: unable to connect to github.com:
github.com: Name or service not known

Couldn't pull latest decocare 0.1.0-dev* I have no idea what's going on and I'm getting ready to throw in the towel

Tim Street
@tim2000s
Feb 21 2018 17:47
Check your /etc/wpa_supplicant/wpa_supplicant.conf file and make sure the Wi-fi configuration is correct.
Sydgimi82
@Sydgimi82
Feb 21 2018 17:50
@tim2000s will take a look.. but what am I looking for?
Sydgimi82
@Sydgimi82
Feb 21 2018 17:59
image.png
Does this look Kosher?
Tim Street
@tim2000s
Feb 21 2018 18:01
As long as your SSIDs match your networks and there are no errors in the passwords, it looks okay.
Sydgimi82
@Sydgimi82
Feb 21 2018 18:02
They do.. is there a "start" wifi command or should oref0 do that automagically
Tim Street
@tim2000s
Feb 21 2018 18:02
Have you enabled the headless setting in preferences which switches over to make the rig a hotspot when the external connection is lost?
oref0-online.sh handles the network up/down processes and then Linux standard networking should pick the right one to connect to.
Sydgimi82
@Sydgimi82
Feb 21 2018 18:03
I have offline hotspot set to true
I have two home networks - Mann and Mann5G - will that be confusing for picking up a connection? I've noticed that when I run setup again, it doesn't find the "strongest network" any more.. and I have to enter that in manually
Sydgimi82
@Sydgimi82
Feb 21 2018 18:12

This is what I am getting when I try to initiate wifi" *Getting new wlan0 IP

No BT MAC provided: not activating local-only hotspot
Cycling wlan0
Failed to bring up wlan0.
Finished oref0-online at Wed Feb 21 13:10:24 EST 2018.

Starting oref0-online at Wed Feb 21 13:11:02 EST 2018.
At Wed Feb 21 13:11:02 EST 2018 my wifi is not connected
At Wed Feb 21 13:11:02 EST 2018 my local wifi IP is: unassigned
At Wed Feb 21 13:11:02 EST 2018 my Bluetooth PAN is not connected
At Wed Feb 21 13:11:02 EST 2018 my public IP is: not found

At Wed Feb 21 13:11:02 EST 2018 my wifi is not connected*

image.png
Last thing... is this the right file name:
ArvoNiilo
@ArvoNiilo
Feb 21 2018 18:23
Why does my autotune.log look like this, i.e. starting only from 14:00?. This has been the case for several days.
Last login: Wed Feb 21 19:35:57 2018 from 192.168.8.103
root@keinohaima:~# tail -F /var/log/openaps/autotune.log
14:00 | | 1.020
15:00 | | 1.032
16:00 | | 1.032
17:00 | | 1.032
18:00 | | 1.032
19:00 | | 1.032
20:00 | | 1.032
21:00 | | 1.032
22:00 | 0.900 | 1.080
23:00 | 0.950 | 1.128
Dana Lewis
@danamlewis
Feb 21 2018 18:24
it's just spitting out the end of it instead of the full thing
ArvoNiilo
@ArvoNiilo
Feb 21 2018 18:25
can I help it? it quite useless as this.
Sydgimi82
@Sydgimi82
Feb 21 2018 18:31
@ArvoNiilo is that because of the tail command?
image.png
ok, I rebooted my rig but the DHCP service failed to start -- from papertrail
ArvoNiilo
@ArvoNiilo
Feb 21 2018 18:41
don't know. Is there an alternative. I found from the readthedocs only this command.
Sydgimi82
@Sydgimi82
Feb 21 2018 18:46
'head' will give you the head of the file and then use the 'more' command to scroll thru the rest of the file.
ArvoNiilo
@ArvoNiilo
Feb 21 2018 18:54
what is the file name? head autotune.log did not work.
Sydgimi82
@Sydgimi82
Feb 21 2018 18:59
head -F /var/log/openaps/autotune.log
ArvoNiilo
@ArvoNiilo
Feb 21 2018 19:01
sorry - got this: root@keinohaima:~# head -F /var/log/openaps/autotune.log
head: invalid option -- 'F'
ArvoNiilo
@ArvoNiilo
Feb 21 2018 19:12
problem solved: cat autotune.2018-02-21-040503.log opened the file from autotune directory
Sydgimi82
@Sydgimi82
Feb 21 2018 20:08
i flashed a new edison and went to setup wifi (me and wifi are not getting along).. entered: vi /etc/network/interfaces
But got a "file doesn't exist" ?????
Scott Leibrand
@scottleibrand
Feb 21 2018 20:09
@Sydgimi82 are you editing wpasupplicant.conf or wpaupplicant.conf ?
Sydgimi82
@Sydgimi82
Feb 21 2018 20:12
@scottleibrand I thought I was editting supplicant but when I looked at the filename up top it said wpaaupplicant. Any way.. i put that aside and flashed a new edison but I am getting a file doesn't exist message when I try open it with vi /etc/network/interfaces command
Scott Leibrand
@scottleibrand
Feb 21 2018 20:17
best to copy and paste what's on the screen, including the command prompt, the command you entered, and the full response
Sydgimi82
@Sydgimi82
Feb 21 2018 20:18
will do
Scott Leibrand
@scottleibrand
Feb 21 2018 20:18
fwiw, the -F (follow) argument only makes sense for tail, not head
Sydgimi82
@Sydgimi82
Feb 21 2018 20:45
image.png
image.png
@scottleibrand hi. here are the before and after screenshots - before is prior to issuing the command and what I see afterwards. Thx.
Scott Leibrand
@scottleibrand
Feb 21 2018 21:18
@Sydgimi82 so you're editing the file, but somehow you erased its contents. you should be able to copy and paste in from the example in the docs
Sydgimi82
@Sydgimi82
Feb 21 2018 21:19
@scottleibrand that's what I was going to do but I tell ya... it seemed like it was empty to begin with.. but will do that... thanks
andyhandy
@andyhandy
Feb 21 2018 21:42
Has anyone seen this sort of error message? "No duration found for 0 U/hr basalundefined { programmed: 1.8"? Thanks
Scott Leibrand
@scottleibrand
Feb 21 2018 21:53
Yeah, that is pretty common (and not a big deal). I think it’s fixed in dev
andyhandy
@andyhandy
Feb 21 2018 22:25
Thanks @scottleibrand
Sydgimi82
@Sydgimi82
Feb 21 2018 22:26
@scottleibrand after copying and pasting I'm getting: "no such file or directory" when doing an <ESC> :wq... does that mean that the file doesn't exist?
image.png
Scott Leibrand
@scottleibrand
Feb 21 2018 22:54
ah, that probably means /etc/network/ directory doesn't exist
if so, there's probably lots of other stuff that won't work
exit out (with <esc>:q! ) and then ls /etc/network to check that
Sydgimi82
@Sydgimi82
Feb 21 2018 23:02
@scottleibrand yeah..not there... I don't understand... all I had done is flash the edison
Sydgimi82
@Sydgimi82
Feb 21 2018 23:15
image.png
@scottleibrand hey, tried to flash the edison again. Is this a runtime error?
Martin Haeberli
@mhaeberli
Feb 21 2018 23:31
edison.png
this part broke off of one of my edisons; doesn’t seem to want to boot any more. Any hints as to who to send it to to fix it?
Eric
@ecc1
Feb 21 2018 23:42
That's the 2.4GHz/5GHz chip antenna for WiFi (and Bluetooth too, I guess). I'm surprised that affects booting though. It should only require a couple of connections if you can find someone with surface-mount soldering skills.
Martin Haeberli
@mhaeberli
Feb 21 2018 23:42
maybe it boots but unsurprisingly doesn’t talk to networks ...
I could probably do it myself but end up very frustrated; luckily I have a local resource ...