These are chat archives for nightscout/intend-to-bolus

25th
Feb 2018
Doug
@dougboss
Feb 25 2018 04:17
Im another one that gets to
[ OK ] Mounted /home.
Starting Rescue Shell...
[ OK ] Started Rescue Shell.
[ OK ] Reached target Rescue Mode.
Im trying to use Intel mini breakout board to flash the edison while I wait for the explorer board
At that point nothing can be entered. Ive tried all the various trouble shooting steps.
If I interrupt the boot and try reflashing I end up at the same spot
Ill redownload jubilinux to be sure
Doug
@dougboss
Feb 25 2018 04:36
fresh copy of jubilinux didnt help
if i interrupt boot and rerun flashall.bat from dos it still ends at Reached target rescue mode
Doug
@dougboss
Feb 25 2018 05:13
ok after another beer and more tries I was able to restart the flash, it flashes and runs for about 5 minutes with about 8 or more reboots that look identical and finally ends up at the same place ... "Reached target rescue mode "
Scott Leibrand
@scottleibrand
Feb 25 2018 06:28
What version of jubilinux?
And how long does the ”please wait 10 minutes” step take?
tazitoo
@tazitoo
Feb 25 2018 14:10
@dougboss - near the bottom of the meowlink wiki ( https://github.com/oskarpearson/mmeowlink/wiki/Prepare-the-Edison-for-OpenAPS ) there's a trouble shooting tip for being stuck in 'rescue mode' that might help
Steve Mann
@stevemann_twitter
Feb 25 2018 15:04
Hi. Having a challenge getting loop back online. Keep getting the following: Waiting up to 4 minutes for new BG: glucose.json newer than pump_loop_completed
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight OK. Profile less than 60m old; Profile valid. Ref
{"status":"normal","bolusing":true,"suspended":false}
Couldn't refresh_pumphistory_and_meal
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Listening for 40s silence before mmtuning: .No interfering pump comms detected from other rigs (this is a good thing!)
mmtune: "916.588", 5, -56. Some guidance would be great. Thank you.
Doug
@dougboss
Feb 25 2018 15:23
@scottleibrand I dont think I ever saw the wait 10 min ... Im using the same PC that worked to flash my other edison last week ...
Matthias
@ceben80
Feb 25 2018 15:50
@danamlewis @scottleibrand Hello Dana, hello Scott ;)
Due to the fact I've been AAPS looping for the last 5 months, currently I am not up to date, my question: is there any G5 solution available (w/o xdrip and original G5 receiver) the rig is receiving the BGs via bluetooth :question:
Doug
@dougboss
Feb 25 2018 16:36
@tazitoo I saw that but when mine gets to rescue mode contrl D does nothing the screen is locked. And I have no idea what uboot variable to change
philipgo
@philipgo
Feb 25 2018 16:47
@ceben80 Check out thebookbins/xdrip-js
tazitoo
@tazitoo
Feb 25 2018 17:05
@dougboss - during the boot process, do you see in the terminal 'Hit any key to stop autoboot: 0 '? That's when you need to just hit any key - and then follow the wiki instructions.
Doug
@dougboss
Feb 25 2018 17:53
with a version of this https://groups.google.com/forum/#!topic/openaps-dev/hh7hc1uKRKo i was able to retunr to poky and now Ill try jubilinux again , at least it confirms my cables are ok and setup is right THANKS !
Juan Mejías
@juanjuanmejias_twitter
Feb 25 2018 18:00
Hi everybody, Juan from Spain here. First of all thank you so much @scottleibrand , @danamlewis and everyone who makes this possible. I recently joined the group and have been reading the docs until I came up with my first roadblock. My current pump (640G) is, as per the docs, not compatible. Fortunately, I had an old 712 stored away in a drawer. Unfortunately, it's givening me an error I can't fix. I wondered if anyone knew bout it and can help me fix it.
Doug
@dougboss
Feb 25 2018 18:01
@juanjuanmejias_twitter whats the error ?
Juan Mejías
@juanjuanmejias_twitter
Feb 25 2018 18:02
The error is E52. The text is as follows (translated from Spanish): E52 - Settings deleted. Reprogram configuration. Call Help Line for Assitance.
Eric
@ecc1
Feb 25 2018 18:06
Have you tried clearing the error with ESC / Act? This may happen when there has been no battery in the pump for a long time.
Juan Mejías
@juanjuanmejias_twitter
Feb 25 2018 18:13
I seemed to have fixed it simply by changing the battery. Thanks! I'll report if I get more issues
Velibor Maric
@vebaba
Feb 25 2018 19:09
@dougboss Take a look at this picture
http://openaps.readthedocs.io/en/latest/_images/mid_flash.png
Do you have that last 1.6GB step? If not, you might run into http://openaps.readthedocs.io/en/latest/docs/Resources/Edison-Flashing/PC-flash.html#b-side-note-regarding-computers-with-less-than-6-gb-ram-b virtual memory problem or you might have a lot of RAM (as I do) and still have same problem. I fixed it by flashing from laptop without any problem....
Velibor Maric
@vebaba
Feb 25 2018 19:17
@scottleibrand @danamlewis I have to gladly report that OAPS had worked unattended for 2 months without hiccups, glitches. If there were problems, they were self corrected. The issue that had arose after that period was lack of the space on Edison and after clearing that update process of the jubilinux failed. Amazing job! Thanks for sharing it with us!
Dana Lewis
@danamlewis
Feb 25 2018 19:30
@vebaba 😊👏🏼 thanks for sharing how it's been going for you!
marafie
@marafie
Feb 25 2018 22:09
hello
i am getting a problem with radio
i did the
•Stop the reboot loop: sudo service cron stop && killall -g oref0-pump-loop && shutdown -c
•Install ccprog tools on your Edison: cd ~/src; git clone https://github.com/ps2/ccprog.git
•Build (compile) ccprog so you can run it: cd ccprog; make ccprog
•Flash the radio chip
and after i did the last line
root@unilinux:~/src# cd ccprog; make ccprog
make: Warning: File 'Makefile' has modification time 570183330 s in the future
make: 'ccprog' is up to date.
make: warning: Clock skew detected. Your build may be incomplete.
root@unilinux:~/src/ccprog#
what is clock skew
Martin Haeberli
@mhaeberli
Feb 25 2018 22:12
here it likely means that your clock is way wrong. try typing time at the prompt and see what it says...
marafie
@marafie
Feb 25 2018 22:25
yes
2000
what does this mean ?
Scott Leibrand
@scottleibrand
Feb 25 2018 22:40
I think you want date instead.
marafie
@marafie
Feb 25 2018 22:40
i reconnected it to the net
and i did the flesh
and i think now its ok after fleshing
but why do i get this radio mulfunction each few days
Scott Leibrand
@scottleibrand
Feb 25 2018 22:42
Check that the rig isn’t getting too hot...
marafie
@marafie
Feb 25 2018 22:42
ahaa
mybe coz its in my pocket
will try it
marafie
@marafie
Feb 25 2018 22:54
how can i know that i am running oref1 ?
Dana Lewis
@danamlewis
Feb 25 2018 22:56
Oref1 references features of SMB etc. So, it depends on which settings you turn on and if the situation warns them.
marafie
@marafie
Feb 25 2018 23:04
thanks
Dana Lewis
@danamlewis
Feb 25 2018 23:05
:+1: if you share what your settings are, and your logs, that makes it possible to answer specific Qs about if it's enabled and when and why or why not
marafie
@marafie
Feb 25 2018 23:08
for the past 4 months i have the UAM and SMB on and running last 3 weeks i have some issues with radio, i solved the radio and seems to me i used oref0 setup not the oref1,
Dana Lewis
@danamlewis
Feb 25 2018 23:09
K. Paste your preferences? It's a matter of what's in your preferences. It's the same setup. Oref1 name is just to distinguish features that weren't in the original design.
(And logs, if you want to pick apart a certain timeframe)
marafie
@marafie
Feb 25 2018 23:15
{ "max_iob": 10, "max_daily_safety_multiplier": 8, "current_basal_safety_multiplier": 10, "autosens_max": 1.2, "autosens_min": 0.7, "rewind_resets_autosens": true, "adv_target_adjustments": false, "exercise_mode": false, "wide_bg_target_range": false, "sensitivity_raises_target": true, "unsuspend_if_no_temp": false, "enableSMB_with_COB": false, "enableSMB_with_temptarget": true, "enableUAM": true, "curve": "rapid-acting", "offline_hotspot": false }
Starting oref0-pump-loop at Mon Feb 26 02:12:03 +03 2018 with 8 second wait_for_silence: Waiting up to 4 minutes for new BG: glucose.json newer than pump_loop_completed Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!) Preflight OK. Profile less than 60m old; Profile valid. Refreshed pumphistory and meal.json Checking pump clock: "2018-02-26T02:12:46+03:00" is within 1m of current time: Mon Feb 26 02:12:50 +03 2018 Temp refreshed Autotune exists! Hoorah! You can use microbolus-related features. {"carbs":67,"nsCarbs":0,"bwCarbs":67,"mealCOB":0,"currentDeviation":-3.28,"maxDeviation":0,"minDeviation":-3.6,"slopeFromMaxDeviation":0,"slopeFromMinDeviation":0.093,"allDeviations":[-3,-3,-4,-3,0,-2,-3,-1],"lastCarbTime":1519588021000,"bwFound":true} {"iob":-0.198,"activity":-0.0022,"basaliob":-0.198,"bolusiob":0,"netbasalinsulin":-0.35,"bolusinsulin":0,"time":"2018-02-25T23:12:51.000Z","iobWithZeroTemp":{"iob":-0.198,"activity":-0.0022,"basaliob":-0.198,"bolusiob":0,"netbasalinsulin":-0.35,"bolusinsulin":0,"time":"2018-02-25T23:12:51.000Z"},"lastBolusTime":1519588021000,"lastTemp":{"rate":0.85,"timestamp":"2018-02-26T02:00:33+03:00","started_at":"2018-02-25T23:00:33.000Z","date":1519599633000,"duration":13.41}} {"delta":-3,"glucose":130,"short_avgdelta":-3.17,"long_avgdelta":-3.17,"date":1519599908650} Autosens ratio: 0.83; Adjusting basal from 1 to 0.85; target_bg from 99 to 107; ISF from 18.2 to 22; CR: 7.087 currenttemp: { duration: 19, rate: 0.85, temp: 'absolute' } lastTempAge: 12 m tempModulus: 1 m SMB disabled (no enableSMB preferences active) Last carbs 206 minutes ago; remainingCATime: 8.8 hours; 100% carbs absorbed Carb Impact: -3.4 mg/dL per 5m; CI Duration: 0 hours; remaining CI (~2h peak): 0 mg/dL per 5m UAM Impact: -3.4 mg/dL per 5m; UAM Duration: 0 hours minPredBG: 130 minIOBPredBG: 115 minZTGuardBG: 130 avgPredBG: 130 COB: 0 / 67 BG projected to remain above 5.9 for 240 minutes naive_eventualBG: 134 bgUndershoot: -60.5 zeroTempDuration: 240 zeroTempEffect: 89 carbsReq: -48 Checking deliverAt: 2018-02-25T23:13:01.077Z is within 1m of current time: Mon Feb 26 02:13:01 +03 2018 and that smb-suggested.json is less than 1m old enact/smb-suggested.json: {"temp":"absolute","bg":130,"tick":-3,"eventualBG":114,"insulinReq":0,"reservoir":"235.2","deliverAt":"2018-02-25T23:13:01.077Z","sensitivityRatio":0.83,"predBGs":{"IOB":[130,127,125,122,120,118,117,116,115,114,114,114,114,114,114,114,114,115],"ZT":[130,130,130,131,131,131,132,132,132,133,133,133,134,134,135,136,136,137,138,138,139,140,141,141]},"COB":0,"IOB":-0.198,"reason":"COB: 0, Dev: -1.1, BGI: 0.0, ISF: 1.2, CR: 7.09, Target: 5.9, minPredBG 7.2, minGuardBG 6.3, IOBpredBG 6.4; Eventual BG 6.3 > 5.9 but Min. Delta -3.17 < Exp. Delta 0.0, temp 0.85 ~ req 0.85U/hr. "} No smb_enact needed. Temp refreshed: monitor/temp_basal.json: {"duration":18,"rate":0.85,"temp":"absolute"} No bolus needed (yet). Pump profile refreshed; Settings refreshed; Edison battery at 67% is charged (>= 98%) or likely charging (60-70%). Pumphistory-24 < 15m old Completed oref0-pump-loop at Mon Feb 26 02:13:25 +03 2018
@danamlewis here is it
Dana Lewis
@danamlewis
Feb 25 2018 23:22
K. So you'll only get SMB 1) when needed and 2) when there's a temp target. (But both of those have to be true). In that set of logs, you'll see it's saying it won't SMB because no settings permit it (e.g. No temp target) and after that, no bolus needed. But otherwise yes you're running a correct version to allow SMB when your settings permit
marafie
@marafie
Feb 25 2018 23:23
so i need to setup enableSMB_with_temptarget""= false
correct ?
Dana Lewis
@danamlewis
Feb 25 2018 23:24
If you want to turn off SMB ability when you set a temp target. Right now, it's set to true and it's your only SMB setting
Read the preferences page for all the SMB options you can choose to enable if you want SMB. Otherwise yes, change your true to false to turn it off (disable)
marafie
@marafie
Feb 25 2018 23:29
enableSMB_always
enableSMB_after_carbs
will set these to true
Dana Lewis
@danamlewis
Feb 25 2018 23:30
The first _(always) overrides all the others, so if you use that you don't need any others. (Doesn't hurt, but just FYI)
marafie
@marafie
Feb 25 2018 23:32
thanks