These are chat archives for nightscout/intend-to-bolus

27th
Feb 2018
Scott Leibrand
@scottleibrand
Feb 27 2018 00:06
85C
Martin Haeberli
@mhaeberli
Feb 27 2018 00:14
k thx
Scott Leibrand
@scottleibrand
Feb 27 2018 00:44
and that has been tested successfully, both with a rig inside a backpack in the overhead bin, and with the rig wrapped up under the blankets on a hotel bed. in both cases it prevented temps from getting to 90C and shutting down the CPU.
wharper11
@wharper11
Feb 27 2018 02:52
hi! is there an area on gitter for xdripaps questions?
Dana Lewis
@danamlewis
Feb 27 2018 03:19
Here's probably best! @wharper11
wharper11
@wharper11
Feb 27 2018 03:20
ok, thanks @danamlewis.
is it possible to BT tether to a second phone? we are openaps master, g4, xdrip, pixel. I'd like to use an old android specifically for xdripaps offline and the pixel for when we have cellular.
Scott Leibrand
@scottleibrand
Feb 27 2018 04:09
BT tether from an OpenAPS rig to two phones?
if so, that is possible, yes. doesn't really have anything to do with whether or not you use xdripaps.
you have to modify your crontab to list both MAC addresses (with just a space between them), and BT pair them both per the directions in the docs
then oref0-online will try them both in order and stop once if it gets connected to the Internet via the first one
skubesch
@skubesch
Feb 27 2018 04:22
I'm having trouble finding a solution in the docs but if I missed it could somebody point me in the right direction? I'm trying to set up a pi as a backup rig with a Carelink stick (for now) but it's not able to communicate. I'm getting mmtune: KeyError: 'mmtune' in the logs
Screen Shot 2018-02-26 at 11.19.09 PM.png
If it is possible to disable mmtune to use carelink, could anybody tell me how it is done?
kitkatter
@kitkatter
Feb 27 2018 04:31
Hello, I am interested in open aps and have some very basic questions, can anyone help me please? Thank you
Scott Leibrand
@scottleibrand
Feb 27 2018 04:34
@skubesch Carelink is not supported until/unless someone (like you) figures out what's needed to make it work again
it has never worked since we switched over to oref0-pump-loop AFAIK, and I'm more interested in making the new HATs work than dealing with the old crappy Carelink radios
phoenixflame611
@phoenixflame611
Feb 27 2018 05:45
Hi all! I got a sample of Fiasp from my Endo today, and was curious if there is anything else I should do in my settings prior to use? I am going to change to ultra-rapid curve, any other suggestions?
Scott Leibrand
@scottleibrand
Feb 27 2018 05:46
don't pre-bolus
if you're using SMB, consider entering all your carbs but only bolusing for half, 2/3, or 3/4 of them, and letting SMB do the rest
phoenixflame611
@phoenixflame611
Feb 27 2018 05:47
Roger, thank you!!
Martin Haeberli
@mhaeberli
Feb 27 2018 06:29
What command can i use to read the Edison temperature?
woodtrevor
@woodtrevor
Feb 27 2018 06:39
@kretep I'd be willing to help if you are interested. I still have a PI/Carelink bedside rig (somehow mine has good range). It hasn't been updated in a while but 0.6.0 has me interested in getting that done. So I also need to get Carelink working again.
Scott Leibrand
@scottleibrand
Feb 27 2018 06:49
@mhaeberli follow those links I sent you
sooperlooper
@sooperlooper
Feb 27 2018 06:54
Any updates on offline OpenAPS integration with Spike iOS? Ive been using the app since it was released and it has been extremely reliable for looping
Perhaps some of the best readings I've ever had because they are so accurate and hardly any missed readings
Only piece of the puzzle that's missing is offline compatibility!! Is there any way I can help?
Scott Leibrand
@scottleibrand
Feb 27 2018 06:58
no one has reviewed the Spike code yet to see how it handles CGM noise and whether it can communicate the noise level to OpenAPS so we can loop safely
is that source code available? if so, would you like to take the first look through to figure that out?
sooperlooper
@sooperlooper
Feb 27 2018 07:02

@scottleibrand I believe it is! https://github.com/SpikeApp/Spike

I can definitely check it out. Also there is a new gitter channel: https://gitter.im/SpikeiOS/Lobby?utm_source=ios&utm_medium=link&utm_campaign=ios-share-link

Martin Haeberli
@mhaeberli
Feb 27 2018 07:19
@scottleibrand thx - sorry I didn’t ‘get it’ the first time
KS615
@KS615
Feb 27 2018 15:05
Hi, I'm updating a rig to the latest developer and have completed all of the preference edits. Its not looping (no temp basals in the pump) and I'm seeing the following error on papertrail: eb 27 10:00:10 edison1 ns-loop.log: Latest NS temptargets: Merging local temptargets: Temptargets merged: Invalid profile.json.new after refresh
I double checked my preferences and can't find a typo, but does this error mean that there must be one (I did have to manually add some of the advanced preferences
?

And, when I check the logs in putty, all I get is ```Starting oref0-pump-loop at Tue Feb 27 09:58:02 EST 2018 with 29 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access /tmp/pump_loop_completed: No such file or directory
mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?

Radio check failed. mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
Listening for 40s silence before mmtuning: ```

I've had two other rigs fail recently (seemed like various issues) but now I'm worried it could be the radiofrequency on my pump. any suggestions based on these messages?
PeetuHongisto
@PeetuHongisto
Feb 27 2018 15:55
2/27/2018, 4:33 PM    Meal Bolus    67 (BolusWizard)    1.7    50    openaps://medtronic/722    Normal bolus with wizard. Calculated IOB: 2.3 Programmed bolus 1.7 Delivered bolus 1.7 Percent delivered: 100% Food estimate 1.7 Correction estimate 0.1 Bolus estimate 1.7 Target low 50 Target high 60 Hypothetical glucose delta -85 Glucose was: 67

2/27/2018, 4:31 PM    BG Check    120 (Finger)            openaps://medtronic/722
I have been wonderin why openaps is zero temping often after meal bolus. I just found this from the NS admin tools. Looks like it's asuming glucose is 67, when it really was 6,7 (120). What's with this and how I could fix it?
This was in pumphistory:
{
    "_type": "BolusWizard",
    "bg": 67,
    "bg_target_high": 60,
    "correction_estimate": 0.1,
    "unknown_byte[10]": 0,
    "_description": "BolusWizard 2018-02-27T16:33:44 head[2], body[13] op[0x5b]",
    "timestamp": "2018-02-27T16:33:44",
    "_body": "32901d3232011100000700113c",
    "carb_input": 50,
    "_head": "5b43",
    "unabsorbed_insulin_total": 0.7,
    "_byte[5]": 1,
    "unabsorbed_insulin_count": "??",
    "_byte[7]": 0,
    "_date": "2ca1101b12",
    "bolus_estimate": 1.7,
    "unknown_byte[8]": 0,
    "carb_ratio": 29,
    "food_estimate": 1.7,
    "bg_target_low": 50,
    "sensitivity": 50
  }
Scott Leibrand
@scottleibrand
Feb 27 2018 16:16
The bolus Wizard BG value is not used by oref0.
PeetuHongisto
@PeetuHongisto
Feb 27 2018 16:16
ok good
Scott Leibrand
@scottleibrand
Feb 27 2018 16:16
How much total insulin is openaps giving after your meal, compared to your normal basal? You can subtract reservoir values in NS.
PeetuHongisto
@PeetuHongisto
Feb 27 2018 16:24
Usually it's dropping from normal basal, even though being high. I only have 4 days of experience so not really extensive logs yet. btw what is subtracting reservoir values :)
Dana Lewis
@danamlewis
Feb 27 2018 16:24
@kitkatter yes, we all can help! Start posting questions and folks will chime in.
@PeetuHongisto look at the total amount of insulin given at the start and end of meal, by comparing the reservoir pill in NS. Subtract what you would normally get in basal rates from that time frame.
PeetuHongisto
@PeetuHongisto
Feb 27 2018 16:29
Will try
where should I see the reservoir pill?
PeetuHongisto
@PeetuHongisto
Feb 27 2018 16:39
Can't find it
Scott Leibrand
@scottleibrand
Feb 27 2018 16:39
the reservoir value is in the pump pill
PeetuHongisto
@PeetuHongisto
Feb 27 2018 16:46
Uusi bittikarttakuva.jpg
What is the pump pill?
th122
@th122
Feb 27 2018 17:00
@PeetuHongisto you may need to enable it in Settings -> Show plugins
PeetuHongisto
@PeetuHongisto
Feb 27 2018 17:01
I just got it to show in show plugins
now I see it
thanks all for help, I have to retire for the night
heippa
Saskia
@Missdazzle
Feb 27 2018 18:19
There used to be a time limit for the TBR of 30 minutes - for safety reasons. But today I noticed that OpenAPS set a TBR of 1h and later even one of 2h (set to 0). When has this been changed and why?
Scott Leibrand
@scottleibrand
Feb 27 2018 18:26
because in those situations it's considered safer to run a longer zero temp. non-zero temps are still limited to 30m
if you need more than 45m worth of zero temping to get eventualBG back to target, it'll set a 60m zero temp instead of a 30m one, in case you lose pump comms
if it loses CGM data, it'll shorten any long temps to 30m, and if the CGM data indicates zero temping is no longer needed before that it'll set a different temp
Saskia
@Missdazzle
Feb 27 2018 18:46
Aaah, that´s why I didn´t notice earlier, usually don´t need so many (long) 0 temps. Thanks! @scottleibrand
Martin Haeberli
@mhaeberli
Feb 27 2018 20:01
not seeing cable-connected Edison on mac - lsusb doesn’t seem to notice a new device either; tried three cables; two different Edisons. rebooted Mac. suggestions sought.
LilDucky
@LilDucky
Feb 27 2018 20:04

Hi all, getting a strange error in the nightly autotune logs and the autotune recommendations are not being calculated.

oref0-autotune-core autotune.2018-02-27.json profile.json profile.pump.json > newprofile.2018-02-27.json

module.js:340
throw err;
^
Error: Cannot find module 'json-stable-stringify'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/root/src/oref0/bin/oref0-autotune-core.js:24:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
false
Could not run oref0-autotune-core autotune.2018-02-27.json profile.json profile.pump.json

Sorry but can’t use back tic marks on the iPad

Scott Leibrand
@scottleibrand
Feb 27 2018 20:19
you can: the ` key is behind a long-press on the ' key
you may need to re-do the npm install step from the docs to get the json-stable-stringify dependency installed
alimhassam
@alimhassam
Feb 27 2018 21:19
:+1: I had the same error with json-stable-stringify need to re run npm install -g oref0
Doug
@dougboss
Feb 27 2018 21:31
@vebaba thanks for the image - the laptop Im using was used to sucessfully flash another edison a week ago and it has either 8 gb or 16 gb ram so memory isnt the issue. Im not sure what it was but I finally was able to flash it back to poky then back to jubilinux. Its now working and oref0 is installed, just waiting for my second explorer board to arrive I can keep going