These are chat archives for nightscout/intend-to-bolus

28th
Feb 2018
Tim Howard
@tghoward
Feb 28 2018 00:03
Howdy all - I've got a couple of TI sticks (http://www.ti.com/tool/CC1111EMK868-915 ) from the days before the Explorer Block that I'm not using any more. Anyone interested in them? Free to a good home.
Dana Lewis
@danamlewis
Feb 28 2018 00:05
:clap:
^^ for anyone who's been trying to use carelink, take one of these instead!!
thx @tghoward :)
Tim Howard
@tghoward
Feb 28 2018 00:06
:smile:
skubesch
@skubesch
Feb 28 2018 00:28
@tghoward I would love a TI stick!
skubesch
@skubesch
Feb 28 2018 00:35
I haven't had any data in my OpenAPS pill today and first I thought my rig was the issue but it is successfully setting temp basals. My mlab database was compressed about 6 months ago and is below the limit at 16.00MB on disk but I compressed again just incase. No size change but not a fix for the pill either; is there something else I can try?
skubesch
@skubesch
Feb 28 2018 00:46
It this normal? It's showing 0 documents in all collections:
Screen Shot 2018-02-27 at 7.45.58 PM.png
katie disimone
@Kdisimone
Feb 28 2018 00:47
not normal.
@skubesch did you set up a custom mlab at some point when you first started ns? and then switch to heroku?
sometimes people forget they may have two databases if they started in azure and moved to heroku
skubesch
@skubesch
Feb 28 2018 01:03
Thanks @Kdisimone! It turns out my string in MONGODB_URI that I copied over from Azure was not the same database I was linked to when I got to mLab from Heroku resources
LilDucky
@LilDucky
Feb 28 2018 01:22
Probably a silly question - is there a way to log "rescue" carbs so that the pank will not add any insulin? sometimes finding that when these are logged, insulin is added that causes an oscillation up and down.
Dana Lewis
@danamlewis
Feb 28 2018 01:23
Do carbs plus a slightly high temp target
There's an example in the ifttt docs
Martin Haeberli
@mhaeberli
Feb 28 2018 01:48
wondering whether my usbserial driver problems relate to FTDI driver kext issues...
Tim Gunn
@Tornado-Tim
Feb 28 2018 02:03
Hi all, getting prepped for looping so I have enough data for autotune, but I have a lowcarb high protein diet, in nightscout and xdrip there isn't a way to put that data in as is not carb but still needs bolusing for. I remember there was formula posted but I forgot what that was that I should put into the carb entry form..... Any ideas?
garykidd
@garykidd
Feb 28 2018 03:14
@Tornado-Tim i had same q uestion recently. I think the answer is that YDMV. Some post zero carbs for the pfotein portion of high protein meals....while others enter a fraction of protein weight/percentage of their meals.
Tim Gunn
@Tornado-Tim
Feb 28 2018 03:18
Thanks @garykidd, I find protein rich food when excess of 30g needs a good bolus, preferably over combo/dual wave bolus. but I hear it blocks any temporary basal being put on top that openaps. Might need a great deal of tinkering when I am on the thing.....
Dave Acklam
@dcacklam
Feb 28 2018 03:26
Question... Did a feature to automatically zero-temp while the pump is suspended ever get added?
@Tornado-Tim IIRC, once you have OpenAPS running you shouldn't need the dual or square-wave functionalty, OpenAPS will handle that for you well enough (especially if you report all your carbs)...
Dana Lewis
@danamlewis
Feb 28 2018 03:33
@dcacklam might be in dev or might still be an open PR (the include suspends in iob calc option)
Tim Gunn
@Tornado-Tim
Feb 28 2018 03:51
Nice thanks @dcacklam. Good to know what functions on the pump will become superfluous with openaps....
Dave Acklam
@dcacklam
Feb 28 2018 04:18
@danamlewis Is there anywhere that lists all the options that dev understands?
I'm currently running Dev & that sort of feature would be quite useful...
Dana Lewis
@danamlewis
Feb 28 2018 04:29
You can look at the open PR of dev to master and look at the diff of the code there
Scott Leibrand
@scottleibrand
Feb 28 2018 04:30
And the preferences parsing is all in one place in the code, in lib/profile
Dana Lewis
@danamlewis
Feb 28 2018 04:30
Haven't started the notes on that PR yet as there's nothing major and we're not nearing release yet, but when we get there, that's where it would be
:+1:
Tim Street
@tim2000s
Feb 28 2018 09:42
Rig question. Has anyone else noticed that when they charge through the OTG USB port, their rig shuts down within about 30 mins, but when charging through the other it doesn’t? Suspect I have a damaged connection somewhere causing an over current but it’s rather odd!
Mike
@libxmike
Feb 28 2018 10:55
@tim2000s I dont have this problem, I only charge through the OTG USB port
my case has opening just for OTG USB port https://www.thingiverse.com/thing:2531071
Tim Street
@tim2000s
Feb 28 2018 11:10
Suppose it’s probably a dying EXB 🙁
philipgo
@philipgo
Feb 28 2018 12:46
@tghoward I would love a TI stick, too 😉
Tim Howard
@tghoward
Feb 28 2018 12:58
@drnoname82 Sorry they are claimed! :worried:
Mike
@libxmike
Feb 28 2018 13:03
@tim2000s not necessary, there was a problem JUST with the charging circuit on EB where the charging chip got hot, this may be described somewhere in the docs
Scott Leibrand
@scottleibrand
Feb 28 2018 16:49
Also try reseating the Edison on the EB if you haven’t already.
Tim Street
@tim2000s
Feb 28 2018 17:04
The connectors are well seated however when you apply any pressure over the join, the connection clearly isn’t all that good as the flickering starts.
This may be why: https://imgur.com/XhwIrvU
Slight disformity of the Edison board.
dan lightner
@danimaniac
Feb 28 2018 18:31
@tim2000s In my opinion, the Edison/EB has always needed at least 3 support points instead of the current 2 (spacers, nuts, screws). Short of that - try this little spacer https://www.thingiverse.com/thing:2157657
Tim Street
@tim2000s
Feb 28 2018 18:32
@danimaniac yup. I’ve thought that a while, and this has hind of proven it.
dan lightner
@danimaniac
Feb 28 2018 18:44
@tim2000s I don't have good access to a 3d printer, so I cut and placed a few cardboard strips (also tried a few test strips) between the 2 boards...works really well. Low tech, but why not? https://photos.app.goo.gl/4KY2KCBJd47BvNQ43
live4sw
@live4sw
Feb 28 2018 19:53
I'm planning to try Fiasp this weekend, are there any good docs (documents, not doctors) about transitioning from normal fast-acting (Humalog for me) to Fiasp on Openaps? I know the release docs mention adjusting the action curve in setup, but is there any other helpful stuff out there?
Scott Leibrand
@scottleibrand
Feb 28 2018 19:57

dunno if any of this has been documented (if not, maybe a good PR opportunity?), but my normal tips are straightforward: don't pre-bolus, and if you're using SMB, consider entering all the carbs but only bolusing for part (half, 2/3, or 3/4) of them and letting SMB take care of the rest.

once you have everything dialed in you could also try the no-bolus approach (enter carbs but let SMB do all the bolusing), starting with smaller meals and eventually working your way up to see how well that works for you on medium and large meals.

Juan Mejías
@juanjuanmejias_twitter
Feb 28 2018 20:27
Hi, I just noticed I skipped a step when deploying the Nightscout app. I followed the instructions directly on the Nightscout website, so I missed the part where I had to switch the branch on GitHub from 'Branch: master' to 'Branch: dev'. What can I do to fix it?
Juan Mejías
@juanjuanmejias_twitter
Feb 28 2018 20:48
:worried:
Tim Gunn
@Tornado-Tim
Feb 28 2018 21:07
Hi @juanjuanmejias_twitter cd to the directory to which you cloned nightscout then issue the command git checkout dev
I would then subsequently git pull and npm install after that.....
Tim Street
@tim2000s
Feb 28 2018 22:03
@juanjuanmejias_twitter You no longer need the dev branch to support OpenAPS.
Thomas
@TH2100
Feb 28 2018 22:09
Hi all, I've finally received an edison with explorer board and all the installation went quite straight forward. But when trying to loop the pump-log indicates "module.js:485 throw err; SyntaxError: /root/myopenaps/settings/profile.json: Unexpected end of input at... at..._" whereas profile.json is just empty. How could I solve that?
Juan Mejías
@juanjuanmejias_twitter
Feb 28 2018 22:09
Hi @Tornado-Tim. Sorry, I'm not very experienced at this. I assume that would be on GitHub, correct? How can I execute those commands? I can't see a command line
Dana Lewis
@danamlewis
Feb 28 2018 22:12
@juanjuanmejias_twitter don't worry about it. Master is fine for now to support OpenAPS, so you don't need to change anything.
Juan Mejías
@juanjuanmejias_twitter
Feb 28 2018 22:14
@danamlewis OK, I'll move on then. Thanks a lot. 'Fine for now' means I might need to change it later?
Dana Lewis
@danamlewis
Feb 28 2018 22:15
it means the docs say dev and need to be updated to master. if you use OpenAPS and we make changes in OpenAPS that in the future requires dev branch of Nightscout in order to use the latest and greatest - then yes you may in future want to change it.
Juan Mejías
@juanjuanmejias_twitter
Feb 28 2018 22:18
@danamlewis OK, thanks for clarifying. I'll leave it for now, hopefully it'll be easier to change down the road with a bit more experience. Thanks!
alimhassam
@alimhassam
Feb 28 2018 22:19
@rollerdecom what type of pump do you use?
Thomas
@TH2100
Feb 28 2018 22:20
It’s a 512...
Dana Lewis
@danamlewis
Feb 28 2018 22:20
@juanjuanmejias_twitter :+1:
Thomas
@TH2100
Feb 28 2018 22:21
All done and checked.
Jon Cluck
@cluckj
Feb 28 2018 22:21
@rollerdecom are you using dev?
Thomas
@TH2100
Feb 28 2018 22:23
Don’t think so? :-)
Jon Cluck
@cluckj
Feb 28 2018 22:24
try running openaps report invoke settings/bg_targets.json in your ~/myopenaps/ directory
Thomas
@TH2100
Feb 28 2018 22:26
There is quite some output… are you looking for something specific or colud I paste just all?
Jon Cluck
@cluckj
Feb 28 2018 22:27
is it a bunch of error messages?
oh, I know what's wrong
Thomas
@TH2100
Feb 28 2018 22:28
It really is… referencing to around 12 lines
Jon Cluck
@cluckj
Feb 28 2018 22:28
you edited settings/bg_targets_raw.json according to the docs?
Thomas
@TH2100
Feb 28 2018 22:29
I think so...
Jon Cluck
@cluckj
Feb 28 2018 22:29
:)
in your myopenaps directory : cp settings/bg_targets_raw.json settings/bg_targets.json
the docs say to edit settings/bg_targets_raw.json, but on master it's looking for settings/bg_targets.json
Thomas
@TH2100
Feb 28 2018 22:32
ok… did so… am looking at pump log… or is better to reboot or so?
Jon Cluck
@cluckj
Feb 28 2018 22:32
it should pick that up on the next loop
Thomas
@TH2100
Feb 28 2018 22:33
the message just came back… reboot won’t hurt :-)
Jon Cluck
@cluckj
Feb 28 2018 22:35
okay, we can try to generate profile.json manually next
Thomas
@TH2100
Feb 28 2018 22:36
It’ currently at „Old settings:"
sorry, but might this be a cause:
"Temp refreshmmeowlink.exceptions.CommsException: No acknowledgement from pump on wakeup."
Jon Cluck
@cluckj
Feb 28 2018 22:45
that's probably not helping :laughing:
Thomas
@TH2100
Feb 28 2018 22:47
… perfect :-)
Jon Cluck
@cluckj
Feb 28 2018 22:48
is it doing any mmtune stuff?
Thomas
@TH2100
Feb 28 2018 22:49
It looks good to me: mmtune: No wait required ….
I also found:
openaps/openaps#134
It looks quite the same as the message I have… what do you think?
Jon Cluck
@cluckj
Feb 28 2018 22:54
How long has it been giving that error message?
Thomas
@TH2100
Feb 28 2018 22:55
SInce the beginning… maybe for 3h ...
Jon Cluck
@cluckj
Feb 28 2018 23:00
the profile.json error, the mmeowlink error, or both?
Thomas
@TH2100
Feb 28 2018 23:01
just the profile.json...
the mmeowlink hasn’t come back … maybe it was a one time...
Jon Cluck
@cluckj
Feb 28 2018 23:02
oh, that's good :)
Thomas
@TH2100
Feb 28 2018 23:03
yesss so!
Jon Cluck
@cluckj
Feb 28 2018 23:03
the code that generates profile.json needs like.....ALL THE THINGS in order to work
so if even one of the things is missing, for whatever reason, it won't work
try: oref0-get-profile settings/settings.json settings/bg_targets.json settings/insulin_sensitivities.json settings/basal_profile.json preferences.json settings/carb_ratios.json settings/temptargets.json --model=settings/model.json settings/autotune.json
Thomas
@TH2100
Feb 28 2018 23:07
copy and paste as a whole…?
Jon Cluck
@cluckj
Feb 28 2018 23:08
yes
that should give you a more detailed error message than was in the logs
Thomas
@TH2100
Feb 28 2018 23:09
command not found...
-bash: oref0-get-profile: command not found
Jon Cluck
@cluckj
Feb 28 2018 23:09
are you in /root/myopenaps/?
(if you're running it as root, of course)
Thomas
@TH2100
Feb 28 2018 23:09
no...
and yes...
:-)
a sec...
Jon Cluck
@cluckj
Feb 28 2018 23:10
you can press the up arrow key in a shell to scroll through the previous commands you've entered, btw
Thomas
@TH2100
Feb 28 2018 23:12
it’s the same error message as I see it in the log:
module.js:485
throw err;
^
SyntaxError: /root/myopenaps/settings/bg_targets.json: Unexpected end of input
at Object.parse (native)
at Object.Module._extensions..json (module.js:482:27)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-get-profile.js:102:26)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
Jon Cluck
@cluckj
Feb 28 2018 23:13
what are the contents of /root/myopenaps/settings/bg_targets.json and /root/myopenaps/settings/bg_targets_raw.json?
Thomas
@TH2100
Feb 28 2018 23:15
both are empty… ???
Jon Cluck
@cluckj
Feb 28 2018 23:15
can you do ls /root/myopenaps/settings please?
Thomas
@TH2100
Feb 28 2018 23:16
cgm determine-basal.ini iob.ini nightscout openaps.ini pebble.ini pump-session.json tz.ini xdrip
cgm.ini enact meal.ini ns-glucose.ini oref0.ini preferences.json raw-cgm units.ini xdrip.ini
detect-sensitivity.ini get-profile.ini monitor ns.ini oref0-runagain.sh pump.ini settings upload
Jon Cluck
@cluckj
Feb 28 2018 23:17
that's /root/myopenaps ;)
Thomas
@TH2100
Feb 28 2018 23:18
right...
root@edisonhost:~/myopenaps/settings# ls
autosens.json.new bg_targets.json model.json pumphistory-24h.json settings.json
basal_profile.json bg_targets_raw.json profile.json pumphistory-24h-zoned.json temptargets.json
Jon Cluck
@cluckj
Feb 28 2018 23:20
if bg_targets.json and bg_targets_raw.json are empty, you'll have to rewrite them
Thomas
@TH2100
Feb 28 2018 23:20
with my basal profile each?
yes
Thomas
@TH2100
Feb 28 2018 23:21
on it...
Jon Cluck
@cluckj
Feb 28 2018 23:23
make sure the other two files have stuff in them, too (basal_profile.json and settings.json)
Thomas
@TH2100
Feb 28 2018 23:28
Set and done… watching the log now...
Jon Cluck
@cluckj
Feb 28 2018 23:28
:thumbsup:
Thomas
@TH2100
Feb 28 2018 23:40
Well, the message is back after 3-4 pump connection attempts… the 4 files are still intact...
Jon Cluck
@cluckj
Feb 28 2018 23:41
can you try that really long oref0-get-profile command again?
and did you say "yes" to 512/712 during the setup?
Thomas
@TH2100
Feb 28 2018 23:42
I did say yes… was prompted at the end for … to edit...
Jon Cluck
@cluckj
Feb 28 2018 23:43
okay, just checking :)
Thomas
@TH2100
Feb 28 2018 23:43
trying the command...
I like double checks :-)
module.js:340
throw err;
^
Error: Cannot find module '/root/myopenaps/settings/settings/settings.json'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-get-profile.js:101:29)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
I think, the error code changed
Jon Cluck
@cluckj
Feb 28 2018 23:45
haha, cd .. and try it again
Thomas
@TH2100
Feb 28 2018 23:48
puhhh ...

root@edisonhost:~/myopenaps# oref0-get-profile settings/settings.json settings/bg_targets.json settings/insulin_sensitivities.json settings/basal_profile.json preferences.json settings/carb_ratios.json settings/temptargets.json --model=settings/model.json settings/autotune.json

module.js:340
throw err;
^
Error: Cannot find module '/root/myopenaps/settings/insulin_sensitivities.json'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-get-profile.js:117:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

in the log it’s code 485 <>340
Jon Cluck
@cluckj
Feb 28 2018 23:52
that's progress, though
Thomas
@TH2100
Feb 28 2018 23:52
really?
Jon Cluck
@cluckj
Feb 28 2018 23:52
if your rig is communicating with your pump, it should pull the sensitivity data from it eventually
Thomas
@TH2100
Feb 28 2018 23:52
ahhh...
so, now it’s all about keepng an eye on that?
Jon Cluck
@cluckj
Feb 28 2018 23:53
yes, give it a few minutes
Thomas
@TH2100
Feb 28 2018 23:54
this is so cool...
Jon Cluck
@cluckj
Feb 28 2018 23:55
lol, wait till it starts looping, then it's reeeeeally cool :D
Thomas
@TH2100
Feb 28 2018 23:56
no, I need some cool now, after all those hours...
… :-)
Would you mind… I’m just wasted...
… I’d let it run and hope for the best till the morning…?
Jon Cluck
@cluckj
Feb 28 2018 23:59
you should know if it's working pretty quickly
but sleep is also important!